fesco
LOGS
16:05:46 <tyll> #startmeeting FESCO (2017-12-08)
16:05:46 <zodbot> Meeting started Fri Dec  8 16:05:46 2017 UTC.  The chair is tyll. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:05:46 <zodbot> The meeting name has been set to 'fesco_(2017-12-08)'
16:05:50 <tyll> #meetingname fesco
16:05:50 <zodbot> The meeting name has been set to 'fesco'
16:05:50 <bowlofeggs> .hellow2
16:05:53 <bowlofeggs> .hello2
16:05:54 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
16:05:56 <tyll> #chair maxamillion dgilmore nirik jforbes jsmith kalev sgallagh bowlofeggs tyll
16:05:56 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll
16:05:59 <sgallagh> .hello2
16:06:00 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:06:02 <kalev> .hello2
16:06:03 <tyll> I guess we could just try to start
16:06:04 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
16:06:05 <jforbes> .hello2
16:06:06 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:06:10 <tyll> .hello till
16:06:11 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
16:06:28 <nirik> morning
16:07:00 * orc_fedo said, pre logging: I have no problem with my bug being held over to let it be considered by more attendees
16:07:16 <kalev> what's your bug?
16:07:22 <orc_fedo> https://pagure.io/fesco/issue/1799
16:07:30 <orc_fedo> only thing on the agenda
16:07:45 * kalev nods.
16:08:00 <orc_fedo> ... I just filed it yestarday pm, so it really has not 'aged' yet
16:08:36 <dgilmore> hey all
16:08:37 <tyll> #topic init process
16:09:08 <tyll> I count six members, so we have quorum
16:10:01 <tyll> #topic #1799 The ProvenPackager rubric needs more formality
16:10:14 <tyll> .fesco 1799
16:10:15 <zodbot> tyll: Issue #1799: The ProvenPackager rubric needs more formality - fesco - Pagure - https://pagure.io/fesco/issue/1799
16:10:39 <tyll> #info orc_fedo would be ok to table the issue since it was filed yesterday
16:10:52 <orc_fedo> tyll: I suggested that in the bug
16:11:09 <orc_fedo> oops -- ment to but the post did not take
16:11:09 <tyll> orc_fedo: ah, ok
16:11:11 <tyll> https://pagure.io/fesco/issue/1799#comment-483725
16:11:33 <orc_fedo> I am fine with holding it over a week to let it be more thoughtfully considered
16:11:40 <kalev> this is being discussed extensively on the devel list right now
16:11:40 <orc_fedo> guess it DID take
16:11:48 <orc_fedo> kalev: I know
16:12:06 <sgallagh> Yup, just like it is roughly once a year...
16:12:13 <kalev> for what it's worth, I'm with zbyszek here and think that adding more process to doing distro wide cleanups makes them just too painful to do
16:12:43 <orc_fedo> some thoughts are tecninical workflow questions, but the real problem a PP is not considering what the maintainer might have in mind
16:12:43 <dgilmore> kalev: indeed
16:12:46 * steved to agrees with zbyszek with massive builds... if something gets in the way it has to be fixed
16:12:56 <bowlofeggs> yeah i also am not in favor of this proposal
16:13:30 <dgilmore> I am good with delaying discussion a week to aloow for more discussion and refinement of the proposal
16:13:32 <nirik> its hard to make it more narrow and still allow all the cases of changes we would hopefully want to allow.
16:13:41 * nirik is fine for more list discussion.
16:13:50 <steved> there has to be way to not allow anybody and every body change anything they want with no review
16:13:52 <bowlofeggs> yeah i'm fine with more discussion and refinement too
16:13:54 <jforbes> I think there needs to be some more discussion perhaps on proven packagers, but this proposal as is bothers me.
16:14:03 <orc_fedo> so ... is a 'second' on a motion to table needed?
16:14:21 <dgilmore> orc_fedo: no.
16:14:23 <steved> jforbes: what is the bother?
16:14:32 <orc_fedo> dgilmore: ty
16:14:47 <bowlofeggs> proposal: delay a week to discuss this and allow the proposal to be refined
16:15:07 <dgilmore> proposal: table for a week to allow discussion and the proposal to be refined
16:15:14 <dgilmore> +1 to bowlofeggs
16:15:24 <tyll> +1 to bowlofeggs
16:16:09 <kalev> I think we could just as well decide to reject it now, not sure it needs an extra week
16:17:19 <sgallagh> kalev: Well, I think it's fair to reject it either for revision or with prejudice. Right now the proposal is "let them try to revise it for a week"
16:17:21 <sgallagh> Which I think is fair.
16:17:28 <sgallagh> So +1 to defer
16:17:31 <kalev> fair enough. +1 then to defer
16:17:35 <nirik> +1
16:17:37 <tyll> we could also decide to explicitly state in the policy that small mass changes can applied when e.g. two provenpackagers agree or something
16:17:40 <jforbes> steved: well more discussion needs to happen because there have been several threads lately. Clearly people aren't happy with what is happening, but overall proven packager is worded as it is to faciltate particular workflows
16:18:19 <tyll> jforbes: afaics your vote is missing
16:18:28 <jforbes> tyll: +1 to defer
16:19:14 <tyll> is there a template for the aggreed message somewhere?
16:19:57 <nirik> just agreed: thing (number of votes for, number against, number abstain)
16:20:09 <bowlofeggs> dont' forget the # on agred
16:20:25 <tyll> #agreed delay a week to discuss this and allow the proposal to be refined (+7, 0, 0)
16:20:59 <tyll> afaics there are no other open meeting issues
16:21:22 <tyll> #topic Next week's chair
16:21:39 * nirik will be on vacation next week.
16:21:46 <tyll> Are there any volunteers?
16:21:48 * dgilmore can do next week
16:21:53 <dgilmore> its been awhile
16:21:55 * tyll will not be there, too
16:21:56 <jforbes> I am on vacation as well next week, I can take the week after
16:22:17 <dgilmore> sounds like the meeting probably will not have enough people next week
16:22:19 <tyll> #action dgilmore will chair next meeting
16:22:33 <bowlofeggs> so far it's possible for there to be 6
16:22:37 <dgilmore> the week after is a company holiday for Red Hat
16:22:49 <dgilmore> bowlofeggs: indeed
16:23:16 <bowlofeggs> i actually can't make the 3 after next week
16:23:22 <tyll> so no meeting on 2017-12-22?
16:23:30 <dgilmore> #info next two meetings will be December 15th then  January 5th
16:23:38 <bowlofeggs> so i can do next week, and then i can't be here again until jan 12
16:23:42 <tyll> dgilmore: thank you
16:23:44 <dgilmore> tyll: nor the week after
16:23:50 <tyll> #topic Open Floor
16:23:57 <dgilmore> Elections
16:24:00 <jforbes> dgilmore: shutdown starts the 22nd?
16:24:11 <jforbes> dgilmore: elections are cancelled/postponed
16:24:21 <dgilmore> jforbes: right
16:24:28 <dgilmore> which is why I wanted to bring them up
16:24:33 <tyll> #info elections are expected to be in January
16:24:56 <dgilmore> jforbes: shutdown is 22nd to Jan 1
16:25:17 <dgilmore> is there anything we can do to make sure they go off without a hitch?
16:25:20 <jforbes> Oh cool
16:26:20 <tyll> we could maybe limit the number of questionsin the questionnaire to make it less effort to write them
16:26:24 <jforbes> Candidates fill out the questions when you get them I suppose. Not sure exactly what the issue was this time around, it was confusing from the ticket
16:26:59 <dgilmore> jforbes: I think that the infra move had the portal up and down
16:27:29 <jforbes> Oh, quite possibly. I had mine filled out before the move really started
16:27:50 <nirik> I got email asking me to fill out the questionare friday afternoon.
16:28:03 <nirik> and the election was supposed to start monday night.
16:28:21 <dgilmore> nirik: saME
16:28:23 <dgilmore> same
16:28:27 <tyll> I guess it depends on when you nominated yourself
16:28:28 <nirik> and I was doing other things over the weekend... then DC work monday
16:28:34 <jforbes> nirik: me too, I think that's when they all went out
16:28:38 * dgilmore was not self nominated :D
16:28:39 <tyll> or maybe not
16:28:45 <orc_fedo> there was also a moving part that 'over the transom' submission of questions was held open until pretty close to the deadline for FECSO answers
16:28:47 <jforbes> tyll: no, I nominated on the day of
16:30:26 * kalev has to drop off irc.
16:32:05 <tyll> maybe we can just think about what to improve and discuss during next meeting?
16:32:28 * nirik nods.
16:32:30 <jforbes> sounds reasonable
16:32:36 <dgilmore> #info all candidates for election please be on top of questions when they come up. report to #fedora-admin and/or https://pagure.io/fedora-infrastructure/ any issues with infra when submitting
16:32:43 <dgilmore> sure
16:32:50 * dgilmore has nothing else for open floor
16:33:29 <tyll> #action everyone think about how to make sure the next election runs smoothly
16:33:39 <dgilmore> till++
16:33:39 <zodbot> dgilmore: Karma for till changed to 1 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:33:45 <tyll> dgilmore: would you file a ticket to discuss this on the next meeting?
16:33:52 <dgilmore> tyll: sure
16:34:04 <tyll> If there is nothing else I will end the meeting in 1 minute
16:34:15 <tyll> dgilmore: thank you
16:35:17 <tyll> Thank you everyone, have a nice Friday and weekend and holidays!
16:35:21 <tyll> #endmeeting