magazine
LOGS
22:00:12 <stickster> #startmeeting Magazine editorial board
22:00:12 <zodbot> Meeting started Wed Sep 27 22:00:12 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:00:12 <zodbot> The meeting name has been set to 'magazine_editorial_board'
22:00:14 <stickster> #meetingname magazine
22:00:14 <zodbot> The meeting name has been set to 'magazine'
22:00:16 <stickster> #topic Roll call
22:00:18 <stickster> .hello pfrields
22:00:19 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
22:00:28 <ryanlerch> .hello ryanlerch
22:00:28 <stickster> #chair ryanlerch
22:00:28 <zodbot> Current chairs: ryanlerch stickster
22:00:29 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
22:01:20 <ryanlerch> good morning stickster!
22:01:31 <ryanlerch> hope you had an awesome day!
22:01:34 <stickster> ryanlerch: let's give a minute or two to see who else shows up, although I bet it's just the two of us... we can make it if we try, just the two of us... 🎶
22:02:12 <stickster> ryanlerch: also, good morning and it was a relatively good day!
22:02:48 <ryanlerch> :D
22:03:25 <stickster> #topic Last week's stats
22:03:46 <stickster> #info holding steady at just shy of 53K page views, not too shabby :-)
22:04:30 <ryanlerch> ooh, awesome
22:04:32 <stickster> #info Sept 2017 has crossed 200K page views. We probably won't make it to 230K, I'm guessing. But it's not a bad month at all
22:05:21 <stickster> ryanlerch: I'm thinking our agenda tonight will need to be a little different. Nothing pending review, sub_pop[m] says he's still working on draft we were going to publish tomorrow, so that's likely not happening
22:05:25 <ryanlerch> that is great, all things considered
22:05:34 <ryanlerch> the stats that is
22:05:41 <stickster> agreed!
22:06:00 <stickster> #topic Publishing schedule and other conundra
22:06:42 <stickster> So, we don't have a post ready for tomorrow but we have one "probably" on the way for next week (Fedora Women Day) and one "maybe" (aforementioned Flatpak article)
22:07:07 <stickster> sorry, not tomorrow, *Friday*
22:07:14 <stickster> although we'd need it tomorrow to edit
22:07:56 <ryanlerch> stickster: i can try to get a post together for tomorrow
22:08:11 <ryanlerch> maybe a quick ansible 2.4 in fedora post?
22:08:34 <stickster> ryanlerch: Oh, did that make it now!
22:08:39 <stickster> oops, s/!/?/
22:09:06 <stickster> Ah, it's in testing
22:09:18 <stickster> requested stable for F27, that counts ryanlerch  ;-)
22:09:33 <ryanlerch> :)
22:09:42 <stickster> ryanlerch: go for it!
22:10:07 <stickster> ryanlerch: if sub_pop[m] isn't done with his article by Friday (for a Monday publication), I may ask him whether I can just snag it and work on it.
22:10:20 <stickster> s/may/will/
22:10:43 <ryanlerch> stickster: sounds good.
22:11:06 <stickster> #action ryanlerch put together quick Ansible 2.4 in F27 post for Friday 2017-Sep-29
22:11:36 <stickster> #action stickster check with Link on Friday for status on flatpak article, and offer help if not done so we can publish Monday 2017-Oct-01
22:11:43 <stickster> #undo
22:11:43 <zodbot> Removing item from minutes: ACTION by stickster at 22:11:36 : stickster check with Link on Friday for status on flatpak article, and offer help if not done so we can publish Monday 2017-Oct-01
22:11:44 <stickster> #action stickster check with Link on Friday for status on flatpak article, and offer help if not done so we can publish Monday 2017-Oct-02
22:11:58 <stickster> Also... let's not forget we have a biggie coming next week, but we might not have a text yet
22:12:10 <stickster> #info F27 Beta is *probably* going to be a go for Tuesday 2017-Oct-03
22:12:38 <stickster> IIRC x3mboy[m] was working on the announcement, not sure of status though
22:12:57 <stickster> Hold the phone ryanlerch!!!!
22:13:05 <stickster> #info --- Fedora Classroom article ---
22:13:07 <stickster> #link https://fedoramagazine.org/wp-admin/post.php?post=18733&action=edit
22:13:55 <ryanlerch> +1 for this -- other than tweaking the title
22:13:59 <stickster> This looks practically ready to go as-is, we could slot this for Friday (since it's a timed announcement), push Ansible 2.4 to Monday, then sub_pop[m] has more time for his article
22:14:08 <stickster> ryanlerch: +1 on article, and +1 on tweaking
22:14:16 <ryanlerch> stickster: stole the words from under me!
22:14:16 <stickster> note I did *not* say +1 on twerking
22:14:33 <ryanlerch> lolz
22:14:47 <stickster> I can't believe this just happened, we went from despair to triumph in under 10 minutes
22:14:55 <ryanlerch> other than that -- ship it!
22:14:55 <stickster> \o/ \o/ \o/ \o/ \o/ \o/ '
22:15:04 <ryanlerch> :D
22:15:16 <stickster> #action stickster quick edit on Classroom article and schedule for publishing 2017-Sep-29
22:15:55 <ryanlerch> if i get time, might do a tailored featre image too
22:16:45 <stickster> What about the Beta article? Can I just yank an old one and make a cheapo Beta image in advance for next week?
22:16:59 <stickster> or is that a cop out?
22:17:11 <stickster> sorry, yank *an old image*
22:17:53 <stickster> ryanlerch: ^
22:18:10 <ryanlerch> yeah, i can do the beta post if you want!
22:18:27 <stickster> the wallpaper IMHO isn't quite ready for primetime as a background for a featured image...
22:18:48 <stickster> it's getting there, I have full confidence in the Artwork folks... they're doing an awesome job volleying ideas to get it to final
22:19:22 <stickster> ryanlerch: Let's find out if x3mboy[m] is on track for the announcement. If so, the image is all that's needed
22:19:36 * stickster checks https://fedoraproject.org/wiki/F27_Beta_release_announcement
22:19:39 <ryanlerch> stickster: awesome! i can sort something out for that!
22:19:45 <ryanlerch> the image that is
22:20:25 <stickster> #action ryanlerch come up with F27 Beta post featured image
22:21:48 <stickster> #proposed #agreed PUBLISHING SCHEDULE: Fri 2017-Sep-29 - Classroom article (edit: paul, image TBA) ; Mon 2017-Oct-02 - Ansible 2.4 (edit, image: ryan) ; Tue 2017-Oct-03 F27 Beta (edit: TBD, image: ryan) ; Wed 2017-Oct-04 - Fedora Women's Day (edit: paul, image: paul) ; Fri 2017-Oct-06 - Flatpak (edit: paul, image: ryan?)
22:21:53 <ryanlerch> so fingers cross the beta article is tuesday/wednesdays post
22:21:59 * stickster too
22:22:20 * ryanlerch can't believe it was that easy!
22:22:43 <ryanlerch> i will also try to do some work this week on getting a few posts in the warchest
22:23:04 <stickster> You good with above?
22:23:13 <ryanlerch> sorry!
22:23:18 <ryanlerch> yes a big +1
22:23:23 <stickster> lol
22:23:26 <stickster> np
22:23:29 <stickster> #proposed #agreed PUBLISHING SCHEDULE: Fri 2017-Sep-29 - Classroom article (edit: paul, image TBA) ; Mon 2017-Oct-02 - Ansible 2.4 (edit, image: ryan) ; Tue 2017-Oct-03 F27 Beta (edit: TBD, image: ryan) ; Wed 2017-Oct-04 - Fedora Women's Day (edit: paul, image: paul) ; Fri 2017-Oct-06 - Flatpak (edit: paul, image: ryan?)
22:23:34 <stickster> oh darn it.
22:23:37 <stickster> #agreed PUBLISHING SCHEDULE: Fri 2017-Sep-29 - Classroom article (edit: paul, image TBA) ; Mon 2017-Oct-02 - Ansible 2.4 (edit, image: ryan) ; Tue 2017-Oct-03 F27 Beta (edit: TBD, image: ryan) ; Wed 2017-Oct-04 - Fedora Women's Day (edit: paul, image: paul) ; Fri 2017-Oct-06 - Flatpak (edit: paul, image: ryan?)
22:23:42 <stickster> there we go.
22:23:47 <ryanlerch> woo!
22:23:53 <stickster> OK, now for another topic entirely
22:24:02 <stickster> #topic Editor in chief retirement
22:24:25 <stickster> So jwf is trying to improve focus on just a couple critical things in Fedora and needs to step down as EIC.
22:24:45 <ryanlerch> :(
22:24:49 <stickster> jwf++ for being up front and transparent, not to mention a GREAT contributor
22:24:56 <stickster> but yeah, it's sad
22:25:01 <ryanlerch> jwf++ for sure!
22:25:42 <stickster> ryanlerch: for now, it looks like you and I are holding down the fort, but we should mention on the list we are going to be looking for an editor to join up -- we should probably have a short list of qualifications to help people decide if they can pitch in here
22:26:09 <stickster> 3 makes it much easier during events or vacations
22:26:22 <ryanlerch> sounds like a plan!
22:28:01 <ryanlerch> stickster++
22:28:38 <stickster> ryanlerch: I was thinking some qualifications are: (1) excellent written English; (2) minimal experience in correcting text to match grammar/style guidelines (can be learned through Magazine contribution); (3) ability to commit 1-3 hours of time per week to the Magazine team
22:28:49 <stickster> actually, make that 2-4 hours, the meeting is 1
22:30:04 <ryanlerch> stickster: i think you nailed it there
22:30:15 <stickster> Okey dokey, I can do a post about it
22:30:24 <stickster> #action stickster post to the list looking for an editor
22:30:30 <ryanlerch> stickster: awesome!
22:30:32 <stickster> I'll probably blog it too
22:31:10 <stickster> ryanlerch: anything else we might need to do to re-improve things for Magazine operations?
22:31:39 <ryanlerch> 
22:32:10 <stickster> well OK then... I guess we'll move on
22:32:17 <ryanlerch> sorry
22:32:17 <stickster> #topic All other business (open floor)
22:32:27 <stickster> oh! sorry, I thought you were saying "nope, nothing" in shorthand :-D
22:33:00 * stickster waits to see if he missed something
22:33:03 <ryanlerch> i scrolled up accidentlyally and it took be a while to get back down there
22:33:05 <stickster> lol
22:33:23 <ryanlerch> sorry, but nothing more form me!
22:33:56 <stickster> ryanlerch: I did notice today while poking around on the magazine.fedorainfracloud.org hosting machine that there is a kind of weird Wordpress setup
22:34:50 <ryanlerch> ooh, what kind of weirdness?
22:34:57 <stickster> I think Wordpress is deployed as a package in /usr/share/wordpress *and* there is also a copy of it in /var/www/html which is not being used. This means stuff is being configured into the /usr directory and I'm worried it will disappear if the machine is ever nuked
22:36:04 <stickster> ryanlerch: If you ask me, this is because of a combination of weird Wordpress architectural choices, and possibly RPM packaging not doing all the right things
22:37:06 <stickster> ryanlerch: the wp-content/ folder, for example, seems like it ought to point to something like /etc/wordpress/...
22:37:09 <nirik> if there is one in /var/www/html it's the old one... and can be nuked
22:37:15 <stickster> nirik: Ah, thanks
22:37:21 <ryanlerch> awesome!
22:37:24 <ryanlerch> :D
22:37:26 <nirik> wp-content should point to /var/lib/wordpress/something
22:37:38 <stickster> Oh right, content, not config.
22:37:54 <stickster> although I note that drupal uses /etc/drupal7/* for this.
22:37:54 <ryanlerch> welcome nirik!
22:38:14 <stickster> I suppose it's a tomato/tomahto situation
22:38:17 <stickster> thanks nirik
22:38:20 <nirik> the package config is in /etc/wordpress/ it's just content thats in var that is outside the package
22:38:38 <nirik> anyhow, i can try and move that old stuff and make sure it doesn't break anything
22:38:44 <stickster> nirik: no worries, I can take care of it
22:38:48 <stickster> nirik: I have access on that box
22:39:24 <stickster> nirik: But one thing though... /var/lib/wordpress doesn't exist and the Wordpress RPM package doesn't contain it.
22:39:47 <stickster> I think this may be a packaging bug, but I guess nowadays I can do a PR for that, right?
22:39:57 <ryanlerch> :D
22:39:59 * stickster resolves to check with limb who he thinks maintains it
22:40:21 <nirik> I'll take a look, have to run here in a min, but can look in a while.
22:40:33 <stickster> nirik: don't worry about it, this is my problem not yours ;-)
22:40:34 <nirik> well, remi does most of the work on it
22:40:41 <ryanlerch> nirik++
22:40:41 <zodbot> ryanlerch: Karma for kevin changed to 30 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
22:40:42 * nirik is also a co-maintainer and uses it at home
22:40:51 <stickster> oh! nice, I didn't realize that nirik
22:41:33 <stickster> I use it all for several things including my personal blog and my podcast site
22:41:40 <stickster> s/all/all the time/
22:42:04 <stickster> #action stickster work with nirik & remi to see if we can improve packaging situation in case of a nuke
22:42:17 <stickster> That's it for me, I think. Anything for you ryanlerch?
22:42:36 <ryanlerch> stickster: nope! all done on my end
22:42:47 <stickster> ryanlerch: Okey dokey, that's a wrap then! thanks for being here
22:42:56 <ryanlerch> stickster: thanks for chairing!
22:42:59 <stickster> #endmeeting