fesco
MINUTES

#fedora-meeting: FESCO (2017-08-11)

Meeting started by sgallagh at 16:01:00 UTC (full logs).

Meeting summary

  1. init process (sgallagh, 16:01:00)
  2. #1721 Non-responsive maintainer process for caillon, and retiring xchat (sgallagh, 16:04:19)
    1. AGREED: orphan all of caillon's packages and announce this. If xchat should go away, someone can pick up ownership and retire it (+6, 0, -0) (sgallagh, 16:06:29)
    2. ACTION: nirik to orphan caillon's packages (sgallagh, 16:07:11)

  3. #1758 ImageMagick Unresponsive Maintainer process - hubbitus (Pavel Alexeev) (sgallagh, 16:07:26)
    1. AGREED: orphan the package and announce it. (+6, 0, -0) (sgallagh, 16:12:09)
    2. https://admin.fedoraproject.org/pkgdb/packager/hubbitus/ for list of packages. don't know how to get that from pagure yet (kalev, 16:13:17)
    3. https://src.fedoraproject.org/user/hubbitus (nirik, 16:14:03)
    4. AGREED: just orphan ImageMagick for now and if someone wants they can start proper nonresponsive maintainer process so they know what's at stake? (+5, 0 , -0) (sgallagh, 16:21:19)

  4. #1758 The maintainer for ixpdimm_sw has left. (sgallagh, 16:21:26)
    1. AGREED: Change the owner of ixpdimm_sw to rutvijk and leave the original owner (nkothapa) as a co-maintainer (+5, 0, -0) (sgallagh, 16:28:59)
    2. ACTION: sgallagh to sponsor rutvijk as a packager (sgallagh, 16:29:08)

  5. #1753 Consider adding sssd-kcm to one of the default comps groups (sgallagh, 16:31:10)
    1. AGREED: Add sssd-kcm to @core (+6, 0, -0) (sgallagh, 16:37:56)
    2. ACTION: sgallagh to send comps PR (sgallagh, 16:38:11)

  6. #1760 F27 approved Changes not in MODIFIED status (considered as not testable) (sgallagh, 16:38:37)
  7. Incomplete Changes - 32 bit UEFI Support (sgallagh, 16:41:47)
    1. AGREED: Defer to F28 unless pjones reports that it's already done and just not updated (+6, 0, -0) (sgallagh, 16:44:43)

  8. Incomplete Changes - Bodhi Non-RPM Artifacts (sgallagh, 16:45:29)
    1. AGREED: Bodhi non-RPM Artifacts is expected to be ready by bodhi enablement, so we give it a pass today. (+6, 0, -0) (sgallagh, 16:59:27)

  9. Incomplete Changes - True Noarch Erlang Packages (sgallagh, 16:59:59)
    1. AGREED: Noarch Erlang is deferred to F28 (+6, 0, -0) (sgallagh, 17:01:44)

  10. Incomplete Changes - Graphical Applications as Flatpaks (sgallagh, 17:02:12)
    1. AGREED: extend the deadline for Flatpak to three days before Beta Freeze (+6, 0, -0) (sgallagh, 17:12:39)

  11. Incomplete Changes - Packaging Rust applications/libraries (sgallagh, 17:13:20)
    1. https://lists.fedoraproject.org/archives/list/rel-eng@lists.fedoraproject.org/thread/CSOOHPG2S6PTXMO5Y3OU57HBLNTX3AQZ/ <-- for reference (ignatenkobrain, 17:15:04)
    2. https://pagure.io/pyrpmmd (Pharaoh_Atem, 17:23:21)
    3. AGREED: Defer this Change to F28 and FESCo will try to get rel-eng's attention focused on it (+5, 0, -0) (sgallagh, 17:26:34)

  12. Incomplete Changes - Java 9 (sgallagh, 17:30:43)
    1. AGREED: Defer Java 9 to F28 (+5, 0, -0) (sgallagh, 17:34:39)

  13. Incomplete Changes - Modular Release (sgallagh, 17:35:39)
    1. https://pagure.io/fedora-infrastructure/issue/6183 (threebean, 17:41:07)
    2. AGREED: extend the deadline to three days before Beta Freeze (+5, 0, -0) (sgallagh, 17:44:30)

  14. Incomplete Changes - Modular Server (sgallagh, 17:44:46)
  15. Incomplete Changes - No More Alphas (sgallagh, 17:52:41)
    1. AGREED: Consider it testable (+5, 0, -0) (sgallagh, 17:58:14)

  16. Incomplete Changes - NSS Default File Format SQL (sgallagh, 17:58:26)
    1. We cannot find any clear evidence whether this has been implemented yet in Rawhide (sgallagh, 18:04:34)
    2. AGREED: Defer to F28 unless it's found to already have been implemented in Rawhide (+5, 0, -0) (sgallagh, 18:04:58)

  17. Incomplete Changes - PHP 7.2 (sgallagh, 18:05:17)
  18. Incomplete Changes - Platform Python Stack (sgallagh, 18:06:21)
    1. https://pagure.io/releng/issue/6917 (mhroncok, 18:07:31)
    2. Changes are ready and will be pushed next week (sgallagh, 18:09:52)

  19. Incomplete Changes - Reduce Initial Setup Redundancy (sgallagh, 18:10:38)
    1. deferred by Change Owner (sgallagh, 18:10:46)

  20. Incomplete Changes - Remove krb5-appl (sgallagh, 18:10:55)
    1. Communication failure. This Change is ready (sgallagh, 18:11:29)
    2. Incomplete Changes - Switch libidn-using applications to IDNA2008Switch libidn-using applications to IDNA2008 (sgallagh, 18:11:46)
    3. Deferred by Change Owner (sgallagh, 18:11:55)

  21. Next week's chair (sgallagh, 18:12:12)
    1. kalev to chair the 2017-08-18 meeting (sgallagh, 18:12:40)

  22. Open Floor (sgallagh, 18:12:47)


Meeting ended at 18:14:19 UTC (full logs).

Action items

  1. nirik to orphan caillon's packages
  2. sgallagh to sponsor rutvijk as a packager
  3. sgallagh to send comps PR


Action items, by person

  1. nirik
    1. nirik to orphan caillon's packages
  2. sgallagh
    1. sgallagh to sponsor rutvijk as a packager
    2. sgallagh to send comps PR


People present (lines said)

  1. sgallagh (210)
  2. maxamillion (74)
  3. nirik (69)
  4. bowlofeggs (57)
  5. kalev (55)
  6. Pharaoh_Atem (29)
  7. zodbot (25)
  8. jforbes (21)
  9. ignatenkobrain (20)
  10. threebean (17)
  11. jsmith (17)
  12. otaylor (12)
  13. langdon (12)
  14. mhroncok (12)
  15. puiterwijk (7)
  16. adamw (7)
  17. dustymabe (6)
  18. Sir_Gallantmon (4)
  19. pviktori (3)
  20. Rathann (0)
  21. jwb (0)
  22. dgilmore (0)


Generated by MeetBot 0.1.4.