council
LOGS
13:00:42 <mattdm> #startmeeting Council (2017-07-26)
13:00:42 <zodbot> Meeting started Wed Jul 26 13:00:42 2017 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:42 <zodbot> The meeting name has been set to 'council_(2017-07-26)'
13:00:43 <mattdm> #meetingname council
13:00:43 <zodbot> The meeting name has been set to 'council'
13:00:45 <mattdm> #chair mattdm jkurik jwb langdon robyduck bexelbie
13:00:45 <zodbot> Current chairs: bexelbie jkurik jwb langdon mattdm robyduck
13:00:47 <mattdm> #topic Introductions, Welcomes
13:00:54 <jkurik> .hello2
13:00:56 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
13:01:59 <robyduck> .hello robyduck
13:02:00 <zodbot> robyduck: robyduck 'Robert Mayr' <robyduck@gmail.com>
13:02:05 <langdon> .hello2
13:02:05 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
13:02:11 <langdon> jkurik, your trick is cool! :)
13:02:16 <jkurik> :)
13:02:18 <robyduck> :)
13:03:35 <mattdm> .hello3
13:03:38 <mattdm> nope :)
13:03:50 <mattdm> I thought maybe that would be Even More Amazing
13:04:15 <mattdm> wow!
13:04:42 <mattdm> OMG the bot is alive
13:04:43 <bexelbie> #hello bex
13:04:48 <bexelbie> .hello bex
13:04:49 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
13:04:56 * bexelbie forgets that zodbot hates markdown
13:05:00 <mattdm> Okay, so, just missing Josh?
13:05:26 <mattdm> There is jwb _and_ jwboyer in this channel....
13:06:11 * mattdm looks at clock.
13:06:16 <mattdm> let's go ahead with the agenda
13:06:23 <mattdm> #topic Agenda
13:06:29 <mattdm> 1. Trademark Approval Request: fedoraloves.net
13:06:31 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/128
13:06:33 <mattdm> 2. Fedora Modules Guidelines and Process
13:06:35 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/123
13:06:37 <mattdm> 3. create draft page with mission statement, foundations, objectives
13:06:39 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/117
13:06:41 <mattdm> 4. What to do with all of the open budget tickets?
13:06:43 <mattdm> 5. What to do with all of the open CoC / community practices tickets?
13:06:45 <mattdm> 6. Upcoming elections
13:06:47 <mattdm> 7. Open Floor
13:06:49 <mattdm> Does that look good to everyone? Anything to add?
13:07:26 <langdon> it looks long :)
13:07:33 <robyduck> yeah
13:07:40 <mattdm> yeah. let's get started :)
13:07:50 <mattdm> #topic Trademark Approval Request: fedoraloves.net
13:07:55 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/128
13:08:16 <mattdm> after understanding the .NET joke, I am okay with this
13:08:30 <mattdm> for the purposes of Fedora .NET stuff
13:08:55 <bexelbie> I am +1 this without any additional subdomains/redirects
13:09:07 <mattdm> (same)
13:09:22 <robyduck> basically it doesn't matter, if it is owned by her and we are fine with the content (which is a redirect), this can be approved as soon as she signs the license agreement.
13:09:40 <mattdm> okay, so anyone opposed?
13:09:53 <jkurik> for me the name is confusing, but meh..
13:09:57 <robyduck> +1 without subdomains is fine
13:10:04 <bexelbie> Should we suggest transferring the domain to Fedora proper?
13:10:25 <robyduck> bexelbie: nope, we are not suggesting to buy fedora domain names
13:10:32 <bexelbie> ok
13:11:00 * langdon almost wore my redhatloves.net shirt today
13:11:04 <langdon> *his
13:11:06 <langdon> +1
13:11:09 <mattdm> robyduck: does she just need to sign the agreement and send it in?
13:11:18 <mattdm> or does it need to be coordinated?
13:11:44 * mattdm reads https://fedoraproject.org/wiki/Legal:Trademark_license_agreement
13:11:48 <robyduck> yes
13:11:53 <robyduck> https://fedoraproject.org/wiki/Local_community_domains#Self-purchased_domain
13:12:06 <robyduck> this should apply also in this case
13:12:50 <mattdm> what's the part about an infra ticket? That's if the domain name is transfered?
13:13:08 <robyduck> mattdm: yes, if we want to transfer it
13:13:24 <robyduck> mattdm: she will probably need to file an Infra ticket to set the redirect
13:13:46 <robyduck> we have already some redirects set for other domain names
13:13:54 <mattdm> robyduck: thanks
13:14:02 <robyduck> yw
13:14:05 <mattdm> okay I'm going to close off that ticket while I start the next topic
13:14:10 <mattdm> 2. Fedora Modules Guidelines and Process
13:14:11 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/123
13:14:16 <mattdm> #undo
13:14:16 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x113ab90>
13:14:21 <mattdm> #topic Fedora Modules Guidelines and Process
13:14:23 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/123
13:16:14 <mattdm> langdon: comments on this?
13:16:18 <mattdm> anyone else comments on this?
13:16:52 <bexelbie> I commented in the ticket
13:16:52 * robyduck agrees with bexelbie comments, it needs probably a bit of clearer wording
13:16:53 <langdon> oops sorry
13:16:57 <langdon> was typing about .net
13:16:59 <mattdm> lol
13:17:15 <mattdm> My main thought is that I'm not sure who the right approving body is for this
13:17:25 <langdon> ahh yes.. that is my question too
13:17:57 <langdon> and, apologies, but boltron release killed a lot of my time over the last few weeks.. so I haven't gotten back to this
13:18:45 <langdon> i believe the container guidelines were approved by the atomic/cloud wg.. this is a bit higher than that.. i would think the council needs to weigh .. but i am not sure how we should do ongoing reviews
13:18:46 <mattdm> At the council level, I care that there *are* guidelines, and that those guidelines don't go crazy off the rails ("Restrition, Enemies, Bugs, Last!")
13:18:53 <langdon> *needs to weigh in
13:19:32 <langdon> we also are working on making the "review of the module" highly automated
13:19:52 <langdon> and executed on every change
13:20:00 <mattdm> langdon: You'd talked about basically disolving the modularity wg once modularity was in production
13:20:08 <langdon> yeah
13:20:15 <mattdm> Is that still the idea, or should the WG still exist as maintainers of these guidelines?
13:20:34 <langdon> they could be.. but it would be a "re-charter" (which is fine, just a point)
13:20:58 <mattdm> It's about time for a re-charter anyway :)
13:21:02 <langdon> ha
13:21:24 * langdon getting bored with all this "things aren't changing every hour"
13:22:22 <langdon> so.. mattdm who's call is this?
13:22:33 <jkurik> From my POV, it is more like syntax description of a module spec. I would expect guidelines describing a process how to pull a module creation through the whole pipeline.
13:22:46 <mattdm> Proposal: Modularity WG to own these guidelines and have the ability to make them approval, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these guidelines is their primary task. ("Module Guidelines Committee" instead of "Modularity WG")
13:23:13 <mattdm> "make them approval". well, fix that wording.
13:23:27 <langdon> jkurik, yes.. that needs to be done too.. but i would say that is the "process" .. but.. hey, "words are hard in fedora"
13:23:29 <mattdm> Proposal: Modularity WG to own these guidelines and have the ability to approve them as official, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these guidelines is their primary task. ("Module Guidelines Committee" instead of "Modularity WG")
13:24:26 <jkurik> mattdm: ack
13:24:27 <langdon> mattdm, i want someone *not* modularity-wg to approve (or final approve).. .we are too close to it..
13:24:32 <langdon> maybe fesco or council
13:24:48 <langdon> like the first set.. then they can maintain it..
13:24:50 <mattdm> FESCo, then.
13:24:57 <bexelbie> I suggest fesco approve it and council just get notified
13:25:06 <mattdm> let me amend proposal
13:25:30 <langdon> mattdm, add in "process"?
13:25:47 <langdon> as well as guidelines? or do you think the word "guidelines" encompasses both?
13:25:49 <robyduck> brb
13:25:50 <mattdm> Proposal: Modularity WG will present these to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these guidelines is their primary task. ("Module
13:25:52 <mattdm> Guidelines Committee" instead of "Modularity WG")
13:26:26 <langdon> I like it..
13:26:47 <langdon> however, my "process" vs "guidelines" question is still open for me
13:26:54 <mattdm> I don't understand that question :)
13:27:24 <langdon> so.. there are two things.. the flowchart for getting a module in to fedora.. and a document that says "this is a good modulemd" ..
13:27:40 <langdon> are those both in "guidelines" or is it "process" & "guidelines"
13:27:48 <mattdm> Those are two separate things
13:27:59 <mattdm> Let's mirror the rpm packaging guidelines as much as possible in form
13:28:05 <mattdm> that is,
13:28:06 <mattdm> https://fedoraproject.org/wiki/Packaging:Guidelines
13:28:10 <mattdm> https://fedoraproject.org/wiki/Packaging:ReviewGuidelines
13:28:23 <mattdm> and
13:28:25 <mattdm> https://fedoraproject.org/wiki/Package_update_HOWTO
13:28:40 <bexelbie> +1 to mirroring the RPM process until it is shown to not make sense
13:28:47 <bexelbie> +1000 to not having this documented in the wiki ...
13:28:49 <bexelbie> #justsayin'
13:29:03 <mattdm> bexelbie: hurry up with your other thing!
13:29:32 <langdon> i guess i was asking .. in your proposal above.. you don't mention the process part.. does the modularity-wg do the same thign to build/make/approve/update the process?
13:29:40 <langdon> not what the process is
13:29:48 <bexelbie> mattdm, you've seen it :)
13:30:02 <jwb> i'm here now.  apologies for being late but had a work meeting
13:30:17 <mattdm> jwb: meetings suck
13:30:37 <jwb> and yet you now have me in another
13:30:38 <mattdm> langdon: whoever is working on the process updates the process, I think
13:30:41 <bexelbie> welcome to our meeting jwb - it doesn't suck
13:30:52 <langdon> well.. it certainly sucks less
13:31:09 <langdon> mattdm, sure.. so put that in the proposal :)
13:31:22 <mattdm> langdon: Are you asking if it needs to be called the Module Guidelines and Process Committee?
13:31:31 <langdon> ha.. no.. one sec
13:31:33 <mattdm> Because I think jwb's head will explode and he JUST showed up
13:31:46 <langdon> Modularity WG to own these guidelines & process and have the ability to update as needed without going to FESCo every time
13:31:50 <langdon> or some such
13:31:54 <mattdm> ah, fine.
13:32:26 <mattdm> Proposal: Modularity WG will present these to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and process and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these guidelines is their primary task.
13:32:27 <mattdm> ("Module Guidelines Committee" instead of "Modularity WG".)
13:32:37 <jwb> "these"?
13:32:45 <langdon> i was just gonna fix that :)
13:32:46 <jwb> oh, guidelines
13:32:49 <langdon> its in the first one
13:32:51 <mattdm> "these" = https://fedoraproject.org/wiki/Module:Guidelines
13:33:04 <jwb> i guess i have a question
13:33:13 <jwb> why would you have to go to FESCo anyway?
13:33:15 <langdon> Proposal: Modularity WG will present guidelines and a process for modules to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and process and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these
13:33:15 <langdon> guidelines is their primary task.
13:33:15 <langdon> <mattdm> ("Module Guidelines Committee" instead of "Modularity WG".)
13:33:23 <langdon> oops.. bad cp
13:33:30 <mattdm> "these guidelines". or "this document". I will take whatever. :)
13:33:38 <langdon> Proposal: Modularity WG will present guidelines and a process for modules to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and process and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these
13:33:38 <langdon> guidelines is their primary task. ("Module Guidelines Committee" instead of "Modularity WG".)
13:34:06 <langdon> one more typo..
13:34:09 <langdon> Proposal: Modularity WG will present guidelines and a process for modules to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and process and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so maintaining these
13:34:09 <langdon> guidelines as their primary task. ("Module Guidelines Committee" instead of "Modularity WG".)
13:34:16 <mattdm> what typo got changed there?
13:34:25 <langdon> is -> as in the last sentence
13:34:53 <langdon> i suppose it might be more style.. in retrospect
13:35:28 <mattdm> jwb: langdon felt more comfortable with the formal approval in that way. initial version of proposal was much shorter :)
13:35:35 <langdon> im happy with that.. despite repeating words somewhat unnecessarily
13:36:05 <langdon> jwb, i don't think the first version of the guidelines & process should be approved by the group that wrote it :/
13:36:37 <langdon> we just need some other group to catch bad assumptions because the WG is very close to the problem
13:36:52 <mattdm> And I think it's more a FESCo thing than council level
13:36:54 <langdon> and mattdm threw fesco under the bus
13:37:08 <langdon> or you could say it his way ;)
13:37:29 <jwb> langdon: oh, the initial fesco thing makes sense i guess
13:37:33 <mattdm> As I said in the scrollback, I think the council just cares that there *are* guidelines and that the basic concept is Fedora-ish
13:37:38 <jwb> langdon: but yeah, long term i like this proposal
13:37:47 <jwb> so +1 with whatever typos fixed
13:38:05 <mattdm> ok. I sense no opposition so I'm going to mark this as approved in the ticket
13:38:09 <bexelbie> +1 to this with typos or without :)
13:38:14 <langdon> +1
13:38:20 <langdon> moar typos!
13:38:31 <mattdm> and langdon since you wrote it last can you "#agreed" it?
13:38:38 <langdon> sure
13:38:51 <langdon> #agreed Proposal: Modularity WG will present guidelines and a process for modules to FESCo for initial approval as a Fedora standard. After that, Modularity WG to own these guidelines and process and have the ability to update as needed without going to FESCo every time, subject to sanity check and possible dispute override by FESCo. In the near future, Modularity WG may be rechartered so
13:38:51 <langdon> maintaining these guidelines as their primary task. ("Module Guidelines Committee" instead of "Modularity WG".)
13:38:56 <langdon> ohh.. but it breaks..
13:39:06 <langdon> i assume zodbot can't fix that?
13:39:15 <bexelbie> it'll be in the logs and the ticket - that is enough :)
13:39:16 <langdon> let me make it two #agreeds
13:39:22 <langdon> ok.. cool
13:39:24 <langdon> next!
13:39:38 <mattdm> #topic create draft page with mission statement, foundations, objectives
13:39:41 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/117
13:39:56 <mattdm> Got feedback from bexelbie.
13:40:26 <mattdm> Would like feedback and approval from the rest of y'all
13:40:41 <mattdm> And, my plan is to use Bex's New Unicorn Doc System to publish ths
13:40:43 <mattdm> this
13:40:58 <mattdm> replacing https://fedoraproject.org/wiki/Overview
13:41:21 <bexelbie> you'll be a good case to write the docs for how to bring stuff over
13:41:22 <mattdm> and everything linked in the "About Fedora" box on that page, basically.
13:41:50 * mattdm looks at rapidly approachign bus bex sent barreling down at me
13:42:15 <bexelbie> don't worry, it is made of marshmallow fluff ... oh wait physics
13:42:41 * mattdm assumes everyone else is reading
13:42:41 <bexelbie> will this close #114?
13:42:57 <langdon> bexelbie, will what close it?
13:43:03 <langdon> ohh 114
13:43:06 <mattdm> yes
13:43:55 <langdon> so shouold we be reading/editing this pre or post unicorn?
13:44:08 * langdon is gonna just start using that phrase all the time
13:44:27 <jkurik> I have no info of the New Unicorn Doc System, but I am +1 to try it
13:44:45 <langdon> jkurik, its NUDS for short ;)
13:44:52 <bexelbie> #info Unicorn: https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/7QCQS6JWXB7ZGKYOKLYYZYRYOE7RAZSF/
13:44:53 <mattdm> read and comment in ticket on substantial changes (or just edit if it's obvious)
13:45:20 <bexelbie> langdon, I believe you should read pre-unicorn - conversion will not be in the next two weeks based on my understanding mattdm and my combined workloads
13:45:50 <langdon> no problem .. just wanted it clearly stated so no one was accidentally waiting
13:46:00 <mattdm> My basic goal is to have it by flock.
13:46:08 <mattdm> yeah don't wait on unicorns
13:46:13 <mattdm> that's a fundamental rule :)
13:46:24 <mattdm> they're fickle by nature
13:47:21 <bexelbie> I thought it was about leapfrog and unicorns ...
13:47:35 <mattdm> I have no idea
13:47:38 <langdon> next?
13:47:46 <mattdm> #info please read and comment. thanks.
13:47:54 <mattdm> #topic What to do with all of the open budget tickets?
13:48:00 * langdon should really leave in the next 5 or so.. prep for next thing
13:48:04 <mattdm> bexelbie I am looking significantly at you
13:48:19 <bexelbie> I believe we should resolve #120
13:48:34 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/120
13:48:39 <mattdm> as in, resolve right now?
13:48:45 <bexelbie> and it will close 113, 108, and 125
13:49:06 <bexelbie> there are issues around mission raised in those that are not related to those tickets - those are resolved by mindshare and our last order of business
13:49:18 <bexelbie> also, I need council votes on unrelated budget ticket 130
13:49:39 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/130
13:49:42 <bexelbie> #120 resolution should be $9K/region per our discussion at the FAD
13:50:04 <mattdm> #info Council please vote on GSoC funding ticket
13:50:19 <mattdm> bexelbie: Yeah, I thought we agreed on that. What more to do?
13:50:21 <bexelbie> #130 is non-public for now ... for those reading - for transparency reasons it will be made public as soon as the unresolved issue inside of it is resolved one way or the other
13:50:56 <bexelbie> #130 had questions - they were answered - are there others?  It'd be great to see more +1s (or even unamity :P)
13:51:10 <bexelbie> more important is the #120, 113, 108, 125 chain
13:51:16 <bexelbie> the other will lazy consensus out
13:51:48 <mattdm> bexelbie: What do you need from the rest of us on that chain?
13:51:49 * langdon will set some time aside to read tickets tonight..
13:52:00 * langdon has to jet
13:52:07 <mattdm> bye langdon
13:52:12 <bexelbie> proposed: Allocation of $3000 per region per quarter for Q2-4 for resolution of #120
13:52:26 <mattdm> I think we entirely lost robyduck too :(
13:52:40 <mattdm> bexelbie: I have the strong belief that we already okayed that at the FAD
13:52:46 <mattdm> but I will +1 it again for the record
13:53:02 <bexelbie> proposed close #113, 108, 125 as resolved by #120 and encourage mission/policy questions to go to Council in a non-budget ticket or to Mindshare
13:53:08 <bexelbie> mattdm, we have no public record of that decision :)
13:53:18 <bexelbie> it was not in our outbound reporting on purpose
13:53:40 <bexelbie> but if people think it is done, I'll take the actions outline above? #agreed
13:53:41 <bexelbie> ?
13:53:49 <mattdm> bexelbie: oh, ok. Let's go ahead and make it formal
13:53:57 <nb> ?
13:54:08 <mattdm> I think we've lost too many people from this meeting at this point so we should probably take it to the ticket
13:54:10 <mattdm> nb go ahead
13:54:22 <bexelbie> ok, I'll amend #120
13:54:23 <nb> so this is 3000 per region per quarter, but I think someone mentioned that we can ask for more funding if we have speccific things we wnat to do that we don't have budget for, is this correct?
13:54:32 <bexelbie> nb, correct
13:54:34 <mattdm> nb exactly
13:54:39 <nb> ok, thanks
13:54:50 <mattdm> because obviously 3k doesn't go very far
13:55:06 <bexelbie> well, technically it depends on the cost of gas ... but yeah
13:55:09 <bexelbie> :P
13:55:14 <mattdm> #info bexelbie to update ticket #120, rest of chain to follow from that :)
13:55:24 <mattdm> #topic What to do with all of the open CoC / community practices tickets?
13:55:26 <bexelbie> #info council to cast votes in #120 :)
13:55:40 <mattdm> oops sorry got ahead of you
13:55:44 <bexelbie> no worries
13:55:51 <mattdm> but anyway, my proposal here is to basically devote an upcoming meeting to this
13:55:58 <mattdm> because it's no fun but we do need to respond
13:56:03 <bexelbie> yes
13:56:09 <bexelbie> we need to schedule a closed meeting for it though
13:56:17 <bexelbie> maybe we can do a video-conference?
13:56:22 <mattdm> #info We'll devote an upcoming closed meeting to this.
13:56:27 <mattdm> possibly yeah
13:56:43 <mattdm> or that Seychelles thing
13:56:59 <bexelbie> I believe Seychelles means closed meeting ...
13:57:12 <mattdm> #topic Upcoming elections
13:57:18 <mattdm> jkurik: oh yeah also, welcome back :)
13:57:26 <mattdm> We have one seat up for election, right?
13:57:33 <jkurik> right
13:57:58 <mattdm> #info It's Langdon's seat :)
13:58:17 <jkurik> btw: the elections are already running (not upcoming) :)
13:58:19 <mattdm> anything in particular to note here in the last minute?
13:58:26 <mattdm> ah, that's a good note. :)
13:58:57 <mattdm> #link https://fedoraproject.org/wiki/Council/Nominations
13:59:10 <jkurik> so far no issues with elections, nothing else from my side atm
13:59:16 <mattdm> jkurik: thanks!
13:59:50 <mattdm> No time left for open floor... take any other issues to the list or tickets!
13:59:53 <mattdm> thanks everyone!
13:59:56 <mattdm> #endmeeting