dotnet
LOGS
14:00:57 <Rhea> #startmeeting Fedora DotNet (2017-07-20)
14:00:57 <zodbot> Meeting started Thu Jul 20 14:00:57 2017 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:57 <zodbot> The meeting name has been set to 'fedora_dotnet_(2017-07-20)'
14:01:00 <Rhea> #meetingname dotnet
14:01:00 <zodbot> The meeting name has been set to 'dotnet'
14:01:03 <Rhea> #nick dotnet
14:01:31 <Rhea> #topic Agenda
14:01:33 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_latest
14:01:36 <Rhea> #info (1) Roll Call
14:01:39 <Rhea> #info (2) Announcements
14:01:42 <Rhea> #info (3) Action items and Tickets
14:01:46 <Rhea> #info (4) Packaging progress / Open Floor discussion
14:01:48 <Rhea> #topic Roll Call
14:01:58 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
14:02:00 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
14:02:04 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
14:03:21 <omajid> hello!
14:03:28 <aslice> Andrew Slice; EDT; C#, C++, Perl
14:03:38 <Rhea> #chair aslice omajid axels pcreech
14:03:38 <zodbot> Current chairs: Rhea aslice axels omajid pcreech
14:03:55 <aslice> .hello
14:03:57 <zodbot> aslice: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
14:04:04 <pcreech> .hello pcreech17
14:04:05 <zodbot> pcreech: pcreech17 'Patrick Creech' <pcreech@redhat.com>
14:04:06 <aslice> .hello aslice
14:04:08 <Rhea> Yeah I don't have too much time either, i'm in a bit less frequent bluejeans at 16:30
14:04:08 <zodbot> aslice: aslice 'Andrew Slice' <andrew.slice@redhat.com>
14:04:16 <axels> .hello axels
14:04:17 <zodbot> axels: axels 'None' <axel@redhat.com>
14:04:26 <Rhea> #topic Announcements
14:04:29 <Rhea> Anything to announce?
14:05:22 <Rhea> #info === "Rider Release Candidate: performance, refactorings, Unity and more!" ===
14:05:24 <Rhea> #link https://blog.jetbrains.com/dotnet/2017/07/14/rider-release-candidate-performance-refactorings-unity/
14:06:41 <Rhea> I've got also a... http://fedoraloves.net to bring to your attention, where you can also point people to our mailing list using http://list.fedoraloves.net etc...
14:07:05 <axels> I love that url :D
14:07:16 <Rhea> Submit subdomain ideas you would find useful via smoke signals to me...
14:07:56 <Rhea> When the domain is OK'ed by the council I'll jump on tshirts and stickers themed as hearts and dotnets o.o (similar to redhatloves.net design)
14:08:16 <aslice> I'm concerned about the security of smoke-signal based communications. Can we use Esperanto as an intermediary layer to help with that?
14:08:27 <Rhea> Hopefully we will have all kinds of cool stuffs AND a package with 2.0 :]
14:08:32 <axels> But.. but.. muh AES encrypted smoke signals o.o
14:08:40 <Rhea> errr i no speek esperanto
14:08:53 <aslice> No one does. That's why it works for security.
14:09:07 <aslice> mumblemubmlesecuritythroughobscuritymumblemumble
14:09:20 <Rhea> o.o
14:09:51 <Rhea> Sooo next... spamtickets
14:09:58 <Rhea> #topic Action items and Tickets
14:10:00 <Rhea> #link https://meetbot.fedoraproject.org/teams/dotnet
14:10:03 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
14:10:06 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
14:10:10 <Rhea> #info === [WIP] developer.fedoraproject.org update #17 ===
14:10:14 <Rhea> #link https://pagure.io/fedora-dotnet/issue/17
14:10:20 <Rhea> #link https://github.com/Fedora-dotnet/developer-portal-content
14:10:28 <Rhea> #info === [wip] axels - finish the dev portal formatting and... stuff! ===
14:10:45 <axels> Finished!
14:10:56 <Rhea> Well finished but needs to be added moar stuff into it
14:11:06 <axels> Hmm
14:11:09 <axels> Like what?
14:11:25 <axels> You mentioned splitting each section into it's own page right?
14:11:46 <Rhea> So basically as i already mentioned, worded stuff that's not pure documentation. Example "the difference between dotnet build and publish is... and you can publish targetting specific stuffa, or as standalone, where the difference is........."
14:12:14 <axels> Ah, right
14:12:19 <axels> Okay, I'll get on that
14:12:21 <Rhea> And also "dotnet run will first compile your project and then run it, or if supplied with path to dll it will do this instead..."
14:12:40 <axels> Alrighty
14:12:42 <Rhea> I don't know what else there could be, I don't exactly remember what did i want in the very beginning, some kind of text to start with.
14:13:07 <Rhea> #action axels - continue improving the dotnet-usage dev portal page
14:13:14 <Rhea> #info === [COMPLETE] omajid to email Matt regarding the use of "MSDrop" ===
14:13:25 <axels> I'll write something down and show it to you
14:14:11 <Rhea> #info We can use the source we used for RH package to work with til 2.0 release. Tracking ticket for our next steps and packaging efforts: https://pagure.io/fedora-dotnet/issue/19
14:14:28 <pcreech> \o/
14:15:43 <Rhea> #action Rhea - create dev portal pages with example systemd service for ASP.NET Core, and example Apache/NGINX proxy
14:15:51 <Rhea> #undo
14:15:51 <zodbot> Removing item from minutes: ACTION by Rhea at 14:15:43 : Rhea - create dev portal pages with example systemd service for ASP.NET Core, and example Apache/NGINX proxy
14:15:55 <Rhea> #action Rhea - create dev portal pages with example systemd service for ASP.NET Core, and example Apache/NGINX proxy configuration
14:16:01 <Rhea> #topic Packaging progress / Open Floor discussion
14:16:13 <Rhea> There, ligning fast part of the meeting done...
14:16:47 <Rhea> I have to admit that I've no idea what now, I'm really messy after this last week and did not have time to catch up yet.
14:17:04 <aslice> How did the presentation go?
14:17:05 <Rhea> We've got the source in the above linked ticket, we can start trying to play with it.
14:17:22 <omajid> i built it on fedora 25. plan to upgrade to 26 soon and will retry
14:17:28 <Rhea> omajid: do you have / could you write some simple instructions in the ticket if you have some time?
14:17:35 <Rhea> So anyone can fiddle with it?
14:17:45 <omajid> its a simple extract + ./build.sh
14:17:47 <omajid> but sure
14:17:52 <Rhea> Someone could also try arm but... doubt that's gonna work...
14:18:09 <omajid> i am fairly sure even i686 is not going to work :D
14:18:10 <pcreech> omajid: is that from the ms provided source?
14:18:15 <omajid> pcreech: yup
14:18:16 <Rhea> heh
14:18:21 <pcreech> Interesting...
14:18:23 <pcreech> \o/
14:18:57 <omajid> i will ask them to open up their github repo
14:19:03 * pcreech will play with that on his f26 machine later today
14:19:36 <omajid> pcreech: please share any build issues
14:20:18 <pcreech> omajid: will do
14:21:48 <Rhea> Okay so we can start fiddling with it...
14:22:44 <Rhea> #action omajid - write down brief instructions / guide to building and testing in the ticket #19
14:23:16 <Rhea> aaaand on that note, we can call it today? Anyone anything to add?
14:23:55 * omajid doesnt have anything
14:24:07 <Rhea> I can mention that I'll be setting up a bot to bridge our fedora channel with discord which axels and myself use and chat in sometimes...
14:24:38 <axels> I've been using the bot very successfully these past couple of day btw :D
14:24:45 <axels> It's really good
14:25:25 <axels> But, I'd suggest making another irc-general channel on Discord for the bot
14:28:03 <Rhea> Well it's just dotnet-sig here with dotnet-sig there...
14:28:18 <Rhea> ANyway got to go (as you can see already distracted)
14:28:21 <Rhea> See you <3
14:28:24 <Rhea> #endmeeting