fesco
LOGS
16:00:06 <jforbes> #startmeeting FESCO (2017-07-14)
16:00:06 <zodbot> Meeting started Fri Jul 14 16:00:06 2017 UTC.  The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:06 <zodbot> The meeting name has been set to 'fesco_(2017-07-14)'
16:00:06 <jforbes> #meetingname fesco
16:00:06 <zodbot> The meeting name has been set to 'fesco'
16:00:06 <jforbes> #chair maxamillion dgilmore jwb nirik jforbes jsmith kalev sgallagh Rathann
16:00:06 <zodbot> Current chairs: Rathann dgilmore jforbes jsmith jwb kalev maxamillion nirik sgallagh
16:00:06 <jforbes> #topic init process
16:00:17 <sgallagh> .hello sgallagh
16:00:17 <jsmith> .hello jsmith
16:00:17 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:00:20 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:00:21 <contyk> .hello psabata
16:00:23 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
16:01:09 * jreznik is around
16:01:44 <jforbes> Will see if we have enough for quorum today, I know several said they were out this week
16:02:44 <maxamillion> .hello maxamillion
16:02:45 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:04:44 <sgallagh> jforbes: We may still have effective quorum for most decisions
16:04:50 <sgallagh> jsmith and jwb both voted in tickets
16:04:59 <maxamillion> jillysciarilly: Jill Jubs?
16:05:02 <jforbes> point
16:06:22 <jforbes> Okay, I suppose let's start with the issues jwb voted on (jsmith is here). If another person shows up we can cover others as well
16:07:03 <jforbes> #topic #1738 - F27 System Wide Change: 32 bit UEFI Support
16:07:03 <jforbes> .fesco 1738
16:07:04 <jforbes> https://pagure.io/fesco/issue/1738
16:07:05 <zodbot> jforbes: Issue #1738: F27 System Wide Change: 32 bit UEFI Support - fesco - Pagure - https://pagure.io/fesco/issue/1738
16:07:28 <jsmith> +1 from me
16:07:30 <jforbes> I am +1 on this
16:07:37 <maxamillion> +1
16:07:47 <sgallagh> +1
16:08:16 <jforbes> #agreed F27 System Wide Change: 32 bit UEFI Support is approved (+5,0,-0)
16:08:42 <jforbes> #topic #1739 - F27 System Wide Change: Drop 256term.sh
16:08:43 <jforbes> .fesco 1739
16:08:43 <jforbes> https://pagure.io/fesco/issue/1739
16:08:44 <zodbot> jforbes: Issue #1739: F27 System Wide Change: Drop 256term.sh - fesco - Pagure - https://pagure.io/fesco/issue/1739
16:09:08 <jforbes> +1 here as well
16:09:15 <maxamillion> +1
16:09:57 <jsmith> +1
16:10:30 <sgallagh> +1
16:10:45 <jforbes> #agreed F27 System Wide Change: Drop 256term.sh is approved (+5,0,-0)
16:11:12 <jforbes> #topic #1740 - F27 System Wide Change: The GNU C Library version 2.26
16:11:12 <jforbes> .fesco 1740
16:11:12 <jforbes> https://pagure.io/fesco/issue/1740
16:11:13 <zodbot> jforbes: Issue #1740: F27 System Wide Change: The GNU C Library version 2.26 - fesco - Pagure - https://pagure.io/fesco/issue/1740
16:11:19 <jforbes> +1
16:11:29 <sgallagh> +1
16:11:37 <maxamillion> +1
16:13:35 <jsmith> +1
16:13:37 <jforbes> #agreed F27 System Wide Change: The GNU C Library version 2.26 is approved (+5,0,-0)
16:13:40 <jforbes> #topic #1741 - F27 System Wide Change: Graphical Applications as Flatpaks
16:13:41 <jforbes> .fesco 1741
16:13:41 <jforbes> https://pagure.io/fesco/issue/1741
16:13:44 <zodbot> jforbes: Issue #1741: F27 System Wide Change: Graphical Applications as Flatpaks - fesco - Pagure - https://pagure.io/fesco/issue/1741
16:14:40 <jforbes> I am +1, but jsmith was wanting to hear from releng first. They haven't chimed in
16:14:46 <maxamillion> it's going to be a lot of work to accomplish, but I'm not inclined to block the change just because of that ... I mostly wanted to note that it's going to be a lot of work (and there's already a lot of moving parts going on right now in the f27 cycle because of modularity, CI, and Factory 2.0)
16:14:47 <sgallagh> I'm of two minds on this. I think we definitely need to get the gears moving on supporting Flatpaks better in Fedora
16:15:01 <sgallagh> On the other hand, I'm wary of upgrades switching from RPMs to a flatpak
16:15:48 <jforbes> Perhaps defer this one until releng has had a chance to chime in and we have more discussion?
16:15:49 <jsmith> Proposal: Defer to next meeting to get more discussion
16:15:59 <jforbes> jsmith +1
16:16:02 <sgallagh> Yeah, I think that's reasonable
16:16:07 <sgallagh> jsmith: +1
16:16:23 <maxamillion> jsmith: +1
16:17:00 <jforbes> #agreed F27 System Wide Change: Graphical Applications as Flatpak deferred a week for further discussion
16:17:18 <jforbes> #topic #1742 - F27 Self Contained Change: Improved Bay- and Cherry-Trail device support
16:17:18 <jforbes> .fesco 1742
16:17:18 <jforbes> https://pagure.io/fesco/issue/1742
16:17:20 <zodbot> jforbes: Issue #1742: F27 Self Contained Change: Improved Bay- and Cherry-Trail device support - fesco - Pagure - https://pagure.io/fesco/issue/1742
16:17:27 <jsmith> +1
16:17:31 <jforbes> +1 here, not sure this really needed approval
16:17:31 <sgallagh> +1
16:17:52 <maxamillion> +1 - also not sure this needed a Change filed, but it's nice to get transparency on things either way
16:18:22 <jforbes> #agreed F27 Self Contained Change: Improved Bay- and Cherry-Trail device support is approved (+5,0,-0)
16:18:37 <jforbes> Okay, that was all we had jwb votes on
16:18:55 <jforbes> And without quorum we can't go further.
16:19:15 <jforbes> #topic Next week's chair
16:19:19 <jforbes> Any takers?
16:19:23 <sgallagh> I'll take it
16:19:26 <maxamillion> sgallagh: +1
16:19:31 <jsmith> I'll be out next week, but would be happy to take the week after next
16:19:34 <jforbes> #info sgallagh to chair next week
16:19:55 <jforbes> #info jsmith volunteered for the week after as he is out next week
16:20:05 <jforbes> Thanks guys!
16:20:05 <jsmith> sgallagh: Please remind me that I volunteered for the next meeting, if you would please ;-)
16:20:17 <jforbes> #topic Open Floor
16:20:18 <contyk> well, that was quick :)
16:20:20 <sgallagh> I'll see what I can do
16:20:26 <jsmith> sgallagh: I appreciate it :-)
16:20:29 <jforbes> contyk: without quorum we were a bit restrained
16:20:51 <Rathann> hi
16:21:26 <Rathann> sorry for being late
16:21:40 <Rathann> this time isn't working well for me
16:21:49 <jforbes> Well, that gives us quorum, should we go through the other issues?
16:22:30 <maxamillion> I'm in
16:22:50 <jreznik> if you won't make the rest change tickets today, please make sure it's on the next meeting agenda - especially for system wide change
16:22:52 <contyk> :)
16:22:58 <jforbes> Okay
16:23:13 <jforbes> #topic #1729 - F27 System Wide Change: Host and Platform
16:23:14 <jforbes> .fesco 1729
16:23:14 <jforbes> https://pagure.io/fesco/issue/1729
16:23:15 <jreznik> I'm sorry for not tagging it to meeting, I don't have permissions so I bet on you :)
16:23:15 <zodbot> jforbes: Issue #1729: F27 System Wide Change: Host and Platform - fesco - Pagure - https://pagure.io/fesco/issue/1729
16:23:28 <sgallagh> jreznik: We should figure out how to give you that privilege
16:23:45 <sgallagh> When you're subbed in, at least
16:23:50 <jforbes> jreznik: that's my fault too, when I have chaired in the past, it seems someone usually did that, so I didn't know I needed to
16:24:22 <jreznik> sgallagh: it's one more week, so I think it's enough if someone with permission does it before meeting
16:24:50 <maxamillion> so this one is interesting
16:27:26 <jsmith> Indeed...
16:27:50 <jsmith> Seems like a lot to swallow for F27, but I don't have a good gauge on the real amount of effort necessary to pull this off in the F27 timeframe
16:28:03 <jsmith> (or whether it can be reasonably split into F27/F28 chunks)
16:28:45 <maxamillion> jsmith: so I think a lot of this is just a progression of the modularity group and afaik some of the proposal here has been proven out with the F26 Boltron project ... so I'm not sure what all is needed to drag this across the finish line
16:28:50 <maxamillion> I'll have to read more about it
16:28:56 <jsmith> And I haven't seen any discussion on the mailing list...
16:29:20 <Rathann> indeed
16:29:42 <Rathann> after skimming through it, I find it reasonable
16:29:48 <jsmith> Proposal: Invite change owners to our next meeting, and hope for more mailing list discussion between now and then
16:30:01 <contyk> it's largely a content change, about the structure of a modular release
16:30:08 <contyk> rearranging components between modules
16:30:14 <sgallagh> The change owners are at this meeting :)
16:30:17 <contyk> o/
16:30:29 <jsmith> Oh, sorry -- didn't recognize the IRC nick
16:30:37 * contyk doesn't attend often
16:30:49 <jsmith> So, contyk, can you give us a quick run-down on what work is needed to push this across the finish line?
16:31:15 <contyk> we have a working concept of the (very) base system in f26 boltron -- the base runtime
16:31:23 <Rathann> and why there's no contingency plan
16:31:40 <contyk> the work here will be splitting it into two sets, one tied to hardware enablement, the other to the rest of the userspace
16:32:13 <contyk> the userspace part is meant to be more useful to module developers than base-runtime was, so we'll be including components that ended up in some of the shared modules in f26, such as shared-userspace
16:32:22 <contyk> we have tools and reasonably good ideas of what should go where
16:32:50 <contyk> we'll base our depsolving on rawhide for the moment but will rebase the set continuously as needed
16:33:06 <contyk> I wouldn't expect any major complications in the process
16:33:34 <jforbes> So it seems a lot of the real work is done, it now boils down to fine tuning the contents of each?
16:33:41 <contyk> more or less
16:33:53 <jsmith> Given the time constraints of the F27 schedule, I would like to know what the contingency plan is, and what RelEng's level of comfort is
16:34:40 <contyk> if the modular release change proposal is accepted and we somehow fail to deliver this split, we could build the base-runtime module for f27 again
16:35:18 <jforbes> Right, the next 2 tickets fall in with this
16:35:30 <contyk> release engineering was involved mainly in the creation of the "bootstrap" module tag for f27 and tagging secure-boot packages into it, as well as configuring it so that it can be used for image builds
16:35:44 <contyk> all of that has been implemented already
16:36:33 <jsmith> OK, I guess you've convinced me -- I'm +1 for this change
16:37:16 <jforbes> I am +1 as well, the scope seems large, but I think a lot of the hard part is done
16:37:44 <contyk> we also have quite a few people working on it :)
16:38:15 <contyk> this is really on behalf of the modularity wg
16:38:28 <jsmith> sgallagh, maxamillion, Rathann: Thoughts?
16:38:53 <sgallagh> I'm biased, as I'm one of those many people.
16:39:00 <Rathann> +1
16:39:02 <sgallagh> But obviously +1 from me :)
16:39:20 <maxamillion> yeah, I'm generally +1
16:39:31 <contyk> awesome, thanks
16:39:46 <jforbes> #agreed  F27 System Wide Change: Host and Platform is approved (+5,0,-0)
16:40:01 <jforbes> #topic #1730 - F27 System Wide Change: Modular Release
16:40:02 <jforbes> .fesco 1730
16:40:02 <jforbes> https://pagure.io/fesco/issue/1730
16:40:03 <zodbot> jforbes: Issue #1730: F27 System Wide Change: Modular Release - fesco - Pagure - https://pagure.io/fesco/issue/1730
16:40:41 <sgallagh> By the same justification as the previous ticket, +1
16:40:57 <maxamillion> +1
16:41:57 <jforbes> +1 here too
16:42:23 <jsmith> +1
16:43:33 <jforbes> Rathann?
16:44:06 <Rathann> looks good, +1
16:44:27 <jforbes> #agreed  F27 System Wide Change: Modular Release is approved (+5,0,-0)
16:44:41 <Rathann> looking forward to working through the Module Guidelines in FPC
16:44:45 <jforbes> #topic #1731 - F27 System Wide Change: Modular Server
16:44:45 <jforbes> .fesco 1731
16:44:45 <jforbes> https://pagure.io/fesco/issue/1731
16:44:46 <zodbot> jforbes: Issue #1731: F27 System Wide Change: Modular Server - fesco - Pagure - https://pagure.io/fesco/issue/1731
16:44:52 <contyk> Rathann: ha
16:44:55 <jsmith> +1, by the same logic
16:45:01 <sgallagh> +1
16:45:21 <jforbes> +! as well
16:45:25 <jforbes> +1 even
16:45:47 <Rathann> +1
16:45:56 <ignatenkobrain> .hello ignatenkobrain
16:45:57 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <ignatenko@redhat.com>
16:46:52 <jforbes> maxamillion?
16:48:00 <maxamillion> +1
16:48:02 <maxamillion> jforbes: sorry
16:48:10 <jforbes> #agreed F27 System Wide Change: Modular Server is approved (+5,0,-0)
16:48:22 <jforbes> #topic #1732 - F27 Self Contained Change: Remove SSH-1 from OpenSSH clients
16:48:23 <jforbes> .fesco 1732
16:48:23 <jforbes> https://pagure.io/fesco/issue/1732
16:48:26 <zodbot> jforbes: Issue #1732: F27 Self Contained Change: Remove SSH-1 from OpenSSH clients - fesco - Pagure - https://pagure.io/fesco/issue/1732
16:49:19 <jsmith> +1 from me
16:49:20 <maxamillion> +1
16:49:22 <jsmith> Seems smart
16:49:41 <sgallagh> +1 Kill it with fire
16:50:07 <jforbes> +1
16:50:10 <Rathann> +1
16:50:34 <jforbes> #agreed F27 Self Contained Change: Remove SSH-1 from OpenSSH clients is approved (+5,0,-0)
16:50:51 <jforbes> #topic #1733 - F27 Self Contained Change: Samba AD
16:50:51 <jforbes> .fesco 1733
16:50:51 <jforbes> https://pagure.io/fesco/issue/1733
16:50:52 <zodbot> jforbes: Issue #1733: F27 Self Contained Change: Samba AD - fesco - Pagure - https://pagure.io/fesco/issue/1733
16:52:06 <jsmith> +1 from me... seems reasonable
16:52:32 <jforbes> +1 here
16:52:32 <sgallagh> +1
16:52:40 <maxamillion> +1
16:53:52 <jforbes> Rathann?
16:54:16 <Rathann> right, I reviewed this before
16:54:17 <Rathann> +1
16:54:22 <jforbes> #agreed F27 Self Contained Change: Samba AD is approved (+5,0,-0)
16:54:33 <jforbes> Okay, that was all I believe
16:54:39 <jforbes> #topic open floor
16:55:38 <jforbes> If no one has anything, I will close in 2 minutes
16:56:11 <Rathann> nothing from me, thanks
16:57:39 <jforbes> #endmeeting