infrastructure
LOGS
18:00:37 <smooge> #startmeeting Infrastructure (2017-05-18)
18:00:37 <zodbot> Meeting started Thu May 18 18:00:37 2017 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:37 <zodbot> The meeting name has been set to 'infrastructure_(2017-05-18)'
18:00:37 <smooge> #meetingname infrastructure
18:00:37 <zodbot> The meeting name has been set to 'infrastructure'
18:00:37 <smooge> #topic aloha
18:00:37 <smooge> #chair smooge relrod nirik abadger1999 dgilmore threebean pingou puiterwijk pbrobinson
18:00:37 <zodbot> Current chairs: abadger1999 dgilmore nirik pbrobinson pingou puiterwijk relrod smooge threebean
18:00:42 <smooge> Hello everyone
18:00:46 <nirik> morning
18:00:49 <marc84> hi
18:00:51 <clime> hey
18:00:54 <puiterwijk> hi
18:00:55 <axk4545> o/
18:01:12 * relrod_ here
18:01:15 <Skeer> hi
18:01:21 <pingou> o/
18:01:41 * cverna here
18:01:42 <smooge> #topic New folks introductions
18:01:49 <smooge> Hi do we have any new people?
18:02:09 <skamath> Hi. Not new around here but I was looking to join the team again :)
18:02:17 <skamath> Was a bit busy with my academics.
18:03:18 <Skeer> WB ;)
18:03:22 <smooge> hello skamath
18:03:30 * skamath waves to smooge
18:03:34 <smooge> ok onto our next item
18:03:49 <smooge> #topic announcements and information
18:03:49 <smooge> #info we are now in f26 Beta freeze - everyone
18:03:49 <smooge> #info freeze rules are outlined here: https://docs.pagure.org/infra-docs/sysadmin-guide/sops/fedora-releases.html
18:03:49 <smooge> #info fmn 1.2 pushed to prod on Monday, only minor bumps - jcline
18:03:50 <smooge> #info bodhi-2.7.0 beta in staging (at least until freeze ends) and copr - bowlofeggs
18:03:51 <smooge> #info dist-git 1.0 in staging
18:04:05 <smooge> So as it says on the tin, we are in freeze
18:04:33 <puiterwijk> #info we have an openshift cluster in staging after last week. Will likely be rebuilt another 42 times though
18:05:09 <nirik> #info serveral new pagure releases out the last few days.
18:05:38 <nirik> hopefully we can stablize pagure and get it performant again... its locking up has been anoying to everyone. ;(
18:06:15 <puiterwijk> nirik: I'll be working on that tonight
18:06:41 <axk4545> nirik: what was the load in terms of users when it started acting up?
18:06:49 <puiterwijk> axk4545: it's not load
18:06:52 <smooge> #info everyone is a bit tired and cranky. please be patient, explain clearly any problems, wait and listen for answers and take deep breaths
18:07:06 <nirik> it's locking or threading issues... anytime it can get hit...
18:07:09 <puiterwijk> The locking mechanism I built yesterday does not work as intended
18:07:21 <puiterwijk> Or well, it works too well I guess...
18:07:41 <axk4545> ok. fair enough :)
18:07:42 <nirik> also theres libgit2 improvements we had long ago that would be nice to re-add (to make things faster)
18:07:52 <puiterwijk> Anyway, as said, I'll be working on that as soon as I get the flock reg stuff working.
18:08:11 * axk4545 nods
18:08:21 <clime> puiterwijk: let me know if you would like some assistence
18:08:49 <puiterwijk> clime: well, I know what to do. So as soon as I get to it, I'll be doing that
18:08:59 <puiterwijk> For more info, we can continue in #fedora-apps after the meeting
18:09:19 * axk4545 nods
18:09:30 <puiterwijk> Just wanted to let people know it's on my prio list
18:10:38 <smooge> ok anything else ?
18:10:55 <smooge> #topic Recap of 2017 CI/Infrastructure hackfest - kevin
18:11:18 <nirik> So, I wanted to go over the hackfest we had last week and let anyone ask questions, etc.
18:11:27 <nirik> I had a blog post with all I could recall. ;)
18:11:38 <Skeer> Whats teh url to your blog?
18:11:51 <nirik> https://www.scrye.com/wordpress/nirik/2017/05/15/ci-and-infrastructure-hackfest-2017/
18:11:57 <Skeer> ty
18:11:59 <nirik> basically to hit the highlights:
18:12:17 <nirik> * we setup a openshift cluster in staging... still needs more work, but we made a lot of progress.
18:12:44 <nirik> * There was a bunch of work on CI/testing frameworks so we could have CentOS ci test fedora packages and get results back
18:12:59 <nirik> * puiterwijk filled everyone in on auth setup and debugging and application writing.
18:13:15 <axk4545> puiterwijk++
18:13:25 <nirik> Then a bunch of smaller things:
18:13:46 <nirik> * We might be moving our servers around in our main datacenter later this year... still in planning tho
18:14:20 <nirik> * We will pobibly be slicing up our storage volumes some soon to possibly take advantage of new storage setups later this year
18:14:58 <nirik> * postgres BDR is going to be on a per app basis and we will look at what makes sense to move when
18:15:23 <nirik> * some qa stuff might move to our private cloud once we reinstall it in coming months.
18:15:41 <nirik> All these things will generate tickets and discussion closer to when they happen. :)
18:15:54 <nirik> as always folks are welcome to chime in anytime with feedback on things.
18:16:48 <nirik> I think thats all I had on it... any questions? or other folks there want to add anything else I missed?
18:17:01 <Skeer> Sounds like alot of fun work
18:17:27 <smooge> that sounds like everything
18:17:39 <smooge> #topic Apprentice work day next week (2017-05-23) - kevin
18:17:44 <smooge> your turn again kevin
18:17:58 <nirik> yeah, we talked about doing an apprentice work day next week...
18:18:05 <nirik> I don't know that we decided a topic...
18:18:13 * nirik looks for the mailing list theread
18:18:16 <nirik> thread even
18:18:54 <nirik> https://lists.fedoraproject.org/archives/list/infrastructure@lists.fedoraproject.org/
18:18:57 <nirik> oops
18:19:18 <nirik> https://lists.fedoraproject.org/archives/list/infrastructure@lists.fedoraproject.org/message/FDVIH6OYJ5F6T24YP5UVCHXMJSICYFJ6/
18:20:04 <nirik> Ideas were: unloved app day (try and work on some of our apps that don't get much attention), ansible cleanup day, or something else...
18:20:55 <smooge> since we are in freeze wouldn't ansible cleanup day be more possible?
18:21:18 <axk4545> nirik: in the something else vein I think triage and issue cleanup might be good.
18:21:50 <nirik> smooge: possibly less possible, since we dont't want to mess up freeze.
18:22:09 <x3mboy> o/
18:22:11 <x3mboy> Hi
18:22:18 <x3mboy> A little late maybe
18:22:18 <nirik> axk4545: sure, thats an option... there's some apps we have that have a ton of issues...
18:22:25 <x3mboy> .fas x3mboy
18:22:26 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
18:22:31 <nirik> hey x3mboy
18:22:37 <x3mboy> nirik, o/
18:23:28 <capitanocrunch> what about moving stages ip ?
18:23:38 <smooge> nirik, well I was thinking maybe we could the cleanup in a git branch ? [I have probably started the OMG PTSD :)]
18:23:43 <nirik> capitanocrunch: we could do those yeah...
18:24:06 <nirik> smooge: we could, but it would diverge pretty quickly...
18:24:43 <smooge> nirik, its a freeze, there should be no divergence *cough* *cough*
18:24:51 <puiterwijk> hah
18:25:01 <smooge> but yeah unloved apps sounds good
18:25:04 <nirik> we could also decide on list I suppose... or just make it unfocused and work on lots of various things.
18:25:29 <axk4545> so maybe we just do a triage and unloved apps since that is unaffected by freeze
18:25:35 * nirik will try and clear his schedule to be available all day in #fedora-admin to help folks work on things.
18:25:47 <marc84> +1
18:25:48 <cverna> which apps are unloved :p
18:26:36 <nirik> just off the top of my head: askbot, packages,
18:27:19 <Skeer> What kind of requirements are needed to hel with that?  I mean I assume coding...
18:28:20 <smooge> well it would be: 1) choose an app (this is on us), 2) go through all the tickets for that app, 3) triage those tickets down to "can this be fixed", "who fixes it"
18:28:37 <nirik> well, for packages: we could triage bugs (that doesn't need much requirements), possibly get it to run on rhel7 instead of 6 (packaging work), do a new release (might need some coding), add tests (might need coding)
18:29:05 <axk4545> ooh packaging
18:30:25 <cverna> for askbot there is some packaging too, we need a newer version of django
18:30:29 <Skeer> fair enough.. so could be things for 'erebody
18:30:41 <nirik> Skeer: yep. Hopefully so...
18:30:54 <nirik> we could also work on getting all the infra-docs PR's updated and merged up...
18:30:58 <x3mboy> Some noc job? sysadmin, bash-scripting? Networking?
18:31:07 <x3mboy> No?
18:31:53 <jcline> nirik, it's on today's todo list for me
18:32:17 <nirik> There's some nagios checks that would be good to add... I dont think there's likely to be much one off scripting or noc stuff since we are in freeze...
18:32:34 <axk4545> x3mboy: may be kinda hard with apprentice access too
18:32:35 <nirik> jcline: which? infra-docs?
18:32:53 <jcline> Yeah, infra-docs. Sorry for not qualifying :)
18:32:57 <x3mboy> axk4545, yea, I supose that
18:33:26 <marc84> nirik is there any python related stuff
18:33:30 <handles> Hi everyone, sorry i was 6mins late to this meeting (4am in AUS)i joined this community about a week ago. Ill lurk in the background before jumping in and contributing. keen to get inolved in desbribed work tho :) ^
18:33:45 <Skeer> May 24th still the day?
18:33:58 <x3mboy> handles, normally we all start that way. Welcome!
18:34:14 <smooge> Skeer, I thought it was 2017-05-23
18:34:25 <nirik> marc84: likely... packages and askbot (and most of our apps) are python based... so likely to be some work there if you want. ;)
18:34:36 <marc84> nirik: thanks
18:34:45 <Skeer> smooge:  the last archive link nirik pasted was the 24th.  But IDC either way.
18:34:52 <handles> @x3mboy thanks :) my bad, i didnt want to but in once the meeting was rolling...
18:34:59 <nirik> 23rd or 24th both are fine with me.
18:35:07 <x3mboy> Well, I set a new goal for this month: Beat my monthly tag record!
18:35:19 <nirik> handles: welcome. ;) and thanks for coming out so early your time...
18:35:39 <axk4545> marc84: you can have the python and I will take some of the specs :P
18:36:01 <axk4545> don't want to leave no work for anyone.
18:36:19 <handles> pleasure, iv got my weekend setup to go through all the apprentice workflows etc
18:36:49 <marc84> :)
18:37:42 <axk4545> nirik: so 23rd or 24th as a final answer?
18:37:47 <nirik> anyhow, we can concentrate on apps and also do other stuff as people want...
18:38:04 <nirik> what works best for everyone? 23rd or 24th? or both?
18:38:11 <Skeer> Either ;)
18:38:24 <cverna> I have a small preference for 23rd :p
18:38:32 <cverna> but don't mind 24th
18:38:58 <axk4545> as of now either.
18:39:17 <x3mboy> 23rd
18:39:19 <smooge> I am unavailable on the 24th so would prefer the 23rd
18:39:43 <nirik> ok, lets do the 23rd then. ;)
18:39:50 <jlozadad> :)
18:39:54 <cverna> anyway how do we organise it ?
18:39:56 <x3mboy> And time setted in UTC to easy translation
18:41:20 <smooge> I would say starting around 1400 UTC-> 2000 UTC
18:41:47 <nirik> yeah, thats when I can be around... 14 to 23 or something
18:42:22 <nirik> I think we can use #fedora-admin for it... show up and we can coordinate there and start working on things. ;)
18:42:33 <cverna> sounds good to me :)
18:42:46 <axk4545> will be there.
18:42:56 <jlozadad> awesome
18:42:56 <smooge> #agreed Fedora Infrastructure Apprentice Activity Day 2017-05-23 1400->2100 UTC
18:43:08 <x3mboy> Cool!
18:43:21 <nirik> looking forward to it. ;)
18:43:25 <marc84> +1
18:43:37 <jlozadad> same!
18:43:54 <handles> +1
18:44:16 <smooge> OK so next up is
18:44:18 <smooge> #topic Apprentice Open office hours
18:44:45 <smooge> #topic Apprentice Open office minutes
18:44:59 <smooge> any questions ?
18:45:31 <axk4545> what is needed that I can do with apprentice privs? beyond easyfix since those seem in progress or assigned
18:46:44 <axk4545> smooge: ^
18:47:36 <nirik> being assigned doesn't always mean they are being worked on anymore. If it's been a while since an update you can ping on the ticket and take it over...
18:47:42 <smooge> That is a good question.
18:47:52 * nirik should file some more
18:48:21 <axk4545> nirik: I mean don't artificially create them just for us :P
18:48:41 <smooge> agreed with nirik. some of the tickets may be taken by someone who is stuck or had something else come up
18:49:23 <nirik> well, they are good to get folks involved. Its just sometimes hard to come up with them... either it's something I can just do quickly myself and it's done or it's not easy... so I have to remember to tell myself to file them so I don't bypass them. ;)
18:49:28 <nirik> if that makes sense.
18:50:12 <axk4545> yeah. smthg that would take a while or need privs
18:50:57 <Skeer> I'd love to finally get these sops taken care of..
18:51:39 <axk4545> Skeer: I can help during that work day if not sooner. :0
18:52:14 <axk4545> er :)
18:52:39 <Skeer> axk4545: well its getting the two big ones I've worke don put to bed ;)
18:52:49 <smooge> axk4545, did that answer things?
18:53:20 <axk4545> smooge: I think so. if I am still lost I will bug you guys in -admin :P
18:54:44 <smooge> ok off to
18:54:48 <smooge> #topic Open Floor
18:54:59 <smooge> Thank you everyone for your time toay
18:55:07 <clime> I'd like to mention http://miroslav.suchy.cz/blog/archives/2017/05/16/distgit_1_0/index.html
18:55:29 <clime> ...as a follow-up to my info about dist-git 1.0 package :)
18:55:47 <clime> just if would like to take a look
18:56:00 <handles> do these meetiings normally run for ~ hour?
18:56:09 <axk4545> handles: yup
18:56:16 <handles> awesome
18:56:51 <Skeer> thanks for chairing smooge, and all teh infoz nirik/clime/ others
18:57:11 <clime> Skeer: yw
18:58:15 <clime> (=you welcome)
18:58:24 <x3mboy> Yay
18:58:33 <x3mboy> I get into another infra meeting
19:03:25 <clime> tx smooge
19:03:34 <smooge> #endmeeting