fesco
LOGS
16:00:02 <nirik> #startmeeting FESCO (2017-03-31)
16:00:02 <zodbot> Meeting started Fri Mar 31 16:00:02 2017 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:02 <zodbot> The meeting name has been set to 'fesco_(2017-03-31)'
16:00:02 <nirik> #meetingname fesco
16:00:02 <zodbot> The meeting name has been set to 'fesco'
16:00:02 <nirik> #chair maxamillion dgilmore jwb nirik jforbes jsmith kalev sgallagh Rathann
16:00:02 <zodbot> Current chairs: Rathann dgilmore jforbes jsmith jwb kalev maxamillion nirik sgallagh
16:00:02 <nirik> #topic init process
16:00:14 <jforbes> .hello jforbes
16:00:15 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:00:15 <sgallagh> .hello sgallagh
16:00:18 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:00:20 <nirik> who all is around for a fesco meeting?
16:00:26 <maxamillion> .hello maxamillion
16:00:26 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:01:05 <jsmith> .hello jsmith
16:01:06 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:02:09 <nirik> ok, thats quorum anyhow. ;)
16:02:12 <Rathann> .hello rathann
16:02:13 <jwb> hi
16:02:20 <zodbot> Rathann: rathann 'Dominik Mierzejewski' <dominik@greysector.net>
16:03:07 <nirik> I went though our open tickets and closed some / added meeting to some / pinged on some...
16:03:18 <nirik> #topic #1634 - EOL and vulnerable software
16:03:18 <nirik> .fesco 1634
16:03:18 <nirik> https://pagure.io/fesco/issue/1634
16:03:19 <zodbot> nirik: Issue #1634: EOL and vulnerable software - fesco - Pagure - https://pagure.io/fesco/issue/1634
16:03:52 <nirik> so, I am not sure where we were on this one...
16:04:08 <sgallagh> I stand by my assertion the last time: this is likely to be sufficiently rare that I don't see a need for a general policy.
16:04:08 <maxamillion> oh, I thought we'd concluded with what sgallagh commented on the ticket
16:04:12 <maxamillion> sgallagh: +1
16:04:23 <nirik> we handled the python* case but not a general policy
16:04:25 <jsmith> I thought so too...
16:05:04 <Rathann> just close it if the majority feels no need for a policy
16:05:04 <sgallagh> Or, put another way, if we start seeing this come up more often, consider a general policy at that time
16:05:26 <nirik> we also did have the webkitgtk/webkitgtk3 case recently.
16:06:15 <nirik> but yeah, it's hard to say how common it is... since I doubt we notice every case of it.
16:06:28 <jsmith> We don't know what we don't know...
16:06:32 <jforbes> Sure, but all of these things need to be case by case. Sometimes there is "another upstream" like RHEL who is supporting something for a period of time.
16:06:38 <nirik> the unknown is unknown. ;)
16:06:52 <nirik> so, anyone care to make a proposal to vote on here?
16:07:06 <maxamillion> jforbes: +1 - a vendor (whom ever) willing to support something in Fedora space effectively un-EOLs $thing
16:07:07 <jforbes> And it might be possible that the packager is willing to essentially take over with real maintenance. But I don't see anything in particular to propose
16:07:21 <sgallagh> Proposal: FESCo will hear any such future examples on a case-by-case basis.
16:07:27 <maxamillion> sgallagh: +1
16:07:31 <jforbes> sgallagh: +1
16:07:33 <jsmith> sgallagh: +1
16:07:42 <nirik> ok, sure, +1... will see how it goes.
16:08:02 <sgallagh> Our rules aren't carved in stone; in fact I doubt they're even printed out regularly :)
16:08:15 * Rathann still thinks there should a policy, so 0
16:08:21 <dgilmore> sure +1
16:08:23 <jforbes> Time to get a chisel and a stone tablet...
16:08:37 <sgallagh> Rathann: I think we just made the policy: bring it to FESCo
16:08:50 <jwb> Yes
16:09:38 <nirik> #agreed FESCo will hear any such future examples on a case-by-case basis. (For: +5, Against: 0, Abstain: 1)
16:09:51 <nirik> #topic #1653  [Meta] Better communicating roles and responsibilities of
16:09:51 <nirik> FESCo for elections
16:09:51 <nirik> .fesco 1653
16:09:51 <nirik> https://pagure.io/fesco/issue/1653
16:09:53 <zodbot> nirik: Issue #1653: [Meta] Better communicating roles and responsibilities of FESCo for elections - fesco - Pagure - https://pagure.io/fesco/issue/1653
16:10:02 <nirik> This was an old ticket commops filed a while back
16:10:12 <sgallagh> nirik: I think you miscounted above, but it doesn't change the result
16:10:30 <nirik> oh?
16:10:38 <nirik> sorry if so
16:10:45 <sgallagh> Not worth fixing.
16:11:23 <nirik> ok. So on this... they want us to add a roles and responsabilities section to our wiki.
16:11:36 <nirik> Do we want to brainstorm it? or would someone like to draft something for us to review?
16:11:41 <sgallagh> So what's the output we want here? A sound-bite on FESCo's general policy or a detailed list of what a member is expected to do and what sort of time-commitment it is?
16:12:31 <nirik> I think a roles and responsabilities section on https://fedoraproject.org/wiki/Fedora_Engineering_Steering_Committee?rd=FESCo
16:12:35 <sgallagh> Also: representative of how we currently operate vs. aspirational for how we would prefer?
16:12:41 <nirik> so people have enough info to tell if they could handle the job
16:13:26 <sgallagh> /me is concerned that writing that accurately will reduce future nominations :-P
16:13:39 <jwb> i'm concerned we can't write it accurately
16:13:52 <sgallagh> Also that
16:14:21 <maxamillion> same
16:14:26 <nirik> how do other groups that get voted on handle this? does the council have something?
16:14:37 <sgallagh> That being said, if we can't define our job, how do we know if we're doing it well?
16:14:55 <sgallagh> nirik: https://fedoraproject.org/wiki/Council#Responsibilities
16:14:56 <nirik> https://fedoraproject.org/wiki/Council#Responsibilities
16:14:57 <nirik> yes
16:16:06 <nirik> So, I think we need a draft to poke holes in...
16:16:23 <nirik> I can try and write up something...
16:16:26 <sgallagh> /me is overbooked for the next week
16:16:39 <jsmith> nirik: I'm swamped too, but I'll squeeze in time to review anything you write
16:16:45 <jforbes> Right, and honestly I think the council's description there is not so detailed that it would have to be inaccurate
16:16:46 <jsmith> nirik: ... and give feedback
16:16:49 <sgallagh> nirik: If you don't, I'll try to get something after this week
16:17:14 <nirik> ok. I'll try and whip up something soon and add it to the ticket and everyone can poke at it there...
16:17:25 <sgallagh> nirik: Thanks
16:17:36 <nirik> #action nirik to draft a initial text to start with and add to ticket.
16:17:37 <jforbes> nirik: thanks
16:18:22 <nirik> #topic #1690 - f27 self contained changes
16:18:25 <nirik> .fesco 1690
16:18:26 <zodbot> nirik: Issue #1690: F27 Self Contained Changes - fesco - Pagure - https://pagure.io/fesco/issue/1690
16:18:29 <nirik> https://pagure.io/fesco/issue/1690#comment-434408
16:18:35 <nirik> we have one new f27 change...
16:18:42 <nirik> Replace Yumex-DNF with dnfdragora
16:18:46 * nirik is +1
16:19:02 <maxamillion> +1 here as well
16:19:04 <sgallagh> Existing package is dead upstream and its replacement is highly motivated. +1
16:19:06 <Rathann> seems straightforward
16:19:07 <Rathann> +1
16:19:32 <jforbes> +1
16:19:50 <jsmith> +1
16:20:58 <nirik> #agreed Replace Yumex-DNF with dnfdragora is approved (For: +6, Against: 0, Abstain: 0)
16:21:05 <nirik> #topic Next weeks chair
16:21:12 <jwb> +1
16:21:13 <nirik> who wants the hot potatoe next week?
16:21:21 <jforbes> I can do it
16:21:25 <jwb> how many of us will even be available?
16:21:34 <jwb> i know myself and sgallagh are probably out
16:21:48 <Rathann> why is it a hot potato?
16:21:51 <Rathann> I'm available
16:21:57 * nirik should be here.
16:22:21 <nirik> Rathann: just a general statement, nothing particularly hot that I know of. ;)
16:22:25 <Rathann> ah, ok
16:23:02 <nirik> so, lets let jforbes do it and if we don't have quorum we have a short meeting? ;)
16:23:19 <jforbes> works for me
16:23:22 <nirik> #action jforbes to chair the 2017-04-07 meeting.
16:23:27 <nirik> #topic Open Floor
16:23:28 <jsmith> Sounds like a plan
16:23:31 <nirik> anyone have anything for open floor?
16:23:57 <jsmith> I still owe the group about proposal about systemd default settings...
16:24:14 <jsmith> I haven't been able to spend as much time on it as I would have liked to, so I still don't have the proposal ready
16:24:28 <jsmith> Hopefully I'll have something more concrete in the next two or three weeks.
16:24:36 <nirik> cool
16:24:48 * jsmith curses at ${DAYJOB} and ${HOMELIFE} for complicating things...
16:24:55 <jsmith> I haven't forgotten :-)
16:26:09 <dgilmore> sorry someone was at teh door, I will not be here next week
16:26:22 <maxamillion> oh, I won't be here next week either
16:26:34 <jwb> nirik: i saw your ping about the demotion thing
16:26:52 <nirik> yeah... just wanted to check on old ticket. ;)
16:26:54 <nirik> tickets.
16:26:59 <jwb> nirik: really i guess my plan is to just actually writeup what we did with i686 and use that as a basis.  i wasn't thinking about anything grand
16:27:07 * jsmith has nothing further for open floor
16:27:09 <jforbes> So that's 4 who won't be here next week, should we defer?
16:27:09 <nirik> sounds good to me.
16:27:23 <dgilmore> jforbes: likely
16:28:03 <nirik> well, if the other 5 will attend thats still quorum...
16:28:08 <jforbes> And the week after is a RH holiday
16:28:21 <jwb> it is?
16:28:22 <Rathann> what's "RH holiday"?
16:28:30 <maxamillion> jforbes: wha?
16:28:34 <nirik> "spring holiday" ?
16:28:37 <jforbes> jwb: yeah, good friday is "spring holiday"
16:28:39 <jwb> Rathann: the Red Hat employees have the day off
16:28:46 <Rathann> ah
16:28:48 <jwb> at least in the US
16:28:57 <Rathann> is being on FESCo part of your job, guys?
16:29:04 <maxamillion> oh, we sure do
16:29:09 <maxamillion> Rathann: it is not
16:29:14 <jforbes> Rathann: no, but when given a day off, I try to spend it with my family
16:29:18 <jwb> jforbes: forgot about that.  guess i need to figure out where else to use that PTO day
16:29:21 <maxamillion> Rathann: but most people will go and do things with their families on days off work
16:30:04 <Rathann> jforbes, maxamillion: sure, I do the same when I have a day off
16:30:13 <Rathann> but I don't call it "Citi holiday" then
16:30:20 <maxamillion> Rathann: fair
16:30:42 <Rathann> just "day off"
16:30:46 <jforbes> Rathann: only specified because it is a less standard holiday
16:30:49 <maxamillion> Rathann: +1
16:30:59 <Rathann> ah, then it's clear, thank you
16:32:08 <nirik> anyhow, shall we just see next week? and cancel the one after?
16:32:24 <jforbes> works for me, I will be here next week
16:32:36 * Rathann too
16:32:44 <jsmith> Works for me -- I should be here next week, and probably the week after that as well
16:32:44 <sgallagh> +1
16:33:09 <nirik> ok.
16:33:21 <nirik> If nothing else will close out in a minute or less
16:33:40 <dgilmore> Rathann: because the US is silly, public holidays are up to the discression of the company you work for
16:33:41 * jsmith has to run to another meeting... thanks nirik, thanks everyone!
16:33:59 <dgilmore> Rathann: which tends people to say its a RH holiday rather than a public holiday
16:34:10 <dgilmore> as many people will be working that day and not get it off
16:34:23 <Rathann> alright, thank you for the explanation
16:35:00 <nirik> thanks for coming everyone!
16:35:03 <nirik> #endmeeting