translations
LOGS
11:01:21 <pravins> #startmeeting Translations
11:01:21 <zodbot> Meeting started Wed Mar 29 11:01:21 2017 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:01:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
11:01:21 <zodbot> The meeting name has been set to 'translations'
11:01:24 <pravins> #meetingname Translations
11:01:24 <zodbot> The meeting name has been set to 'translations'
11:01:29 <paragan> hi
11:01:35 <pravins> hi paragan :)
11:01:36 <jonatoni> .hello jonatoni
11:01:37 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
11:01:39 <pravins> who else available here?
11:01:42 <jibec> .hello jibecfed
11:01:42 <pravins> hi jonatoni :)
11:01:42 <zodbot> jibec: jibecfed 'Jean-Baptiste Holcroft' <jean-baptiste@holcroft.fr>
11:01:48 <pravins> hi jibec :)
11:01:54 <pravins> #chair jonatoni paragan jibec
11:01:54 <zodbot> Current chairs: jibec jonatoni paragan pravins
11:02:02 <jonatoni> hey guys :)
11:02:07 <pravins> aeng: around ^^
11:02:55 <pravins> lets start while other joins.
11:03:01 <pravins> #topic agenda and roll call
11:03:01 <pravins> #link https://fedoraproject.org/wiki/G11N/Meetings/2017-03-29
11:03:08 <pravins> kept very short agenda.
11:03:28 <pravins> #topic Upcoming schedule
11:03:28 <pravins> #link https://fedoraproject.org/wiki/Releases/26/Schedule
11:03:29 <pravins> #info 2017-03-07  	Software String Freeze
11:03:29 <pravins> #info 2017-04-04    Alpha Release
11:03:29 <pravins> #info 2017-05-02    Software Translation Deadline
11:04:15 <pravins> so, we do have some time for Software Translation deadline.
11:04:21 <pravins> almost a month.
11:04:29 <pravins> it gives us some time for planning vFAD
11:04:34 <pravins> #topic  Fedora 26 virtual translation sprint
11:04:34 <pravins> #link  https://pagure.io/g11n/issue/36
11:04:41 <jibec> Matthew and Jiri asked us if those items are still useful and when should it happens
11:04:58 <pravins> jibec: right, i was looking for that email before sometime.
11:05:12 <jibec> the question asked is "should we still have Software Translation deadline"
11:06:13 <aeng_> hi pravins
11:06:14 <jibec> my position is: it is not respected by upstream or fedora sub-projects, so we can keep it for information, but it won't change anything to have it or not
11:06:18 <pravins> hi aeng_ :)
11:06:21 <pravins> #chair aeng_
11:06:21 <zodbot> Current chairs: aeng_ jibec jonatoni paragan pravins
11:06:28 <jibec> hi aeng_
11:06:35 <pravins> jibec: perfect, me too think same.
11:07:10 <jibec> we should probably observe a statu quo here for F26, and suggest to discuss it at Flock
11:07:34 <pravins> Its important to have that milestone for 2 reasons.
11:08:27 <pravins> yeah, make sense to talk with Data. !!
11:08:45 <pravins> i will reply to that thread after this meeting.
11:09:09 <pravins> aeng: regarding "Translation Deadlines and the Fedora 27 schedule"  on trans list
11:09:20 <aeng_> ok
11:09:20 <pravins> thanks jibec for raising it.
11:09:26 <pravins> coming back to vFAD.
11:09:33 <jibec> so decision is: not much use right now, let's keep it for F26 and discuss at Flock what to do for F27?
11:10:06 <pravins> i think, it is important to have that deadline, since contributors become more active during this deadline.
11:10:24 <aeng_> agree, some sense of urgency
11:10:40 <pravins> and also it gives surety that my translated things will be part of particular release.
11:11:08 <jibec> do we have data from Zanata to show this?
11:11:37 <aeng_> data on translation frequency?
11:11:44 <aeng_> i dont have it at the moment
11:11:54 <jibec> aeng_: yes, ok
11:12:02 <pravins> yeah, may be translations done prior translation deadline and after translation deadline.
11:12:05 <zdenek> question: If I translate something after that due date, that translation is not going to be loaded into the particular release?
11:12:42 <jibec> zdenek: it may, but there is no guarentee
11:12:53 <pravins> exactly.
11:13:07 <zdenek> I see, thank you
11:13:09 <jibec> it depends on the package maintainer who may have a second look to Zanata to see if some translation arrived
11:13:24 <pravins> https://fedoraproject.org/wiki/L10N_Freezes#Translation_Deadline
11:13:33 <jibec> for those using Zanata, we have no control over upstream content
11:14:25 <pravins> though we are trying to improve it gradually :)
11:14:31 <pravins> ok, coming back to the topic of vFAD
11:14:33 <jibec> pravins: in your answer, can you please ask to add a deadline for Website and Documentation?
11:14:51 <pravins> sure, i will ask for same.
11:15:11 <jibec> we need one or two weeks before announcment to translate
11:15:30 <pravins> can you elaborate this?
11:16:36 <jibec> website and documentation content should be freeze at lease two weeks before release, so we can translate it and make sure it's ready for release day
11:16:54 <pravins> perfect. thanks jibec
11:17:02 <jibec> (sorry for typos)
11:17:23 <pravins> We had nice vFAD for F24 nd F25 and i think we should continue with this tradition.
11:17:49 <zdenek> Yes, I agree :-)
11:18:01 <pravins> It motivates more members to become part and help to make Fedora better from translation side.
11:18:19 <pravins> thanks zdenek :)
11:18:32 <pravins> since, we already did this 2 times most of the things should be quick now.
11:18:37 <pravins> lets iterate over TODO list.
11:18:44 <pravins> 1. Dates
11:18:44 <pravins> We need to complete all our pre-requicite before one week, so starting from today
11:19:21 <pravins> 2nd May is Software translation deadline, so i think we should have at least one week prior to fix bugs etc.
11:19:37 <pravins> so may be 3rd Week of April?
11:19:58 <pravins> say from 11-17 April.
11:20:39 <pravins> #chair
11:20:39 <zodbot> Current chairs: aeng_ jibec jonatoni paragan pravins
11:20:44 <pravins> need your inputs :)
11:20:53 <pravins> #chair zdenek
11:20:53 <zodbot> Current chairs: aeng_ jibec jonatoni paragan pravins zdenek
11:20:59 <jibec> 11-17 April: sounds good to me.
11:21:11 <zdenek> I know it is probably too fast but could we start more early?
11:21:19 <zdenek> like on 08th or 9th of April
11:21:27 <mfabian> For something like “ibus-typing-booster”, a translation deadline makes no sense at all, or does it?
11:21:44 <jonatoni> I think its better 11-17 and not too early, so we can have more time to prepare
11:21:46 <jibec> mfabian: nope, it's upstream
11:22:12 <jibec> zdenek: why?
11:22:32 <pravins> zdenek: 08-09 will be good, if we can complete our pre-requisite by 4th/5th April
11:22:57 <pravins> jonatoni: +1
11:23:01 <zdenek> well because there are too many projects for translation left each time and it is hard to translate it till the dead line
11:23:19 <jibec> zdenek: the vFAD is an invitation for teams to focus
11:23:20 <zdenek> so involving more people more early would help to translate more, may be ...
11:23:30 <jibec> each team can start earlier if they wish to
11:23:41 <zdenek> yes, I know
11:24:04 <zdenek> but people are attracted with badges and then they participate and translate a lot
11:24:16 <pravins> right.
11:24:20 <jibec> ah, ok
11:24:28 <zdenek> but out of these events -the frequency of tranlations is less then nothing
11:24:54 <jibec> maybe can we focus vFAD on some day, but extract contribution statistics for the whole freeze period?
11:25:02 <pravins> zdenek: do you specifically want to have more Sat/Sun into vFAD?
11:25:23 <zdenek> yes, that could maybe help as well
11:25:49 <zdenek> or not, it depends. Over the week - please work and have less time for translation support
11:26:10 <pravins> but that will spoil broader interest of vFAD. it like for specific time period more people come together and complete the tasks.
11:26:16 <zdenek> over the weekend, there is more time bt people could attend in some private activities instead of translations
11:26:35 <zdenek> yes, you are right
11:26:44 <zdenek> let's keep that original proposal
11:27:05 <pravins> from our past experience, preparation takes some time.
11:27:15 <jibec> I doubt we can be ready  by 4th/5th April, let's keep it on initial proposal (11-17 april)
11:27:24 <pravins> right.
11:27:35 <pravins> great, thanks.
11:27:50 <pravins> #agreed Dates for vFAD 11-17 April
11:28:37 <pravins> for awarding badges, we have been bit flexible. So it should be fine.
11:28:51 <pravins> next one.
11:28:56 <pravins> 2. Provide prioritize package list.
11:29:00 <pravins> For F25 https://fedoraproject.org/wiki/G11N/vFAD_Translation_Packages_F25
11:29:20 <pravins> May be we can simply copy paste it for F26? I really dont know how this used to be decided by group.
11:29:59 <pravins> may be piotrdrag for zoltan can help here?
11:30:07 <pravins> s/for/or
11:30:25 <jibec> Zanat's group "priority packages" should be up to date
11:30:35 <pravins> good point.
11:30:38 <jibec> I can send them a message to make sure
11:30:52 <jibec> to have an up to date list
11:31:18 <pravins> nice.
11:31:59 <pravins> jibec: do send email on trans list as well, so if anyone want to add any package there
11:32:06 <pravins> but i am still not sure, how this list was prepared :)
11:32:43 <aeng_> it is individual's decision
11:32:50 <pravins> aha
11:33:05 <jibec> aeng_: what do you mean?
11:33:05 <aeng_> based on understanding of fedora packages and understanding of the support
11:33:37 <pravins> right, means this is just guideline/suggestion..one can decide his own interest package for translation
11:33:37 <jibec> by piotr and zoltan?
11:33:52 <aeng_> it was by noriko, myself and piotr
11:34:03 <aeng_> but now mainly piotr
11:34:26 <jibec> ok, by trustees, it's the best we can have
11:34:52 <pravins> in last vFAD, i remember 2-3 members mentioned priority list of packages were already 100%, so they translated other packages.
11:34:59 <jibec> I'll ask Zoltan and Priotr, plus l10N mailing list in copy if they want to suggest something
11:35:12 <pravins> excellent
11:35:21 <jibec> aeng_: looks good to you?
11:35:29 <aeng_> fine by me
11:35:34 <jibec> <3
11:36:08 <pravins> i think, rather than making vFAD bound within this packages, we can say good to translate prioritize package or one can choose package as per his own interest.
11:36:12 <pravins> how do you think?
11:36:22 <pravins> s/this/these
11:36:36 <jonatoni> +1 pravins
11:37:06 <zdenek> yes, priority should go first but if all are translated, we can focus on other packages, I vote +1 too
11:37:17 <jibec> +1
11:37:20 <pravins> great.
11:37:28 <jibec> I think it's already what we did in the past
11:37:45 <pravins> #agreed To have priority package list just as guideline..one can choose package of his own interest.
11:38:07 <pravins> jibec: yes, we are always permissive. :)
11:38:13 <pravins> moving to next one.
11:38:20 <pravins> 3. Badges
11:38:35 <pravins> I will take care of this, it should be fast this time, we made last time generic design.
11:38:46 <pravins> 4. Community outreach
11:38:57 <pravins> Announcing to public.
11:39:12 <pravins> In last sprint jonatoni did great work for spreading this message.
11:39:23 <pravins> jonatoni: would you like to write an article as well for commblog this time?
11:39:25 <pravins> or anyone else?
11:39:34 <jonatoni> yeah sure
11:40:05 <jibec> jonatoni, pravins: we should almost copy/paste previous content
11:40:20 <pravins> jibec: yes, we have nice reference now.
11:40:29 <jibec> but I would prefer to talk about l10n better than g11n
11:40:37 <pravins> me..too.
11:40:40 <pravins> :)
11:40:47 <pravins> its l10n, so lets talk about l10n.
11:40:51 <pravins> https://communityblog.fedoraproject.org/fedora-25-translation-sprint/
11:41:02 <jibec> g11n it our internal discussion group/structure, for the outside, all useful documentation is under l10n wiki pages
11:42:01 <pravins> yeah, we have to spread this vFAD as a l10n rather than g11n.
11:42:30 <pravins> moving to next item
11:42:31 <pravins> 4. Help during sprint.
11:42:53 <pravins> last time, paragan volunteered for this. Though we are naming few people i think anyone can jump it for help.
11:43:18 <paragan> yeah good to get new people everytime
11:43:49 <pravins> paragan: i am not sure, whether noriko will be here this time
11:43:55 <pravins> so may be lets have your name as of now
11:43:59 <zdenek> what is expected to be done? Is there any list of actions volunteers can take?
11:44:03 <jibec> is there a lot of request? where?
11:44:05 <aeng_> pravins, most likely she will not
11:44:25 <pravins> aeng_: aha, sure. then i will remove her name.
11:44:48 <paragan> pravins, okay np
11:44:54 <pravins> jibec: request are very less, since last time we did great join for preparing prioritize package list and Zanata readiness
11:45:21 <jibec> ok, I'll help on mailing list request if needed, next then ;)
11:45:37 <pravins> zdenek: jibec i think last time more request were, person not part of particular language team
11:45:40 <pravins> and not able to translate
11:46:09 <pravins> so, i will add l10n pillars name there :)
11:46:25 <jibec> there is only piotr
11:46:32 <jibec> as Noriko left
11:46:36 <pravins> zdenek: you are welcome to help !!
11:46:46 <zdenek> sure, count on me
11:46:50 <pravins> great.
11:47:05 <zdenek> but I can assist mainly during preparation phase
11:47:34 <pravins> sure, all kind of help is very valuable for Fedora 👍
11:47:36 <zdenek> but during vFAD itself - I will be out of country most of the time and I will have no internet access abroad :\
11:47:55 <pravins> that is why we are looking for multiple members for help.
11:48:01 <pravins> moving to next topic
11:48:05 <pravins> less time remain
11:48:05 <pravins> 5. Effective closing
11:48:09 <jibec> pravins: we need new l10n pillars, I suggest to add Zoltan and I (it means Zanata admin rights)
11:48:26 <pravins> jibec: yes, i agree we do need few more.
11:48:39 <pravins> but we do not have decision making framework for it.
11:49:03 <pravins> so may be have ticket and discuss in mailing list?
11:49:05 <jibec> aeng is obviously an admin with superpower/knowledge, but we said we should not rely on Zanata team unless problem
11:49:22 <jibec> (problem we can't solve by ourselves)
11:49:35 <pravins> right, though aeng has admin right, he cant use power without community support. etc.
11:49:37 <jonatoni> pravins I agree with you, mailing list should be the place to start discussion about it
11:49:48 <jibec> pravins: yep, I'll send a proposal
11:50:06 <pravins> perfect, it will be great to have new members as a pillars.
11:50:13 <pravins> for effective closing
11:50:18 <pravins> alex has been helpful always
11:50:28 <pravins> its tricky to get exact starts
11:50:39 <jibec> pravins: +1
11:50:40 <pravins> jibec: you also very interest in stats.
11:50:54 <pravins> i will write an article for closing
11:51:06 <pravins> with 3rd sprint, it will be an interesting article for me to write.
11:51:11 <jibec> pravins: I have interest in it, but I can't extract reliable data, only aeng_ can
11:52:01 <pravins> i think he can help you.
11:52:11 <pravins> i am almost done with vFAD topic.
11:52:13 <jibec> aeng_: I would love to have a per day extract of Zanata stats so we can analyse this overtime and be autonomous for vFAD
11:53:00 <pravins> ok
11:53:03 <pravins> lets take it later.
11:53:08 <pravins> 7 min to go.
11:53:12 <pravins> moving to next topic
11:53:13 <pravins> #topic T-shirts for active contributors of Translation group
11:53:13 <pravins> #link https://pagure.io/g11n/issue/32
11:53:32 <pravins> jonatoni: would you like to update anything about this?
11:54:24 <jonatoni> I opened again the council ticket
11:54:24 <pravins> hmm, council also migrated to pagure.
11:54:30 <jonatoni> to ask them about budget
11:54:42 <pravins> jonatoni: can you point to new ticket?
11:54:44 <jonatoni> but they have not responded to my comment
11:55:20 <jonatoni> I will try to ping them again, to see if its better to open a new ticket
11:55:31 <pravins> https://pagure.io/Fedora-Council/tickets/issues
11:55:32 <jonatoni> or keep the old one, and they can review it again
11:55:55 <pravins> #link https://pagure.io/Fedora-Council/tickets/issue/69
11:56:24 <pravins> sure
11:56:40 <pravins> only 4 min to go
11:56:47 <pravins> #topic  Next Meeting Date and Time
11:56:57 <jonatoni> I need to update also the contributors that we need more time about this
11:57:10 <pravins> more time means?
11:57:10 <jonatoni> because they are asking when will the tshirt arrive
11:57:29 <jibec> I like this new schedule, I suggest to do it again next time to see if more attendees
11:57:30 <pravins> ohh, right. tell them yet no updates on budget :)
11:57:38 <pravins> jonatoni: do mention this thing in council ticket as well.
11:57:39 <jonatoni> more time I mean the budget needs to be approved
11:57:56 <pravins> jibec: yeah, how about next week same time?
11:57:58 <jonatoni> pravins yes sure
11:58:02 <pravins> #chair
11:58:02 <zodbot> Current chairs: aeng_ jibec jonatoni paragan pravins zdenek
11:58:11 <pravins> 05th April 11:00 UTC
11:58:17 <zdenek> +1
11:58:30 <jibec> I think only aeng_ is impacted because it's quite late
11:58:36 <jibec> aeng_, do you agree?
11:58:40 <aeng_> im fine
11:58:43 <jibec> great
11:58:44 <aeng_> its only 9pm
11:58:46 <pravins> aeng: excellent.
11:58:50 <jonatoni> I will be traveling, but I hope I will find internet to join the meeting
11:58:55 <pravins> yeah 9pm is better than 5am ;)
11:59:12 <pravins> actually this is good time, dunno why i never considered this. :(
11:59:16 <jibec> great
11:59:29 <pravins> #topic Open Floor
11:59:33 <jibec> !
11:59:36 <pravins> lets be here for 1 min and close
11:59:38 <jibec> we have 21 request
11:59:44 <jibec> for cvsl10n group
11:59:46 <pravins> 21 request for what?
11:59:48 <pravins> aha
12:00:13 <pravins> do we have any procedure for approving it?
12:00:15 <jibec> can I send a public message to them with l10n mailing list in CC to ask for introduction/information and deleted request if no answer?
12:00:24 <pravins> soon, all cvsl10n group members will get badges.
12:01:10 <pravins> also, i think some team coordinator should sponsor them.
12:01:19 <jibec> let's say: if no answer in 14 days I remove the request
12:01:31 <jonatoni> jibec +1
12:01:44 <jibec> pravins: yep, but too many emails I think nobody takes care to have a look to it
12:01:49 <pravins> yeah, agree +1
12:01:54 <pravins> lets go ahead with this.
12:02:20 <pravins> lets stop here, then? i hope next meeting we will have most of the things ready.
12:02:31 <zdenek> Don't you know when Zanata v4.0 will be relased please?
12:02:38 <jibec> yep, thanks pravins
12:02:41 <zdenek> *released
12:02:46 <pravins> aeng: ^^
12:02:55 <aeng_> zdenek, there's no ETA yet, we are working with infra team to get this sorted
12:02:59 <jibec> zdenek, I think it's already released, but not deployed
12:03:11 <zdenek> ok, thanks
12:03:13 <pravins> thanks aeng for clarification.
12:03:27 <pravins> lets stop here. Thanks all for inputs and making meeting fruitful :)
12:03:31 <pravins> #endmeeting