infrastructure
LOGS
18:00:21 <bowlofeggs> #startmeeting Infrastructure (2017-03-23)
18:00:21 <zodbot> Meeting started Thu Mar 23 18:00:21 2017 UTC.  The chair is bowlofeggs. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:21 <zodbot> The meeting name has been set to 'infrastructure_(2017-03-23)'
18:00:23 <bowlofeggs> #meetingname infrastructure
18:00:23 <zodbot> The meeting name has been set to 'infrastructure'
18:00:24 <bowlofeggs> #topic aloha
18:00:26 <bowlofeggs> #chair smooge relrod nirik abadger1999 lmacken dgilmore threebean pingou puiterwijk pbrobinson
18:00:26 <zodbot> Current chairs: abadger1999 bowlofeggs dgilmore lmacken nirik pbrobinson pingou puiterwijk relrod smooge threebean
18:00:27 <bowlofeggs> #topic New folks introductions
18:00:43 <bowlofeggs> oh whoops
18:00:48 <bowlofeggs> #topic aloha
18:00:54 <puiterwijk> .hello puiterwijk
18:00:55 <zodbot> puiterwijk: puiterwijk 'Patrick "マルタインアンドレアス" Uiterwijk' <puiterwijk@redhat.com>
18:01:03 <cverna> .himynameis cverna
18:01:04 <zodbot> cverna: cverna 'Slim Shady' <cverna@tutanota.com>
18:01:09 * yudocaa is here
18:01:13 <nirik> morning everyone.
18:01:15 <yudocaa> .hello sayanchowdhury
18:01:16 <zodbot> yudocaa: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
18:01:22 * nirik is in the no-go meeting, but will try and pay attention too.
18:01:35 <vivek_> .hello batman
18:01:36 <zodbot> vivek_: batman 'None' <vivekanand@tutanota.com>
18:03:01 <bowlofeggs> #topic New folks introductions
18:03:02 * pingou here
18:03:21 <bowlofeggs> is anyone new to fedora or the infrastructure group who would like to say hello?
18:03:33 <cyberworm54> Hello everybody!
18:03:40 <bowlofeggs> hello cyberworm54!
18:03:59 <smooge> hello
18:04:31 <cyberworm54> is there anything else that I've to do to get access to the aprentice group?
18:04:45 <dgilmore> hola amigos
18:04:55 <cyberworm54> I've done pretty much everything from the getting started guide.
18:04:55 <puiterwijk> cyberworm54: are you more interested in sysadmin stuff or application development?
18:05:03 <cyberworm54> puiterwijk: sysadmin
18:05:13 <puiterwijk> And for apprentice group, please see me in #fedora-admin after the meeting
18:05:29 <bowlofeggs> welcome cyberworm54!
18:05:33 <cyberworm54> puiterwijk: will do, thank you!
18:05:43 <bowlofeggs> is anyone else here new who would like to introduce themselves?
18:05:45 <jcline> .hello jcline
18:05:47 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
18:06:11 <bowlofeggs> ok, we will move on to announcements
18:06:20 <linuxmodder> .fas linuxmodder
18:06:26 <bowlofeggs> #topic announcements and information
18:06:26 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
18:06:27 <bowlofeggs> #info Fedora 26 Alpha freeze is on now! - everyone
18:06:29 <bowlofeggs> #info Bodhi 2.5.0 beta deployed to staging, release notes available at https://bodhi.stg.fedoraproject.org/docs/release_notes.html#id1 - bowlofeggs
18:06:30 <bowlofeggs> #info Fedora 26 alpha testing in full swing - kevin
18:06:32 <bowlofeggs> #info distgit testcases enabled in production - tflink
18:06:34 <bowlofeggs> #info There have been multiple problems with copr reported.
18:06:35 <bowlofeggs> #info We will be moving stg hosts to new ip space after freeze. #5931
18:07:03 <bowlofeggs> any other announcements, or shall we move on to discussion topics?
18:07:29 * jcline has nothing to report. All is quiet.
18:07:52 <bowlofeggs> i'll add a detail about the bodhi 2.5.0 beta - the web ui has a new design by ryanlerch that looks really great. check it out at https://bodhi.stg.fedoraproject.org
18:08:09 <linuxmodder> not exactly  infra related but  we will have a influx of summer-applicants in the coming weeks and soem havce come in -admin for things for those not familiar pls direct them to -summer-coding
18:08:29 <nirik> yeah, the new bodhi look in stg is pretty slick
18:08:58 <nirik> bowlofeggs: I wonder if we could make the test tab in red or show a number for all failed tasks? something to bring attention if there's failures?
18:08:59 <bowlofeggs> #info summer interns can be directed to #fedora-summer-coding
18:09:40 <linuxmodder> nirik,  will have to look not spending as much time lately on anything stg.*
18:09:47 <bowlofeggs> nirik: actually ryanlerch's newest PR does show a count of tasks, but doesn't differentiate success vs. fail - want ot make that suggestion there? https://github.com/fedora-infra/bodhi/pull/1379
18:10:02 <bowlofeggs> i agree - it'd be nice if it showed a fail count
18:10:20 <bowlofeggs> ok, let's move on to discussion
18:10:35 <bowlofeggs> #topic OpenShift trial - kevin
18:10:48 <bowlofeggs> nirik: ^
18:10:57 * linuxmodder is 2 mtgs atm and making repo edits for respins sig if need me and no reply  ping pls
18:11:11 <nirik> ok... so I wanted to mention this...
18:11:20 <nirik> we don't need to do much today aside from ponder on it. ;)
18:11:46 <nirik> For a number of reasons I've been thinking about standing up a openshift instance in our infrastructure.
18:12:10 <nirik> It's new and hot and all that, but also would help deploy some of these new services coming along (the factory 2.0 stuff, etc)
18:12:30 <nirik> We are looking at a FAD to explore this more.
18:12:56 <smooge> that would be in May?
18:13:02 <nirik> There's no way it would replace everything we have now at all... but it could be along side it and a good fit for lots of things.
18:13:23 <bowlofeggs> i spent some time using openshift in february and it did seem pretty nice
18:13:43 <nirik> t would be radically different from how we do things now.
18:13:46 <bowlofeggs> i've heard that it can be difficult to upgrade it from release to release, but i don't have any personal experience trying to do that
18:13:59 <nirik> well, the ideal setup is:
18:14:05 <jcline> I'm open to new and exciting things
18:14:44 <nirik> you commit some (hopefully tested) PR, openshift sees this, builds a new container, builds your git checkout of your app, tests it, deploys it and lets it have some traffic, then gradually replaces all the old ones with this new one. done.
18:14:59 <nirik> so the idea is that you are always deploying
18:15:20 <cverna> I have tested building flask app from pagure with openshift :)
18:15:20 <ForrestalGrim> very cool and useful sounding..
18:15:21 <puiterwijk> And if a commit doesn't start for whatever reason, it will automatically roll it back
18:15:24 <nirik> and that your CI and will test everything
18:15:36 <nirik> yeah.
18:15:53 <nirik> So in this world... you wouldn't need staging. Or have freezes.
18:16:08 <smooge> so you need to work on the CI part as it could break but if there aren't tests for that breakage
18:16:14 <nirik> but also some things don't fit well in openshift IMHO... like databases. Or proxies.
18:16:15 <smooge> s/you/the developer/
18:16:19 <nirik> or builders
18:16:29 <nirik> smooge: yep. absoletely
18:16:49 <linuxmodder> how would the push to prod work tho or is it not really a stg ?prod thing with openshift ? still not spun up on it much
18:16:52 <bowlofeggs> yeah database schema migrations would not work well with the 'roll it back if it doesn't work' part
18:17:14 <nirik> linuxmodder: theer would be no need for staging...
18:17:19 <linuxmodder> ah
18:17:30 <ForrestalGrim> so basically dev then prd?
18:17:32 <nirik> you test your app by testing it with jenkins or whatever then deploying it and making sure it runs
18:17:33 <puiterwijk> bowlofeggs: that's why you need to make schema migrations very rare :)
18:17:44 <bowlofeggs> haha
18:17:53 <puiterwijk> bowlofeggs: not even a joke.
18:17:58 <pingou> just a wish
18:18:01 <puiterwijk> schema changes should be rare
18:18:02 <bowlofeggs> it is possible to use it without connecting it so directly to git
18:18:03 <jcline> bowlofeggs, just use mongo, no schema means no migrations means no problem
18:18:08 <bowlofeggs> hahaha oh my
18:18:09 <pingou> *should* being a keyword :)
18:18:24 <nirik> bowlofeggs: well, git is pretty tied in, but you can do just containers...
18:18:36 <nirik> ie, a container that installs rpms or whatever
18:19:03 <bowlofeggs> yeah that's what i mean
18:19:16 <bowlofeggs> i don't agree that schema migrations should be rare - they happen when they need to happen
18:19:17 <nirik> right we could skip the CD part if desired.
18:19:39 <nirik> but it has advantages too... saves all the work making a release, building a rpm, signing, etc.
18:19:46 <bowlofeggs> not all new features can be accomplished without migrations, and features priorities are not always decided by us
18:19:53 <pingou> bowlofeggs: in an ideal world they should, in practice they don't
18:19:58 * jcline has two pending schema migrations for anitya this release alone
18:20:24 <nirik> in theory, theory and practice are the same. In practice they are not.
18:20:29 <puiterwijk> bowlofeggs: sure. But most changes can be made backwards compatible. Aka, adding a new table wouldn't be a problem when you roll back
18:20:40 <puiterwijk> Anyway, let's keep that discussion for some othe time
18:21:12 <nirik> also, another question around this is how much we want ansible to manage things in a openshift world
18:21:33 <nirik> since it has it's own command line and web interface... do we make ansible configure all apps and not use those?
18:21:53 <puiterwijk> I would say we make ansible configure it all, yes
18:21:55 <nirik> again, nothing needs deciding today, just lots to think about
18:22:15 <nirik> puiterwijk: well, you mean deploy it, but also control say how many pods on app foo? or ?
18:22:24 <puiterwijk> nirik: also deploy the apps itself.
18:22:42 <nirik> ok.
18:22:43 <puiterwijk> How many pods - maybe not, but creating the image streams, routes and deployments: yes
18:23:03 <nirik> I know origin has deployment ansible scripts for everything...
18:23:09 <nirik> (for the base setup)
18:23:26 <puiterwijk> That's also the deployment mechanism for the RH product
18:23:32 <nirik> I'm still trying to understand how it all works and fits too. :) it's really complex.
18:24:13 <nirik> Things like koji I don't see fitting in this at all...
18:24:28 <nirik> but things like fedocal or whatever could fit nicely
18:24:40 <smooge> copr :)
18:25:29 <smooge> gives himself a ಠ_ಠ, and moves back to topic
18:25:31 <nirik> The frontend sure... the backend, perhaps, the builders... not sure at all. Containers don't contain enough for me.
18:25:43 * nirik looks for the fad page
18:25:44 <bowlofeggs> yeah i think it'd be good to pick a very simple app to test with first and see how it goes
18:25:59 <puiterwijk> How about Ipsilon? :)
18:26:12 <nirik> https://fedoraproject.org/wiki/CI_and_Infrastructure_Hackathon_2017
18:26:31 <puiterwijk> (I actually have a production deployment of Ipsilon running on Openshift. It works nicely)
18:26:33 <nirik> all tenative so far... but if you are in RDU area or can get there. ;)
18:26:57 <nirik> how about download servers? ;)
18:27:46 <bowlofeggs> sounds cool to me. any other thoughts, or shall we move on?
18:27:50 <nirik> anyhow, just wanted to bring it up so everyone thinks about it... I figure we might be able to scrape up 2 machines to setup a test instance on
18:27:51 <linuxmodder> I'd be down for that hackathon but may have to do remote
18:28:21 <nirik> feel free to move on
18:28:42 <bowlofeggs> #topic Apprentice Open office hours
18:29:16 <bowlofeggs> do any apprentices have any questions? need help finding things to do?
18:29:57 <capitanocrunch> Any apprentice workday planned?
18:30:02 <capitanocrunch> https://fedoraproject.org/wiki/Workday_planning_page
18:30:27 <ForrestalGrim> I am looking for some ansible stuff
18:30:52 <puiterwijk> There's currently none planned, I think. Feel free to suggest one on the list
18:31:13 <ForrestalGrim> well stuff meaning if I can help with anyhting..
18:31:37 <ForrestalGrim> maybe if anyone who has time can toss me an assignment or the like
18:31:54 <smooge> capitanocrunch, ForrestalGrim I would think an apprentice work day could be done after F26 release
18:32:11 <smooge> we could do one before hand in a non-freeze period
18:32:20 <linuxmodder> ForrestalGrim,  tried looking onteh easyfix page for some ansible ?
18:32:20 <puiterwijk> ForrestalGrim: did you look at https://pagure.io/fedora-infrastructure/issues?status=Open&tags=easyfix if there's anything interesting for you there?
18:32:25 <capitanocrunch> Ok.
18:32:29 <ForrestalGrim> Not fully understanding the process, Ill take whatever :)
18:32:35 <cyberworm54> once I get added, I am going to start looking at the easyfix and start working on somehting
18:32:36 <bowlofeggs> i've got an ansible thing i've been meaning to do actually - bodhi uses two separate files for its staging.ini and production.ini templates - it would be better if there was just one settings template and the staging/production stuff was just if statements in it
18:32:50 <smooge> capitanocrunch, I would say the apprentice day would be good for you to bring up on the list
18:32:51 <linuxmodder> smooge,  possible to do one in between beta and rc ?
18:32:55 <bowlofeggs> i haven't filed an issue abotu that, but if it sounds fun you could try that out
18:33:07 <ForrestalGrim> insofar as the easyfix not I need to inspect those more.  I was playing the assumption game than advanced stuff like that wouldnt be easyfix.  Maybe my bad there
18:33:08 <linuxmodder> and show some of the pre flip and such
18:33:14 <ForrestalGrim> I'll look deeper tonight
18:33:44 <nirik> FYI, the f26 alpha go/no-go meeting just finished and we are no go. So that means another week of freeze. :)
18:33:58 <bowlofeggs> it's getting too cold around here
18:33:59 <pingou> so I might ask for a FBR to upgrade pagure
18:34:04 <nirik> we could do another docs work day during freeze (which would be fine since docs aren't frozen)
18:34:14 <nirik> pingou: feel free. :)
18:34:14 <pingou> 2.14 brings some IO optimization which I think we be nice to put out
18:34:19 <linuxmodder> worst it could open other doors with things you may not have seen as someone wants your ideas / help elsewhere from work on an easyfix ForrestalGrim
18:34:22 <pingou> the changelog is rather long though :(
18:34:36 <ForrestalGrim> linuxmodder very true
18:35:01 <ForrestalGrim> bowlofeggs do you have a ticket on your bohdi/ansible thing?
18:35:06 <ForrestalGrim> somehtng I can read?
18:35:22 <bowlofeggs> ForrestalGrim: i don't, but i can file one and send you a link after this meeting
18:35:35 <ForrestalGrim> bowlofeggs thanks, thatd be much appreciated
18:35:37 <bowlofeggs> it was just something in my soft, human brain
18:35:41 <ForrestalGrim> lol
18:36:54 <bowlofeggs> any other thoughts?
18:36:57 <bowlofeggs> questions?
18:37:54 <bowlofeggs> #action bowlofeggs will file a ticket about unifying bodhi's staging/production.ini files for ForrestalGrim to check out
18:38:06 <bowlofeggs> ok, let's move on to open floor
18:38:12 <bowlofeggs> #topic Open Floor
18:38:56 <bowlofeggs> <crickets>
18:39:13 <cyberworm54> :)
18:39:49 <puiterwijk> Any other questions or remarks? Favorite build systems?
18:40:07 <nirik> imake!
18:40:08 <ForrestalGrim> Fedora!
18:40:09 * nirik runs
18:40:22 * bowlofeggs installs koji on puiterwijk's smart watch
18:40:43 * puiterwijk is surprised nirik and bowlofeggs didn't mention COPR just to mess with me :D
18:41:00 <puiterwijk> bowlofeggs: which smart watch? I can't even wear a normal watch :-). But I do have koji run everywhere!
18:41:14 <smooge> puiterwijk, I did but was promptly ignored
18:41:43 <ForrestalGrim> thanks guys! (boss just walked in)
18:42:09 <bowlofeggs> hehehe
18:42:23 <bowlofeggs> cool, well it's about that time
18:42:29 <bowlofeggs> #endmeeting