dotnet
LOGS
19:12:49 <Rhea> #startmeeting Fedora DotNet (2017-02-21)
19:12:49 <zodbot> Meeting started Tue Feb 21 19:12:49 2017 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:12:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:12:49 <zodbot> The meeting name has been set to 'fedora_dotnet_(2017-02-21)'
19:12:51 <Rhea> #meetingname dotnet
19:12:51 <zodbot> The meeting name has been set to 'dotnet'
19:12:52 <Rhea> #nick dotnet
19:12:54 <Rhea> #topic Agenda
19:12:56 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_2017-02-21
19:12:58 <Rhea> #info (1) Roll Call
19:13:04 <Rhea> #info (2) Announcements
19:13:09 <Rhea> #info (3) Action items and Tickets
19:13:13 <Rhea> #info (4) Packaging progress
19:13:18 <Rhea> #info (5) Open Floor
19:13:22 <Rhea> #topic Roll Call
19:13:28 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
19:13:34 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
19:13:44 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
19:14:00 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
19:14:06 <amitosh> hello!
19:14:12 <bt0> #info Alberto Rodriguez; UTC-6;Commops, dotnet, infra
19:14:14 <jwf> Oh, I forgot you all had your meeting in this channel, sorry… will try to make sure we are more timely next week!
19:14:22 * Rhea waves at amitosh tmds omajid nmilosev bt0
19:14:24 <bt0> .hello bt0dotninja
19:14:27 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
19:14:28 <omajid> hello!
19:14:31 <bt0> hello
19:14:36 <nmilosev> .fas nmilosev
19:14:37 <zodbot> nmilosev: nmilosev 'Nemanja Milosevic' <nmilosevnm@gmail.com>
19:14:40 <Rhea> don't worry jwf - i couldnt split myself into two meetings either way
19:15:01 <rkieley> #info Roddie Kieley; UTC-3.5; DotNet, powershell, msbuild
19:15:16 <tmds> .hello tmds
19:15:17 <zodbot> tmds: tmds 'Tom Deseyn' <tom.deseyn@gmail.com>
19:15:19 <tmds> hi everyone
19:15:39 <rkieley> hey tmds, et al.
19:15:56 * pcreech late
19:16:00 <amitosh> #info Amitosh Swain; UTC+5:5:30; DotNet, Go, web, ..
19:16:18 <pcreech> or, er... on time :)
19:16:24 <Rhea> :D
19:17:53 <amitosh> so, i'll mostly be observing this one, this is my first meeting
19:18:03 <nmilosev> Welcome amitosh!
19:18:19 <Rhea> welcome =]
19:18:27 <Rhea> #topic Announcements
19:18:40 <Rhea> Anyone anything - me not... I've not seen anything significant since 7th feb.
19:19:06 <Rhea> going once... going twice...
19:19:10 <Rhea> #topic Action items and Tickets
19:19:10 <nmilosev> !
19:19:12 <Rhea> #link https://meetbot.fedoraproject.org/teams/dotnet/dotnet.2017-01-17-19.04.html
19:19:15 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
19:19:18 <Rhea> too late ! :D
19:19:31 <Rhea> what is it nmilosev
19:19:32 * nmilosev did we announce that .net core 2.0 release date got pushed away
19:19:39 <nmilosev> Q3
19:19:45 <nmilosev> not "spring"
19:19:48 <Rhea> Oh nope, yeah i heard, not sure it's true.
19:19:54 * nmilosev checks
19:19:57 <Rhea> (internally i don't believe it)
19:20:12 <Rhea> At least previews will still be spring in my personal opinion
19:20:14 <nmilosev> Yep, https://github.com/dotnet/core/blob/master/roadmap.md
19:20:19 <nmilosev> Q3
19:20:25 <tmds> the thing is, spring means something different at the southern hemisphere
19:20:27 <Rhea> yeah maybe the final thing i guess
19:20:33 <Rhea> haha tmd
19:20:33 <tmds> so they replaced it by Q3
19:20:35 <Rhea> tmds
19:20:38 <tmds> no really, not a joke
19:20:53 <nmilosev> Q3 is more precise :D
19:21:02 <nmilosev> Thing is, Fedora 26 is ~June
19:21:12 <Rhea> :D
19:21:16 <tmds> https://github.com/dotnet/core/commit/21217cefb344b84292508bea4e6b3ed3f18058e7
19:21:29 <Rhea> funny
19:21:42 <omajid> oh. crud. are we going to have a repeat of last time where f24 and .net core 1.0 were released a few days of each other and f24 wasn't supported?
19:21:45 <nmilosev> (Ctrl+D -> best of github)
19:21:46 <tmds> I agree, it's not a joke... but still funny :D
19:21:59 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
19:22:02 <Rhea> yes omajid
19:22:03 <nmilosev> omajid, yes, thats my worry too
19:22:18 <Rhea> well, we will work to make it work
19:22:26 <tmds> I am worried more about OpenSSL
19:22:37 <omajid> nmilosev: want to mention the good news?
19:22:39 <nmilosev> tmds, that's also very bad
19:22:51 <nmilosev> good news! omajid found a compat package
19:23:07 <tmds> good
19:23:08 <nmilosev> So if everything works as it should F26 builds will be live later tonight or tomorrow
19:23:16 <Rhea> nmilosev obsolete the old 1.0 copr packages -- status?
19:23:19 <nmilosev> (will try later)
19:23:21 <nmilosev> Rhea, done!
19:23:25 <Rhea> #info === [COMPLETE] nmilosev obsolete the old 1.0 copr packages ===
19:23:41 <Rhea> nmilosev cleanup the dotnet-clean rpm (remove debug symbols) --- status?
19:23:48 <nmilosev> Rhea, done
19:23:50 <nmilosev> :D
19:24:11 <Rhea> #info === [COMPLETE] nmilosev cleanup the dotnet-clean rpm (remove debug symbols) ===
19:24:17 <nmilosev> but it's omajid++ you should thank
19:24:18 <zodbot> nmilosev: Karma for omajid changed to 5 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:24:31 <tmds> what is a compat package?
19:24:33 <Rhea> #info === [COMPLETE] Rhea create an issue on pagure to keep rid info and discussion together ===
19:24:35 <Rhea> #info Fedora 25 and 26 RID PR was already merged. A lot more work necessary for smooth builds though (more in packaging topic)
19:24:38 <Rhea> #link https://github.com/dotnet/corefx/pull/16302
19:24:41 <omajid> i was just prodding, nmilosev did the work :)
19:24:49 <nmilosev> tmds https://koji.fedoraproject.org/koji/buildinfo?buildID=841460
19:24:59 <nmilosev> Rhea, good work
19:25:06 <nmilosev> Did we think about rawhide?
19:25:12 <nmilosev> Or no point now?
19:25:23 <Rhea> lets quickly do gsoc then packaging
19:25:27 <Rhea> #info === GSoC ===
19:25:34 <Rhea> #link http://etherpad.rhea-ayase.eu/p/dotnet-gsoc2017
19:25:37 <tmds> nmilosev: you specify this as a dependency and it just installs?
19:25:45 <Rhea> #info The original idea was scratched, we have two different ones.
19:25:56 <Rhea> #info Idea#1 was changed - a bit of research necessary.
19:26:01 <nmilosev> tmds, in theory yes, we do a rpm thing to check if Fedora 26
19:26:03 <Rhea> #action Rhea rewrite the Idea #1 to reflect recent findings
19:26:08 <Rhea> #info Idea#2 - .NET Core wrapper library for systemd
19:26:31 <Rhea> Feel free to pitch in on the linked etherpad if you have any interest or feedback
19:26:33 <nmilosev> tmds, check Idea #2
19:26:40 <nmilosev> it should use tmds.Dbus
19:26:42 <Rhea> (note that the idea1 has to be fixed up - i didnt have time to)
19:27:17 <rkieley> I like idea#2 vs idea#1 - can reach more folks who might want to use it
19:27:21 <tmds> nmilosev: systemd is exposing a lot of stuff on dbus
19:27:32 <tmds> but I don't know what :D
19:27:35 <nmilosev> tmds, that's why I proposed the idea to Rhea :)
19:27:57 <nmilosev> Rhea, what about FAS changes?
19:28:09 <Rhea> Yeah it should be interesting to have it available
19:28:11 <nmilosev> Is there no point now to make a client
19:28:18 <Rhea> and i'd use it in my projects
19:28:19 <tmds> what can someone do with the dbus wrapper library?
19:28:49 <Rhea> e.g. i'm writing load ballancer in C# for my other C# project... i would like to have systemd access to check on mah services or control them
19:28:52 <nmilosev> use dbus to talk to systemd = library for systemd
19:29:14 <tmds> what do you want to tell systemd?
19:29:30 <nmilosev> "give me all running services"
19:29:36 <nmilosev> "kill service firewalld"
19:29:46 <nmilosev> "reboot in 15 minutes"
19:30:37 <amitosh> tmds Or check if service X is running? I have seen a real world use case by a analytics company who use dotnet core on linux
19:30:56 <amitosh> they shell out a python script to do the check and return a status code
19:31:24 <nmilosev> It could be done without dbus probably
19:31:29 <nmilosev> But much cleaner with it
19:31:39 <nmilosev> + you get 1000 github stars :D
19:31:57 <tmds> I like it personally, I don't know if many people are waiting for it though
19:32:17 <Rhea> Oh right
19:32:21 <tmds> it will be fun to build
19:32:27 <Rhea> I created fedora .net org on github
19:32:28 <tmds> that is a nice thing :D
19:32:33 <Rhea> for the purpose of mainly gsoc right now
19:32:38 <Rhea> i invited you guys as well
19:32:42 <tmds> but I think it will < 1 downloads per day on nuget
19:32:58 <Rhea> This is so we can easily maintain our product projects and they don't fall forgotten on students github account...
19:33:07 <Rhea> To ensure that SOMEONE will be there to keep it going
19:33:17 <Rhea> (someone - dotnet sig in this case)
19:33:37 <tmds> not sure an org solves that
19:33:41 <nmilosev> Rhea, why not pagure? Just asking?
19:33:58 <Rhea> our pagure is for packaging
19:34:07 <Rhea> and i wanted to keep it on github for the community reach
19:34:20 <nmilosev> I mean separate pagure
19:34:22 <Rhea> our non-packaging projects
19:34:27 <nmilosev> dotnet-fedora-gsoc2017
19:34:35 <Rhea> yeah but i think that dotnet is simply better for nuget libraries and stuff
19:35:10 <Rhea> and i want to keep it running and maintain it after gsoc... we discussed this with jwf as well, we kinda agreed that many gsoc projects simply fall forgotten on student repo somewhere...
19:35:36 <nmilosev> (like all student projects)
19:35:37 <nmilosev> :D
19:35:42 <Rhea> yeah
19:35:45 <tmds> I don't think an org solves that
19:35:48 <Rhea> thats what i'd like to avoid...
19:36:00 <Rhea> Well org just makes it easier to manage permissions of many projects
19:36:09 <Rhea> i dont want to end with one gsoc project guys :D
19:36:14 <Rhea> think future!
19:36:19 <Rhea> okay moving on to packaging?
19:36:53 <Rhea> Also it looks cool on our github profiles to have both RH and Fedora logos next to each other
19:37:01 <Rhea> xD
19:37:22 <Rhea> packaging...
19:37:24 <Rhea> going once
19:37:26 <Rhea> twice
19:37:35 <Rhea> #topic Packaging progress
19:37:58 <Rhea> So i was looking into what would be needed to be upgraded upstream dotnet to support f25/6
19:38:04 <Rhea> It sucks.
19:38:07 <nmilosev> a lot
19:38:13 <Rhea> :D
19:38:18 <nmilosev> vertical build supports only F23
19:38:22 <nmilosev> for now
19:38:28 <nmilosev> which is EOL
19:38:58 <Rhea> yep
19:40:32 <tmds> the source-build should help there, right?
19:40:44 <Rhea> yup
19:41:00 <nmilosev> source-build still requires bootstrapping
19:41:07 <nmilosev> which is very weird for me
19:41:17 <nmilosev> I though everything would be built with clang
19:41:38 <nmilosev> bottom -> top
19:41:58 <omajid> nmilosev: .net core sources are written in C#, so you need a compiler to build it, which means you need roslyn, which means you need a runtime. it's a cycle
19:42:10 <nmilosev> maybe it changes in the future, but apart from rebuilding roslyn it is almost exactly the same as rover
19:42:18 <omajid> same problem exists with any language, fwiw.
19:42:35 <nmilosev> yeah, I just hoped it would be simpler :(
19:42:46 <nmilosev> So we need F25 .NET Core 2.0 to build for F25
19:42:54 <Rhea> yup
19:42:57 <Rhea> and 26
19:43:02 <Rhea> we need to focus on 26
19:43:03 <nmilosev> which we can't have because we can't build it
19:43:05 <Rhea> not 25 imho
19:43:12 <nmilosev> omajid, can we build with 23 for 25/26?
19:43:15 <Rhea> we have solid 25 package and i'd stop there
19:43:21 <Rhea> and push towards 26
19:43:28 <Rhea> to have official 26 packages
19:43:33 <tmds> nmilosev: why not bootstrap using portable linux-x64?
19:43:39 <Rhea> to catchup with the delay in microsoft releases
19:43:46 <nmilosev> tmds, no binaries :(
19:44:05 <tmds> you can download the CI binaries
19:44:05 <omajid> we will have to use a binary for boostrapping.
19:44:18 <tmds> they are being built
19:44:19 <nmilosev> tmds, link please?
19:44:34 <nmilosev> The biggest issue with F26 is the default OpenSSL 1.1
19:44:51 <tmds> if you have the compat package, that is fixed
19:45:06 <nmilosev> I'd rather not use it :(
19:45:27 <nmilosev> But it's a brilliant option we have right now
19:45:41 <tmds> I find it is acceptable
19:45:45 <tmds> OpenSSL broke API compat
19:45:56 <tmds> but 1.0 is not less secure than 1.1
19:46:04 <tmds> it is missing some features which dotnet doesn't use
19:46:51 <tmds> so, it isn't strange that when the API is broken, you need both packages during some time
19:47:29 <nmilosev> okay so my next task is to play with source-build
19:47:40 <nmilosev> to see what do we need to do to build on f25/26
19:47:57 <nmilosev> maybe we can really use generic payload
19:48:05 <nmilosev> (linux-x64 I mean)
19:49:03 <tmds> https://github.com/dotnet/core-setup has linux-x64 downloads
19:49:31 <tmds> It just says tar.gz so I don't know if it has the full sdk in it
19:49:54 <tmds> or only the runtime
19:49:57 <nmilosev> didn't notice this, thank you
19:50:42 <tmds> np
19:50:45 <Rhea> Yep, i have to focus on RH side of things but feel free to poke me nmilosev and i'll be more than happy to split some tasks with you, if you have a bug or whatever that we could maybe even push upstream fix
19:51:03 <nmilosev> sure thing :)
19:51:37 <omajid> likewise from me
19:52:11 <amitosh> tmds: https://www.microsoft.com/net/core says the tar.gz is the SDK
19:52:40 <nmilosev> I'm checking it right now :)
19:52:42 <tmds> then nmilosev is set to go
19:53:11 <nmilosev> nah, just runtime
19:53:41 <tmds> as long as it has the native binaries ...
19:53:47 <Rhea> The nice thing is what i like a lot that everything we do at RedHat affects all distros more-less...
19:53:49 <tmds> it isn't an empty tar.gz file, right :D
19:53:54 <Rhea> Especially Fedora as being the closest
19:54:07 <nmilosev> yeah should work :D
19:55:09 <omajid> sdks are normally named `dotnet-dev-$OS*`. runtime images are just `dotnet-$OS`
19:55:29 <nmilosev> yeah, I noticed that as well
19:55:35 <nmilosev> dotnet-dev is only for f23
19:55:41 <nmilosev> I think f24 link is broken
19:55:45 <nmilosev> (last time I checked)
19:55:52 <omajid> hey guys, i have to step away for another meeting.
19:56:08 <nmilosev> see you omajid :)
19:56:11 <Rhea> Can I action this to you nmilosev to start a ticket to note things you have and don't have, we will pitch in (omajid posted some links in our channel, etc...)
19:56:16 <Rhea> bai!
19:56:41 <nmilosev> Rhea, sure
19:56:48 <tmds> bb
19:57:43 <Rhea> #action nmilosev create a ticket tracking source build for f26 (25)
19:58:02 <Rhea> Do we have anything else or are we packing it?
19:58:25 <nmilosev> We are almost packing it :D
19:58:47 <Rhea> #topic Open Floor
19:58:50 <Rhea> hehe yep
20:01:55 <Rhea> #endmeeting