magazine
LOGS
22:00:01 <stickster> #startmeeting Magazine editorial board
22:00:01 <zodbot> Meeting started Thu Jan  5 22:00:01 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:00:01 <zodbot> The meeting name has been set to 'magazine_editorial_board'
22:00:02 <stickster> #meetingname magazine
22:00:03 <zodbot> The meeting name has been set to 'magazine'
22:00:04 <stickster> #topic Roll call
22:00:05 <stickster> .hello pfrields
22:00:07 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
22:00:24 <stickster> #chair jflory7 ryanlerch
22:00:24 <zodbot> Current chairs: jflory7 ryanlerch stickster
22:00:40 <ryanlerch> .hello ryanlerch
22:00:41 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
22:00:43 <sub_pop> .hello linkdupont
22:00:44 <zodbot> sub_pop: linkdupont 'Link Dupont' <link@sub-pop.net>
22:00:57 <ryanlerch> morning sub_pop stickster !
22:00:59 <stickster> #chair sub_pop
22:00:59 <zodbot> Current chairs: jflory7 ryanlerch stickster sub_pop
22:01:07 <sub_pop> hello hello
22:01:15 <stickster> morning/afternoon/evening everyone, and Happy New Year
22:01:48 * stickster not sure jflory7 is attending due to schedule, so let's plunge ahead
22:01:50 <ryanlerch> happy new year and happy 5million!
22:01:56 <stickster> #topic Last week status
22:02:02 <stickster> #info HAPPY 5 MILLION VIEWS!
22:02:14 <ryanlerch> #WOOOOOOOOOOOOOOOOOOO
22:03:19 <stickster> I should point out we had a fantastic December. Weekly pace was good, but notably Oct/Nov/Dec 2016 was the strongest quarter we've ever had, over 768K views in that quarter
22:03:35 <stickster> December didn't dip that much from November like we normally see post-release
22:03:38 <ryanlerch> stickster: wow, amazing
22:03:43 <sub_pop> wow, that's a lot of views
22:03:53 <stickster> probably because we had a lot of "lift" from additional articles, such as upgrading
22:04:03 <ryanlerch> we had nearly 2.4 million views for 2016
22:04:19 <stickster> #info almost 2.4M views in 2016
22:04:36 <stickster> #idea We should strive to increase in 2017... 3M views doesn't seem impossible to me
22:05:18 <stickster> Maybe we can use part of this meeting at the end (after settling schedule) to throw around a few ideas about how to make that happen
22:06:08 <stickster> Anything else on week in review?
22:07:03 <ryanlerch> we can loop back to this at the end, but surprisingly, hte best non-release related article of the year was the i3 window manager artuicle
22:07:15 <ryanlerch> gets a lot of consistent hits
22:07:38 <sub_pop> i really liked the gnupg article series. that was 2016 wasn't it?
22:08:12 <stickster> whoa, ryanlerch, that is interesting
22:08:20 <stickster> sub_pop: Yes, I believe it was
22:09:19 <stickster> OK, moving onward
22:09:28 <stickster> #topic Pending review
22:10:14 <stickster> Unfortunately, we got our first spam article this week. It's been trashed, but let's be on the look out for those. If you see an upsurge, puiterwijk asked that we contact him.
22:10:25 <stickster> It was in Pending Review, which is why I mention it here
22:10:48 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending
22:11:11 <stickster> #info --- Docker and OpenShift ---
22:11:12 <ryanlerch> if it gets too bad, we might need to close off writing new articles to author status again
22:11:41 <stickster> ryanlerch: agreed... if it turns out to be a consistent problem, at least it's easy to solve
22:11:59 <stickster> #link https://fedoramagazine.org/?p=16001&preview=1&_ppp=6619143bce
22:12:41 <stickster> So I actually corresponded with phracek about this article earlier in the week. It's actually a SUPER article for us. Only minor issue I had is that it doesn't spell out enough "why" at the top
22:12:51 <ryanlerch> this one looks good -- it's heavy on the how, but needs more why and what IMHO
22:12:56 <ryanlerch> jinx
22:12:56 <stickster> ha, *jinx
22:13:00 <stickster> *metajinx
22:13:22 <stickster> lame C joke: That should have been *(*metajinx)
22:13:28 <ryanlerch> lol
22:13:34 <sub_pop> lol
22:13:43 <stickster> HERE ALL WEEK, TRY THE PRIME RIB
22:13:52 <sub_pop> no C joke is lame
22:14:19 <stickster> ryanlerch: I got a note from Petr about it... it didn't completely answer my questions but was useful
22:14:34 * stickster thinks this is one good edit away from publishing, but needs an image too
22:15:02 <ryanlerch> might also be useful to note that thisis running openshift locally, rather than using online
22:15:13 <ryanlerch> i can do the image today
22:15:21 <stickster> exactly -- meaning anyone can do it without joining up with the service
22:15:35 <stickster> Maybe that would be enough background on top of what Petr provided
22:15:47 <stickster> ryanlerch: I can volunteer to edit after meeting, might not get it done for a couple hours though
22:16:15 <ryanlerch> stickster: i can do the featured image straight after the meeting
22:16:26 <stickster> then we could get it out at 8UTC tomorrow?
22:16:34 <stickster> er, today for you
22:16:35 <ryanlerch> stickster: sounds good to me
22:16:38 <ryanlerch> :D
22:16:40 <stickster> coolio
22:16:50 <stickster> #action ryanlerch do featured image for docker+openshift post
22:17:02 <stickster> #action stickster finish editing docker+openshift post, note no need for openshift online
22:17:20 <stickster> #info --- FreeOrion in Fedora ---
22:17:38 <stickster> #link https://fedoramagazine.org/?p=15847&preview=1&_ppp=bcafc5b4b8
22:17:40 <sub_pop> that's me!
22:17:44 <stickster> \o/
22:18:03 <ryanlerch> is freeorion in the repos yet?
22:18:23 <sub_pop> I've been holding it out of bodhi in order to sync it with this article
22:18:34 <stickster> Ha
22:18:46 <sub_pop> since the intention was to make it an article sort of about freeorion and sort of about contributing using bodhi.
22:18:57 <stickster> Well, maybe it would make more sense to post this as a Friday selection, because people might play more games over the weekend
22:20:11 <stickster> We actually could reuse the existing image from https://fedoramagazine.org/install-freeorion-fedora/
22:20:13 <sub_pop> sure. the package is ready, i just need to submit the updates for f25 and f24. It should already be in rawhide. and there's like a day or so lead time between the submit and when the packages land in the updates-testing
22:20:56 <stickster> Oh good point sub_pop... so maybe best to submit now, and we can try to post the article Monday or Tuesday next week when we know the packages are in
22:21:15 <ryanlerch> +1 for reusing the image!
22:21:23 <ryanlerch> +1 for early next week too
22:22:22 <sub_pop> Sure. As long as I know when the article is publishing, I can get the updates submitted ahead of time. I think the article needs an editor/review too though. I keep writing this stuff way too late at night.
22:22:28 <stickster> sub_pop: Let's do this -- you submit to Bodhi. When you know the packages have been pushed out to at least a couple mirrors, let us know on Magazine list and we'll schedule accordingly
22:23:04 <stickster> no need to wait for a slot, we can push the article within 24 hours. That's better than hoping things sync to mirrors in time, it's less predictable
22:23:35 <sub_pop> haha ok. I'll verify the packages are good and submit them tonight or tomorrow.
22:23:49 <stickster> cool
22:24:12 <stickster> #action sub_pop submit packages to bodhi, advise Magazine team when they start hitting updates-testing repos on mirrors
22:24:43 <stickster> #topic Drafts
22:24:47 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft
22:26:06 <stickster> So there are only a couple things here that are "fresh"
22:26:23 <stickster> (1) Devilspie terminal emulator -- but as noted on list, doesn't work in Wayland and author is looking for a substitute
22:26:47 <stickster> (2) Testing packages -- yay sub_pop -- might make an excellent follow on to the FreeOrion article
22:27:17 <sub_pop> ohh yea. that was a genericified version of my freeorion article.
22:27:27 <stickster> (3) ModernPaste -- this is more or less waiting for the new Fedora pastebin deployment, should be within the next week or two
22:27:30 <ryanlerch> there are a few in here that were starter pitches too i think, that were assigned and never worked on it seems
22:27:35 <sub_pop> not sure if there's enough substance there to make it a full article yet.
22:27:38 <stickster> ryanlerch: *nod
22:29:00 <stickster> So I think I could write one of these articles in time for next Wed publication. I'll have some spare time this weekend. No gigs, might be snow, and I have other work to do at the desk anyway
22:29:43 <ryanlerch> i could grab the openweather one
22:29:58 <stickster> ryanlerch: How about that for next Friday?
22:30:04 <ryanlerch> stickster: +1
22:30:11 <stickster> #topic Fill out publishing schedule
22:30:33 <stickster> #action ryanlerch Write and schedule OpenWeather article for next Friday
22:30:57 <ryanlerch> okies, just reassiged that one to me
22:31:22 <stickster> #action stickster Write up a Starter Pitch article for next Wed
22:32:14 <stickster> ^^ this will probably be the Apache one, or maybe one of the extension articles
22:33:11 <stickster> #info Publishing schedule: Fri 2017-01-06, docker+openshift; Mon 2017-01-09, FreeOrion; Wed 2017-01-11, Apache (or TBA); Fri 2017-01-13, OpenWeather
22:33:29 <stickster> Also, if we get something fun for Tue or Thu on top, that's great too, more is better
22:33:42 <stickster> ^ look good?
22:34:01 <sub_pop> sounds good to me
22:35:14 <stickster> #topic Open floor
22:35:40 <stickster> #info --- How can we get to 8M pageviews total in 2017? ---
22:36:22 <stickster> soliciting ideas here, don't be shy!
22:36:35 <misc> split the article in 2 pages, like phoronix :) ?
22:37:39 <misc> more seriously, get it mentionned on HN/LWN etc that would bring new readers, so find what do this audience is interested in ?
22:39:24 <stickster> misc: I should have been more clear... we *have* a target audience, so it's not about changing the focus such that the audience we have drifts away
22:39:43 <sub_pop> i3 was the most popular article. what were some of the others?
22:40:02 <stickster> misc: the 2 page idea isn't terrible though
22:40:17 <stickster> if there are meaningful articles we can split, that's not a bad thing at all!
22:41:08 <stickster> ryanlerch: do you have a "top NN list" of articles for the year?
22:41:25 <sub_pop> What about some community roundups? Like a This week in Fedora?
22:41:54 <sub_pop> or is that more suited for the community blog?
22:42:24 <stickster> sub_pop: more for comm-blog -- we try to engage the audience that doesn't really care how Fedora works internally as a project
22:42:41 <sub_pop> cool ok
22:42:54 <ryanlerch> stickster: https://paste.fedoraproject.org/520500/36561601/
22:42:56 <misc> stickster: 2 pages is gaming the stats, and I kinda dislike how phoronix does it :)
22:43:02 <stickster> heh
22:43:34 <stickster> ryanlerch: one of the noticeable things... the "listicle" articles *do* score high!
22:43:58 <stickster> roundups like that could be really good... so idea: we brainstorm some other listicle pitches
22:44:41 <stickster> we might have gamed the system by republishing those, but IIRC the *reason* we reprinted them is they scored highly already
22:45:08 <ryanlerch> stickster: these are just the stats for the 2016 period
22:45:14 <misc> the stats seems to favor newer articles over older ones, no ?
22:45:17 <stickster> ryanlerch: well blow me down
22:45:28 <ryanlerch> so some posted later in the year might also not show up higher
22:45:46 <stickster> misc: top articles are older ones actually -- release of F24 for example
22:46:04 <misc> stickster: I was more looking at the bottom :)
22:46:18 <misc> but if that's for 2016, i guess that's why F21 news wasn't interesting
22:46:38 <stickster> *nod
22:47:06 <stickster> #idea more listicles
22:47:16 <ryanlerch> i think also having articles about new package updates of popular software might be a good thing too
22:47:32 <stickster> #idea articles about package updates of popular software
22:47:33 <ryanlerch> they wont rate as high on the stats view above
22:47:47 <ryanlerch> since they are more newsy
22:48:05 <stickster> ryanlerch: but easy to write as filler so we can have more total posts
22:48:12 <stickster> Here's another idea... I think another continuing series would be great
22:48:12 <ryanlerch> stickster: agreed
22:48:28 <stickster> Like HDYF, which has been *tremendous* thanks to cproffit
22:48:35 <ryanlerch> the tough part with package updates articlesis getting the ideas for content
22:48:43 <misc> release every month instead of every 6 months :p
22:48:51 <ryanlerch> trolling through bodhi is high noise to signal
22:49:09 <sub_pop> what about just critical path?
22:49:33 <misc> wasn't critical path deprecated ?
22:49:40 <ryanlerch> sub_pop: a lot of critical path is kinda boring IMHO :)
22:49:46 <misc> but mhh, what about kernel stuff ?
22:49:53 <sub_pop> haha
22:50:05 <ryanlerch> important, but boring :D
22:50:16 <misc> I guess that might not fit the audience, and might already duplicate phoronix/lwn :/
22:50:22 <sub_pop> can we see what new packages get scooped up into appstream-data?
22:50:33 <ryanlerch> we sporatically did firefox updates
22:50:41 <misc> what about speaking of new arm board being supported by Fedora arm ?
22:50:41 <ryanlerch> but havent done any for a while
22:51:06 <ryanlerch> stickster: i like the idea for a new series
22:51:20 <ryanlerch> any thoights on what kind of angles we could take?
22:52:10 <misc> a historical recap, like "fedora 1", and associated softwaer ?
22:52:13 <misc> and 2, and 3
22:52:40 <sub_pop> oh man!
22:52:50 <ryanlerch> sub_pop: it might be worth reaching out to package maintainers of popular software to contact us when a new major(ish) update of their software is in the pipeling
22:53:13 <sub_pop> can we offer qcows2 images of Fedora Core 1 for download?
22:53:16 <stickster> ryanlerch: sub_pop: Yeah, nice idea... maybe get that on the comm-blog and/or lists?
22:54:25 <stickster> #idea use comm-blog and/or devel list to ask maintainers of popular SW packages to let us know when a new major(ish) update is coming soon
22:54:59 <stickster> #idea start another continuing series
22:55:38 <ryanlerch> #idea [series] -- living on the command line
22:55:51 <stickster> Not sure what that would be.... elements of HDYF that make it work well: (1) scalable, since the profiled person just answers an easy set of interview questions; (2) featured images provided by subjects as well
22:56:12 <stickster> Oh ryanlerch, nice idea -- like "substitute <C> for <G>" in terms of packages?
22:57:08 <ryanlerch> yeah a lot of terminal apps arent really clear on how to set up on fedora
22:57:21 <ryanlerch> like powerline, tmux, mutt, etc
22:57:26 <ryanlerch> lots of potential there
22:57:44 <ryanlerch> its more of an informative series, but might have some staying power
22:57:59 <stickster> ryanlerch: true
22:58:18 <stickster> So this is a bunch of good ideas, maybe we can take to list for further discussion?
22:58:33 <ryanlerch> stickster: sounds like a plan and a half
22:58:47 <stickster> #action stickster to escalate list of ideas for moar hits to the mailing list
22:58:58 <stickster> Anything else before we close up?
22:59:10 <ryanlerch> 5 MILLLLLLLLLLION VIEEEEEEWS!
22:59:42 <ryanlerch> half of our total recorded views came in 2016
22:59:56 <stickster> ٩(^ᴗ^)۶
23:00:49 * stickster emailed the list to congratulate the crew
23:00:58 <ryanlerch> stickster: i saw! woo
23:00:59 <stickster> OK then, I think that's it, closing in 10
23:01:11 <ryanlerch> yeah nothing more from me for this meeting
23:01:21 <stickster> Thanks for coming, everyone!
23:01:23 <stickster> #endmeeting