fedora-qa
LOGS
16:00:11 <adamw> #startmeeting Fedora QA meeting
16:00:11 <zodbot> Meeting started Mon Dec 12 16:00:11 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:11 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:16 <adamw> #meetingname fedora-qa
16:00:16 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:19 <adamw> #topic Roll call
16:00:53 * coremodule is here.
16:01:13 <coremodule> Good morning!
16:01:57 * a2batic is here
16:02:47 * cmurf coalesces
16:03:38 <adamw> morning morning
16:03:41 <adamw> how's everyone doing this morning?
16:03:51 * sumantrom is here
16:03:58 <adamw> cmurf: you know it's only supervillains who coalesce, right?
16:04:03 * sumantrom is sorry that i am late
16:04:10 <coremodule> Doing well, how 'bout you?
16:04:37 <cmurf> adamw: myth
16:04:48 <sumantrom> hii adamw
16:04:50 <cmurf> adamw: but I could be a supervillain
16:05:03 <adamw> cmurf: well, duh, of course you'd say that
16:05:11 <sumantrom> cmurf & coremodule o/
16:05:41 <adamw> alllrighty
16:05:49 <adamw> time for the weekly round of Stuff Adam Forgot To Do Since Last Time
16:05:58 <adamw> #topic Previous meeting follow-up
16:06:21 <adamw> ooh yes, and that's exactly what we've got!
16:06:29 <cmurf> hi sumantrom
16:06:42 <adamw> #info "adamw to look into USB writing tool coverage in the validation matrices, draft something up" - still didn't get around to that, note it's not super high priority. putting back one more time
16:06:53 <adamw> #action adamw to look into USB writing tool coverage in the validation matrices, draft something up
16:06:55 <adamw> aaand that's it
16:06:59 <adamw> any other follow-up from last time?
16:07:23 <cmurf> seems like ages
16:08:07 <adamw> it was only two weeks
16:08:14 <adamw> shocking i know
16:09:08 <adamw> #topic Optical media test coverage discussion
16:09:14 <cmurf> those brain cells aren't available right now
16:09:32 <adamw> so one validation change that *did* get proposed, since kparal isn't useless like me, is this one
16:09:42 * adamw whacks cmurf to spin the brain cells around a bit
16:10:37 <cmurf> clarity might have been in emergence, but now it's all mixed up
16:11:09 <adamw> in case anyone missed it, we're talking about https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/KICRVUS3YHNTLHY47O5A2XL2C5YMCFIH/
16:11:19 <adamw> yeah, it's a bit of an ongoing discussion
16:11:34 <adamw> anyone know if kparal's actually around?
16:11:42 <adamw> not sure we got anyone from brno
16:11:45 <adamw> maybe they're all at the bar
16:12:24 <cmurf> Yeah the way he put it in the email made me suspicious.
16:12:59 <adamw> how do you mean?
16:13:23 <cmurf> Ahh yes, "we'll be at a different event"
16:13:34 <cmurf> suuure, gotcha ;-) code for "bar"
16:13:53 <adamw> oh, email today? i don't have any rh emails from the last two days as my mail server fell off the vpn again (actually the rh vpn config changed today so that's probably why)
16:14:06 <cmurf> he replied to the announcement
16:14:22 <adamw> so i guess my take on this is there's lots of random tangential discussion but i haven't really seen anything that goes against the basic idea of the proposal
16:14:28 <adamw> ah, thanks
16:14:34 <adamw> yeah, i guess they're at BeerCon
16:14:40 <cmurf> haha
16:14:47 <adamw> it's a weekly event in brno
16:14:51 <adamw> ...BeerCon Monday, that is
16:14:52 <cmurf> When it it not BeerCon in Brno?
16:15:03 <adamw> BeerCons Tuesday, Wednesday, Thursday, Friday, Saturday and Sunday also run weekly
16:15:47 <cmurf> 1/2 day and full day tickets available
16:16:05 <adamw> so does anyone actually have a problem with the basic idea here, which is to cut down the guaranteed validation testing of physical optical media a bit?
16:16:15 <cmurf> No. Cut it.
16:16:17 <adamw> it seems to me like there's generally no significant objections
16:16:27 <cmurf> Open question is which one or two to keep.
16:16:31 <coremodule> No objection here.
16:17:09 <cmurf> The likelihood server netinstall passes the baremetal optical test, but other netinstalls don't work is pretty close to zero.
16:17:37 <adamw> yeah, i think i proposed one netinstall, one live, and one dvd (which would be server, since it's the only one)
16:17:43 <cmurf> Off hand I'd say test server netinstall, and workstation live.
16:17:52 <adamw> but i just wanted to have the topic in case someone had a strong objection or alternative idea
16:18:12 <cmurf> I'd flip a coin on netinstall or DVD, even the DVD is based on boot.iso
16:19:00 <cmurf> Maybe one day we get a pure UDF image with none of this whacky partition stuff
16:19:05 <adamw> there's enough of a difference in the compose process that it's probably worth testing both.
16:19:27 <adamw> cmurf: your mission, should you choose to accept it, is to burn every mac in the world
16:19:49 <cmurf> Macs don't have optical drives anymore :-P
16:19:58 <adamw> alllrighy
16:20:12 <adamw> #agreed there are no objections to the basic idea of cutting down guaranteed optical media testing
16:20:26 <adamw> #topic Fedora 26 Test Day status
16:20:50 <adamw> so, this is for coremodule and sumantro: where do we stand with the organization process?
16:20:54 <sumantrom> Mailed all the propose change owners :)
16:20:57 <cmurf> Oh you want the Macs themselves burned...cute but not an original idea.
16:21:28 <cmurf> In fact I'm pretty sure one of mine did burn. Just without the smoke and soot.
16:21:31 <sumantrom> DNF 2.0 team replied saying they are ready to go right after the early branch of f26
16:22:17 <sumantrom> waiting for reply from Petr Sabata about MBS
16:22:22 <coremodule> Will our new ticket system be in place before F26 is branched?
16:22:32 <adamw> hah, i was actually going to bring that up next
16:22:37 <adamw> forgot to put it on the agenda
16:22:45 <sumantrom> and yet to recieve any conformation from BlivetGUI
16:22:52 <adamw> alrighty
16:23:22 <adamw> #info Test Day organization team is in the process of contacting relevant change owners and pre-planning the list of events
16:23:23 <sumantrom> tickets has been filed and I will update them with all the info soon after f26 is branched
16:23:41 <cmurf> squirrel
16:24:13 <adamw> sounds great
16:24:36 <sumantrom> Thanks :)
16:24:53 <adamw> when are we planning the 'call for test days' mail? bit closer to branching?
16:25:12 <sumantrom> yes when we are bit closer to branching .
16:25:22 <cmurf> just a guess that most people's brains are in hibernation through jan 2
16:25:32 <adamw> yeah, that's usually the case
16:25:37 <cmurf> ok maybe jan 10 but at some point time to crack that whip
16:25:39 <sumantrom> A bit off topic but , the retrospection email needs to go out as well
16:25:41 <adamw> best time to change things while no-one's paying attention! ;)
16:25:52 <adamw> sumantrom: yes, did you send me a draft of it? i may have missed it
16:26:11 <adamw> #info call for Test Days will go out in the new year, closer to branching
16:26:14 <sumantrom> yes adamw i did and you confrimed it reached you
16:26:16 <adamw> #topic Fedora 25 Retrospective status
16:26:22 <adamw> sumantrom: oh man, i'm gettin' old - sorry, my bad
16:26:35 <adamw> #info sumantro has drafted a retrospective email and it's waiting for adamw to review it, will go out to the list soon
16:26:44 <adamw> #action adamw to review the draft retrospective mail
16:26:59 <cmurf> shhhh do not say you're getting old
16:27:03 <adamw> #info we will convert retrospective to actionable tickets in the new year after there's been some time for contributions
16:27:10 <cmurf> stike that from the record
16:27:16 <cmurf> or strike
16:27:19 <adamw> alright, so as we were saying...
16:27:30 <adamw> #topic Trac to Pagure migration status
16:27:40 <adamw> so, a2batic sent out an initial plan a few weeks back
16:28:03 <sumantrom> a2batic is looking at it i suppose
16:28:09 * a2batic nods
16:28:10 <adamw> and we just agreed that the next step will be to try a test migration into the staging Pagure (which functions as a sandbox instance) to see how it looks
16:28:33 <adamw> are you okay to go ahead with that, a2batic? sounds like you have some help on the pagure engineering side which is great
16:29:07 <a2batic> adamw: yes
16:29:23 <a2batic> I need to look at the tools
16:30:01 <adamw> awesome
16:30:12 <a2batic> adamw: we have to make a demo fedora-qa repo, or working one?
16:30:51 <adamw> a2batic: a working one should be fine - staging pagure is there for playing around with
16:31:01 <adamw> i believe you can even run multiple migrations under different names
16:31:11 <adamw> just call 'em test-fedoraqa-1, test-fedoraqa-2 or something like that
16:31:35 <a2batic> oh, that will be nice idea
16:31:46 <adamw> check with the pagure folks but i think that's correct
16:31:47 <adamw> oh, one thing i'd like to request, please test migrating into a repo that uses a 'namespace', as we'll probably want to do that
16:32:28 <adamw> at first all pagure repos were in the same namespace, but as it got more popular they've added namespacing so you can have repos like fedora-qa/fedfind . i put all the repos i've moved into pagure so far under the fedora-qa namespace, so we'll probably want to do the same with this one
16:32:29 <a2batic> 'namespace' ?
16:32:54 <adamw> it's just the difference between your repo appearing as 'https://pagure.io/myrepo' and 'https://pagure.io/myproject/myrepo', basically
16:32:58 <adamw> 'myproject' is the namespace
16:33:14 * a2batic clicks
16:33:19 <adamw> those were fake names :)
16:33:52 <a2batic> oh ok :)
16:34:04 <adamw> they don't *look* any different, it's purely just a difference in the URL and so on - it's only about naming
16:34:21 <adamw> but since it'
16:34:23 <adamw> sigh
16:34:23 <a2batic> adamw: yes, got it
16:34:28 <adamw> but since it's a newer feature in pagure, it sometimes has bugs
16:34:45 <adamw> awesome
16:35:02 <adamw> #action a2batic to try and run some test migrations of trac into pagure
16:35:37 <a2batic> so, fedora-qa should appear as https://pagure.io/fedora-qa ...right?
16:35:53 <a2batic> and not a sub repo
16:36:06 <adamw> no, we *want* it to be under a namespace
16:36:57 <adamw> so i'm expecting something like https://pagure.io/fedora-qa/jobs or something like that
16:37:02 <adamw> (someone please come up with a better name :>)
16:37:55 <adamw> so that it's grouped alongside the 'code project' repositories we already have, like fedora-qa/check-compose , fedora-qa/qa-misc and fedora-qa/qa-stats
16:38:01 <adamw> maybe call it 'qa-tasks' so it's 'fedora-qa/qa-tasks'
16:38:29 <a2batic> oh ok
16:38:33 <adamw> so the namespace is 'fedora-qa' and the repo is 'qa-tasks'
16:38:35 <adamw> makes sense?
16:38:56 <sumantrom> yes ! :)
16:39:14 <a2batic> yes :)
16:39:24 <adamw> allllrigthy
16:39:31 <adamw> a2batic: hopefully after a try or two you should have a pagure project that looks OK; once you get to that stage, please post it to the list so other people can have a look and point out any problems they see
16:39:58 <a2batic> adamw: sure thing !
16:40:26 <adamw> once we have a staging repo that everyone's happy with, we can just re-run the same migration for production and hopefully it'll work out ok
16:40:53 <adamw> ideally we should have this done by early january so other things like test days and retrospective tickets can use it
16:41:27 * a2batic nods
16:41:31 <adamw> cool :) anything else on this topic?
16:42:20 <a2batic> Nothing from my side
16:42:33 <adamw> alllllrighty then
16:42:36 <coremodule> Good here.
16:42:38 <adamw> #topic Open floor
16:42:44 <adamw> so, any other business?
16:42:48 <sumantrom> All good here :)
16:42:59 <adamw> we have the 'release validation ng' design process moving along
16:43:03 <tflink> as a heads up: phabricator's url will be changing
16:43:10 <adamw> aha, thanks tflink
16:43:14 <adamw> to what, and when?
16:43:18 <tflink> to phab.qa.fedoraproject.org
16:43:29 <tflink> hopefully this week unless something new goes wrong :)
16:43:59 <tflink> I will send out an email before I make the change and a redirect should point you at the new instance
16:44:04 <adamw> #info phabricator will be moving to https://phab.qa.fedoraproject.org this week, unless something new goes wrong. redirects should be in place
16:46:16 <adamw> for any new folks who don't know about it: red hat shuts down from around dec 24 to jan 2 every year. fedora doesn't, officially, but of course with the number of rh folks involved in fedora it tends to have a knock-on effect. so expect things to be a bit quieter than usual until the new year
16:46:49 <coremodule> Gotcha, that's good to know.
16:47:13 <sumantrom> this is new adamw
16:47:24 <adamw> huh, i expected someone to have told the rh folks about it by now :P
16:47:25 <sumantrom> *news :D
16:48:03 <adamw> that's about all i got
16:48:32 <adamw> we finally got a rawhide validation event for a compose that should pretty much work, so everyone please help out with testing that, so we know where Fedora 26 stands :)\
16:48:57 <Southern_Gentlem> adamw,  and thanks for getting openqa testing my respins
16:49:07 <sumantrom> \me stands at the ready
16:49:15 <adamw> #info please help out with testing the Rawhide 20161210.n.0 nightly, now nominated
16:49:30 <adamw> Southern_Gentlem: no prob, i'll have it test the new ones in a minute (it's not automated yet as the scheduler changes are still waiting on review)
16:49:40 <Southern_Gentlem> adamw++
16:49:41 <zodbot> Southern_Gentlem: Karma for adamwill changed to 7 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:49:42 <adamw> anyone got anything else?
16:50:15 <cmurf> adamw++
16:50:16 <zodbot> cmurf: Karma for adamwill changed to 8 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:50:24 <cmurf> seeing as I only get one cookie per release
16:50:50 <sumantrom> adamw++
16:50:50 <zodbot> sumantrom: Karma for adamwill changed to 9 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:51:00 <cmurf> I was so annoyed I couldn't start a plot to get adamw a unicorn poop cookie
16:51:01 <a2batic> adamw++
16:51:01 <zodbot> a2batic: Karma for adamwill changed to 10 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:51:21 <cmurf> that's really really hard to do with only one cookie alotment per release
16:51:23 <adamw> OM NOM NOM
16:51:24 <Southern_Gentlem> cookie parrty at adamw
16:51:25 * adamw eats all the cookies
16:51:51 <adamw> Southern_Gentlem: thanks for building the respins!
16:51:57 <adamw> southern_gentlem++
16:52:07 <Southern_Gentlem> kbwillia
16:52:08 <adamw> what fas name do you go by again? :P
16:52:11 <adamw> jb, right?
16:52:12 <Southern_Gentlem> jbwillia
16:52:16 <adamw> jbwillia++
16:52:16 <zodbot> adamw: Karma for jbwillia changed to 4 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:52:18 <adamw> there ya go
16:52:36 <adamw> okely dokely
16:52:41 <adamw> sounds like it's all over apart from the cookies
16:52:49 <a2batic> adamw: Is this the last qa meeting of the year  ?
16:53:39 <adamw> a2batic: it may be. we have a slot next week but if there's nothing to discuss there, it'll be the last one till new year
16:53:55 <adamw> of course if we have topics next week, we can meet again :)
16:54:16 <a2batic> ok :)
16:54:22 <adamw> thanks for coming, everyone!
16:54:43 <coremodule> Thanks adamw for leading.
16:54:45 <sumantrom> thanks adamw for hosting and chairing :)
16:54:50 <satellit> thanks
16:54:55 <adamw> #endmeeting