fedora_docs
LOGS
14:02:08 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:02:08 <zodbot> Meeting started Mon Dec  5 14:02:08 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:08 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:02:08 <randomuser> #meetingname Fedora Docs
14:02:08 <zodbot> The meeting name has been set to 'fedora_docs'
14:02:08 <randomuser> #topic Roll Call
14:02:19 * pbokoc 
14:02:19 <mclasen> .hello mclasen
14:02:21 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
14:02:40 <stickster> mclasen: we are in #fedora-workstation ... this room is supposed to be in use by Docs this hour, my fault
14:02:53 * mclasen sees himself out
14:02:57 <stickster> heh
14:02:59 * pravins listening :)
14:03:02 <randomuser> you're welcome to stay :P
14:03:09 <shaunm> .hello shaunm
14:03:10 <zodbot> shaunm: shaunm 'Shaun McCance' <shaunm@gnome.org>
14:03:24 * Capesteve waves
14:06:07 <randomuser> #topic New Writers
14:06:19 <randomuser> new writers and news of new writers...
14:07:45 <randomuser> there's an introduction email, did Trapier happen by?
14:09:13 * randomuser shrugs
14:09:21 <randomuser> let's talk about shaunm's email
14:09:29 <randomuser> #topic guide conversion
14:09:43 <shaunm> sorry I just sent it
14:09:59 <shaunm> after my phone reminded me of this meeting and I said "oh crap I have an action item"
14:10:37 <randomuser> i have some time this week, was thinking of working at the sysadmin guide
14:11:21 <shaunm> sysadmin guide would be a great choice
14:11:25 <bexelbie> .hello bex
14:11:26 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:11:57 <shaunm> lots of disjointed but related topic areas. lends itself well to topic-oriented
14:12:42 * randomuser nods
14:13:21 <randomuser> my plan was to do markup conversion, then look at structure
14:14:02 <randomuser> your email seems to suggest more planning is needed, shaunm, do you have thoughts to share?
14:14:16 <bexelbie> +1 to that as it lets have a fall back position (even with moving forward in a more aggressive way with one guide)
14:14:58 <shaunm> randomuser: not necessarily planning before markup conversion. just human thought somewhere along the way.
14:15:09 <randomuser> of course
14:15:56 <shaunm> doing the markup conversion first is reasonable.
14:16:41 <bexelbie> perhaps we should split the work so that shaunm and some people can focus on the book->topic and randomuser and others can focus on docbook -> asciidoc
14:16:55 <randomuser> i could use some help with the expected directory structure
14:17:36 <shaunm> is "flat" ok?
14:18:23 <randomuser> i'm still rather thick when it comes to the build tools, so I don't know what I'm aiming for
14:18:48 <randomuser> lots of .adoc in one folder? one top level one with includes? some combination?
14:18:59 <bexelbie> I think we can massage, but I suggest you go with flat as shaunm suggest
14:19:00 <bexelbie> s
14:19:54 <shaunm> us old people remember having to get directory structure right from the beginning because cvs sucked at moving files
14:21:06 <bexelbie> you had directories?  luxury :P
14:21:32 <shaunm> haha
14:22:19 <bexelbie> I think the dir structure for markup conversions is less critical to worry about
14:22:27 <randomuser> what about frontmatter? do we need some kind of metadata at the top of articles, or just title and go?
14:22:31 <bexelbie> I presume shaunm and co will have a directory structure come out of their thought processes
14:22:52 <bexelbie> I strongly encourage us to not do anything that isn't fully AsciiDoc compliant
14:22:58 * randomuser is looking to https://pagure.io/documentation-guide/blob/new-workflow/f/en-US for guidance
14:23:48 <bexelbie> randomuser, I think we should go with flat for markdown conversions (or mirror the existing docbook structure)
14:24:15 <shaunm> randomuser: personally, I've never been a fan of the first page of any documentation being a page full of attributions and legal information.
14:24:17 <bexelbie> for the topic stuff, I have personal opinions (all topics in one dir at the top; meta/linkages in a side dir)
14:24:39 <shaunm> you should have that stuff somewhere, but I think it's better to tuck it into a footer of each page.
14:24:40 <bexelbie> shaunm, I hope that as you come up with topics, we can move that stuff to a header or footer link
14:24:41 <randomuser> shaunm, yes, I agree that should ont be at the top of every article
14:24:53 <shaunm> yes
14:25:13 <bexelbie> I also think separating topics into a separate dir and putting assembly details elsewhere will make it easier for us to share with other communities (CentOS, etc.)
14:25:53 <randomuser> i agree
14:26:06 <randomuser> some kind of directory structure is natural and logical
14:26:16 <bexelbie> +1 to having directories :P
14:27:55 <randomuser> so, i'll just organize content logically as I go along and other people can do that too
14:28:16 <bexelbie> +1
14:28:29 <bexelbie> randomuser, it also lets us see what happens in practice instead of spending a lot of time on theory
14:28:37 <bexelbie> and trying to decide solely on that
14:30:01 <shaunm> yes, that
14:30:13 <shaunm> just do it, see what works, and revise
14:31:37 <randomuser> this horse is starting to bruise
14:31:59 <bexelbie> +1
14:32:05 <randomuser> #action randomuser to start asciidoc conversion of sysadmin guide
14:33:19 <randomuser> anything else actionable/
14:33:21 <randomuser> ??
14:34:15 <apetrova> Hey guys, have you thought about how to write the topics? Do you have any templates/models/examples for that?
14:34:47 <shaunm> apetrova: that's largely what's going to come out of the first test conversion
14:34:57 <randomuser> yes, that
14:34:58 <shaunm> do one guide, see what we learn, write it up for others to follow
14:35:32 <apetrova> shaunm, we have been working on that for RH docs, it might make sense to share the experience
14:35:43 <randomuser> apetrova, please do!
14:36:23 <apetrova> The problem is it wasn't just me. I worked on the templates, but not the directory structure planning.. so I don't have the whole picture.
14:36:35 <randomuser> it would be great to align out models as much as is reasonable
14:37:01 <shaunm> yes, especially since part of the motivation here is that we can share content down the line
14:37:55 <apetrova> Any ideas on how to do that? I could perhaps invite other people for the next meeting here.
14:38:42 <randomuser> apetrova, that would be a great start
14:39:10 <apetrova> randomuser, ok, I guess that's my action item
14:40:26 <randomuser> #randomuser to prep agenda to intro rh writers to fedora docs resources
14:40:30 <randomuser> ahem
14:40:34 <randomuser> #action randomuser to prep agenda to intro rh writers to fedora docs resources
14:41:49 <bexelbie> I also think, that with proper reporting, the sub-teams should be able to hold a meeting at a different time
14:44:47 <randomuser> sure, people can talk about things whenever their schedule allows
14:47:46 <shaunm> anything else?
14:47:59 <randomuser> i think we're good
14:48:22 <pbokoc> just something unrelated. randomuser, do you think you could republish f25 relnotes? https://bugzilla.redhat.com/show_bug.cgi?id=1401342
14:48:31 <randomuser> pbokoc, sure
14:48:37 <pbokoc> cool
14:50:32 <randomuser> okay, i'm wrapping up
14:50:37 <randomuser> see you around
14:50:42 <randomuser> #endmeeting