kde-sig
LOGS
15:16:32 <rdieter> #startmeeting kde-sig
15:16:32 <zodbot> Meeting started Tue Nov 15 15:16:32 2016 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:16:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:16:32 <zodbot> The meeting name has been set to 'kde-sig'
15:16:35 <rdieter> nirik: ah, thx
15:16:39 <rdieter> #topic roll call
15:16:43 <rdieter> hi all, who's present today?
15:16:45 <lupinix> .hello lupinix
15:16:46 <zodbot> lupinix: lupinix 'Christian Dersch' <lupinix@mailbox.org>
15:16:54 <rdieter> #info rdieter lupinix tosky present
15:17:36 <rdieter> #chair tosky lupinix
15:17:36 <zodbot> Current chairs: lupinix rdieter tosky
15:18:22 <Kevin_Kofler> Present, can report on dnfdragora.
15:18:45 * jreznik_ is here
15:19:00 <mbriza> hello
15:19:17 <rdieter> #info Kevin_Kofler jreznik mbriza present
15:19:26 <rdieter> chair Kevin_Kofler jreznik mbriza
15:19:31 <rdieter> #chair Kevin_Kofler jreznik mbriza
15:19:31 <zodbot> Current chairs: Kevin_Kofler jreznik lupinix mbriza rdieter tosky
15:20:19 <rdieter> #info agenda
15:20:32 <rdieter> what to discuss today?  Kevin_Kofler offered to report on dnfdragora
15:21:13 <lupinix> nothing special here
15:21:48 <rdieter> k
15:21:58 <rdieter> #topic dnfdragora status
15:22:01 <rdieter> Kevin_Kofler: go ahead
15:22:36 <Kevin_Kofler> OK
15:22:50 <Kevin_Kofler> So, I packaged dnfdragora and all its dependencies (updated libyui stack including libyui-mga) at https://copr.fedorainfracloud.org/coprs/kkofler/dnfdragora/
15:23:06 <Kevin_Kofler> Specfiles, patches, scripts: https://pagure.io/copr-dnfdragora
15:23:23 <Kevin_Kofler> I've tried it, it kinda works, but needs more work before it can be unleashed on users.
15:23:33 <rdieter> Kevin_Kofler: can you briefly describe what dnfdragora is, for any present not familiar with it?
15:23:38 <Kevin_Kofler> I'm trying to fix some of the Fedora-specific stuff.
15:24:07 <Kevin_Kofler> dnfdragora is a software package (RPM) manager written in Python 3, using DNF through dnfdaemon,supporting Qt, GTK+ and ncurses through libyui.
15:24:45 <Kevin_Kofler> It does similar things as Apper, but it does not go through PackageKit, but uses the dnfdaemon from Yumex instead.
15:24:48 <heliocastro> here
15:25:05 <Kevin_Kofler> It is being developed by anaselli from Mageia.
15:25:33 <rdieter> #info heliocastro present
15:25:35 <rdieter> #chair heliocastro
15:25:35 <zodbot> Current chairs: Kevin_Kofler heliocastro jreznik lupinix mbriza rdieter tosky
15:26:52 <rdieter> Kevin_Kofler: looks like a total of ~10 packages involved?
15:27:01 <lupinix> Kevin_Kofler: i checked the changes in libyui packages, i think it is save to include them in official repo
15:27:22 <lupinix> once björn gave me commit access (he told me that he'll do it today)
15:27:27 <Kevin_Kofler> Upstream URL: https://github.com/anaselli/dnfdragora
15:27:53 <Kevin_Kofler> rdieter: Yes, and the -mga ones need to go through review, they're new.
15:28:29 <rdieter> ok, I had assumed they were all new, so ~5 new packages needing review?
15:28:30 <lupinix> btw i'll use dnfdragora for the LXQt remix
15:29:36 <Kevin_Kofler> The other libyui stuff is already in Fedora, it was imported by Björn Esser.
15:29:46 <Kevin_Kofler> lupinix: I'd wait until it is production-ready.
15:29:57 <Kevin_Kofler> Try it from my Copr and you will see the glitches that are still there.
15:30:11 <lupinix> well, the remix will be some informal testing release first
15:30:15 <rdieter> Kevin_Kofler: will these be reviewable soon?
15:30:37 <Kevin_Kofler> I think they're already reviewable, they just need to be filed. :-)
15:31:08 <Kevin_Kofler> I'll file review requests.
15:32:00 <rdieter> #action Kevin_Kofler to file review requests for dnfdragora and it's dependencies (~5 in total)
15:32:11 <rdieter> any other comments ?
15:33:07 <lupinix> nope
15:33:14 <tosky> no
15:33:59 <Kevin_Kofler> For dnfdragora, I'm going to wait with the review.
15:34:14 <rdieter> k
15:34:17 <rdieter> #topic open discussion
15:34:19 <Kevin_Kofler> I need it working well first, and maybe also get some improvements upstream to ease packaging.
15:34:24 <rdieter> I think that's all we had for formal topics
15:34:28 <Kevin_Kofler> (Right now, I have to install everything by hand in the specfile.)
15:34:36 <rdieter> fyi, plasma-5.8.3 is in bodhi now for f25/f24
15:34:39 <Kevin_Kofler> And the libyui stack needs to be sorted out first anyway.
15:34:56 <Kevin_Kofler> Yay for 5.8.3!
15:34:58 <rdieter> f25: https://bodhi.fedoraproject.org/updates/FEDORA-2016-58403bce23
15:35:05 <rdieter> f24: https://bodhi.fedoraproject.org/updates/FEDORA-2016-47a1d520ae
15:35:38 <Kevin_Kofler> Ah, there's one more item that I wanted to discuss: Any idea why qupzilla-kwallet reportedly stopped working in F25?
15:36:21 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=1394562
15:36:23 <lupinix> nope, i tried a rebuild, no success
15:36:49 <Kevin_Kofler> Nothing changed in QupZilla, so it must be the libraries' fault.
15:36:56 <rdieter> maybe kf5-5.27 landing ?
15:37:00 <lupinix> yes, works fine @f24
15:37:21 <rdieter> kf5-kwallet-5.27.0 (or it's dependencies) come to mind
15:37:39 <rdieter> but hard to say for sure
15:37:47 <rdieter> (f24 also has 5.27 though)
15:39:50 <rdieter> fwiw, this is the error:  Plugins::loadPlugins Loading "/usr/lib64/qupzilla/libKWalletPasswords.so" failed: "Plugin verification data mismatch in '/usr/lib64/qupzilla/libKWalletPasswords.so'"
15:39:58 <rdieter> do other plugins load ok?  just this one is problematic?
15:40:02 <lupinix> yes
15:41:05 <rdieter> anyone know where that error comes from?
15:41:17 <rdieter> "Plugin verification..." is that from qupzilla or Qt or other?
15:41:48 <lupinix> i googled a bit, seems to be quite common issue with qt related plugins. for example qt creator showed such a thing in the past too
15:42:20 <rdieter> plugins sometimes have hard dep on the exact Qt version used to build it, yes
15:42:32 <rdieter> but that's not the case heimere, it should be Qt-5.7.0 for both build and runt
15:42:43 <rdieter> arg, both runtime and build should be the same
15:42:45 <lupinix> yes and i also tried a local rebuild
15:43:07 <lupinix> now i'm installing manjaro testing release with same versions of qt and kf5
15:43:20 <lupinix> to see whether they have the same issue
15:43:20 <rdieter> anyone experiencing this, post output from ' ldd /usr/lib64/qupzilla/libKWalletPasswords.so' in the bug
15:43:29 <rdieter> in case there are other 3rd-party libs interfering
15:44:04 <lupinix> http://paste.fedoraproject.org/482336/24638147/
15:44:19 <lupinix> i already tried a clean new install
15:45:39 <rdieter> k, I'm out of initial ideas to try, but the core issue is determining why "Plugin verification data mismatch" is happening obviously
15:47:48 <Kevin_Kofler> Different GCC version, breaking the build-id?
15:47:51 <tosky> there are few interesting results coming from that string
15:48:07 <tosky> like http://stackoverflow.com/questions/30141951/plugin-verification-data-mismatch-while-loading-plugin-for-qt5-project or https://bugreports.qt.io/browse/QTCREATORBUG-8500
15:48:55 <Kevin_Kofler> Well, can't really be it, GCC is 6.2.1 in both f24-updates and f25.
15:49:32 <rdieter> possible qt-5.7.0 is different or more strict or something though
15:49:52 <Kevin_Kofler> Maybe the build-id changed with 5.7.0?
15:50:01 <Kevin_Kofler> Can you check that the build-id is still the same?
15:50:04 <rdieter> hard to say without looking closer @ build.log and root.log of affected pkgs
15:50:06 <Kevin_Kofler> If not, we are in for WORLDS of pain.
15:50:21 <Kevin_Kofler> (A mass rebuild of all Qt stuff post-release, ewww!)
15:51:01 <Kevin_Kofler> And if the build-id really changed, there is no way around a mass rebuild, no matter whether we revert it or not, because some stuff will have the old build-id and some the new.
15:51:06 <rdieter> not sure how Qt5 handles that, I've only ever had to look at the Qt4 stuff wrt build-id
15:51:58 <rdieter> anyone able/willing to look into verifying our f25/Qt5 build-id ?
15:52:19 <rdieter> I'm assuming that's not it, but better to be safe than sorry here
15:52:23 * heliocastro out of ime this week
15:54:18 <rdieter> I can at least look briefly after meeting
15:54:28 <than> rdieter: i can help
15:54:30 * rdieter also has qt-5.6.2 to do (for f24)
15:54:40 <rdieter> than: ok, thanks!
15:56:24 <rdieter> anything else for today (almost out of time)
15:56:25 <rdieter> ?
15:57:55 <rdieter> alright, thanks everyone
15:57:58 <rdieter> #endmeeting