dotnet
LOGS
12:59:28 <Rhea> #startmeeting Fedora DotNet (2016-11-04)
12:59:28 <zodbot> Meeting started Fri Nov  4 12:59:28 2016 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:59:28 <zodbot> The meeting name has been set to 'fedora_dotnet_(2016-11-04)'
12:59:28 <tpokorra> .hello tpokorra
12:59:29 <zodbot> tpokorra: tpokorra 'Timotheus Pokorra' <timotheus.pokorra@solidcharity.com>
12:59:33 <Rhea> #meetingname dotnet
12:59:33 <zodbot> The meeting name has been set to 'dotnet'
12:59:36 <Rhea> #nick dotnet
12:59:44 <Rhea> #topic Agenda
12:59:46 <pcreech> .hello pcreech17
12:59:47 <zodbot> pcreech: pcreech17 'Patrick Creech' <pcreech@redhat.com>
12:59:48 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_2016-11-04
12:59:52 <Rhea> #info (1) Roll Call
12:59:55 <Rhea> #info (2) Announcements
12:59:59 <Rhea> #info (3) Action items from our previous meeting
13:00:02 <Rhea> #info (4) Tickets
13:00:05 <Rhea> #info (7) Open Floor
13:00:09 <Rhea> #topic Roll Call
13:00:18 <moto-timo> .hello ttorling
13:00:20 <zodbot> moto-timo: ttorling 'Tim Orling' <ticotimo@gmail.com>
13:00:30 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
13:00:32 <bt0> .hello bt0dotninja
13:00:33 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
13:00:35 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/DotNet ]
13:00:40 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
13:00:45 <Rhea> .hello rhea
13:00:46 <zodbot> Rhea: rhea 'Radka Janek' <radka.janek@redhat.com>
13:00:51 <rkieley> .hello rkieley
13:00:52 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
13:00:52 <zodbot> rkieley: Sorry, but you don't exist
13:01:04 <Rhea> poor rkieley
13:01:21 <rkieley> rhea: lol, leave it to the bot to determine my existence
13:01:24 <Rhea> Halloween took you I guess, ghost now..
13:01:34 <rkieley> rhea hopefully it'll pass...
13:02:09 <bt0> #info Alberto Rodriguez; UTC-6;CommOps,Metrics,DotNet and more
13:03:05 <moto-timo> #info Tim Orling; UTC-7; Python, Perl, DotNet, Modularity
13:03:18 <rkieley> #info Roddie Kieley; UTC-2.5; DotNet,TBD...
13:04:00 <pcreech> #info Patrick Creech; UTC-5; DotNet
13:04:01 <Rhea> hum... quite a few people are missing >_<
13:04:17 <tpokorra> #info Timotheus Pokorra; UTC+1; DotNet, Mono, OpenPetra, Kolab, etc
13:05:08 <Rhea> Well let me throw out the news in the meantime, maybe they show up :]
13:05:41 <Rhea> #topic Announcements
13:05:45 <Rhea> #info === "Announcing .NET Core 1.1 Preview 1" ===
13:05:47 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2016/10/25/announcing-net-core-1-1-preview-1
13:05:52 <Rhea> #info DotNet Core 1.1 preview1 was released a week ago.
13:06:11 <Rhea> Anyone already tried 1.1?
13:06:25 <Rhea> #info === ".NET Core Tooling" ===
13:06:26 <rkieley> rhea not yet unfortunately :(
13:06:28 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2016/10/19/net-core-tooling-in-visual-studio-15/
13:06:35 <Rhea> #info The final release of .NET Core tools will provide a build and project system that are unified with the rest of .NET project types, moving away from the project.json infrastructure that was specific to .NET Core. While this means we need to move away from the straightforward JSON format for project files and embrace the XML format used in MSBuild, this change will bring significant benefits in
13:06:37 <Rhea> the overall experience.
13:06:50 <Rhea> uh it didn't fit into one message...
13:06:52 <Rhea> whatever
13:06:54 <Rhea> :D
13:07:07 <tanaka733_> I tried a little about .NET Core 1.1 Preview 1 on RHEL.
13:07:17 <rkieley> rhea I did poke at msbuild and powershell a bit separately however
13:07:31 <moto-timo> we've been working on .NET Core 1.0 for IronPython
13:07:40 <moto-timo> haven't tried 1.1 yet
13:07:45 <Rhea> I'm quite happy with the projectfile change, it means that i can open it in monodevelop
13:07:45 * pcreech hasn't touched dotnet in a while... sadly :(
13:08:13 <rkieley> ragreed, I think it'll be a little painful in the short term but a big win in the long term
13:08:52 * nmilosev is sorry for being late
13:08:55 <nmilosev> .fas nmilosev
13:08:55 <zodbot> nmilosev: nmilosev 'Nemanja Milosevic' <nmilosevnm@gmail.com>
13:08:59 <Rhea> Frankly i personally don't see much of a difference between the two... just some config files in some user-readable format *shrugs*
13:09:22 <moto-timo> json is a bit easier to parse, but *shrug*
13:09:22 <bt0> I agree
13:09:29 <Rhea> #topic Action items from our previous meeting
13:09:30 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
13:09:59 <Rhea> So there wasn't previous meeting, however i imagined the initial setup of things being an action item so i'll tell you about what's done here
13:10:10 <Rhea> #info === [COMPLETE] Establish basic structure and organization. ===
13:10:11 <Rhea> #info Wiki page for the team was created, although it will require changes. Mailing list and the FAS group are in place as well, however this may change as well in the future (dotnet-devel would be created if necessary) We will be using Pagure for organization and GitHub for code - if any.
13:10:17 <Rhea> #link https://fedoraproject.org/wiki/DotNet
13:10:22 <Rhea> #link https://lists.fedoraproject.org/admin/lists/dotnet-sig.lists.fedoraproject.org
13:10:25 <Rhea> #link https://pagure.io/fedora-dotnet
13:10:48 <Rhea> The wiki/dotnet page should contain some info about dotnet in Fedora and dotnet in general, while our team and organization should be under wiki/SIGs/dotnet (or wiki/dotnet/join instead?) Any suggestions or ideas about this?
13:11:49 <rkieley> I think the info about the team and org should be under wiki/SIGs/dotnet while the wiki/dotnet/join should talk about benefits/responsibilities/etc of joining the group
13:12:00 <moto-timo> +1
13:12:01 <Rhea> Whenever I asked someone they said that it's good idea to split it like that, so I guess that the next question is what to have on the dotnet page... Some links to documentation, download links and how to install it on fedora... what else? o.o
13:12:03 <nmilosev> +1
13:12:33 <moto-timo> at some point, packaging guidance
13:12:34 <rkieley> current status of what should be expected when running .net core on fedora; limitations, known issues, workarounds
13:12:55 <tpokorra> at some point, https://developer.fedoraproject.org/tech/languages/csharp/mono-installation.html should be updated as well to reference dotnet and mono, for C# development
13:13:34 <Rhea> nice one tpokorra
13:14:42 <Rhea> hmm
13:15:13 <tpokorra> thank you Rhea for doing the setup work so far!
13:15:37 <Rhea> #action Rhea Create a ticket about updating Fedora developer website with info about dotnet.
13:15:43 <Rhea> #link https://developer.fedoraproject.org/tech.html
13:15:46 <Rhea> :]
13:17:28 <Rhea> #action Rhea Split the wiki page into wiki/dotnet which will contain info about dotnet in general, running it on Fedora, current limitations, known issues and workaround; and wiki/SIGs/dotnet with organization side of things
13:17:46 <Rhea> Moving on if nobody has anything to add here...
13:18:22 <bt0> no, looks fine
13:18:23 <Rhea> I could also mention that once we get packaging sorted out we will probably split the FAS group and mailing list as well, to hve one as a SIG and another for devel/packagers...
13:18:32 <Rhea> But that's far enough for now so no need to care
13:18:42 <rkieley> that makes sense
13:18:49 <moto-timo> +1
13:18:55 <bt0> +1
13:19:40 <nmilosev> Rhea, is this the definitive schedule for all future meetings? I mean Fridays 13h UTC?
13:20:05 <Rhea> #agreed Review the FAS group and mailing list once we get into packaging, possibly create new ones for devel/packagers.
13:20:08 <Rhea> I don't know!
13:20:28 <Rhea> I'm open to any time and day, almost :D
13:20:35 <moto-timo> it's the time that worked based on the input requested
13:20:50 * moto-timo didn't input, so no complaints
13:20:52 <nmilosev> Okay, just wanted to check. It works for me
13:21:01 <bt0> :D
13:21:24 <Rhea> Yep, that's the thing... there was literally no time that everyone would like
13:21:51 <moto-timo> that's actually a good sign. global presence
13:22:02 <Rhea> This time is that kind of that muricans are either waking up / almost too early, so that's a problem..
13:22:24 * moto-timo thinks sleep is overrated and a myth
13:22:28 <Rhea> Everything between 1pm and 7pm was like NOPE by everyone basically
13:22:37 <Rhea> 1pm was more-less okay
13:22:42 <Rhea> and 7pm was more less okay
13:22:44 <Rhea> that's it
13:22:57 <Rhea> so maybe you can think about 7pm - it was tuesday one that was good
13:23:05 <Rhea> (good-ish)
13:24:01 <Rhea> #action Rhea Create another email about meeting time to make sure that people can attend.
13:24:24 <Rhea> Also it's a thing that we have that weird week of when the world is no longer on summer time but murica still has summer time
13:24:41 <moto-timo> \o/
13:24:43 <tpokorra> just checked muricans online, I think we should not continue to use that word :) "An impolite way of saying "American" while wanting to project a sense to dislike towards that country and its inhabitants."
13:24:45 <Rhea> :D
13:24:48 * nmilosev laughs at murica
13:25:10 <Rhea> I say it in a funny way like... imagine southern accent saying it :D
13:25:13 <moto-timo> bloody continentinalists
13:25:24 <nmilosev> wait you can check if a word is offensive?
13:25:29 <nmilosev> :D
13:25:37 <tpokorra> http://de.urbandictionary.com/define.php?term=Murican
13:25:38 * pcreech is murican and doesn't care :)
13:25:45 <tpokorra> then that is fine with me :)
13:26:07 <Rhea> pcreech is murican dawg O_O
13:26:15 * Rhea pets
13:26:15 * moto-timo didn't know to be offended ;)
13:26:20 <pcreech> (south eastern murican at that :)
13:26:29 <Rhea> haha awesome even better
13:26:43 <Rhea> I wish i could actually speak a bit of that accent i fint it cool sometimes
13:27:03 * Rhea waves at dmulford
13:27:14 * dmulford waves back
13:27:14 <Rhea> Do you mind being called "murican?"
13:27:27 <Rhea> Just making sure i'm not offending someone :D
13:27:46 <dmulford> nah you're good
13:27:47 <Rhea> #topic Tickets
13:27:48 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
13:27:56 <Rhea> #info === Ticket #1 ===
13:27:58 <Rhea> #info "Set-up meeting schedule" ===
13:28:00 <Rhea> #link https://pagure.io/fedora-dotnet/issue/1
13:28:04 <Rhea> #info Minutes and agenda will be published, as you can see we are using the MeetBot.
13:28:08 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_2016-11-04
13:28:13 <Rhea> #link https://apps.fedoraproject.org/calendar/SIGs/2016/11/4/#m4933
13:28:26 <Rhea> #action dotnet Import the meeting to your calendar.
13:28:36 <Rhea> So we already mentioned this bit just now heh...
13:29:39 <Rhea> And thats actually all there was about organization, we could look into answering some questions about dotnet in Fedora
13:29:50 <Rhea> #topic Open Floor
13:29:52 <Rhea> #info What is our long-term goal?
13:30:03 <Rhea> What are we trying to achieve?
13:30:07 <moto-timo> world domination
13:30:10 <Rhea> +12
13:30:15 <bt0> +1
13:30:16 <Rhea> eh even +12
13:30:32 <Rhea> :D
13:30:54 <tpokorra> having Fedora packages for developing with dotnet
13:31:13 <tpokorra> not needing to download binary packages from the outside
13:31:13 <pcreech> having a robust dotnet ecosystem in fedora?
13:31:17 <rkieley> having stable reliable packages for developing with dotnet, but yeah +1
13:31:20 * moto-timo goal is IronPython packaged for Fedora
13:31:31 <Rhea> So I guess that the ideal result will be dotnet package in F26, and we should support F23, 24, 25...
13:31:35 <nmilosev> IronPython works with .NET Core?
13:31:45 <moto-timo> we're working on it
13:31:50 <nmilosev> Wow, awesome!
13:31:52 <rkieley> do we also include powershell as well as the stuff already listed by tpokorra via e-mail?
13:32:10 <rkieley> s/e-mail/mailing list/
13:32:18 <bt0> Introduce Hydra agents on the Fedora Project???
13:32:23 <nmilosev> On a slightly related note, what about packaging Visual Studio Code?
13:32:35 <bt0> kidding (or not??)
13:32:46 <Rhea> :D
13:32:50 <tpokorra> powershell would be a package that uses dotnet
13:32:51 <tpokorra> makes sense to maintain with this in this group as well
13:33:00 <Rhea> Good question
13:33:01 <Rhea> (vs code)
13:33:10 <nmilosev> It's MIT yes?
13:33:13 <Rhea> I didn't look into it yet... I like my monodevelop
13:33:16 <tpokorra> I guess that would all be part of a dotnet ecosystem
13:33:17 <nmilosev> Not sure though
13:33:19 <rkieley> nmilosev I think so
13:33:20 <tpokorra> vs code is MIT
13:33:27 <tpokorra> it is quite a simple IDE
13:33:28 <sgallagh> nmilosev: It's an acceptable license.
13:33:34 <Rhea> We would probably go for something similar like mono does
13:33:35 <nmilosev> we have electron already
13:33:35 <tpokorra> not to be confused with visual studio
13:33:38 <sgallagh> There is a COPR repo for it currently.
13:33:41 <Rhea> mono-devel / mono-complete
13:33:44 <rkieley> nmilosev confirmed - according to the github repo anyway
13:33:59 <moto-timo> in the Fedora spirit, if you package it, they will come
13:34:11 <sgallagh> If someone wants to package it properly for Fedora, that would be great.
13:34:20 <sgallagh> The COPR repo is a bit out of date.
13:34:44 <nmilosev> moto-timo, in my case it's if I package it's wreckage
13:35:36 <pcreech> it would be nice to have...
13:35:36 <Rhea> Yeah so to sum it up...
13:35:40 * pcreech could start working on it
13:35:52 <nmilosev> Do you think we should package vscode or not? I mean it's a really more than just for .NET
13:36:18 <pcreech> it's getting a lot of push by ms as somethign to use on alt os's, so it's probably a good idea
13:36:19 <rkieley> nmilosev true, I think it could be a good segway for devs coming over from windows
13:36:41 <Rhea> #agreed The final goal is to have dotnet packages in Fedora, these would include dotnet CLI, Visual Studio Code, etc...
13:36:54 <nmilosev> and aside, it's a really good tool, but that's just me
13:36:55 <bt0> +1
13:37:03 <moto-timo> +1
13:37:06 <tpokorra> +1
13:37:08 <rkieley> +1
13:37:13 <pcreech> +1
13:37:15 <nmilosev> +1 for the 'agreed'
13:37:40 <tanaka733_> +1
13:37:46 <Rhea> #info What should be our next steps?
13:37:59 <Rhea> Where to begin
13:38:32 <Rhea> First of all we need to fix it up so it runs in F24 (which will ideally be a fix for f25 as well as whatever future brings)
13:38:37 <nmilosev> I would like to begin with Rhea++ for being so organized
13:38:37 <zodbot> nmilosev: Karma for rhea changed to 12 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:38:46 <Rhea> COOKIES
13:39:18 <rkieley> nmilosev agreed rhea++
13:39:18 <Rhea> :D
13:39:21 <pcreech> Rhea++
13:39:21 <zodbot> pcreech: Karma for rhea changed to 13 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:39:27 <tpokorra> for packaging, is not rawhide the first target?
13:39:34 <tpokorra> Rhea++
13:39:34 <zodbot> tpokorra: Karma for rhea changed to 14 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:40:03 <nmilosev> tpokorra: I think we will have issues with libicu
13:40:04 <bt0> Rhea++
13:40:09 <Rhea> I don't know, you tell me... I just know that I use 24 and want it running here :D
13:40:18 <nmilosev> The version is hardcoded in dotnet
13:40:18 <tpokorra> or are you thinking we help Microsoft to fix dotnet for Fedora 24?
13:40:29 <moto-timo> and MS already provides a F23
13:40:42 <nmilosev> I think we should try for rawhide, but it will probably include writing a lot of patches
13:40:47 <nmilosev> for the RPM
13:40:53 <rkieley> I think the onus is on us to help them keep up a little better
13:41:00 <Rhea> I'm thinking we should come up with a way to package it for everything - yes, to fix it up and submit pull request if necessary
13:41:09 <moto-timo> +1
13:41:12 <nmilosev> And maybe when we figure out how we should do it -> send a PR
13:41:23 <tpokorra> +1
13:41:26 <rkieley> nmilosev +1
13:41:48 <moto-timo> so do we create an organization on GitHub?
13:41:48 <nmilosev> The package in my copr works but it is probably the worst package in history of Fedora
13:41:54 <nmilosev> Because of libicu
13:41:56 <Rhea> I mean do we really expect anyone from the microsoft community to fix it for us? :p
13:42:01 <rkieley> nmilosev no where to go but up in that case ;)
13:42:10 <nmilosev> rkieley haha true
13:42:16 <bt0> :D
13:42:17 <rkieley> rhea exactly
13:42:19 <tpokorra> nmilosev, last time I checked you are just bundling the binaries. not builing from source
13:42:28 <moto-timo> step one: it builds; step two: it works; step three: polish
13:42:29 <tpokorra> are we alright with that for the first steps?
13:42:36 <nmilosev> tpokorra yes it's pretty horrid
13:42:47 <bt0> sounds like a plan
13:42:55 * moto-timo wonders if we need macros
13:43:36 <Rhea> Sooo we need to look into the "libicu issue" in the first place, are there any other blockers?
13:43:49 * Rhea has no idea..
13:43:59 * moto-timo hasn't looked yet
13:44:12 <tpokorra> we need to know which order the packages should be built in as described in my email
13:44:15 <moto-timo> file a bug on libicu?
13:44:21 <tpokorra> also if we need msbuild or if it works with xbuild from Mono
13:44:22 <nmilosev> problem is they hardcode the libicu version
13:44:31 <nmilosev> so it looks for the wrong .so
13:44:32 <tpokorra> we can patch hardcoded stuff
13:44:46 <rkieley> tpokorra that'd be a good start
13:44:50 <nmilosev> I can look into it, where it is hardcoded if it helps
13:44:51 <tanaka733_> I'm not sure the detail, but they say .NET Core 1.1 will support Fedora24. https://github.com/dotnet/core/issues/305#issuecomment-256388284
13:45:16 <nmilosev> tanaka733_ that probably means libicu is hardcoded for the version which ships in F24 :(
13:45:28 <moto-timo> we can fix that
13:45:35 <nmilosev> We would need a more permanent solution, I think
13:45:42 <tanaka733_> nmilosev: thanks. I see.
13:45:45 <nmilosev> eg. patch
13:47:18 <nmilosev> I think the first step would be to see what can we do without in the binary dotnet distribution
13:47:34 <nmilosev> i.e. kestrel or libicu - because we don't want to bundle stuff
13:48:00 <nmilosev> When we arrive to a minimal package that would be the dotnet-core package, I think
13:48:15 <nmilosev> Afterwards, it's easy to build up on it
13:48:25 <moto-timo> yeah. no bundling
13:48:27 <rkieley> nmilosev makes sense to me
13:48:49 <bt0> I agree, No bundling
13:48:52 <Rhea> Omajid had some info about libicu if i could only find it
13:49:08 <nmilosev> My experience with dotnet on F24 and F25 is that it works just fine, apart from the libicu
13:49:13 <Rhea> And +1 on bundling topic
13:49:21 <nmilosev> We also have to think about the dependency tree
13:49:25 * moto-timo wonders if debian has packaged it
13:49:57 * Rhea doubts any linux distro did
13:50:01 <Rhea> (maybe ubuntu..)
13:50:11 <pcreech> i think even ubuntu hasn't
13:50:13 <tpokorra> archlinux did something for msbuild
13:50:36 <moto-timo> we can be first!
13:50:39 <tpokorra> even https://aur.archlinux.org/packages/dotnet-cli/
13:50:49 <tpokorra> but I did not check it, if it is built from source
13:51:19 <bt0> but it is in AUR
13:51:37 <nmilosev> even though, we can probably learn a lot from it
13:51:58 <nmilosev> Do we have SRPMs for the binaries on the dot.net site?
13:52:15 <nmilosev> That would be a good starting point
13:52:38 <nmilosev> Nevermind, they don't have RPMs
13:52:45 <nmilosev> it's just a tarball :(
13:52:51 <tpokorra> but Redhat has rpms, so Omajid could help us with that
13:52:59 <bt0> the pkgbuild script from AUR is a gem :)
13:53:02 <nmilosev> Well yes
13:53:07 <pcreech> is a scl, that is just a binary to /opt iirc
13:53:17 <pcreech> (the redhat rpm)
13:53:21 <tpokorra> ah, ok
13:53:40 <nmilosev> so the best source we have is the arch pkgbuild
13:53:47 <nmilosev> #link https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=dotnet-cli
13:54:18 <Rhea> So...
13:55:05 <nmilosev> the pkgbuild uses fedora 23 binaries haha ČD
13:55:06 <nmilosev> :D
13:55:31 <Rhea> Next steps should be to look into dotnet 1.1 support for F24 and to take a look at how did they solve these issues for Arch Linux..
13:55:42 <Rhea> oh? o.o
13:56:02 <moto-timo> and ping upstream on GitHub about whatever is missing
13:56:05 <nmilosev> yes, it would be awesome if they build an RPM like for vscode
13:56:06 <tpokorra> so archlinux is not compiling it themselves, but using the binaries from Microsoft?
13:56:42 <pcreech> they seem to be using the ./build.sh
13:56:44 <bt0> yeah,
13:56:57 <pcreech> https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=dotnet-cli#n54
13:56:59 <nmilosev> But they have the binaries in the source list T_t
13:57:12 <pcreech> bootstrapping?
13:57:20 <nmilosev> https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=dotnet-cli#n30
13:58:12 <tpokorra> I guess we have to do bootstrapping at some point. but then be able to build from our own builds
13:58:29 <nmilosev> +1
13:58:33 <moto-timo> +1
13:58:41 <nmilosev> So what to do next?
13:59:01 <nmilosev> Check the dotnet 1.1 for F24 and see if the libicu is still a problem
13:59:12 <moto-timo> +1
13:59:20 <nmilosev> and use tpokorra copr as a base?
13:59:22 <Rhea> Any volunteers? :D
13:59:29 <tpokorra> my copr does not work I think
13:59:33 <bt0> +1
13:59:57 <tpokorra> I did not get it to work
14:00:00 <nmilosev> We have another problem, which we haven't discussed
14:00:22 * pcreech could look into it
14:00:27 <nmilosev> The way they package dotnet, they have to add runtimes for specific operating systems
14:00:36 * moto-timo can shadow pcreech
14:00:51 <nmilosev> Which is fine, if we are using the shared .netcore without a specific runtime
14:01:07 <nmilosev> But it will take time from Fedora release -> next dotnet release
14:01:22 <nmilosev> You can see now, they added F24 with F25 just around the corner
14:01:49 <nmilosev> So we would have to send a PR almost immediately upon, or even before the Fedora release :(
14:01:54 <moto-timo> I suspect if we volunteer to help, they will be more open about it
14:02:08 <moto-timo> the new Microsoft
14:02:27 <tpokorra> if we build from source, that should not affect us?
14:02:47 <nmilosev> If we can get our PR (or patch) and build from source
14:02:50 <pcreech> that's my thinking.  And if we build from source, we could 'patch' in support
14:02:51 <nmilosev> We are good
14:02:52 <Rhea> technically it's ran by .NET Foundation and not microsoft anymore, you sign some CLA and you're in
14:02:53 <tpokorra> only for the bootstrapping, when introducing new architectures
14:03:13 <nmilosev> Also, what about i686? Is it supported?
14:03:20 <moto-timo> IronPython is joining .NET Foundation
14:03:21 <nmilosev> Or just x86_64
14:03:39 <nmilosev> The arm port is still far away AFAIK
14:04:03 <moto-timo> so we have an exclude arch issue...
14:04:18 <bt0> I have have experience cross-compiling things
14:04:24 <nmilosev> and both these are main Fedora architectures
14:04:25 <tpokorra> we had that with Mono as well, and then more and more arches were added
14:04:31 <moto-timo> my life is cross-compiling
14:04:37 <nmilosev> :D
14:04:40 <Rhea> Did anyone try this? https://github.com/dotnet/core/issues/305#issuecomment-258354469
14:04:49 <bt0> moto-timo++
14:04:50 <zodbot> bt0: Karma for ttorling changed to 4 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:04:52 <bt0> my hero
14:05:21 <bt0> :D
14:05:24 <nmilosev> Failed to initialize CoreCLR, HRESULT: 0x80131500
14:05:27 <nmilosev> That is libicu
14:05:29 <nmilosev> error
14:05:31 <nmilosev> 99% sure
14:05:48 <tanaka733_> Rhea: I just tried. But it's only runtime. not included SDK
14:05:58 <rkieley> nmilosev yeah I think so, you can bring in the right icu or export some COMplus environment variable (have to look it up)
14:06:03 <Rhea> hmm
14:06:16 <nmilosev> If you use older libicu it would probably work
14:06:18 <tanaka733_> So I can't do anything except "dotnet help" or
14:06:35 <nmilosev> and the COMplus is for some kernel versions (it's in the description on my copr)
14:07:48 * nmilosev has to go soon :(
14:07:51 <Rhea> #action Rhea Create an issue in pageure to keep track of our libicu progress.
14:08:06 * pcreech has to go soon as well
14:08:08 <Rhea> Yeah, let's call it for the day :]
14:08:24 <rkieley> nmilosev right - COMPlus_Internal_ThreadSuspendInjection=0
14:08:58 <nmilosev> Rhea, we need actions or issues for dependancies and modularity
14:09:11 <nmilosev> Or is that too far away now?
14:09:31 <moto-timo> make it an agenda item for next time
14:09:44 <Rhea> pcreech++ nmilosev++ tanaka733++ tanaka733_++ rkieley++ bt0++ tpokorra++ dmulford++ thanks for the awesome guys :]
14:09:44 <zodbot> Rhea: Karma for pcreech17 changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:09:47 <zodbot> Rhea: Karma for nmilosev changed to 14 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:09:48 <Rhea> moto-timo: +1
14:09:50 <zodbot> Rhea: Karma for tpokorra changed to 5 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:09:53 <nmilosev> +1
14:09:53 <zodbot> Rhea: Karma for dmulford changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:09:56 <pcreech> mmm, coookies...
14:09:58 * Rhea observes the spam
14:10:03 <moto-timo> I love cookies
14:10:32 <bt0> My second cookie :')
14:10:46 <moto-timo> I'll start looking at https://github.com/dotnet/coreclr
14:11:02 <Rhea> #action dotnet Discuss dpendencies and modularit
14:11:14 <nmilosev> I can check if the binaries still expect the wrong libicu
14:11:18 <Rhea> #endmeeting