infrastructure
LOGS
18:00:18 <nirik> #startmeeting Infrastructure (2016-11-03)
18:00:18 <zodbot> Meeting started Thu Nov  3 18:00:18 2016 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:18 <zodbot> The meeting name has been set to 'infrastructure_(2016-11-03)'
18:00:18 <nirik> #meetingname infrastructure
18:00:18 <zodbot> The meeting name has been set to 'infrastructure'
18:00:18 <nirik> #topic aloha
18:00:18 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore threebean pingou puiterwijk pbrobinson
18:00:18 <zodbot> Current chairs: abadger1999 dgilmore lmacken nirik pbrobinson pingou puiterwijk relrod smooge threebean
18:00:19 <nirik> #topic New folks introductions
18:01:04 <cyberhack> hi My name is Feng, Cs student at Iowa State CDT
18:01:04 <trishnag> .hello trishnag
18:01:05 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
18:01:14 <lousab> .hello lousab
18:01:15 <zodbot> lousab: lousab 'luigi sainini' <luigi.sainini@tiscali.it>
18:01:22 <nirik> oh good. Some people at least. ;) Didn't want to just meet with myself.
18:01:35 <lousab> \ò hi nirik
18:01:43 <nirik> morning everyone
18:01:44 <jcline> .hello jcline
18:01:45 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
18:01:48 <aikidouke> o/ Feng and welcome
18:01:58 <cyberhack> Thanks ailkidouke
18:02:01 * pingou a tad late
18:02:33 <aikidouke> nirik usually has a question for new people cyberhack
18:02:39 <nirik> cyberhack: welcome. Are you interested in sysadmin or application development? :)
18:02:45 <aikidouke> :)
18:02:45 <nirik> I do. :) ^
18:03:08 <cyberhack> yes, I am interest in application development. Haha, I am know Java and Python. C/C++
18:03:13 <cyberhack> :)
18:03:55 <smooge> hello
18:04:24 <nirik> cyberhack: cool. Folks in #fedora-apps can point you on how to get started... we mostly have python based apps.
18:04:33 <nirik> morning smooge
18:04:54 <cyberhack> sounds good!
18:06:25 <nirik> ok, any other new folks like to give a short introduction?
18:06:39 * stickster lurks
18:06:55 <nirik> ok, on to status/info...
18:06:56 * doteast late, but present
18:07:10 <nirik> #topic announcements and information
18:07:10 <nirik> #info Fedora 25 Final FREEZE now in effect - everyone
18:07:10 <nirik> #info infra-docs git hooks fixed up - patrick
18:07:10 <nirik> #info ansible updated to 2.2.0.0 on batcave01 - kevin
18:07:11 <nirik> #info November apprentice nag out, all apprentices please answer - kevin
18:07:12 <nirik> #info updated taskotron's triggering system so it ignores the new signing tags in koji - tflink
18:07:13 <nirik> #info Time to clean up sysadmin groups
18:07:23 <nirik> anything anyone wants to add there or talk about further?
18:07:26 <nirik> I have one more...
18:07:47 <nirik> #info puiterwijk and nirik will be on site at PHX2 the week of 2016-12-05.
18:08:02 <nirik> if you have anything we need to do 'hands on' at our main datacenter, let us know
18:08:40 <smooge> I need a salami on rye
18:09:09 <nirik> smooge: we can use bladecenter02 as a panini press. ;)
18:09:23 <smooge> oooooh
18:09:40 * stickster wracks brain
18:09:45 <nirik> ok, on to discussion items. ;)
18:09:45 <sayan> .hello sayanchowdhury
18:09:46 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
18:09:59 <nirik> #topic more outreach / improving onboarding - stickster / kevin
18:10:12 <clime> ah time-shift. Hi!
18:10:14 <nirik> stickster and I were talking about this the other day...
18:10:24 <nirik> clime: ah, sorry. I hate DST. ;(
18:10:26 <stickster> yeah, that was it, thanks nirik  :-)
18:10:49 * pcreech here
18:10:51 <clime> ye, me too
18:11:23 <sayan> timezone-shift for me :)
18:11:37 <nirik> so, we were thinking that perhaps we should work some on our apprentice/application dev onboarding some, then look at giving some talks in likely places to get more contributors.
18:12:00 <nirik> places like devconf or ansiblefest or lisa
18:13:19 <pingou> lisa?
18:13:19 <pingou> sysadmin?
18:13:19 <pingou> linux sysadmin conf?
18:13:30 <nirik> yeah, it's
18:13:35 <nirik> unix/linux...
18:13:35 <pingou> cool
18:13:47 <sayan> I'll will be giving a talk this weekend at FUDCon/Barcamp Phnom Penh. My plan is to rather than talk I will be demoing codebase
18:13:57 <nirik> Another thing that occurred to me is that we could look at improving our drive by contributions at the same time.
18:14:14 <stickster> nirik: I think one easyfix project might be cleaning up wiki pages or other get-involved info
18:14:25 <sayan> and showing how to approach an issue
18:14:32 <nirik> https://lwn.net/Articles/688560/ is a good read in this area. It suggests having a really nice "quick start" guide and other things
18:14:37 <stickster> +1
18:14:38 <nirik> sayan: excellent!
18:14:55 <lousab> nirik: i like it
18:15:17 <stickster> Is there anyone who wants to take on the wiki changes?
18:16:06 <nirik> stickster: I can take it on... I think it will need feedback especally from the existing apprentices and new folks
18:16:17 <nirik> to tell us what is confusing and what they want to know better, etc.
18:16:40 <stickster> yeah, for sure -- like gathering input on what parts they had trouble with, how we could simplify things without being obtuse, etc.
18:16:42 * pingou knows that problem
18:16:45 <nirik> another idea: should we delete most of the wiki pages and move this to pagure?
18:16:50 <athos> you mean after the changes or before it, nirik?
18:17:02 <pingou> nirik: together w/ our SOPs?
18:17:03 <nirik> athos: either one. ;) both I guess.
18:17:21 * threebean is here
18:17:22 <smooge> yes
18:17:26 <nirik> pingou: yeah. The one issue there is what happens if pagure is down. ;(
18:17:27 <sayan> nirik: yes
18:17:37 <smooge> I think that the wiki really should just be for QA to use for testing :)
18:17:46 <smooge> everything else should be a git page
18:17:56 <stickster> nirik: Maybe it makes sense to step it out, like: 1. Survey the list and ask people to present 1-3 pain points; 2. Sort through results and make fixes accordingly; 3. Test with new apprentices
18:17:59 <nirik> Where Information Kills Itself. ;)
18:18:03 <stickster> yep
18:18:42 <nirik> true...
18:19:14 <stickster> So how should we action this and move on?
18:19:20 <nirik> I guess the place doesn't matter so much as the content...
18:19:27 * stickster doesn't want to monopolize time here :-)
18:19:55 <nirik> how about I take a look at what we have now and ask on list for pain points... and we revisit next week?
18:20:01 <stickster> Makes sense to me
18:20:02 <doteast> stickster, I think the monthly apprentice email does 1.
18:20:09 <stickster> doteast: ah, good point!
18:20:10 <nirik> mixed into this perhaps is the monthly apprentice nag email
18:20:16 <nirik> yeah, jinx. ;)
18:20:52 <nirik> one problem with that is that it's the same all the time and someone who has been around a while probibly finds it tedious.
18:21:21 <doteast> nirik, reading or writing end?
18:21:27 <pingou> nirik: you have a local clone? :D
18:21:27 <pingou> nirik: I still want to mirror things onto batcave if we can
18:21:27 <tflink> smooge: the idea of QA having a wiki only for test results makes me sad in so many ways :)
18:21:33 <nirik> so perhaps we could move to a automated thing... look for logins or activity and if none just remove
18:21:57 <stickster> nirik: and/or target people for a length of time, and after that assume they're not so new anymore
18:22:33 <nirik> yeah, would be more complex to keep track of tho. The idea was that we didn't want people to stay apprentices forever, that they would move on to some sysadmin groups
18:22:50 <nirik> and we didn't want people no longer interested with access.
18:23:20 <nirik> anyhow, I'll survey what we have and we can discuss more next week. ;)
18:23:22 <lousab> nirik: right i think it could be a faster process to start from
18:23:40 <nirik> #action nirik to survey getting started docs and survey apprentice emails and revisit next week
18:24:06 <clime> I liked the apprentice emails
18:24:26 <nirik> lousab: yeah, the big gap is between starting out and us knowing that you will be around a while and that you are able to fix things...
18:24:28 * jflory7 will follow along for that thread / discussion too
18:24:36 <nirik> but thats hard to know quickly
18:24:50 <nirik> ok, anything else on this ?
18:25:04 <jflory7> If anything goes into a ticket, please feel free to @tag me in case I miss it - anything on-boarding related, I'd be happy to help lend time and effort with. :)
18:25:17 <nirik> #topic testing out new dist-git(-min) package - clime
18:25:30 <nirik> clime: take it away. hum, zodbot is slow
18:25:46 <clime> oh yeah, so I finished the first proof of concept of an upstream dist-git package
18:25:56 <stickster> get with it zoddie!
18:26:18 <clime> I'd like to test it on pkgs01.stg. Is that possible? Cause I have only gitolite access and not sure if I can deploy there.
18:26:36 <clime> Also I am not sure if anyone else is using it at the time.
18:26:51 <clime> So I don't want to mess his testing up :).
18:27:49 <nirik> net must be having problems.
18:27:54 <nirik> clime: you there?
18:27:59 <clime> yes
18:28:38 <stickster> heh
18:28:45 <nirik> wow. lagorama
18:28:55 <clime> hello, do you read me?
18:28:59 <nirik> clime: yep. :)
18:29:06 <clime> I'd like to test it on pkgs01.stg. Is that possible? Cause I have only gitolite access and not sure if I can deploy there.
18:29:12 <nirik> well, threebean and the modularity folks might be using it...
18:29:18 <nirik> so I would coordinate with them.
18:29:23 <clime> oh ok
18:29:36 <nirik> what all does it take? just install package and test? or some ansible changes too?
18:29:51 <clime> also ansible changes.
18:30:00 <clime> I will need to redeploy it there.
18:30:06 * threebean waves
18:30:17 <threebean> we're using it pretty frequently atm.
18:30:27 <clime> basically the script is shrunk now cause some of the stuff got packaged.
18:30:41 <clime> threebean: ok, so I will continue to test in VM
18:30:52 <threebean> could we spin up a pkgs02.stg VM and try deploying your work there?
18:30:58 <nirik> yeah, I was just thinking that...
18:31:06 <clime> oh that would be great!
18:31:07 <threebean> (nots ure if that would be helpful to clime or not)
18:31:11 <clime> yes!
18:31:30 <clime> cause there are nfs mounts on lookaside and ssl auth that I haven't tested yet.
18:31:48 <nirik> well, stg doesn't have the nfs mounts. ;(
18:31:51 <clime> I could somehow do it in VM but I'd like to have the closest possible env to prod
18:32:01 <nirik> ssl auth for lookaside upload?
18:32:05 <clime> ok, so without that :)
18:32:06 <clime> yes
18:32:17 <nirik> ok. Note we are moving that to kerberos. ;)
18:32:30 <clime> cool
18:32:36 <clime> i'll talk to Patrick about it
18:32:37 <threebean> also note that I think stg has a read-only nfs mount of the prod lookaside.
18:32:43 <nirik> so, yeah, coordinate there.
18:33:03 <clime> okay
18:33:08 <nirik> threebean: oh right. I forgot about that.
18:33:13 <nirik> so it does have nfs. ;)
18:33:24 <threebean> :p
18:33:28 <clime> but you cannot upload there...
18:33:31 <threebean> right.
18:33:45 <clime> anyway, I'd like to test on staging at some point
18:34:04 <clime> testing just in VM is alright but, yeah...:)
18:34:26 <nirik> yeah, we can spin up an 02, or wait for some window when modularity isn't using 01 much
18:34:29 <threebean> hey, as you get closer to saying "this is ready for prime time", let's talk and we can schedule saving out all the modularity data and converting over pkgs01.stg for real.
18:35:00 <clime> I'd like to have pkgs02 but not sure how that is hard to setup
18:36:01 <clime> I think it might be easier than to coordinate and perhaps I would also like to try out pagure there as a frontend to dist-git
18:36:01 <nirik> well, pretty easy, but we would have to figure out the details... if there's a prod ro mount or not, etc.
18:36:28 <clime> (...just for fun to see what can be done)
18:36:35 <threebean> +1
18:36:37 <nirik> well, we have a test one on pkgs01.stg
18:36:39 <threebean> we want pagure too :)
18:36:58 <clime> :)
18:37:52 <nirik> I guess file a ticket for pkgs02 and we can work on it as time permits?
18:38:06 <clime> cool!  Thanks!
18:38:08 <nirik> #info will make a pkgs02.stg for dist-git testing
18:38:26 <nirik> #topic Github->Pagure pull request transfer with pagure-importer - clime
18:38:28 <linuxmodder> .fas linuxmodder
18:38:29 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
18:38:32 <linuxmodder> (super late)
18:38:55 <clime> oh, so I'd like to implement support into pagure-importer for transporting PRs from Github to Pagure
18:39:19 <clime> Open ones are very practical to move
18:39:47 <nirik> that sounds nice to me. ;) I'd say work with the pagure-importer folks.
18:40:00 <clime> but closed ones are also nice cause you Merge commit messages will stay correct and people will know who contributed etc.
18:40:10 <clime> alright.
18:40:11 <linuxmodder> clime,  I'd be willing to help and learn some more in that space if you need help
18:40:23 <nirik> one trick I think is that PR numbers are also tied to issue number?
18:40:27 <nirik> somehow
18:40:43 <clime> oh ok.
18:40:44 <linuxmodder> if done right they are yes
18:40:45 <pingou> yes but same for github
18:40:52 <clime> linuxmodder: sure we can look into that together
18:41:12 * linuxmodder is good on gh not so much on pagure tho
18:41:13 <clime> I was thinking about using Remote PRs
18:41:27 <nirik> cverna / vivek in #fedora-apps would be the ones to talk with
18:41:35 <clime> create them and then change status to 'Merged' with Pagure Request hook enabled.
18:41:38 <linuxmodder> clime, what keeping those as remotes on gh ?
18:41:58 <pingou> so for projects coming from github that should be fine (and consistent w/ github)
18:42:03 <pingou> clime: not sure it's the best idea, in case the remote repo disapears
18:42:08 <clime> but that doesn't work currently cause you cannot change statuses like that :(
18:42:31 <clime> pingou: well, that can always happen even on Github
18:42:36 <linuxmodder> pingou,  would it be possible /hard to do the archive thing like the fedorahosted >  pagure did for docs
18:42:48 <dgilmore> hey all
18:42:51 <clime> pingou: but not sure how Pagure handles it
18:43:10 <linuxmodder> where things were ro for like 2 weeks or whatever it was
18:43:11 <clime> but it's very close to the actual solution
18:43:58 <linuxmodder> either way we'd need to make sure to get out in fron tof that to let projects know so they can migrate seemlessly
18:44:42 <nirik> cool.
18:44:46 <nirik> anything else on this ?
18:45:17 <linuxmodder> clime would you still want the webhooks on gh to cross over?
18:45:31 <linuxmodder> or manage solely on pagure point forward and let old ones die
18:45:45 <linuxmodder> like a firm sunset logic
18:46:07 <clime> linuxmodder: well, something easy
18:46:07 <linuxmodder> nothing further from me tho nirik  atm
18:46:14 <clime> :)
18:46:27 <nirik> #topic Apprentice Open office hours
18:46:31 <pingou> clime: you might just set the start and stop commits and create the PR from the main repo
18:46:31 <linuxmodder> clime,  tag up with me after to brainstorm pls
18:46:31 <pingou> clime: no because iirc, github stores a local copy of the PR (in the main repo)
18:46:31 <pingou> linuxmodder: and I think jflory7 is doing a great job at that
18:46:31 <pingou> nirik as well actually
18:46:31 <pingou> clime: what seems to me the easiest is to create the PR via the requests git repo (w/ the pagure request hook enabled), give these PRs the proper start/stop commits and create them as 'Merged'
18:46:31 <pingou> clime: if there is something pagure doesn't do, let us know :)
18:46:40 <nirik> sheesh freenode
18:46:59 <linuxmodder> at what pingou ?
18:47:12 <linuxmodder> getting in front of the migrations announces?
18:47:28 * jflory7 looks up
18:47:30 <pingou> linuxmodder: yes and for a while already
18:47:44 <clime> pingou: sounds good. I'll talk to you about. Thx for input
18:47:56 <linuxmodder> dgilmore,  o/
18:47:59 <nirik> any apprentices with questions / comments / looking for things to do?
18:48:18 <nirik> I may be pinging folks for more getting started feedback soon.
18:48:25 <linuxmodder> nirik,  I've been busy with work lately and been out of loop anything easy-ish to get back in the saddle
18:48:29 <nirik> and do answer the nov apprentice nag email if you got it
18:48:42 <jflory7> Ahh, Pagure migrations. Yeah, I've discovered some migration strategies that are especially helpful for ticket-based teams. :)
18:48:45 <nirik> linuxmodder: no worries. we do have some easyfixes marked.
18:48:58 <linuxmodder> will look again after mtg
18:49:06 <jflory7> pingou: For reference, there is a post coming on the CommBlog soon that offers tips and suggestions about migrating from FedoraHosted.
18:49:11 <pingou> jflory7: still need to fully read your report ^^
18:49:23 <pingou> cool
18:49:24 <linuxmodder> jflory7,  mind a few minutes after on that to talk about the migrations ?
18:49:27 <pingou> jflory7++
18:49:27 <zodbot> pingou: Karma for jflory7 changed to 59 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:49:29 <jflory7> I'll be sure to share the link so we can use it for anyone who has questions or is just getting around to migrating.
18:49:58 <nirik> oh, one other onboarding idea I had was to assign someone weekly/monthly or something as a greeter... people seem to expect one and sometimes everyone is busy. But will ponder on it more.
18:49:59 <jflory7> linuxmodder: Normally any other time, but I'm getting ready to travel tonight, so an email will work better for me.
18:50:08 <jflory7> pingou++ :)
18:50:24 <jflory7> nirik: In IRC or the mailing list?
18:50:29 <nirik> yes
18:50:35 <jflory7> Yes... both? :)
18:51:33 <nirik> both. ;)
18:51:48 <nirik> #topic Open Floor
18:51:51 <jflory7> For some of the other teams, I have a response that I recycle for newcomers that has a lot of the key info about how to get started (e.g. could be highlighting Apprentice program, easyfix tickets, other helpful guides for getting set up to contribute to Infra).
18:52:02 <jflory7> Something like that could be helpful for whoever responds to a thread first.
18:52:24 <nirik> jflory7: yeah. I often answer them, but it might be nice to have someone assigned so we spread it around and also so we don't all reply
18:52:25 <jflory7> It's tougher to write the first time because it usually runs long, but then you can just reuse it and change small bits depending on the individual person
18:52:31 * jflory7 nods
18:53:07 <smooge> or none of us reply because we thought someone did privately
18:53:30 <pingou> nirik: dgilmore was wondering about sysadmin-main clean up recently
18:53:37 <pingou> is that something we should consider?
18:53:50 <nirik> pingou: yes, and I already sent mail to the non active folks
18:53:51 <smooge> I think we should look at cleaning up all the sysadmin groups
18:54:01 <pingou> like maybe removing puiterwijk from there from 8PM to 8AM or so :)
18:54:08 <nirik> if I don't hear from them by next week I will remove them...
18:54:10 <pingou> nirik: ah ok, thanks :)
18:54:22 <nirik> but yeah, I am not opposed to cleaning up sysadmin* groups too
18:54:24 <smooge> pingou, he would have to write the code to do that
18:54:43 <smooge> and then he would come up with him being in 2 timezones
18:54:48 <pingou> smooge: nah, I'll spare him this :)
18:55:02 <nirik> I would say a mass email to them, then wait a week and collect replies, remove anyone who didn't reply?
18:55:03 <dgilmore> for a later time, we should look at some more granularity
18:55:10 <pingou> smooge: that's the whole idea, put him back to one :D
18:55:30 <smooge> I could see him moving to the south pole so he was in opposite zones depending on the side of the shelter he was in
18:55:56 <smooge> nirik, I can put that on my list
18:56:05 <pingou> smooge: don't tempt him!
18:56:24 <smooge> hey the cooling costs would be great.. or he would be the cause of the great global melt.
18:56:25 <nirik> smooge: ok, sounds good. really base 'sysadmin' and 'sysadmin-noc' are the ones I think we have lots of people in...
18:57:06 <smooge> nirik, yes
18:57:29 <nirik> cool.
18:57:43 <nirik> #action smooge will start cleaning up inactive sysadmin accounts as time permits.
18:57:54 <nirik> Anyone have anything else for open floor? or shall we call it a meeting?
18:58:45 <nirik> alright then. Thanks for coming everyone.
18:58:46 <cyberhack> sorry, what can I get start?
18:59:03 <nirik> cyberhack: #fedora-apps for development stuff, #fedora-admin for sysadmin side. ;)
18:59:23 <nirik> lets continue over there. ;)
18:59:24 <cyberhack> okay, thanks. can anyone give me access to "fi-apentice"?
18:59:27 <nirik> #endmeeting