fedora-qa
LOGS
15:00:25 <adamw> #startmeeting Fedora QA meeting
15:00:25 <zodbot> Meeting started Mon Oct 10 15:00:25 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:25 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:29 <adamw> #meetingname fedora-qa
15:00:29 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:32 <adamw> #topic Roll call
15:00:39 <adamw> morning folks, who's here for qa meeting times?
15:00:51 * tenk is here
15:01:09 * garretraziel seems to be here
15:01:51 <adamw> garretraziel: while we're waiting - you saw i commented on your ARM kernel/initramfs naming diff, right?
15:02:18 <garretraziel> yeah, I have noticed not long ago
15:02:39 <garretraziel> I'm going to install you scratchbuild of openQA and test my diff with it
15:02:48 * kparal is here
15:02:54 * pschindl_ is here
15:03:00 * Southern_Gentlem 
15:05:02 <adamw> morning folks
15:05:41 <tenk> hello
15:06:46 <adamw> welp, guess that's everyone :)
15:07:02 <adamw> #topic Previous meeting follow-up
15:07:44 <adamw> #info "adamw to arrange a Wayland test day" - we have a ticket for this and I'm aiming to run it this Thursday, 2016-10-13: https://fedorahosted.org/fedora-qa/ticket/492
15:07:53 <adamw> i'll set up the page and send out announcements tomorrow
15:07:55 * coremodule is here, late.
15:08:00 <adamw> morning coremodule
15:08:19 <coremodule> Good morning!
15:08:27 <adamw> "sumantro to organize a test day for  https://fedoraproject.org/wiki/Changes/BetterSwitchableGraphicsSupport"
15:08:32 <adamw> anyone know where we're up to on that one?
15:10:48 * kparal doesn't
15:11:00 <adamw> i guess i'll throw it back on the agenda for next time
15:11:07 <adamw> #action sumantro to organize a test day for https://fedoraproject.org/wiki/Changes/BetterSwitchableGraphicsSupport
15:11:27 <adamw> #info "adamw to run firmware/hardware RAID tests" - did that, along with pschindl, it made for an interesting week...:)
15:12:29 <adamw> #info "coremodule to run Cloud tests" - tests were run by lbrabec for beta
15:13:20 <adamw> #info "adamw and sumantro to blog, mail, social media etc. i18n Test Day" - we did that, looks like there was a good turnout for the event: http://testdays.fedorainfracloud.org/events/10
15:13:40 <adamw> #info "sumantro to send post-event report for FMW Test Day" - he'd actually already done that and we missed it, but he did it again
15:14:10 <adamw> #info "adamw to troll for interest in release validation app development project outside of test@ list" - i've set up a trac ticket for the design, for now: https://fedorahosted.org/design-team/ticket/483
15:14:32 <adamw> #info "adamw to do some very preliminary work on validation app planning, maybe with design WG" - see above
15:14:48 <adamw> whew, that was a bumper crop. any other previous meeting follow up before we move on?
15:15:06 <Southern_Gentlem> would love to send my respins though autoqa
15:16:26 <garretraziel> do you mean openqa?
15:16:46 <Southern_Gentlem> yes
15:17:07 <adamw> yeah, i'd like to set that up but it's on the list of 'things i'd like to find time for', heh
15:17:49 <cmurf> oh if only we could just divide in two...
15:17:54 <garretraziel> adamw: you can do it now, temporarily, by hand
15:17:59 <garretraziel> don't you?
15:18:01 <adamw> yeah, you could
15:18:21 <adamw> we should throw up a phab issue for it i guess
15:18:32 <garretraziel> yeah
15:18:53 <garretraziel> doesn't upstream plan on something like this? infrastructure for submitting your own isos for testing?
15:19:00 <adamw> they do?
15:19:11 <adamw> i hadn't heard
15:20:39 <garretraziel> hmm, maybe that was only impression I got when I talked about https://github.com/os-autoinst/openQA/issues/684 with them
15:20:42 <adamw> #action garretraziel or adamw to file a phab ticket for looking into setting up openQA testing of the post-release live respins
15:20:51 <adamw> garretraziel: i'm not saying you're wrong, just i hadn't heard about it :)
15:21:06 <adamw> alrighty
15:21:13 <adamw> #topic Fedora 25 Beta post-mortem
15:21:24 <adamw> so we signed off on Beta last week, on time - many thanks for all the testing work, everyone!
15:21:33 <adamw> #info thanks to all for their work testing F25 Beta
15:21:55 <adamw> i'm not aware of anything out of the ordinary we still need to do around Beta, is anyone?
15:22:10 <adamw> kparal: did you do anything on commonbugs yet?
15:22:16 <kparal> not yet
15:22:17 * adamw is technically on a vacation day today
15:22:25 <adamw> ok, i'll look at it later then
15:22:35 <kparal> I'll have a look as well
15:22:40 * kparal forgot about that
15:23:58 <adamw> #action adamw and kparal to update commonbugs for Beta
15:24:16 <cmurf> Columbus Day in the U.S. (is it still called that?)
15:24:34 <cmurf> It is - weird, whatever.
15:25:32 <Southern_Gentlem> cmurf yes its one of those holidays people bank for later
15:25:33 <adamw> i dunno, i'm in Canada. :P it's Thanksgiving
15:25:47 <adamw> silly americans think that comes next month, but they are of course wrong
15:25:52 <cmurf> of course
15:26:03 <tenk> Japan, today was off to, don't know why
15:26:05 <cmurf> But I wouldn't be anywhere near a computer on Thanksgivign
15:26:49 <adamw> welp
15:26:59 <adamw> sounds like we don't have any Beta fires to worry about, which is good...
15:27:21 <adamw> moving onto:
15:27:25 <adamw> #topic Fedora 25 Final planning
15:28:11 <adamw> #info dates for Final: freeze 2016-11-01, go/no-go 2016-11-10
15:28:16 <adamw> so keep those in mind :)
15:28:36 <adamw> do we have any major concerns about Final going forward? how are we feeling about the Wayland switch, comfortable?
15:28:57 <kparal> not stellar, but ok
15:29:33 <adamw> the paste-into-password-overlay bug i personally was stuck on is claimed fixed upstream now...
15:29:57 <Southern_Gentlem> so is wayland going to be default for only gdm or for workstation?
15:30:03 <kparal> adamw: display rotation still doesn't work for me properly
15:30:08 <cmurf> I have some odd duck Wayland things every now and then. We may start to see transient issues once the big ones are fixed.
15:30:09 <adamw> Southern_Gentlem: for workstation, unless anyone pulls any escape cords
15:30:17 <cmurf> Yeah no display rotating is a bit of a bummer.
15:30:23 <cmurf> I'll live.
15:30:37 * kparal now has to use only 2 monitors
15:30:48 <Southern_Gentlem> but we will have the option for gnome-X correct?
15:30:54 <kparal> yes
15:31:03 <cmurf> Some programs with multiple windows, suddenly one window will becomed "pinned" forward in the layering stack so any other windows from any other program including itself will always drag behind that pinned window.
15:31:09 <Southern_Gentlem> as long as we have a choice thats fine
15:31:18 <cmurf> But it's not a freak out moment.
15:31:32 <kparal> cmurf: I haven't seen that oe
15:31:33 <kparal> one
15:31:42 <adamw> yeah, realistically we're gonna have to live with a few bugs, it's kinda inevitable
15:31:44 <cmurf> It happens somewhat often with Leaf
15:31:47 <adamw> but i haven't heard about anything disastrous yet
15:31:51 <cmurf> Leafpad
15:31:57 <cmurf> No disasters
15:32:06 <cmurf> Surprisingly quite calm.
15:32:44 <cmurf> But hey let's wait until the Beta gets into people's hands :D
15:32:49 <adamw> yeah :P
15:33:13 * satellit sorry I am late
15:33:18 <cmurf> fire him!
15:33:29 <adamw> .fire cmurf now, now, no need for that.
15:33:29 <zodbot> adamw fires cmurf now, now, no need for that.
15:33:33 <cmurf> :D
15:33:52 <adamw> morning satellit
15:34:06 <adamw> so we should definitely be getting the Final validation tests run ASAP
15:34:24 <adamw> we had good test coverage for Beta, but a lot of the Final tests weren't run, we need to be finding out where that stuff is broken
15:35:00 <satellit> is it true that mediawriter does not work in wayland?
15:35:02 <adamw> please do run some Final tests against Beta and fill out the tables if you have time, new nightly compose nomination should come soonish (the robot will decide)
15:35:15 <adamw> satellit: huh, i hadn't heard that...kparal? have you tried?
15:35:29 <kparal> satellit: that's liveusb-creator
15:35:37 <kparal> marketed as FMW in gnome-software
15:35:43 <kparal> an update is pending to fix the names
15:36:05 <cmurf> Yeah that situ is confusing.
15:36:34 <cmurf> Beta hits getfedora.org when?
15:36:36 <cmurf> Tomorrow?
15:37:09 <kparal> I believe so
15:37:11 <satellit> then the mediawriter in f25 workstation updated today mediawriter installed with gnome-software does not start....
15:37:25 <cmurf> I'm a bit concerned about the macOS Fedora Media Writer, and a fallback if it's not signed by tomorrow, or otherwise doesn't launch.
15:37:38 <kparal> satellit: can you try running mediawriter from the terminal?
15:37:45 <satellit> is this still liveusb-creator renamed in gnome-software?
15:37:56 <satellit> will boot it
15:38:04 <kparal> satellit: yes, most probably
15:38:08 <adamw> satellit: the one to test is mediawriter; the package name is 'mediawriter' and so is the command name, i believe
15:38:15 <satellit> k
15:38:23 <adamw> but liveusb-creator for now still exists and recent versions of it do still show up as 'Media Writer' in the overview, confusingly
15:39:01 <kparal> and the correct one is still not visible in gnome-software
15:39:07 <satellit> ok
15:39:21 <tenk> So priority this week is to test last nighlty compose with Final tests?
15:39:59 <adamw> tenk: for now the Beta is the 'current' compose, so run Final tests on the Beta compose
15:40:10 <adamw> tenk: when a new nightly is selected for testing there'll be an announcement mail as usual
15:40:15 <kparal> and report to Beta matrices
15:40:18 <adamw> yep
15:40:38 <adamw> alright, any more on Final planning before we move on?
15:41:34 <kparal> nothing here
15:42:12 <adamw> #topic Test Day status
15:42:22 <adamw> so, sumantro's not around again, so probably not much here
15:42:31 <adamw> i'm a bit behind on the wayland one but aiming to pull it together tomorrow
15:45:40 <adamw> #info sumantro is not around so we don't have much to discuss here, wayland test day is behind but adamw will try to get it done tomorrow
15:45:51 <adamw> #topic 'Default boot and install' validation test proposal / USB testing
15:46:21 <adamw> so this is about that proposal i mailed for revising the 'default boot and install' / usb matrices
15:46:26 <adamw> thanks for the reply today kparal
15:46:33 <adamw> did anyone else have comments on the proposal they didn't mail yet?
15:47:52 <cmurf> no
15:47:59 <cmurf> but question about splitting out boot
15:48:31 <cmurf> kparal's idea sounds compelling but at what point in startup is the actual cutoff?
15:48:55 <kparal> cmurf: talking about a) ?
15:48:56 <adamw> so the situations we've had issues with there before, iirc, fall into three buckets...
15:49:04 <adamw> 1) actually reaching anaconda at all
15:49:22 <adamw> 2) detecting attached disks (the 'filter out "protected" usb devices' code can affect this)
15:49:46 <adamw> 3) using the packages on the image, for DVD-type images
15:49:48 <cmurf> kparal: yes
15:50:05 <adamw> 3) is the one you actually need to *run the install* to be entirely sure about
15:50:34 <kparal> however, it's likely to stay the same regardless of environment, right?
15:50:47 <adamw> mehhhhh, i dunno. :P
15:50:51 <cmurf> me either
15:50:52 <kparal> dvd vs usb, bios vs uefi, bare metal vs vm
15:51:03 <cmurf> ends up being different packages
15:51:04 <satellit> I have been unable to reclaim disks in anaconda if the external usb HD install is the same as the USB boot.....get naming conflicts error
15:51:33 <satellit> have to reformat usb HD extrnally first
15:51:44 <adamw> kparal: i guess my take on it isn't strongly in either direction
15:52:17 <adamw> kparal: i think the amount of testing in my proposal unmodified isn't really that crazy, if we're only entirely guaranteeing it for Final (that was my intent, though I guess I didn't entirely mention it)
15:52:38 <cmurf> If decouple, I'd say rename "boot" to "startup" and define startup as "arrives at multi-user.target"
15:52:45 <adamw> on the other hand, i do understand where you're coming from in trying to cut it down and i don't think any of your ideas is wrong or particularly dangerous
15:52:51 <kparal> I didn't understand it's just for Final
15:53:06 <adamw> kparal: it's hard to express with wiki tables :/
15:53:10 <kparal> yeah
15:53:29 <adamw> but i was kinda figuring we'd do our best to at least get a sampling of coverage for alpha/beta, but really do *all* the tests for final
15:54:08 <cmurf> I was thinking this mornign it'd be neat if each matrix item were something like Bodhi's karma page, list the test cases for that matrix, tick off the boxes add a comment and the matrix gets autofilled
15:54:20 <kparal> the problem is that we need to repeat all of those for every RC, which gets time consuming very quickly
15:54:22 <cmurf> editing the wiki isn't super painful by anymeans but it is slow
15:54:29 <adamw> kparal: fair point
15:54:51 <adamw> cmurf: well, that's basically the 'new release validation tool' plan i was talking about last week.
15:54:57 <cmurf> yes i know
15:55:04 <adamw> kparal: believe me i don't love doing this testing either :P
15:55:15 <kparal> I'd rather try to consolidate as much as we dare, and explode that into suboptions if we hit an issue
15:55:15 <cmurf> yeah I'm bored with it myself haha
15:55:26 <kparal> that way we can spend more time on exploratory testing or building automation
15:55:37 <adamw> kparal: i'm just a bit paranoid about us shipping something that flat out doesn't work, i'd hate for that to happen at any point
15:55:47 <cmurf> really thankful for all the openqa work
15:56:21 <kparal> adamw: but do you understand we've been doing that all the time? :-)
15:56:31 <adamw> heh
15:56:35 <cmurf> fwiw mattdm just replied to the thread under discussion
15:56:42 <cmurf> make optical media go away in the next couple releases
15:57:04 <adamw> bold!
15:57:07 <cmurf> If that's true, it means we could dump the whole isohybrid thing
15:57:23 <cmurf> the funky iso9660 + three way partitioned hob goblin
15:57:32 <cmurf> which is pure genius but it's still a goblin
15:58:50 <adamw> alrighty
15:58:54 <adamw> welp, we're nearing the end of the timeslot
15:59:02 <cmurf> damn that was fast
15:59:03 <adamw> a kickaround was all i wanted on this topic, so thanks for the thoughts :)
15:59:07 <adamw> we'll continue it on the list i guess
15:59:17 <adamw> #info we'll continue this discussion on the list thread, thanks for the thoughts everyone
15:59:19 <adamw> #topic Open floor
15:59:23 <adamw> any open floor business?
16:00:23 * adamw sets the fuse
16:00:25 <coremodule> Yeah, the HoF nightly testing deal.
16:00:48 <cmurf> HOF?
16:00:58 <adamw> oh, right
16:01:02 <adamw> good call
16:01:28 <coremodule> I'll make mention that some of the information reported on the Heroes of Fedora blogposts for F24 Alpha, Beta, and Final, as well as F25 Alpha was erroneous.
16:01:42 <adamw> juliuxpigface pointed out (private mail to me and coremodule) that the F24 'Hall of Fame' validation testing numbers were not as expected
16:02:02 <cmurf> I *knew* I was supposed to be on the top of that list!
16:02:08 <adamw> cmurf: :P
16:02:10 <coremodule> Particularly it was lacking the nightly-validation test stats.
16:02:13 <kparal> that have to be collected immediatelly after the testing period. if they are collected later, they're off
16:02:14 <cmurf> Haha
16:02:14 <adamw> it basically comes down to how we tweaked the validation test cycle with F24, so there are nightly validation events throughout the cycle and far fewer TCs / RCs
16:02:24 <adamw> kparal: nah, it's not that
16:02:48 <adamw> the way the user-stats code worked if you asked for the '24 Alpha' numbers it only considers pages with '24' and 'Alpha' in the names
16:03:08 <adamw> so it did not include nightly events that were within the Alpha timeframe
16:03:11 <adamw> ditto Beta and Final
16:03:30 <adamw> so the numbers were only including the validation events for 'candidate' composes, the ones like Beta-1.2 and RC-1.3 and so on...it wasn't including any of the nightly events at all
16:03:36 <kparal> I see
16:03:57 <adamw> for F23 and earlier this wasn't really an issue as we only did nightlies before Alpha TC1, so for F23's blog posts I just added one table for the pre-Alpha nightlies
16:04:26 <adamw> but we can't do that any more for F24+ because we have nightly events throughout the cycle now. so i tweaked relval so you can give it just a release number and a date range, now, and it'll consider all events for that release in that date range
16:04:37 <cmurf> adamw++
16:04:38 <adamw> that should let coremodule re-do the blog posts better
16:04:40 <cmurf> kparal++
16:05:15 <cmurf> wth am I out of cookies to give?
16:05:18 <adamw> so as coremodule said...expected revised/updated numbers soon :)
16:05:23 <coremodule> I've emailed jflory7 about getting the published blogposts amended and will make sure that all of the future posts use the new relval.
16:05:28 <adamw> cmurf: you can cookie any person only once per cycle iirc
16:05:40 <kparal> I didn't know
16:06:04 <coremodule> Yes! And expect a HoF post on F25 Beta to be submitted for publishing sometime today or tomorrow.
16:06:27 <adamw> this will mean that you can't really compare the numbers sensibly between <24 and >=24 releases
16:06:33 <cmurf> adamw: that puts a serious damper on my most recent conspiracy plans
16:06:43 <adamw> but we can at least acknowledge people properly :)
16:07:40 <adamw> #info there were some issues with the Fedora 24 and 25 'Hall of Fame' blog post statistics, coremodule will be revising those soon
16:07:47 <adamw> alrighty, any other open floor business?
16:09:09 <cmurf> change Beta to Final, and ship it?
16:09:17 <adamw> +1
16:09:19 <cmurf> haha
16:09:21 <adamw> SS SHIPIT
16:09:25 <cmurf> yes!
16:09:28 * adamw sets the fuse again
16:10:41 <adamw> thanks for coming, folks
16:10:43 <adamw> #endmeeting