fedora_docs
LOGS
14:01:56 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:56 <zodbot> Meeting started Mon Oct  3 14:01:56 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:56 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:01:56 <randomuser> #meetingname Fedora Docs
14:01:56 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:56 <randomuser> #topic Roll Call
14:02:24 * zoglesby is kinda sorta here
14:02:51 * grundblom here(ish)
14:03:12 * pbokoc 
14:03:34 * shaunm quack
14:03:51 <grundblom> fire alarm
14:03:53 <grundblom> gotta go
14:03:59 <pingou> g'd luck
14:04:10 <pbokoc> hah
14:06:14 <randomuser> #topic New Writers
14:06:26 <randomuser> Any new folks around?
14:06:42 <randomuser> or lurkers that would like to say hello, perhaps?
14:09:41 * randomuser presumes not
14:09:53 <randomuser> #topic Where are with the Release Cycle and Docs?
14:10:09 <randomuser> #link https://fedorapeople.org/groups/schedule/f-25/f-25-docs-tasks.html
14:10:47 <randomuser> there's still release notes stuff, and books to update
14:11:17 <pbokoc> I got one red hatter to take 3 changes, but I still haven't done anything myself
14:11:23 <randomuser> #action randomuser to do lots of relnotes stuff
14:11:48 * randomuser notes ctl+w does not work like that here
14:12:25 <randomuser> Beta release notes should be published next monday
14:13:02 <randomuser> there's usually not a lot of changes post-beta, only a handful of discoveries to add, so knocking it out this week would get us nicely back on schedule
14:13:35 <pbokoc> we should probably talk about branching. Since grundblom already did a ton of work on f25 and branched it off of f24, I'd say we could just keep using that
14:13:44 <randomuser> there's also a release announcement thing
14:13:55 <randomuser> pbokoc, right, i was supposed to deal with that...
14:13:55 <pbokoc> it doesn't really matter if it's branched off master or the previous release as long as we clean up old content properly
14:14:09 <pbokoc> randomuser, yeah, and I'm saying don't bother :)
14:14:13 <randomuser> heh
14:14:22 <randomuser> it has to be bothered with one way or another
14:14:53 <pbokoc> eh, I can go through everything and clean it up
14:15:21 <pbokoc> oh also, cspicer is still sick and probably will be all week so I guess I'll handle installer relnotes this time
14:15:28 <randomuser> while we're on the subject, if you've been following fedoramagazine.org, you might have noticed that they're coming up with a ton of documentation and such about things in the upcoming release
14:15:33 <randomuser> pbokoc++
14:16:00 <pbokoc> oh?
14:16:55 <randomuser> https://fedoramagazine.org/whats-new-389-directory-server-1-3-5/ for example
14:17:05 * randomuser shrugs
14:17:43 <randomuser> or https://fedoramagazine.org/gnome-3-22-released/
14:17:55 <randomuser> stuff we can link to for further details
14:18:34 <pbokoc> oh yeah, I was thinking we should have a section on gnome, even if it's not in changes
14:18:50 <pbokoc> brb 5 minutes
14:19:22 <randomuser> the last few releases, i've gone over upstream release notes and pulled in interesting bits
14:20:17 <randomuser> #link https://pagure.io/release-notes/issues
14:20:26 <randomuser> #info track release notes needs at pagure
14:20:49 <pbokoc> alright, let's see if my DM crashes again when I dock
14:22:09 <pkovar> btw, its interesting to see https://fedoramagazine.org/gnome-3-22-released/ not mentioning wayland
14:22:29 <randomuser> indeed
14:22:52 <randomuser> we really should have some solid wayland info for our users, but I don't know much about it
14:23:38 <randomuser> besides the fact that I expect tons of compatibility and usability complaints from users with low graphics performance, or users with proprietary drivers
14:24:28 <randomuser> #info wayland content needed
14:24:37 <randomuser> #topic Specific Doc Status
14:24:51 <randomuser> we haven't had much to say lately in this section
14:25:23 <randomuser> and afaik, there haven't been many disruptive changes in the scope of our books, so that's probably ok
14:26:00 <randomuser> systemd changes are likely to be the most impacting
14:27:03 <pkovar> btw, there's one publish req from fr team, https://pagure.io/docs-fp-o/issue/28, i do not have time to work on it this week otherwise i would take it
14:27:28 <randomuser> I can probably work on that
14:27:35 <randomuser> will take assignment as I start
14:28:11 <pkovar> do you know the black magic behind updating docsite-publican, randomuser?
14:28:15 <pkovar> i don't
14:28:20 <grundblom> back, firealarm over
14:28:22 <randomuser> pkovar, O
14:28:24 <randomuser> ahem
14:28:39 <randomuser> I've done it before, and have upstream commits... we'll see
14:28:59 <pkovar> okay
14:29:15 <pkovar> (also, why is pagure so slow?)
14:29:28 <randomuser> seems fine here
14:30:56 <randomuser> #topic Outstanding BZ Tickets
14:31:00 <randomuser> #info All Bugs - http://tinyurl.com/lbrq84
14:31:15 <randomuser> zoglesby, you were working on something to aggregate pagure issues, iirc?
14:32:10 <zoglesby> I wrote the script, we just need to set it up to run automatically and put the html on something.
14:32:28 <randomuser> can you open an issue for it?
14:32:41 <zoglesby> sure, on what project?
14:32:55 <randomuser> hm.. docs.fp.o i suppose
14:33:02 <zoglesby> Okay
14:34:24 <randomuser> thanks
14:34:45 <randomuser> #topic Open floor discussion
14:35:06 <randomuser> what else is on your mind?
14:36:37 <grundblom> Hi everyone, I missed a lot due to the fire alarm... but I wanted to ask, do we work in the f25 branch or master branch
14:37:34 <randomuser> grundblom, work where you've been working.  Ideally we would clear the old content out of the master branch before adding new stuff, but since you've already jumped ahead we've decided to go with it.  pbokoc intends to delete the old content from the files.
14:38:07 <grundblom> randomuser roger that f25 it is
14:38:42 <pbokoc> grargh I hate IRC
14:38:58 <randomuser> grundblom, awesome work on the release notes, btw
14:39:15 <pbokoc> yeah, good job grundblom!
14:39:25 <grundblom> randomuser thanks! a friend turned me on to mechanical keyboards, and I cant stop myself...
14:39:30 <randomuser> hehe
14:39:38 <grundblom> pbokoc thank you!
14:39:45 <pbokoc> I can relate to that :)
14:39:55 <pbokoc> (he types on his Das Keyboard Model S)
14:40:30 <randomuser> mine is too noisy for work, I should get a brown switch kbd one of these days
14:40:56 <randomuser> also, I don't type all that proficiently and the extra noise would make that painfully obvious :P
14:41:12 <grundblom> pbokoc nice! mine is a used WASD V2 I am hoping to get a new one for my birthday with mx-clears
14:41:26 <pbokoc> screw that, get an IBM Model M - if anyone complains about the racket you can hit them over the head with it
14:41:27 <grundblom> but thank you, I am glad I am helping out!
14:41:40 <randomuser> buckling spring ftw!
14:41:53 <pbokoc> buckling spring and cranial fractures
14:42:22 <grundblom> oh about Wayland Support in f25,
14:42:29 <randomuser> it must be so fun to work with you, pbokoc
14:42:52 <grundblom> I emailed the people on the wiki about Wayland, but they havent gotten back to me, so until they do, I will just leave the blurb I have about it
14:43:07 <randomuser> grundblom, which wiki and people?
14:43:35 <grundblom> I shall find the link, just a second,
14:43:49 <grundblom> https://fedoraproject.org/wiki/Changes/WaylandByDefault
14:43:56 <grundblom> mclasen@redhat.com rstrode@redhat.com ofourdan@redhat.com jadahl@redhat.com mchalupa@redhat.com
14:44:19 <pbokoc> damn, it *is* a change!
14:44:30 <randomuser> grundblom, you might try CCing desktop@lists.fedoraproject.org
14:44:30 <pkovar> might be a better idea asking in #fedora-desktop on gimpnet, grundblom
14:44:51 * randomuser notes this change is still not in https://fedoraproject.org/wiki/Releases/25/ChangeSet
14:45:03 <grundblom> Great ideas, I shall do that
14:45:48 <randomuser> also, this is basically the F24 gdm-session-is-wayland change with the target release edited to be F25
14:46:15 <randomuser> they're recycling the previous release's change page; it isn't in the F25 summary because it is the F24 change
14:46:31 <pbokoc> f23 actually :)) https://fedoraproject.org/w/index.php?title=Changes/WaylandByDefault&oldid=407859
14:46:37 <grundblom> Ah, I was wondering about that, if it was a not accepted change or something...
14:46:55 <randomuser> yeah, all that stuff was done last year
14:47:14 <pbokoc> randomuser, wait, so changes that get moved to the next release don't show up in that release's changeset? I thought they did
14:47:17 <randomuser> for this release, they're changing the default user login session, not just gdm
14:47:42 <randomuser> pbokoc, I'm suggesting that this was handled outside of the normal and expected process
14:49:52 <randomuser> however they've documented it on the wiki, the thing is happening
14:50:52 <randomuser> mclasen, fyi, we were just discussing the change to wayland sessions by default; it looks like you're reusing the f23 change page for gdm-wayland at https://fedoraproject.org/w/index.php?title=Changes/WaylandByDefault without new content?
14:52:11 <randomuser> no, actually, the 'how to test' section does lead one to infer that we're now talking about a login session
14:53:23 <randomuser> any other thoughts for today, folks?
14:54:42 <grundblom> not for me, thanks you all, I have to go to my next meeting
14:54:48 <grundblom> er, thank you all
14:54:52 * grundblom waves
14:55:19 <randomuser> okay, I'm calling it
14:55:29 <randomuser> thanks for coming, all, see you around
14:55:32 <randomuser> #endmeeting