magazine
LOGS
21:00:04 <stickster> #startmeeting Magazine editorial board
21:00:04 <zodbot> Meeting started Thu Sep 29 21:00:04 2016 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:04 <zodbot> The meeting name has been set to 'magazine_editorial_board'
21:00:06 <stickster> #meetingname magazine
21:00:06 <zodbot> The meeting name has been set to 'magazine'
21:00:07 <stickster> #topic Roll callo
21:00:11 <stickster> .hello pfrields
21:00:12 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
21:01:49 <ryanlerch> .hello ryanlerch
21:01:50 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
21:02:41 <ryanlerch> morning stickster
21:03:54 <stickster> hi ryanlerch!
21:04:08 <stickster> jflory7: are you around too?
21:04:22 <jflory7> .hello jflory7
21:04:23 <zodbot> jflory7: jflory7 'Justin W. Flory' <jflory7@gmail.com>
21:04:27 <jflory7> Yes, sorry, I am here :)
21:04:33 <stickster> Oh yay, sorry for pinging you in the other channel just jnow
21:04:36 <stickster> #chair jflory7 ryanlerch
21:04:36 <zodbot> Current chairs: jflory7 ryanlerch stickster
21:04:37 <jflory7> No worries :)
21:04:45 <stickster> #topic Last week roundup (very quick!)
21:04:59 <stickster> #info GREAT stats last week, up to ~49K hits from 36K the week before
21:05:06 <stickster> #info big hit article: GNOME 3.22 release, thank you ryanlerch
21:05:12 <stickster> ryanlerch++
21:05:15 <jflory7> ryanlerch++
21:05:28 <ryanlerch> stickster: yeah, it was a lot more popular than i expected!
21:05:51 <stickster> ryanlerch: I think you skunked a lot of other "news" outlets and got linked
21:06:00 <robyduck> .hello robyduck
21:06:01 <zodbot> robyduck: robyduck 'Robert Mayr' <robyduck@gmail.com>
21:06:04 <stickster> We are #3 in google right behind gnome.org :-)
21:06:08 <stickster> #chair robyduck
21:06:08 <zodbot> Current chairs: jflory7 robyduck ryanlerch stickster
21:06:19 * ryanlerch apologises to robyduck
21:06:33 <robyduck> ?
21:06:38 <stickster> #info September monthly stats beating August, might be able to edge out July, let's see ;-)
21:06:41 <ryanlerch> magazine feed images
21:06:44 <stickster> #topic technical trivia
21:07:10 <robyduck> ryanlerch: no problem
21:07:34 <stickster> #info some weird rss breakage, but I think it's being worked on and fixed shortly
21:07:49 <robyduck> should rebuild right now
21:08:38 <jflory7> Ah, this is for the problem with start.fp.o?
21:08:54 <stickster> yeah
21:08:56 <robyduck> ryanlerch: at least I noticed how many people are using start.fpo and how important it is for us
21:08:59 <jflory7> gotcha
21:09:04 * ryanlerch takes full blame!
21:09:10 <stickster> robyduck: ha, for sure
21:09:26 <robyduck> ryanlerch: no blame, but a cold beer instead? :D
21:09:35 <stickster> ryanlerch: no worries... I'll get my nose out of it and let you guys work it out :-)
21:09:36 <ryanlerch> robyduck: done!
21:09:40 <stickster> beer++
21:09:45 <ryanlerch> beer++
21:09:52 <robyduck> YAY
21:09:58 <ryanlerch> robyduck++
21:09:58 <zodbot> ryanlerch: Karma for robyduck changed to 11 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
21:10:09 <stickster> #info stickster removed [magazine] from mailing list header, since jflory7 agreed on list there were other ways to deal with filtering
21:10:28 <stickster> #info stickster also removed list reply-to header munging which is generally considered evil :-)
21:10:44 <jflory7> robyduck++
21:10:55 <stickster> robyduck++
21:10:58 <stickster> argh, no cookie party today
21:10:59 <jflory7> stickster++ all sounds good to me there.
21:11:06 <robyduck> wow, how many cookies
21:12:02 <stickster> jflory7: Shall we push on to pending review posts?
21:12:09 <jflory7> Yep, sounds good to me!
21:12:35 <stickster> #topic Pending review
21:12:38 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending&post_type=post
21:13:59 <stickster> #info --- Remote file system unlock ---
21:14:05 <stickster> #link https://fedoramagazine.org/?p=14276&preview=1&_ppp=ca86658817
21:14:14 <stickster> #nick linuxmodder
21:14:41 <stickster> linuxmodder: Did you ever get any response from the author on this article? You left some notes on things to address in the article, but it doesn't look touched in a month.
21:16:17 <stickster> Hm, seems no answer
21:16:26 <jflory7> I dropped him a line in Telegram
21:16:31 <jflory7> He might come around a bit later
21:16:45 <stickster> I'll email the author too
21:16:51 <jflory7> Sounds good to me.
21:18:07 <stickster> #action stickster email the author to see about an update
21:18:34 <stickster> #info --- postgresql 9.5 & upgrading ---
21:18:35 <robyduck> is the 'start with python' article ready to go? Seems quite complete
21:18:36 <stickster> #link https://fedoramagazine.org/?p=14181&preview=1&_ppp=60589343e7
21:18:42 <stickster> we'll get there robyduck  :-)
21:18:43 <robyduck> woops, sorry
21:18:46 <stickster> np :-)
21:19:19 <stickster> Has anyone edited this one yet?
21:19:50 <jflory7> I haven't yet - I can't remember if this one was me?
21:20:04 <jflory7> Or was this the one that needed additional material from the author?
21:20:07 * jflory7 is trying to remember...
21:20:22 <ryanlerch> it looks pretty solid
21:20:30 <jflory7> It seems pretty complete now
21:20:31 <jflory7> Yeah
21:20:31 <ryanlerch> just a few copy edits i think
21:20:47 <ryanlerch> and a featured image, which i can oganise today
21:20:47 <robyduck> yes
21:20:50 <jflory7> I think this one could be prepped and ready sometime soon.
21:21:07 <jflory7> ryanlerch++
21:21:20 <stickster> I think just editing for language/style, yeah
21:22:22 <jflory7> Want to give this one a publishing date + editor towards the end? I think we can get it out next week or tomorrow.
21:22:53 <stickster> yeah that sounds good.
21:22:57 <stickster> moving on...
21:23:00 <jflory7> Yup!
21:23:09 <stickster> #info --- GRUB ---
21:23:12 <stickster> #link https://fedoramagazine.org/?p=14701&preview=1&_ppp=cb3130478d
21:24:35 <jflory7> Seems like a lot of formatting to work with on this one. Also maybe a nicer way to close out the article. Otherwise, it seems good to me at a quick glance
21:24:36 <robyduck> seems half completed to me
21:25:11 <stickster> There's a lot to be technically checked here too, though
21:25:12 <jflory7> I'd like a little more of a wrap-up / conclusion for the dual-boot content
21:25:24 <stickster> Like... can we make sure the instructions for dual booting are correct?
21:25:29 <jflory7> stickster: Yeah, definitely
21:25:48 <jflory7> If I recall now, we actually wanted to get this one technically proofed before spending editing cycles on it, I think
21:26:39 <stickster> jflory7: This article is a perfect example of why I think we need to come together around a more specific startup routine for new writers
21:27:07 <jflory7> I caught some of that discussion in-channel with cprofitt, but I think I lost some lines.
21:27:29 <ryanlerch> yeah, this one is a tough one!
21:28:02 <ryanlerch> also, the value of spending a lot of time on it is pretty low, IMHO
21:28:11 <stickster> ryanlerch: yeah...
21:28:46 <ryanlerch> it might be useful to just turn itinto a "what is GRUB" type artcile, and not instruct how to do dual boots etc
21:28:51 <stickster> jflory7: what I'd suggest is we ask people not to write an article until they either (1) work out a pitch with someone who agrees to edit, or (2) take one of a list of short "how to" topics instead, where there's less to check at one time
21:28:53 <ryanlerch> that can be a minefield
21:29:06 <ryanlerch> stickster++
21:29:12 <stickster> ryanlerch: that might be a good way to go -- nice idea!
21:29:51 * stickster just suggesting that we could better motivate writers & editors with smaller bite size topics, as opposed to random "everything about <topic_X>" articles
21:30:22 <stickster> but we also need to make sure all our list members understand the strategy too, so they don't randomly +1 things resulting in the same issues
21:30:44 * stickster realizes this is a digression and gets off soapbox :-D
21:30:50 <jflory7> Yeah... seems a lot of the time, the pitch step is skipped, which can make it more difficult to reshape articles like this one. We discussed the idea of forming an example article / process for writing articles before, I think. Might be useful to spend the time working on that now to improve the ease of review for future work.
21:31:21 <stickster> jflory7: we have https://fedoramagazine.org/writing-an-article-for-the-fedora-magazine/, and that also points to https://fedoramagazine.org/how-to-structure-your-article/
21:31:36 <jflory7> Oh! The second page is new to me.
21:31:40 <stickster> any improvements would be awesome
21:31:54 <stickster> jflory7: the second is the one I wrote at Flock, and it's now linked from the first noe
21:32:05 <stickster> (the latter part I had forgotten to do until someone reminded me today)
21:32:08 <jflory7> Will take a look but I'll take a bet it's pretty solid as-is
21:33:09 <stickster> so back to this GRUB article... should we chop out the dual boot stuff and use what's left?
21:33:27 <jflory7> I think that's fair
21:33:53 <stickster> jflory7: do you want to take on editing this one?
21:34:12 <jflory7> Yes, if we aim for a Wednesday or Friday publication for this one, I can take it.
21:34:24 <stickster> Wednesday++
21:34:28 <jflory7> Wednesday++
21:34:39 <jflory7> Works for me.
21:34:46 * jflory7 writes action item
21:34:52 <stickster> :-)
21:35:08 <jflory7> #action jflory7 Review and edit GRUB article based on feedback from 2016-09-29 meeting, create featured image
21:35:30 <jflory7> #agreed Will aim to publish GRUB article on Wednesday, Oct. 5
21:35:37 <jflory7> eof
21:36:04 <stickster> #info --- Starting with Python ---
21:36:06 <stickster> #link https://fedoramagazine.org/?p=14577&preview=1&_ppp=4507697315
21:36:20 <ryanlerch> this one def needs a new featured image
21:36:25 * jflory7 clicks
21:36:34 * ryanlerch can do that too
21:38:12 <stickster> This article I'm torn on... the concept of a getting started with Python article is very appealing, but this one is kind of light on details
21:38:33 <ryanlerch> stickster: i kind of felt the same way
21:39:01 <jflory7> I was also thinking it might be helpful to point to some more specific tools and make recommendations for people getting started. Might be helpful to delve deeper into the side of setting up a workspace with a given editor or IDE
21:39:07 <ryanlerch> it kinda needs more of a Fedora focus too
21:39:10 <stickster> It talks about a list of reading resources, but there's only one book listed
21:39:37 <jflory7> stickster: There's a few books mentioned towards the bottom.
21:39:38 <ryanlerch> like some details about installing python on Fedora
21:39:47 <ryanlerch> and python packages in Fedora
21:39:55 <stickster> Oh, PEBCAK error
21:39:58 <stickster> I see them now
21:40:01 <jflory7> ryanlerch: +1.
21:40:24 <jflory7> ryanlerch: It does mention that Python comes pre-packaged in Fedora, but maybe do the commands anyways just in case people have it removed for whatever reason.
21:40:36 <jflory7> Oh, and distinguish between python2 and python3 being preinstalled by default
21:40:42 <jflory7> That's a question I actually have too
21:40:44 <stickster> or push them toward Python 3 -- because that's where everyone's going
21:40:51 <stickster> I'm not sure all those books cover that
21:40:57 * jflory7 nods
21:40:59 <robyduck> stickster: +1
21:41:23 <stickster> ah, looks like most do
21:42:47 <stickster> So this seems like it needs some refocus then
21:43:20 <jflory7> If the author knows of some more tools and specifics for getting started, we can encourage them to cover some of them. Otherwise, we might need to have some other experienced Pythonistas take a peek
21:43:56 <jflory7> Maybe not a bad idea to poke someone from the Python SIG on this one before we push the article too, regardless - I'm sure they would love to have a look at it to make sure we cover some of the big details for getting started on Python with Fedora.
21:44:04 <jflory7> .fas churchyard
21:44:05 <zodbot> jflory7: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
21:44:30 <stickster> jflory7: yeah, if the article gets rewritten in a way that provides more concrete detail, we could ask someone to look
21:44:38 <ryanlerch> yeah, IMHO, lets move this back to draft, and try to provide some content direction for the post (i.e. summarize some of the comments above) on the list
21:44:49 <jflory7> ryanlerch: +1 for that.
21:45:42 * stickster hits a wrong button and fixes *sigh
21:46:29 <stickster> #info --- Containers with Atomic Host, Ansible, and Cockpit ---
21:46:33 <stickster> #link https://fedoramagazine.org/?p=14729&preview=1&_ppp=194ebcd073
21:47:31 <stickster> OTOH this article is more concrete
21:47:41 <stickster> But could maybe use a bit more in the way of example
21:48:41 <stickster> trishnag wrote this one
21:48:44 <jflory7> Maybe a shorter title too, "Atomic-powered containers with Ansible and Cockpit"
21:48:49 <jflory7> Oh, cool :)
21:48:50 <stickster> agreed!
21:49:09 <ryanlerch> it might be also worth explaining atomic a bit more here
21:49:14 <ryanlerch> it still confuses me
21:49:42 <jflory7> stickster +1 on examples ryanlerch +1 on Atomic background
21:49:49 <jflory7> Other than that, this seems pretty sound to me
21:50:06 <stickster> ryanlerch: agreed on that too
21:50:08 <jflory7> Lots of outside links to the source for the playbooks and other tools used
21:50:21 <robyduck> also because atomic will be the default for F25
21:50:26 <stickster> trishnag: ^^^
21:50:34 <stickster> ryanlerch: jflory7: I pointed trishnag earlier at that "how to structure your article" thing
21:50:43 <stickster> robyduck: for Cloud deliverable yes
21:51:16 <stickster> I'll try and communicate these ideas to her tomorrow
21:51:16 <stickster> #action stickster talk to trishnag about fixes for article scope/coverage
21:51:17 <jflory7> .localtime trishnag
21:51:20 <zodbot> jflory7: The current local time of "trishnag" is: "03:21" (timezone: Asia/Kolkata)
21:51:25 <stickster> ;-)
21:51:31 <jflory7> Little early :)
21:51:37 <jflory7> Should be easy to follow up tomorrow.
21:52:03 <stickster> So where are we on publishing? Do we have anything from Charles for a HDYF?
21:52:16 * robyduck is also leaving, rather late here. See you soon.
21:52:23 <stickster> g'night robyduck and thanks!
21:52:47 <robyduck> thanks ;)
21:53:22 <jflory7> Night, robyduck!
21:53:32 <jflory7> I think it was a work-in-progress on the HDYF
21:53:55 <jflory7> I think it might be safe to say one will be available during next week (maybe in time for Friday)
21:54:50 <stickster> Do we have anything for tomorrow?
21:55:06 <jflory7> I also know devyani7 is working on rewriting the Hubs article to be more of a "what is Hubs?" instead of the setup guide it was before (that was just published on the CommBlog). Hopefully should have that ready in the near future.
21:55:45 <jflory7> For tomorrow, I'm not sure... seems like we just have some bigger ones right now
21:56:22 <stickster> ryanlerch: Would you be able to edit the postgresql article for Monday?
21:56:40 <stickster> then we could have jflory7 edit the reduced-size GRUB article for Wednesday
21:56:50 <stickster> and I could probably take Trishna's article for Friday
21:56:54 <ryanlerch> stickster: yes i can do it today!
21:57:19 <stickster> thanks ryanlerch :-)
21:58:10 <stickster> #info Publishing schedule: Postgresql Monday 10/3 (ryanlerch editing) -- GRUB Wed 10/5 (jflory7 editing) -- Atomic/Ansible/Cockpit Fri 10/7 (stickster editing)
21:58:18 <stickster> oops
21:58:24 <stickster> #undo
21:58:24 <zodbot> Removing item from minutes: INFO by stickster at 21:58:10 : Publishing schedule: Postgresql Monday 10/3 (ryanlerch editing) -- GRUB Wed 10/5 (jflory7 editing) -- Atomic/Ansible/Cockpit Fri 10/7 (stickster editing)
21:58:29 <stickster> #propsed Publishing schedule: Postgresql Monday 10/3 (ryanlerch editing) -- GRUB Wed 10/5 (jflory7 editing) -- Atomic/Ansible/Cockpit Fri 10/7 (stickster editing)
21:58:58 <jflory7> +1
21:59:05 * stickster +1 on his own proposal :-)
21:59:25 <stickster> ryanlerch: ?
21:59:42 <stickster> and if Charles comes through we'll slot something in on Tue or Thu
21:59:59 <jflory7> Sounds like a plan to me.
22:00:08 <stickster> he usually does :-)
22:00:17 <stickster> OK, silence gives consent
22:00:26 <stickster> #agreed Publishing schedule: Postgresql Monday 10/3 (ryanlerch editing) -- GRUB Wed 10/5 (jflory7 editing) -- Atomic/Ansible/Cockpit Fri 10/7 (stickster editing)
22:00:32 <stickster> And that's all for today folks :-)
22:00:34 <stickster> #endmeeting