fedora-qa
LOGS
15:00:25 <adamw> #startmeeting Fedora QA meeting
15:00:25 <zodbot> Meeting started Mon Aug  8 15:00:25 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:25 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:30 <adamw> #meetingname fedora-qa
15:00:30 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:34 <adamw> #topic Roll call
15:00:39 * coremodule is here
15:00:41 * sumantro is here
15:00:42 <adamw> ahoyhoy folks, who's around for qa funtimes?
15:01:20 * cmurf is on pins and needles
15:01:29 * brunowolff is here
15:01:41 <adamw> cmurf: that doesn't sound like a very good prescription
15:01:46 <potty> adamw: me
15:02:03 * potty is here
15:04:07 * garretraziel is almost here
15:05:21 <adamw> garretraziel: here or not here, there is no almost
15:05:22 <adamw> ;)
15:05:29 * kmurarka is here
15:05:37 <adamw> alright, thanks for coming folks, let's see what we have...
15:05:44 * h4xr is here
15:05:45 * yosef7 is here
15:05:47 <adamw> #topic Previous meeting follow-up
15:06:07 * satellit listening
15:06:54 <adamw> hmm, so...
15:07:01 <adamw> "coremodule to consult with adamw about the F24 HoF post when he returns"
15:07:08 <adamw> coremodule: well, here i am =)
15:07:29 * kparal is here
15:07:37 <adamw> what needed consulting about?
15:07:39 <adamw> morning kparal
15:08:25 <coremodule> Sometime back, there was mention of a F24 HoF post, but upon looking, it could not be located.
15:08:34 <coremodule> Is there an ETA on this?
15:08:59 <adamw> yeah, 'this week some time'
15:09:12 <adamw> i only finished the f23 posts relatively recently, i started on the f24 alpha post on friday
15:09:35 <adamw> unless you wanted to do it? :)
15:10:52 <adamw> #action adamw to start Fedora 24 'Heroes of Fedora' posts
15:10:53 <coremodule> adamw, That works for me. Can you add it to the log?
15:11:02 <adamw> timing...
15:11:07 <coremodule> Ha!
15:11:08 <adamw> #undo
15:11:08 <zodbot> Removing item from minutes: ACTION by adamw at 15:10:52 : adamw to start Fedora 24 'Heroes of Fedora' posts
15:11:15 <adamw> #action coremodule to start Fedora 24 'Heroes of Fedora' posts
15:11:20 <coremodule> Whoa, not that.
15:11:27 <coremodule> I'll do it, but I don't know the criteria.
15:11:48 <adamw> #undo
15:11:48 <zodbot> Removing item from minutes: ACTION by adamw at 15:11:15 : coremodule to start Fedora 24 'Heroes of Fedora' posts
15:11:53 <adamw> #action adamw and/or coremodule to start Fedora 24 'Heroes of Fedora' posts
15:11:55 <adamw> how bout that
15:11:56 <adamw> :P
15:11:59 <adamw> i'll mail you
15:12:05 <coremodule> That works! Cool, thanks.
15:12:34 <adamw> #info "coremodule to consult with adamw about the F24 HoF post when he returns" - we discussed it in the meeting, we'll work on the posts this week
15:13:25 <adamw> there's an 'action item' shown as "This will be deferred until adamw returns as satellit was not able to get in touch with the devs needed to submit the pull request.", which i think should have been a #info, and is about the how-to-create-live-cd instructions
15:13:35 <adamw> so, i think i need to follow up with satellit on that
15:13:50 <adamw> #action adamw to check in with satellit on live CD creation instructions next steps
15:14:10 <satellit> I still have not had help with this
15:14:16 <adamw> satellit: yeah, sorry, i went on vacation.
15:14:31 <satellit> np
15:14:50 <adamw> there's also "Will wait until we can get in touch with cmurf to move forward here.", which is about "cmurf to collect replies to blocker notification thread and make a proposal for changes if any"
15:14:59 <adamw> since you're here today, cmurf, where do you think we stand on that?
15:15:24 <cmurf> There weren't really any concerns.
15:15:50 <cmurf> The thread went no where. So it might be a matter of how it was framed. Or it may be that no one really sees a problem.
15:16:16 <cmurf> So my summary is QA folks, in particular adamw, shouldn't feel like they have to chase people down getting status reports on their bugs in order to prevent slips.
15:17:23 <adamw> cmurf: both the replies to the mail were negative, iirc.
15:17:54 <cmurf> I didn't see them as negative so much as "there's no problem here"
15:18:42 <cmurf> There was a general denial that developers need a notification mechanism other than bugzilla emails, or the blocker bug tracker app.
15:19:09 <adamw> yeah, sounds about accurate...
15:19:36 <adamw> let's say the response was basically a big shrug :)
15:19:40 <adamw> so what do you think the next step is?
15:19:43 <cmurf> Had I really thought that baby sitting was going to be in part a QA job description, I likely would have put my foot in my mouth.
15:19:58 <cmurf> Since I didn't do that, I don't think anyone literally expects personal contact from QA about their bugs.
15:20:57 <cmurf> No problem, no next step. Not that I can see anyway.
15:23:10 <adamw> okay. that sounds fine to me, i don't think there's really a huge issue here (the effort of manually contacting people about blockers is not really so big)
15:23:15 <adamw> we can always come back to it if necessary
15:24:15 <adamw> #info on cmurf's blocker notification proposal - as the response to the mail did not suggest developers think there is a problem here, we'll let the issue slide for now, if blocker notification becomes a problem in future we can always come back to it
15:24:40 <adamw> i think that's all the follow up, or am i missing anything?
15:25:49 <cmurf> That's it.
15:26:03 <coremodule> That looks good to me, those were the big ones.
15:26:58 <adamw> alrighty
15:27:15 <adamw> #topic Fedora 25 Alpha/Test Days status
15:27:43 <adamw> so, we have blocker review coming up at the top of the hour
15:28:09 <sumantro> I contacted the change owner of Parallel Debug info , but didnt get a reply yet .
15:28:23 <sumantro> should I contact someone else?
15:28:57 <adamw> sumantro: is anyone else mentioned on the change page or in relevant changelogs or anything?
15:29:11 <sumantro> no just one guy.
15:29:31 <adamw> hmm :/
15:29:42 <sumantro> https://fedoraproject.org/wiki/User:Mjw
15:29:43 <adamw> well if that person doesn't seem responsive, it's probably best to move on to something else
15:30:13 <adamw> we *can* run test days without developer support if it's a sufficiently important topic, but for something like this it's probably not worthwhile if the dev isn't interested
15:30:45 <adamw> #info owner of https://fedoraproject.org/wiki/Changes/ParallelInstallableDebuginfo does not seem interested in our proposal to run a test day so far
15:31:36 <sumantro> Can we run https://fedoraproject.org/wiki/Changes/Replace_UDisks2_by_Storaged as test day?
15:31:46 <sumantro> I can start off contacting the people
15:31:51 <adamw> sumantro: yeah, i think that was on our list of changes to test
15:32:39 <sumantro> Yes ,it is . I will go ahead with mailing the propose change owner for test day
15:33:10 <adamw> #action sumantro to contact owners of https://fedoraproject.org/wiki/Changes/Replace_UDisks2_by_Storaged for potential test day
15:33:41 <adamw> sumantro: did you have any other test day proposals?
15:34:24 <sumantro> No , nothing uptil now. I wanted to start with ParallelDebug info but didn't get any reply
15:34:57 <adamw> ok
15:35:07 <sumantro> I saw one ticket although of an testday on august 25th
15:35:17 <adamw> ah, a test day request?
15:35:34 <sumantro> yes
15:35:42 <adamw> https://fedorahosted.org/fedora-qa/ticket/488
15:35:49 <adamw> it seems pschindl is taking care of that one
15:35:58 <adamw> so it should be fine, you shouldn't need to worry about it...
15:36:12 <sumantro> okay!
15:37:33 <adamw> alrighty, so on general f25 status - we have a few validation tests not yet done for Alpha, so if folks can help with those it'd be great
15:37:45 <adamw> remember https://www.happyassassin.net/testcase_stats/25 is useful for seeing tests which still need covering
15:38:02 <adamw> #info some F25 Alpha validation tests have still not been done or not done recently, so we could improve there
15:38:03 <satellit> I tested in vm's https://fedoraproject.org/wiki/Test_Results:Fedora_25_Branched_20160807.n.0_Installation#Default_boot_and_install
15:38:39 <adamw> #info F25 Alpha freeze is 2016-08-09, IIRC that usually means 00:00 UTC on 2016-08-09, so in ~8 hours
15:39:57 <adamw> i'm not aware of any other issues for f25 besides setting up test days and getting the validation coverage improved, does anyone have anything?
15:40:06 * kparal notes pschindl is on vacation this week
15:40:54 <kparal> btw, jskladan seems to have some troubles running initrd with kickstart included, bug not yet reported
15:41:25 <cmurf> Is wayland by default a feature for F25? Maybe a test day there is warranted?
15:41:40 <adamw> kparal: that is, https://fedoraproject.org/wiki/QA:Testcase_Kickstart_File_Path_Ks_Cfg ?
15:41:45 <adamw> cmurf: hmm, good question.
15:41:59 <adamw> i don't see it in https://fedoraproject.org/wiki/Releases/25/ChangeSet .
15:42:01 * satellit wayland is first in latest live menu
15:42:09 <cmurf> Another one might be the dual headed GPU work for GNOME.
15:42:10 <kparal> adamw: yes, that would be it, but he's running it as part of image_factory for building taskotron images. only f25 and rawhide seem to be affected
15:43:15 <cmurf> https://fedoraproject.org/wiki/Changes/BetterSwitchableGraphicsSupport
15:43:39 <adamw> kparal: ok. i think that's beta or final, right? so not urgent right now, but we should definitely get a bug report in if it's broken...
15:43:47 <kparal> Final, IIRC
15:43:51 <adamw> i also think i meant to openqa-ify that test, but doesn't look like i did it yet :P
15:44:05 <adamw> oh yeah, that's right, it turns out to be an interesting case in openqa test design. anyhow, off topic.
15:44:10 <kparal> yeah, it's a bit difficult, garretraziel says
15:44:34 <cmurf> We'd want to get extra coverage, via a test day, to reduce regressions this might introduce to graphics support.
15:44:42 <adamw> cmurf: good points, can i give you and sumantro an action item to sync up and look at setting up test days for those topics?
15:44:44 <cmurf> Another one for test day, https://fedoraproject.org/wiki/Changes/FedoraMediaWriterAsPrimaryDownloadable
15:45:02 <adamw> cmurf: we did a lot of testing on that one for f24, but we could run it again for sure, wouldn't be too much work
15:45:09 <sumantro> sure! adamw
15:45:35 <sumantro> I am all for both of them !! adamw and cmurf
15:45:44 <cmurf> adamw: Yeah but this invovles Windows and macOS supposedly as official tools, which right now they aren't. And don't really even exist still.
15:45:51 <adamw> cmurf: good point
15:46:10 <cmurf> I'm a bit skeptical it happens for F25, personally.
15:46:15 <adamw> #action cmurf and sumantro to co-ordinate on organizing test days for Wayland-by-default, BetterSwitchableGraphicsSupport and FedoraMediaWriterAsPrimaryDownloadable
15:46:23 <adamw> thanks a lot guys
15:47:44 <adamw> ok, we have another agenda topic and only a bit of time left, so let's move on...
15:47:48 <adamw> #topic New member welcome, sponsorship, another onboarding meeting?
15:48:00 <adamw> so first of all, if there are any new members here today, hi, welcome, and thanks for joining!
15:48:31 <potty> hi adamw. I invited yosef7 here to get know the fedora qa process.
15:48:34 <potty> He is very interested.
15:48:39 <adamw> cool :)
15:48:44 <adamw> hi yosef
15:48:58 <sumantro> hi yosef :)
15:49:04 <yosef7> hi :)
15:49:12 <h4xr> Hello yosef :)
15:49:38 <coremodule> Welcome!
15:49:54 <potty> :)
15:50:02 <adamw> so, i had a couple of topics related to new members: the sponsorship process, and whether we should run another video chat 'onboarding session
15:50:08 <kmurarka> Hi !!
15:50:20 <adamw> hi kmurarka!
15:50:20 <yosef7> Step by step, I want to learn from you
15:50:21 <sumantro> Hi kmurarka! :)
15:50:22 <yosef7> thanks!
15:51:00 <adamw> so i was clearly completely wrong about people not being able to join the list to send self-introduction mails, but having looked at the page again i still think we could make the join process a bit more explicit and have an SOP for sponsors
15:51:03 <adamw> does that sound OK to everyone?
15:51:25 <sumantro> yes :)
15:51:34 <coremodule> Yeah, anything to make it easier to join up.
15:51:40 <potty> yes
15:51:42 <adamw> my thought was basically to make it clear that before you get sponsored we'll need to confirm directly with you that you're a real person and really interested in QA, whether that's by a self-introduction post, IRC, or direct mail
15:51:55 <potty> sounds good
15:52:03 <adamw> and that's what we'd write into QA/Join and the sponsor SOP. if that sounds basically OK, I can draft up the wiki changes and mail them to the list for review
15:52:09 <h4xr> yes, that sounds like a good proposal :)
15:52:34 <sumantro> that sounds perfect !! :)
15:53:00 <sumantro> We can also re-run the video onboarding call
15:53:10 <sumantro> with the new people
15:53:55 <kmurarka> yes, video call would be nice too  !
15:54:54 <adamw> alrighty
15:55:08 <sumantro> adamw , I'll create a doodle and set up the timings somewhere 22nd-26th week of this month!
15:55:23 <adamw> #action adamw to draft clarifications on joining process for QA/Join page, and a new sponsorship SOP for sponsors, and send drafts to test@ for review
15:55:28 <adamw> sumantro: sounds awesome
15:55:35 <adamw> #action sumantro to schedule another run of the onboarding meeting
15:55:52 <adamw> sumantro: it'd be good if we can figure out how to avoid the 10 person limit this time, somehow
15:56:56 <adamw> alrighty, we're running out of time :P
15:56:58 <adamw> #topic Open floor
15:56:58 <sumantro> Yes, I am in lookout for tried and tested alternative which we can implement without much hassle
15:57:09 <adamw> sumantro: cool
15:57:18 <adamw> does anyone have anything else which urgently needs discussing?
15:58:14 <adamw> ok, in that case, everyone grab a quick coffee then head over to #fedora-blocker-review for the blocker review meeting :P
15:58:29 <coremodule> See you there!
15:58:32 <adamw> we'll be starting that meeting in 2 minutes, but i'll leave the roll call open for a bit so everyone can take a break
15:58:45 <adamw> thanks for coming, everyone!
15:59:24 <adamw> #endmeeting