fesco
LOGS
16:01:03 <sgallagh> #startmeeting FESCO (2016-06-17)
16:01:03 <zodbot> Meeting started Fri Jun 17 16:01:03 2016 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:03 <zodbot> The meeting name has been set to 'fesco_(2016-06-17)'
16:01:03 <sgallagh> #meetingname fesco
16:01:03 <zodbot> The meeting name has been set to 'fesco'
16:01:03 <sgallagh> #chair maxamillion dgilmore number80 jwb nirik paragan jsmith kalev sgallagh
16:01:03 <sgallagh> #topic init process
16:01:03 <zodbot> Current chairs: dgilmore jsmith jwb kalev maxamillion nirik number80 paragan sgallagh
16:01:08 <maxamillion> .hello maxamillion
16:01:09 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:01:11 <number80> .hello hguemar
16:01:12 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
16:01:14 <nirik> .hello kevin
16:01:15 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
16:01:18 <sgallagh> .hello sgallagh
16:01:20 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:01:54 <paragan> .hello pnemade
16:01:55 <zodbot> paragan: pnemade 'Parag Nemade' <pnemade@redhat.com>
16:02:34 <jsmith`> .hello jsmith
16:02:35 <zodbot> jsmith`: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:03:54 <sgallagh> Should be a short meeting this week, I hope. Only two topics on the agenda.
16:03:59 <maxamillion> +1
16:04:03 * maxamillion does like short meetings
16:04:08 <sgallagh> First a follow-up from last week:
16:04:09 <sgallagh> #topic #1576 - Evaluate Workstation graphical upgrade Change status
16:04:10 <sgallagh> .fesco 1576
16:04:12 <zodbot> sgallagh: #1576 (Evaluate Workstation graphical upgrade Change status) – FESCo - https://fedorahosted.org/fesco/ticket/1576
16:04:39 <sgallagh> So the Magazine article announcing this is out.
16:05:23 * paragan goes to check it
16:05:39 <sgallagh> I was hoping kalev would be here.
16:06:05 <sgallagh> I heard that the latest builds of g-s have the last two issues fixed, but they haven't been queued for updates-testing yet
16:06:53 <number80> g-s package changelog doesn't have much on that :/
16:07:21 <sgallagh> number80: Sorry, I meant upstream. I don't think the fixes have been built in Fedora yet.
16:07:31 <sgallagh> adamw: You've been following this, do you have more information?
16:07:36 <number80> ack
16:07:50 <paragan> the tracker bug still have some bugs in NEW state -> https://bugzilla.redhat.com/showdependencytree.cgi?id=1308538&hide_resolved=1
16:09:22 <maxamillion> this whole thing kind of makes me nervous
16:09:28 * jsmith too
16:10:06 <sgallagh> Well, we have to rip the band-aid off at some point. If we don't do it now, it's going to land in F24->F25
16:10:15 <number80> *nods*
16:10:18 <sgallagh> (Without real-world testing)
16:10:39 <jsmith> sgallagh: I think there on some bugs on that list that are worrisome, such as    1335458
16:10:40 * nirik doesn't think there's much for us to do. Hopefully those fixes land and things look good
16:10:56 <sgallagh> Anyway, we don't have the right people here, so I propose we just trust that the people involved will land it in F23 when it's ready and not before.
16:11:31 <jsmith> sgallagh: +1
16:11:47 * jsmith is also really worried about bug    1336530, for the record
16:12:01 <number80> jsmith: hasn't 1335458 passed QA?
16:12:04 * nirik has really slow net to bugzilla, so can't really see
16:12:40 <jsmith> 1336503 is "Update doesn't warn of packages that will be erased"
16:13:04 <jsmith> 1335458 is "system upgrade can be triggered without admin password"
16:13:30 <sgallagh> 1335458 is fixed and VERIFIED.
16:14:13 <sgallagh> OK, so I think the real question here is what criteria should be used before we permit this to go to the stable F23 repo.
16:14:45 <paragan> wait for all the bugs to be resolved?
16:14:48 <sgallagh> Proposal: FESCo requires a GO decision from two established members of the QA team.
16:14:53 * nirik trusts maintainers and qa
16:14:59 <number80> upgrades should either fail early or result in a working system
16:15:06 * paragan too trusts QA team
16:15:08 <jsmith> sgallagh: +1 to that proposal
16:15:13 <sgallagh> number80: I'm willing to trust that the QA team agrees :)
16:15:15 <maxamillion> +1 to sgallagh's proposal
16:15:20 <nirik> if we wait until all bugs are fixed it will never be released. ;)
16:15:22 <number80> +1 to sgallagh proposal
16:15:45 <paragan> +1 to sgallagh proposal
16:15:55 <sgallagh> +1 to my own proposal, for the record.
16:16:27 <nirik> I guess +1, but that seems a bit formal... I would think normal karma would apply
16:17:31 <sgallagh> nirik: Well, I think in this specific case we want people like adamw or kparal to have the final say, just because they have a wider knoweldgebase to judge from than the average FAS account holder
16:18:11 <jsmith> (or the average FESCo member) :-p
16:18:51 <sgallagh> jsmith: Well, I'd hope that's not the case, but I was thinking this is the sort of decision best made by a Field Marshall than a Major General. :)
16:19:25 <jsmith> sgallagh: That was the point my humor was trying to convey :-p
16:19:31 <sgallagh> Anyway, I count +6. Anyone want to contradict?
16:20:10 <sgallagh> #agreed FESCo requires a GO decision from two established members of the QA team. (+6, 0, -0)
16:20:15 <sgallagh> #topic #1587 - Policy regarding packaging when upstream has chosen inappropriate name for package
16:20:15 <sgallagh> .fesco 1587
16:20:17 <zodbot> sgallagh: #1587 (Policy regarding packaging when upstream has chosen inappropriate name for package) – FESCo - https://fedorahosted.org/fesco/ticket/1587
16:20:32 <sgallagh> I'm  going to try to sound-bite my proposal in the ticket. One moment.
16:21:20 <sgallagh> Proposal: Packagers are permitted to change the package name if they feel it is offensive, but must include appropriate Provides: for the original name as well as a justification in the spec file comments.
16:21:52 <number80> well, I'm not found of this as what happens when co-maintainers disagree?
16:22:08 <tibbs|w> There's something offensive there?
16:22:25 <sgallagh> number80: Disagreements like that always make their way to FESCo eventually.
16:22:52 <sgallagh> tibbs|w: I'd prefer to stay out of making a judgement on that and just address the broader question.
16:23:29 * jsmith wishes bugzilla weren't being so slow today
16:23:31 <number80> well, I'd prefer avoiding renaming or it must be definitive
16:24:14 <number80> +0 to the proposal (w/o the Provides part, it would have been -1)
16:24:52 <tibbs|w> The naming guidelines say this: "Package names should be in lower case and use dashes in preference to underscores. You can take some cues from the name of the upstream tarball, the project name from which this software came, and the name which has been used for this package by other distributions/packagers in the past. You can also request guidance from the upstream developers. Do not just blindly follow those examples, however, as package names
16:24:53 <tibbs|w> should strive to be consistent within Fedora more than consistent between distributions. "
16:25:57 <maxamillion> yeah, the more I think about it the more +1 I am ...
16:26:00 <maxamillion> I'm going to go with it
16:26:04 <maxamillion> +1 to sgallagh's proposal
16:26:08 <tibbs|w> So there's already room for packagers to make reasonable decisions.  I personally don't see any reason to bring anything else into it.
16:26:26 <maxamillion> disputes between maintainers/co-maintainers will likely make it to FESCo to resolve
16:26:52 <number80> Yeah, but it means renaming packages for no other reasons than personal feelings
16:27:07 <sgallagh> tibbs|w: Yeah, I don't think this is necessarily changing policy, but it's more clear.
16:27:17 <number80> renames due to upstream offensive names should be definitive or should not happen
16:27:19 <tibbs|w> We should just trust our packagers.
16:27:26 <sgallagh> number80: There's also nothing stopping the maintainer from just forking the upstream project, renaming it and packaging that version.
16:27:29 <jsmith> number80: There's a difference between "personal feelings" and something that's more generally offensive
16:27:30 <sgallagh> This is just more expedient
16:27:32 <tibbs|w> That section was chosen to try and avoid this kind of crap.
16:27:41 <number80> sgallagh: it'll be treated as a fork then
16:27:59 <tibbs|w> Rather, the wording of that section was chosen to try and avoid this.
16:28:24 <number80> jsmith: well, the examples given are of a bad taste but depending if you're a western european or a bible-belt american, you may have a different opinion :)
16:29:04 <sgallagh> number80: Which is why I don't want FESCo in the middle of that quagmire.
16:29:11 <number80> ack
16:29:15 <sgallagh> I'm perfectly comfortable letting the person *doing the work* make that call
16:29:23 <sgallagh> And granting them that leeway.
16:29:36 <tibbs|w> sgallagh: We already do that.
16:29:39 <number80> well, I'm not blocking since we have Provides: <original name> which is a good compromise
16:29:47 <jsmith> I guess I'm +1 to sgallagh's proposal -- seems like a balanced approach to me
16:29:48 <maxamillion> number80: +1
16:30:54 <sgallagh> I count (+3, 1, -0) at the moment (including my implicit +1)
16:31:06 <paragan> I agree to what number80 said above
16:31:24 <number80> paragan: are you +1 sgallagh proposal or +0?
16:31:30 <paragan> +0
16:31:34 <number80> (let's make it easier to count)
16:32:02 * nirik isnt' sure it's really needed above what we have in the naming guidelines... is that unclear?
16:32:08 <sgallagh> tibbs|w: I get that you feel that we already do that. The text is unfortunately ambiguous enough to have prompted this ticket, ergo I offer a clarification and a mitigation (with the Provides)
16:32:25 <tibbs|w> All text is ambiguous enough to prompt some complaint.
16:32:35 <number80> well, I agree w/ tibbs on that point
16:32:48 <tibbs|w> At some point we have to stop adding things just to placate someone who has decided that they don't like something.
16:33:29 <nirik> so, do we need the 'if they feel it is offensive' in the proposal? or is it just as good without it?
16:33:33 <sgallagh> Let me add to this that there *are* other concerns here. Unfortunately, whenever "offense" comes up, the offended party is often ridiculed for it. This is providing at least some high-level air-cover that they are justified in their action
16:33:36 <tibbs|w> And this isn't just about people not liking a name.  Someone likes to use 5 space tabs, and it caused an argument not much different from this one.  But we didn't add a special rule for it.
16:35:22 <tibbs|w> At some point all of these disputes come down to a case by case analysis.  Those will get to FPC, FESCo and eventually the Council.
16:35:37 <sgallagh> Well, we can't actually approve this proposal at this point. There are two abstentions and nirik is the only person present who has not yet voted, so it won't sway the decision
16:36:26 <tibbs|w> No reason not to at least say my piece, assuming anyone is inclined to listen.
16:36:53 <nirik> so, punt to next week then?
16:36:55 <sgallagh> nirik: Shall I count you as 0 for now?
16:37:06 <nirik> I guess so.
16:37:16 <number80> tibbs|w: and you're welcome to do so, I think that you have a point about guidelines inflation
16:37:19 <sgallagh> tibbs|w: It's appreciated
16:37:41 <sgallagh> (I may not agree, but if two people always agree, one of them is redundant)
16:37:51 <sgallagh> #info Proposal did not gather sufficient support from present members (+3, 3, 0)
16:38:00 <tibbs|w> Now, there is one thing which is basically unwritten in the guidelines which should probably be written in the guidelines explicitly which might cover this issue.
16:38:27 <sgallagh> #info The existing naming guidelines provide some leeway for the choosing of the name. It is *recommended* to remain close to upstream, but this is not required.
16:38:30 <jsmith> tibbs|w: What's that?
16:38:36 * number80 reads
16:39:19 <tibbs|w> Which is basically "These are guidelines.  For the good of Fedora, we really want packages to follow them, but they cannot cover all situations.  If your package has a valid reason to not follow a particular guideline...."
16:39:25 <tibbs|w> And something else I hadn't written.
16:39:53 <sgallagh> tibbs|w: I'd be concerned about how that would affect the review process.
16:40:07 <tibbs|w> But basically, if you have to break a guideline for some reason, pl.ease think hard about not breaking it, and then document explicitly how and why you did so.
16:40:08 <sgallagh> Or would we have to split things into MUST and SHOULD sections of the guidelines?
16:40:16 <tibbs|w> We already do, basically.
16:40:23 <sgallagh> tibbs|w: The Terry Pratchett Rule about Rules?
16:40:25 <tibbs|w> But even the MUST bits get broken from time to tome.
16:40:41 <tibbs|w> And this has basically been part of the review process since the beginning of time.
16:40:47 <sgallagh> /me nods
16:41:18 <tibbs|w> There are explicit places where we say that something is only to be "violated" if you have some committee approval.
16:41:23 <sgallagh> I'd be okay with a blanket "If for any reason you feel that one of these guidelines should not apply in your case, document the reason in the spec file"
16:41:49 <tibbs|w> I've been meaning to move something like that through FPC for a long time.
16:42:08 <tibbs|w> I can open a ticket, link it through to the FESCo one, give a draft, and see if that ameliorates the original concern.
16:42:41 <tibbs|w> But nowhere in the current "dispute" is any indication that the packager actually has an issue with the name as far as I can see.
16:42:53 <tibbs|w> And I suspect that if they did, they would have chosen another name already.
16:43:20 <paragan> tibbs|w, that will be helpful to open FPC ticket and discuss
16:44:31 <tibbs|w> I'll add that to my list.  My FPC to-do list is sufficiently massive at this point that one more item won't hurt.
16:44:46 <sgallagh> tibbs|w: Thanks
16:44:48 <tibbs|w> I'm sure FESCo has other items on the agenda so I'll shut up now.
16:44:50 <paragan> tibbs|w, thanks
16:45:18 <sgallagh> #action tibbs|w to look into a clarifying statement
16:45:25 <sgallagh> #topic Next week's chair
16:45:39 <sgallagh> /me pulls the pin and tosses the grenade into the air.
16:45:41 <sgallagh> Catch!
16:47:09 <sgallagh> *crickets chirp*
16:47:48 <number80> I can do it
16:48:03 <sgallagh> #info number80 to chair next week's meeting.
16:48:08 <sgallagh> #topic Open Floor
16:48:24 * jsmith has nothing further
16:48:27 <sgallagh> I thought of one topic during the meeting: When does the next FESCo election start?
16:48:34 <sgallagh> (Since we are now Go for F24)
16:49:18 <adamw> sgallagh: sorry, i missed the discussion earlier, was that the graphical upgrade stuff?
16:49:36 <sgallagh> adamw: Yes
16:49:40 <adamw> sgallagh: we did actually come up with a list of 'release blocking' bugs but i think i forgot to put it in the ticket, sorry about that
16:49:46 <adamw> kparal is on PTO atm but i'll dig the list out and put it there
16:49:58 <number80> thanks
16:50:05 <sgallagh> adamw: We settled on having two established Fedora QA people assert GO as the gating factor.
16:50:15 <adamw> the one that jumped out at me yesterday is the slowness bug
16:50:16 <sgallagh> So however you want to make that decision.
16:50:23 <adamw> i'd seen the report but i hadn't actually experienced it, and it is *really* slow
16:50:36 <adamw> i tried to use it to upgrade my f23 laptop and the download process ran for like 2.5 hours then failed
16:50:39 <sgallagh> (Realistically, we expect that to mean you and kparal agreeing that it's ready for stable)
16:50:54 <adamw> dnf system-upgrade finished the download phase in like 10 minutes (I have a local mirror)
16:51:00 <adamw> yeah, i saw
16:51:08 <adamw> thanks for that, we'll try to be more responsive this week now validation is done
16:51:13 <sgallagh> Thanks
16:51:50 <sgallagh> also, thanks for all the hard work leading to the release (directed at everyone listening)
16:52:28 <paragan> sgallagh, https://fedorapeople.org/groups/schedule/f-24/f-24-elections.html
16:53:08 <sgallagh> paragan: Thanks\
16:54:12 <sgallagh> OK, if nothing else, I'll close out the meeting in 60s
16:55:27 <number80> thanks for chairing sgallagh!
16:55:39 <paragan> sgallagh, Thanks
16:56:02 <sgallagh> #endmeeting