f24-beta-go_no_go-meeting
LOGS
17:00:09 <jkurik> #startmeeting F24 Beta Go/No-Go meeting
17:00:09 <zodbot> Meeting started Thu Apr 28 17:00:09 2016 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:09 <zodbot> The meeting name has been set to 'f24_beta_go/no-go_meeting'
17:00:20 <jkurik> #meetingname F24-Beta-Go_No_Go-meeting
17:00:20 <zodbot> The meeting name has been set to 'f24-beta-go_no_go-meeting'
17:00:28 <jkurik> #topic Roll Call
17:00:35 <jkurik> .hello jkurik
17:00:36 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
17:01:42 <nirik> .hello kevin
17:01:43 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
17:01:45 <adamw> .hello adamwill
17:01:46 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:01:46 <jkurik> adamw, sumantro, nirik, dgilmore, roshi, sgallagh - do we have you here ?
17:01:59 <sgallagh> /me lurks
17:02:20 * dgilmore is kinda here
17:02:21 <jkurik> hi nirik & adamw
17:02:27 <jkurik> hi dgilmore
17:02:46 <jkurik> so we have the key people, lets start
17:03:18 <jkurik> #chair dgilmore adamw nirik sgallagh
17:03:18 <zodbot> Current chairs: adamw dgilmore jkurik nirik sgallagh
17:03:44 <jkurik> #topic Purpose of this meeting
17:03:45 <jkurik> #info Purpose of this meeting is to check whether or not F24 Beta is ready for shipment, according to the release criteria.
17:03:47 <jkurik> #info This is determined in a few ways:
17:03:48 <jkurik> #info No remaining blocker bugs
17:03:50 <jkurik> #info Release candidate compose is available (check https://fedorahosted.org/rel-eng/ticket/6371 )
17:03:51 <jkurik> #info Test matrices for Beta are fully completed
17:04:10 <jkurik> #link https://qa.fedoraproject.org/blockerbugs/milestone/24/beta/buglist
17:04:11 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Summary
17:04:13 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Installation
17:04:14 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Base
17:04:16 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Server
17:04:17 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Cloud
17:04:19 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Desktop
17:04:20 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.1_Security_Lab
17:04:22 <jkurik> #topic Current status
17:04:29 <jkurik> #info We have an major issue with the compose: live images have "Alpha" in their names and volume IDs
17:04:37 <jkurik> #link https://fedorahosted.org/rel-eng/ticket/6405#comment:2
17:04:46 <jkurik> #info We also have some proposed and accepted blockers
17:04:46 <adamw> we also have what looks like a blocker bug, btw
17:04:52 <adamw> ah, you were getting there :)
17:05:06 <jkurik> Before we start, I would propose to vote about one week slip due to the issue with "Alpha" in image names
17:05:10 <dgilmore> waiting on 2 images to complete in koji
17:05:14 <jkurik> I think we do not need to do the Mini-blocker review and Test Matrices coverage if we slip due to the wrong names
17:05:21 <jkurik> Can we agree on this or do we prefere to follow the whole protocol ?
17:05:58 <sgallagh> I feel like the "wrong name" should be proposed as a block bug and we should probably do a mini blocker review
17:06:00 <nirik> well, we basically have no RC, and no testing, so it's pretty clearly no-go to my mind.
17:06:15 <sgallagh> But yeah, it's clear that the outcome is going to be "No Go"
17:06:22 <adamw> sgallagh: i'm really not sure we need to jump through hoops for 'the compose is obviously bloody wrong'
17:06:26 <adamw> i don't mind reviewing the other bits
17:06:27 <nirik> wrong name is likely just an autoblocker... the compose isn't complete enough to be a RC
17:06:55 <sgallagh> /me shrugs.
17:06:57 <adamw> but if you want to do it, the criterion is alpha "Any component which prominently identifies a Fedora release version number, code name or milestone (Alpha, Beta, Final) must do so correctly. " i guess
17:07:13 <jkurik> nirik: yes, that is what I have on my mind
17:07:23 <sgallagh> I don't really care either way; the end result will be the same.
17:07:44 <adamw> let's skip the bureaucracy eh? i know, it's surprising for me to say that ;)
17:07:49 <adamw> i will file a bug to track it, though.
17:07:56 <jkurik> If we slip for one week, the list of blocker bugs as well as the coverage of test matrice will be completelly different
17:08:10 <nirik> yeah, so should we just no-go and go back to work?
17:08:13 <adamw> well, i hope not necessarily, but i take the point.
17:08:25 <adamw> nirik: +1 that
17:08:45 <adamw> it would be good to have votes on https://bugzilla.redhat.com/show_bug.cgi?id=1331317 and the new bug once i file it
17:09:26 <jkurik> #info lets skip the Mini-blocker review and Test Matrices as the wrong names leads us to a situation we do not have a valid RC
17:09:49 <jkurik> #topic Go/No-Go decision
17:10:32 <adamw> QA votes no-go on the basis that the naming issue is obviously a blocker and test coverage is not quite complete
17:10:32 <sgallagh> /me votes "No Go"
17:10:33 <nirik> Pretty clearly no go. No RC, no testing, do not pass go, do not collect $200.
17:10:59 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1331504 is the naming bug, vote away.
17:11:11 <jkurik> proposed #agreed due to the issue with having "Alpha" in filenames of some F24-Beta images, we do not have valid RC compose and the decision is No-Go
17:11:38 <nirik> ack
17:11:39 <adamw> ack
17:11:57 <nb> +1
17:11:59 <jkurik> dgilmore: may I ask you for your vote please ?
17:12:51 <adamw> jkurik: nirik's vote counts for releng i believe
17:13:08 <adamw> oh, but dgilmore just showed up
17:14:13 <jkurik> ok, so we have ack from FESCo (nirik), QA (adamw), Releng (nirik), and me
17:14:24 <sgallagh> Also me, FWIW
17:14:48 <jkurik> #agreed due to the issue with having "Alpha" in filenames of some F24-Beta images, we do not have valid RC compose and the decision is No-Go (+4, 0, 0)
17:14:50 <sgallagh> If you want to mark me as FESCo to not have nirik count double :)
17:15:03 <jkurik> sgallagh: ok, I will
17:15:13 <sgallagh> (I mean, don't get me wrong, nirik is awesome, but he's still just one man!)
17:15:19 <jkurik> :)
17:15:23 <dgilmore> jkurik: no go
17:15:29 <jkurik> ok, thanks
17:15:29 <nirik> don't tell my army of nanobots! :)
17:15:32 <dgilmore> sorry I am in another meeting
17:15:34 <jkurik> #undo
17:15:34 <zodbot> Removing item from minutes: AGREED by jkurik at 17:14:48 : due to the issue with having "Alpha" in filenames of some F24-Beta images, we do not have valid RC compose and the decision is No-Go (+4, 0, 0)
17:15:50 <jkurik> #agreed due to the issue with having "Alpha" in filenames of some F24-Beta images, we do not have valid RC compose and the decision is No-Go (+6, 0, 0)
17:16:06 <jkurik> .. (just fixed the counting)
17:16:47 <jkurik> #info the Beta milestone as well as Final GA milestone will slip for one week
17:17:27 <jkurik> #info The next F24 Beta Go/No-Go metting will be organized the next Thursday at 5PM UTC
17:17:41 <jkurik> #topic Open floor
17:17:50 <dgilmore> jkurik: can we make it 17:30 UTC?
17:17:50 <jkurik> Anything else we need to cover ?
17:18:05 <dgilmore> jkurik: I have a meeting at 17:00 every day
17:18:15 <jkurik> dgilmore: ok
17:18:18 <dgilmore> as does the rest fo Rel eng
17:18:40 <jkurik> adamw, nirik: can we agree on 17:30 UTC the next Thursday ?
17:18:56 <adamw> that's ok for me i think
17:19:01 <nirik> sure. Note that infrastructure meeting is at 18
17:19:08 <jkurik> #undo
17:19:08 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1e936d0>
17:19:12 <jkurik> #undo
17:19:12 <zodbot> Removing item from minutes: INFO by jkurik at 17:17:27 : The next F24 Beta Go/No-Go metting will be organized the next Thursday at 5PM UTC
17:19:20 <nirik> so we might need another channel? or keep it to 30min
17:19:31 <jkurik> #info The next F24 Beta Go/No-Go metting will be organized the next Thursday at 5:30PM UTC
17:19:36 <dgilmore> it should be less that 30 mins right?
17:19:45 <dgilmore> unless we have a lot of bugs
17:19:52 <jkurik> nirik: I will find a free channel
17:20:28 <nirik> ok
17:20:36 <jkurik> #topic Open floor
17:21:00 <jkurik> someone have something to add/discuss ?
17:21:12 <adamw> do we push final?
17:21:28 <nirik> yes?
17:21:37 <sgallagh> adamw: Yes, that's the policy.
17:21:52 <sgallagh> So the schedule on F25 gets a little tighter.
17:21:53 <jkurik> as sgallagh wrote :)
17:21:59 <adamw> well, we didn't push beta after alpha.
17:22:05 <adamw> so i thought it worth bringing up. ;)
17:22:21 <nirik> but in the past we always did. That was a one-off mistake. ;)
17:22:43 <jkurik> nirik: not a mistake, it was intended
17:22:57 <jkurik> nirik: but not approved by FESCo as it should be :(
17:23:07 <nirik> sure.
17:23:35 <jkurik> ok, so I am going to close the meeting ...
17:23:47 <jkurik> #action jkurik to publish the Go/No-Go result
17:24:08 <jkurik> thanks all for comming
17:24:37 <jkurik> we have Readiness meeting in 1,5 hour, so see you there
17:24:47 <jkurik> #endmeeting