g11n_(l10n_focused)
LOGS
08:30:10 <pravins> #startmeeting g11n (l10n focused)
08:30:11 <zodbot> Meeting started Wed Apr  6 08:30:10 2016 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
08:30:11 <zodbot> The meeting name has been set to 'g11n_(l10n_focused)'
08:30:15 <pravins> #meetingname g11n (l10n focused)
08:30:15 <zodbot> The meeting name has been set to 'g11n_(l10n_focused)'
08:30:20 <pravins> #topic agenda and roll call
08:30:21 <pravins> #link https://fedoraproject.org/wiki/G11N/Meetings/2016-04-06
08:30:34 <suanand> hi..
08:30:35 <aeng> hi pravins
08:30:35 <pravins> who available for meeting today? :)
08:30:40 <pravins> hi suanand aeng :)
08:30:43 <pravins> #chair suanand aeng
08:30:43 <zodbot> Current chairs: aeng pravins suanand
08:31:03 <pravins> while other joins lets see upcoming schedule.
08:31:12 <pravins> #topic Upcoming schedule
08:31:12 <pravins> #link https://fedoraproject.org/wiki/Releases/24/Schedule
08:31:19 <pravins> #info 2016-04-19 	Beta Freeze (*)
08:31:20 <pravins> #info 2016-04-19 	Change Checkpoint: 100% Code Complete Deadline
08:31:20 <pravins> #info 2016-05-03 	Beta Release
08:31:20 <pravins> #info 2016-05-24 	Final Freeze (*)
08:31:20 <pravins> #info 2016-06-07 	Fedora 24 Final Release (GA)
08:31:21 <jibecfed_> hi
08:31:27 <pravins> hi jibecfed_ :)
08:31:30 <pravins> #chair jibecfed_
08:31:30 <zodbot> Current chairs: aeng jibecfed_ pravins suanand
08:32:05 <pravins> Beta release happening in couple of weeks. Hoping our translations will get pulled by developers.
08:32:26 <aeng> whats the usual process to notiffy the package maintainer?
08:32:40 <pravins> aeng: good question, even i dont know.
08:32:55 <pravins> but may be send email them on devel@list?
08:32:59 <pravins> paragan: ^^
08:33:05 <epico> hi
08:33:07 <aeng> hmm... perhaps emailing for now? we've got all their email address in Zanata
08:33:19 <aeng> or yeah.. devel@list
08:33:29 <paragan> yes fedora devel list
08:33:32 <pravins> aeng: +1 its important to start pinging them from now.
08:33:53 <pravins> #info Its time to ping devels for pulling translations from Zanata.
08:34:06 <pravins> #topic  New members joined in trans
08:34:11 <pravins> #info Eduardo Silva - joined for portuguese
08:34:12 <pravins> Fas name: hoboprimate
08:34:12 <pravins> #info Eduardo Silva - joined for portuguese
08:34:12 <pravins> Fas name: hoboprimate
08:34:28 <pravins> Translation sprint helped to bring couple and actually more members in translation projects.
08:34:48 <juhp> hi
08:34:54 <aeng> agree. The sudden burst of activity in translation brings interest
08:34:54 <pravins> They already did translation for F24 and i have also awarded badges to them :)
08:34:55 <jibecfed_> +1, can see it in french team too
08:34:58 <pravins> hi juhp :)
08:35:00 <pravins> #chair juhp
08:35:00 <zodbot> Current chairs: aeng jibecfed_ juhp pravins suanand
08:35:30 <pravins> #chair epico paragan
08:35:30 <zodbot> Current chairs: aeng epico jibecfed_ juhp paragan pravins suanand
08:35:45 <aeng> but also, credit to people who organise it and coordinating with them
08:36:17 <pravins> true without local ambassadors, coordinators its difficult to make this happen.
08:36:41 <gnokii> thats the point ;)
08:36:50 <jibecfed_> we should organize a feedback in Flock
08:36:54 <pravins> gnokii: good catch :)
08:37:01 <aeng> +1 jibecfed_
08:37:21 <pravins> #idea jibecfed_ suggested to organize feedback session in flock.
08:37:45 <pravins> lets discuss this further in vFAD topic.
08:37:47 <pravins> moving to next topic.
08:37:48 <pravins> #topic Fedor 24 I18N test day planning
08:37:49 <pravins> #link https://fedorahosted.org/i18n/ticket/60
08:38:07 <pravins> Bit worried for this presently, we have i18n test day on 12th April (coming Tue)
08:38:22 <pravins> and still not much work on Test case cleanup and adding new test cases.
08:38:39 <aeng> who update those test cases
08:38:40 <aeng> ?
08:38:50 <pravins> no dedicated person for it :(
08:38:57 <aeng> QA team?
08:39:00 <pravins> but i requested Satya last week
08:39:11 <pravins> yeah, requested help from FLTG.
08:39:45 <jibecfed_> I can help review to see if I understand it, but can't write them
08:39:51 <pravins> Fedora QA helps in organizing test day, example for created testday app, test day wiki page.
08:40:25 <pravins> how about gathering tomorrow and work on cleanup of test cases?
08:41:06 <pravins> it can be whole day, so one can do it as per his time availability.
08:41:36 <aeng> so all available qa?
08:41:37 <juhp> yeah we really need to have the test-cases updated and ready ASAP
08:41:52 <aeng> perhaps devel should help too
08:41:59 <aeng> at least update existing test cases
08:42:09 <pravins> right, so all i18n devel can help to review and update there test cases.
08:42:17 <juhp> yes
08:42:26 <pravins> We have few regular test cases and we add few as per new features.
08:42:28 <paragan> yeah we all can update/clean test cases
08:42:48 <juhp> I think good to send a reminder to i18n list
08:43:00 <juhp> or direct emails too
08:43:12 <pravins> #link Fedora 23 test day https://fedoraproject.org/wiki/Test_Day:2015-09-01_i18n
08:43:18 <aeng> deve@list agian?
08:43:31 <pravins> juhp: good idea.
08:43:51 <pravins> devel list will be too broader though.
08:44:28 <pravins> #action pravins to send email on i18n and g11n list to cleanup test cases.
08:44:51 <pravins> moving to next topic
08:44:51 <pravins> #topic ZNTA-1009 Redhad translation content is imported into Zanata (wrong display and questionable usage as there is no access to context)
08:44:52 <pravins> #link https://zanata.atlassian.net/browse/ZNTA-1009
08:45:24 <pravins> jibecfed_: added this topic earlier.
08:45:32 <pravins> jibecfed_: would you like to update on issue?
08:45:39 <jibecfed_> I created this bug to understand, but finally I'm opposed to that change
08:45:52 <pravins> aha, aeng already replied on ticket.
08:46:02 <aeng> yup
08:46:05 <jibecfed_> to be usefull, translation memory should link to source and context
08:46:26 <aeng> agree
08:46:34 <aeng> thats something that can be helpful
08:46:41 <jibecfed_> if we can't have this, I don't see the point, it's like a glossary, it's a hint but not a memory
08:47:10 <jibecfed_> so if redhat what to do that, we should be able to go see the context and access to source
08:47:35 <aeng> jibecfed_, its not redhat wants to do that
08:47:53 <aeng> the decision to have redhat tm available is to help out translators with more reference
08:48:13 <aeng> most of the japanese translators find it really useful
08:49:07 <aeng> if translator doesn't agree, they can always ignore the TM, like I mentioned,, perhaps filtering of TM would be useful for those who doesnt want to see that
08:49:20 <pravins> i think this is solvable, so need to check who has uploaded Translation memory, we can ask/request him to open.
08:49:30 <pravins> aeng: right, i remember we discussed on this feature in Tokyo.
08:50:35 <aeng> yeah... we in the process of developing new editor, that is why less effort is putting in into this editor
08:51:04 <jibecfed> (sorry, disconnection)
08:51:38 <jibecfed> last sentence I saw was : jibecfed_:  if it is more consistent with Zanata interface and if we can access to source, it's good, if not ...
08:51:38 <pravins> #info Zanata is in the process of developing new editor. Filtering TM would be available after some time.
08:52:16 <aeng> disconnected again
08:52:54 <pravins> jibecfed: given in PM
08:52:56 <jibecfed> next subject
08:52:56 <pravins> lets work further on ticket you raised. :)
08:53:11 <pravins> #topic Fedor 24 L10N test day planning
08:53:11 <pravins> #link https://fedorahosted.org/G11N/ticket/18
08:53:12 <pravins> #link https://fedorahosted.org/fedora-qa/ticket/480
08:54:17 <pravins> #link http://testdays.fedorainfracloud.org/events/3
08:54:35 <pravins> i hope someone from FLTG will provide report soon.
08:55:36 <pravins> noriko: just in time :)
08:55:47 <aeng> woohoo
08:55:48 <noriko> hi, sorry coming in late. I was caught by traffic jam :`-(
08:55:52 <pravins> Wanted to say, L10N test day went very well. !!
08:56:00 <pravins> with so many participants.
08:56:08 <noriko> yay :-D
08:56:14 <pravins> What should be next steps?
08:56:21 <pravins> i think we need to prepare report soon.
08:57:12 <noriko> we should have separate reports, i18n, l10n, fltg and zanata?
08:57:34 <pravins> umm, last time i wrote article on commblog common for i18n and l10n test day.
08:57:58 <jibecfed> i'll do stats, i'll send it to list this weekend, and with graphics (not only raw data)
08:58:02 <pravins> noriko: what kind reports for zanata and fltg??
08:58:02 <noriko> i18n test and l10n test are definitely and totally different things :-)
08:58:20 <noriko> ask them ?
08:58:51 <aeng> jibecfed, have you got the list of contributors?
08:58:58 <noriko> I can take care of l10n, you pravins should be able to take care i18n, right?
08:59:14 <pravins> yes, definitely.
08:59:39 <pravins> #link Fedora 23 G11N test day article. https://fedoramagazine.org/globalization-test-days-report-fedora-23/
08:59:54 <pravins> we can either have single or different, both are fine with me :)
09:00:18 <pravins> getting report is important, for such a nice event :)
09:00:25 <aeng> yup
09:00:41 <jibecfed> aeng: no, I tried yesterday to find it with Zanata's API, but I didn't find anything to extraction to track changes
09:01:01 <pravins> and we actually jumped to next topic.
09:01:02 <pravins> #topic vFAD for Translations
09:01:02 <pravins> #link https://fedorahosted.org/G11N/ticket/5
09:01:03 <aeng> jibecfed, there's a contributors api for project/version
09:01:27 <jibecfed> aeng: ah ? please share link
09:01:28 <pravins> 500+ heats for our article in commblog
09:01:47 <pravins> #link https://communityblog.fedoraproject.org/translate-fedora-24-in-your-language/
09:02:04 <pravins> Its ranking 4th in overall article in last months. !!
09:02:32 <pravins> #link https://fedoraproject.org/wiki/G11N/vFAD_Translation
09:02:37 <pravins> Operation part went well.
09:02:44 <pravins> now its time for effective closing
09:03:06 <pravins> and that is what aeng and jibecfed discussing now :)
09:04:06 <jibecfed> yep, i wait for aeng's link for API
09:04:14 <pravins> It will be nice if we have list of participants, language and number of words/link they translated.
09:04:23 <pravins> s/link/line
09:05:17 * aeng trying to get the information
09:05:37 <jibecfed> aeng: I use this page to get information : https://zanata.ci.cloudbees.com/job/zanata-api-site/site/zanata-common-api/rest-api-docs/index.html
09:06:02 <pravins> #action aeng and jibecfed will provide stats for Virtual translation sprint window.
09:06:02 <jibecfed> but there is only basics, there is nothing to track changes per contributor
09:06:21 <aeng> ah... its in 3.90
09:06:31 <aeng> https://zanata.atlassian.net/browse/ZNTA-742
09:06:46 <aeng> alright... what I can do... get information from database
09:07:01 <aeng> and query on list of contributors
09:07:14 <aeng> then from there... we can use rest api to get the contribution stats
09:07:33 <aeng> i will get the list of contributors by friday
09:08:02 <pravins> aeng: nice, it will help :)
09:08:18 * aeng noting down to do list
09:08:36 <aeng> pravins, whats the date range?
09:08:43 <pravins> 1-5th april
09:08:51 <aeng> done
09:08:56 <pravins> overall commenting on translation sprint.
09:09:04 <jibecfed> aeng: i'll be pleased to help, please share raw stats with me
09:09:18 <aeng> jibecfed, will do
09:09:28 <pravins> It definitely created awareness in community regarding, there used to Window in Fedora release schedule, where one can contribute for translation
09:09:42 <pravins> i am sure, more contributors will be waiting for next one.
09:10:22 <pravins> We have badge for participants. https://badges.fedoraproject.org/badge/fedora-24-translation-sprint
09:10:25 <aeng> :), good effort guys
09:10:33 <pravins> so if you participated during this time, please ping me for this badge.
09:10:55 <pravins> anyhow i am going to award badge, based on stats provided by aeng and jibecfed :)
09:10:57 <pravins> Thanks aeng
09:11:06 <aeng> :)
09:11:06 <jibecfed> pravins: if aeng extract contributors, would they still have to ping you ?
09:11:18 <jibecfed> ok
09:11:18 <pravins> no.
09:11:31 <pravins> next topic
09:11:32 <pravins> #topic Live media with langpacks included
09:11:32 <pravins> https://fedorahosted.org/G11N/ticket/17
09:11:45 <aeng> i will get all of contributors during this time, and also the total words they contributed
09:12:32 <pravins> excellent !!
09:12:43 <pravins> paragan: thanks for comment in ticket
09:12:59 <jibecfed> about langpacks, there is a major issue
09:13:18 <jibecfed> it works when explicitly installing it with dnf, but not from the livecd
09:13:42 <jibecfed> i think pnemad works on this, but i don't have details
09:14:22 <pravins> right, i also talked with paragan earlier.
09:14:28 <paragan> as commented it will take some time
09:14:36 <pravins> its important issue.
09:14:53 <pravins> paragan: lets add this in i18n test cases, so more people will understand issue.
09:15:15 <pravins> aha, it means we will all face this issue in LiveCD testing :)
09:15:18 <paragan> better not add it otherwise I need to explain everyone
09:15:26 <paragan> same thing again and again
09:15:48 <jibecfed> should we expect it for F24 ? Docs team are making release notes, we should advise them
09:16:15 <pravins> true.
09:16:16 <paragan> I will try my best but the decision is in Server and Workstation WG people
09:16:30 <paragan> whether to add langpacks-\* packages or not
09:16:42 <pravins> Do we have any other ticket which reference this in WG/Server group trac?
09:16:54 <paragan> Server WG don't user trac
09:17:00 <pravins> aha
09:17:01 <paragan> Workstation uses I think
09:17:16 <pravins> just thought good to refer it in our trac ticket.
09:17:27 <paragan> will add it
09:17:33 <paragan> but will other people comment there?
09:18:04 <paragan> anyways will add reference in our ticket
09:18:15 <pravins> i think only if required.
09:18:26 <pravins> thanks paragan for an update, hoping we will get solution during F24 :)
09:18:38 <pravins> moving to next topic
09:18:40 <pravins> #topic [Queries in this week]
09:18:47 <pravins> #info  highlighted letters in menus / shortcuts
09:19:37 <pravins> Richard has already provided answer to it.
09:20:08 <pravins> #info  Choosing branches
09:20:23 <pravins> and noriko has already provided answer for this.
09:20:29 <pravins> aeng: one more query to you.
09:20:56 <aeng> yup
09:21:00 <pravins> If i do translation in f24 branch and try to translate same line in master.... Will i get suggestion/reference from f24 branch?
09:21:26 <pravins> since, i did few translation for f24 branch and wanted to replicate it in master.
09:21:30 <aeng> depends on how the master brnach will be created
09:21:48 <pravins> if i get it in suggestion with 100% match, just need to copy it ;)
09:21:59 <pravins> sure, will try for it.
09:22:10 <aeng> if master is created based on f24 branch (create version feature), then it will have all the history and reference
09:22:54 <pravins> umm, normally we convert master to F24.
09:22:56 <aeng> if master is already there and you wish to merge in translation from f24 branch, then use "merge translations" feature, that will bring all matching and approved/translated across
09:23:16 <pravins> this is what i was looking for :)
09:23:44 <aeng> but yeah.. there are few ways to bring across translations
09:23:48 <pravins> #info One can "merge translations" feature to bring all matching and approved string from master to f24.
09:24:05 <pravins> thanks aeng, may be you can see this thread on trans list. :)
09:24:16 <pravins> "Choosing branches"
09:24:27 <pravins> last topic
09:24:30 <pravins> #topic  Next Meeting Date and Time
09:24:30 <aeng> ok
09:24:39 <pravins> can we have someone to chair next meeting?
09:24:51 <pravins> it should happen on 20th April
09:25:18 <pravins> time i am still not sure but may be regular one 04:30 UTC>
09:25:52 <pravins> let me ask on mailing list again.
09:26:09 <pravins> #action pravins to ask on mailing list for next meeting time and chair.
09:26:20 <pravins> jibecfed: i think 04:30UTC works well for you.
09:27:09 <pravins> moving to next one.
09:27:09 <pravins> #topic Open Floor
09:27:18 <pravins> if nothing else lets close meeting in 2 minutes..
09:27:29 <jibecfed> pravins: sorry disconnected again :(
09:27:39 <jibecfed> i'll read the log
09:27:43 <pravins> no problem, thought so :)
09:27:44 <aeng> :)
09:27:52 <aeng> time to get cable
09:28:06 <pravins> yeah
09:28:12 <pravins> thanks all for nice meeting.
09:28:18 <jibecfed> thanks all
09:28:20 <aeng> thanks pravins
09:28:20 <pravins> #endmeeting