fedora-qa
LOGS
15:01:56 <adamw> #startmeeting Fedora QA meeting
15:01:56 <zodbot> Meeting started Mon Mar 28 15:01:56 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:56 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:02:01 <adamw> #meetingname fedora-qa
15:02:01 <zodbot> The meeting name has been set to 'fedora-qa'
15:02:05 <adamw> #topic Roll call
15:02:15 * tflink is here
15:02:16 <adamw> ahoyhoy folks, who's around for QA meeting funtimes?
15:02:36 * satellit_e listening  have to leave in 1/2 hr
15:03:11 <FQ> hi guys, around here.. new comer
15:03:14 <brunowolff> I'm around this morning.
15:04:55 <adamw> morning FQ! thanks for coming
15:05:02 <adamw> and for volunteering
15:05:35 <FQ> thanks, just for observiing the mail group to see how QA works, and check how to help
15:06:05 <adamw> that's the way to do it :)
15:06:08 <adamw> OK, let's get started!
15:06:14 <adamw> #topic Previous meeting follow-up
15:06:20 <adamw> let's see what I didn't do this week
15:06:53 <adamw> #info "adamw to complete matrix changes for i686 no longer blocking media" - yeah, still didn't do that, but this time i promise I will!
15:07:18 <adamw> #info "adamw to mail out a proposal with a few options for adjusting the release validation process to pungi4's expectations" - OK, that one did happen, and we went with the '1.n' numbering style for the alphas
15:07:21 <adamw> was that OK for everyone?
15:07:52 <satellit_e> works here
15:08:39 <tflink> wfm
15:08:56 <adamw> ok, guess we'll stick with that for Beta
15:09:17 <adamw> i think there's a new anaconda build, so we'll need to either karma it up somehow without doing a candidate, or request a Beta 1.1 soon.
15:10:29 <adamw> "pschindl and pryanka to try and help out with setting up and/or running some of the test days"
15:10:37 <adamw> pschindl didn't check in, right?
15:10:58 <adamw> welp, we have a test day topic later in the meeting so we can take a look at where we stand then
15:11:10 <adamw> #info "pschindl and pryanka to try and help out with setting up and/or running some of the test days" - neither is present ATM, will check in later in the meeting
15:11:28 <adamw> #topic Fedora 24 status, Beta planning
15:11:43 <adamw> so Alpha 1.7 was signed off for release as Alpha
15:11:51 <adamw> #info Alpha 1.7 will be released as Alpha
15:12:11 <adamw> we have quite a chunk of CommonBugs to write up, i'll get that started today (if kparal hasn't already)
15:12:37 <adamw> #action adamw and kparal to work on common bugs
15:13:04 <adamw> satellit just pointed out another bug that might need commonbugs (wifi not working in anaconda)
15:13:19 * satellit_e netinstall
15:13:24 <brunowolff> Are "Labs" going to be skipped for alpha?
15:13:24 <adamw> right
15:13:36 <adamw> brunowolff: some of them were built, I think?
15:14:13 <adamw> brunowolff: at present with every compose some lives fail, more or less randomly - this is due to https://bugzilla.redhat.com/show_bug.cgi?id=1315541
15:15:19 <brunowolff> I need to go to alt/stage, they weren't in any of the recent koji composes I looked at.
15:15:44 <adamw> brunowolff: https://dl.fedoraproject.org/pub/alt/stage/24_Alpha-1.7/Labs/x86_64/iso/
15:16:59 <adamw> looking ahead, Beta freeze is scheduled for 2016-04-19, Go/No-Go for 2016-04-28. so we should be shooting to complete Beta test coverage ASAP and find all the blockers
15:17:25 <adamw> for now Alpha 1.7 is still the current validation testing compose, a new nightly should get nominated soon, or we'll do a Beta 1.1.
15:18:07 <brunowolff> Yeah. I usually checked i686 of which there are none. There are some x86_64 spins. Games got hosed because someone made a change that made it too large which is now fatal, and the compose was pulling from the wrong kickstart, so the attempted fix didn't get pulled in until last week.
15:18:25 <adamw> brunowolff: we turned off build of most i686 images since they're all known not going to work anyway.
15:19:20 <adamw> oh yeah - for anyone who doesn't know about that, https://bugzilla.redhat.com/show_bug.cgi?id=1302071 is the bug for 32-bit kernels not working. we may get some movement on it soon we hope.
15:19:33 <brunowolff> Yeah. it seems random whether kernel builds work on i686. I still am dealing with that.
15:20:25 * satellit_e possibly due to compression errors?
15:20:45 <adamw> satellit: no, that's not it.
15:20:49 <satellit_e> k
15:21:16 <brunowolff> I change to binutils brought to light a kernel issue.
15:21:27 <brunowolff> s/I/A/
15:21:58 <adamw> so, that's more or less what I got; where's everyone else at? any other notes/thoughts/comments on f24 so far?
15:22:37 <brunowolff> Is midori likely to get fixed before beta?
15:22:37 <satellit_e> is the new background the final f24?
15:24:14 <adamw> satellit: i'm not 100% sure but I think it's still subject to change at this point
15:24:23 * adamw digs for the docs
15:24:33 <adamw> brunowolff: i'm sorry, i don't know about that - maybe nirik? nirik, you watching?
15:25:22 <nirik> brunowolff: dunno. upstream is working on the wk2 port, but keep wafflaling about when they are going to release something.
15:25:42 <adamw> satellit: per https://fedoramagazine.org/fedora-24-default-wallpaper-preview-alpha/ - "Typically, the default wallpaper in the alpha release is refined and fine-tuned before the final Fedora release"
15:25:53 <satellit_e> k
15:26:58 <adamw> why do you ask?
15:28:05 <brunowolff> Because midori being replaced affected the size of the games spin and might be what put it over size.
15:28:56 <brunowolff> Assuming Dennis lets me put it back for beta, I may need to make other cuts if Midori isn't working at that time.
15:29:06 <adamw> ah, i see
15:29:18 <adamw> so there's two kinds of being 'too big'
15:29:36 <adamw> the build root size specified in the kickstart not being big enough for all the packages to be installed has always been fatal to the image compose
15:29:52 <adamw> the final image being over the size limit never has been and still isn't
15:30:21 <adamw> for Beta the final image size limits are criteria enforced, but only for release-blocking images
15:30:36 <adamw> for non-blocking images, being over the final image size is just an FE issue
15:30:45 <adamw> (that's all AIUI anyhow)
15:30:48 <brunowolff> For alpha I preferred to keep the games and drop firefox, but the changes to the compose process caused problems getting a fix deployed and may the size issue fatal.
15:31:41 * satellit_e afk
15:31:48 <adamw> ok, well, i think we should be able to do something for beta, dennis should be fine if you're actively working on it i think
15:32:11 <brunowolff> Too big right now causes livemedia to croak. I think only the i686 image was oversize, but this caused a complete failure and the x86_64 image wasn't getting built either.
15:32:22 <brunowolff> A fix for this is planned.
15:33:16 <brunowolff> It didn't help that it took a while to realize that the ks file was getting pulled from the master branch, instead of the f24 branch.
15:33:21 <adamw> it's not "right now" is the point i'm making
15:33:25 <adamw> hmm, that should be fixed too
15:33:32 <adamw> it did the same with livecd-creator too
15:33:33 <adamw> it always has
15:33:52 <nirik> thats already fixed
15:33:59 <adamw> nirik: ah, cool.
15:34:44 <brunowolff> Livecd creater switched to UDF when the squashfs image was over 4 GiB. And the image was usable and it was easy to see how much over it was.
15:35:36 <adamw> anyhow...we don't really have anything to decide here, right?
15:35:43 <brunowolff> It's just a growing pains issue and the Games spin is at that boundry so it hits some things that others don't.
15:35:58 <brunowolff> No. I'm just venting.
15:36:20 <adamw> alrighty
15:36:27 <adamw> welp, moving on for now...
15:36:33 <adamw> #topic Test Days
15:36:44 <adamw> so i've seen some test day mail whizzing by lately but i'm not really on top of where we're at
15:36:47 <adamw> let's have a quick look
15:37:37 <adamw> it looks like l10n Test Day is scheduled for tomorrow, 2016-03-29
15:37:41 <adamw> so, everyone come on out for that
15:37:56 <adamw> Ani was asking for help getting the testdays webapp working; tflink, where are we on that?
15:38:13 <tflink> i  just read the email a little while ago, so nowhere
15:39:01 <tflink> those links need to be updated
15:39:55 <adamw> sorry, i didn't mean where are we in replying to apeter, i meant where are we with the app
15:39:58 <adamw> is it actually up and running?
15:40:16 <tflink> i think so
15:40:57 <adamw> OK, so we should be able to help get that up and running
15:41:12 <tflink> we should, yes
15:41:16 <adamw> i'll sync up with you in #fedora-qa later on that
15:41:31 <adamw> #action adamw and tflink to sort out a reply to apeter about the testdays webapp
15:42:20 <adamw> they also requested a live image from releng and looks like there was a bit of confusion there, but it should be sorted out soon...
15:43:55 <adamw> #info l10n Test Day will be tomorrow, 2016-03-29, please come out and help test if you can!
15:44:04 <adamw> #action adamw to blog / microblog about l10n Test Day
15:44:08 <adamw> (and anyone else who wants to do that)
15:44:23 <adamw> that looks like it for test days right now, which is a bit of a shame, we could do with having some more
15:44:37 <adamw> anyone working on anything there?
15:46:41 <adamw> ok, well then, i  guess that's that :)
15:46:55 <adamw> if anyone's interested in working on or helping out with a test list, please poke me on IRC, or mail the list
15:47:20 <adamw> #topic Open floor
15:47:24 <adamw> anything else goin' on?
15:50:09 <adamw> alrighty then, sounds like we're done
15:50:25 <adamw> we've got blocker review in 10 minutes in #fedora-blocker-review, everyone loves blocker review, right?
15:52:00 <tflink> oh yeah, lots of fun
15:52:32 <adamw> ok, see you all over there :) thanks for coming out
15:52:41 * adamw always expects there'll be more to argue about at meetings, but...
15:52:46 <adamw> #endmeeting