fesco
LOGS
17:00:19 <maxamillion> #startmeeting FESCO (2016-03-11)
17:00:19 <zodbot> Meeting started Fri Mar 11 17:00:19 2016 UTC.  The chair is maxamillion. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:19 <zodbot> The meeting name has been set to 'fesco_(2016-03-11)'
17:00:28 <maxamillion> #meetingname fesco
17:00:28 <zodbot> The meeting name has been set to 'fesco'
17:00:33 <maxamillion> #chair maxamillion dgilmore number80 jwb nirik paragan jsmith kalev sgallagh
17:00:33 <zodbot> Current chairs: dgilmore jsmith jwb kalev maxamillion nirik number80 paragan sgallagh
17:00:38 <maxamillion> #topic init process
17:00:39 <jsmith> .hello jsmith
17:00:40 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
17:00:42 <maxamillion> .hello maxamillion
17:00:43 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:00:44 <kalev> .hello kalev
17:00:46 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
17:00:57 <number80> .hello hguemar
17:00:58 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:01:08 <nirik> morning
17:01:11 <nirik> .hello kevin
17:01:12 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
17:02:05 <sgallagh> .hello sgallagh
17:02:08 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:02:32 <dgilmore> hey
17:02:39 <maxamillion> ok, we have quorum
17:02:53 <jsmith> That's always good :-)
17:02:57 <maxamillion> # topic Follow Up Items
17:03:02 <sgallagh> maxamillion: Can we push the Mozilla discussion to the end? I'm trying to reach them right now
17:03:12 <paragan> .hello pnemade
17:03:12 <maxamillion> sgallagh: certainly
17:03:12 <zodbot> paragan: pnemade 'Parag Nemade' <pnemade@redhat.com>
17:03:51 <maxamillion> #topic Follow Up Items
17:03:54 <maxamillion> spacing matters :)
17:03:59 <maxamillion> #topic #1552 Review of delayed Changes for F24
17:04:04 <maxamillion> .fesco 1552
17:04:05 <zodbot> maxamillion: #1552 (Review of delayed Changes for F24) – FESCo - https://fedorahosted.org/fesco/ticket/1552
17:04:51 <maxamillion> I'm pretty sure the systemd split was done, and the Layered Docker Image Build Service is mine ... I have everythong deployed and it's testable, but the tests are failing and we're chasing down a potential NSS bug
17:04:57 <jwb> apologies for being late
17:05:06 <dgilmore> systemd split was done
17:05:17 <nirik> yep.
17:05:36 <maxamillion> if that's an acceptable state then I can change the tracking bug on the Layered Docker Image Build Service to MODIFIED
17:05:43 <dgilmore> maxamillion: quick q, which builder are you using for the osbs testing?
17:05:50 <maxamillion> dgilmore: koji01.stg
17:05:54 <dgilmore> maxamillion: don't
17:06:01 <sgallagh> maxamillion: It has to be "testable" by this point, so I'd say that's acceptable.
17:06:07 <dgilmore> maxamillion: use buildvm01.stg
17:06:23 <dgilmore> maxamillion: koji01.stg is rhel7, it will be deployed on f23
17:06:35 <maxamillion> dgilmore: alright, we can follow up off-meeting about that
17:06:37 <dgilmore> use the buildvm that will mirror prod
17:06:43 <dgilmore> maxamillion: indeed
17:06:44 <maxamillion> sgallagh: alright, I'll move to MODIFIED
17:06:57 <dgilmore> I agree with sgallagh
17:07:40 <maxamillion> alright, I'll update the tracker bug after the meeting
17:07:49 <jsmith> maxamillion: Awesome, thanks...
17:07:57 <maxamillion> #topic #1555 Please clarify updates policy for security issues
17:08:02 <maxamillion> .fesco 1555
17:08:03 <zodbot> maxamillion: #1555 (Please clarify updates policy for security issues) – FESCo - https://fedorahosted.org/fesco/ticket/1555
17:08:23 <jsmith> I haven't updated the text yet -- but will before next week's meeting
17:08:40 <jsmith> Sorry, been a busy week of travel for me :-/
17:08:42 <maxamillion> Proposal: Defer #1555 to next week to give jsmith time to get that updated
17:08:54 <nirik> +1
17:08:58 <kalev> +1
17:09:00 <jwb> +1
17:09:02 <paragan> +1
17:09:22 <maxamillion> +1
17:09:28 <jsmith> +1, obviously :-)
17:09:49 <number80> +1
17:09:55 <sgallagh> +1
17:10:06 <dgilmore> +1
17:10:15 <maxamillion> #agreed Defer #1555 to next week's meeting (2016-03-18) to allow jsmith time to update (+1: 9, 0:0, -1:0)
17:10:16 <number80> well, it was originally intended to leave some time to jsmith :)
17:10:21 <maxamillion> (Did I dot that right?)
17:10:29 <jwb> maxamillion: yes
17:10:30 <jsmith> maxamillion: Looks good to me
17:10:37 <maxamillion> cool, thanks
17:10:56 <maxamillion> Alright, going to move on to new business and hold the firefox item until the end
17:11:00 <maxamillion> #topic New Business
17:11:08 <maxamillion> #topic #1559 jvanek would like to become provenpacakger
17:11:13 <maxamillion> .fesco 1559
17:11:14 <zodbot> maxamillion: #1559 (jvanek would like to become provenpacakger) – FESCo - https://fedorahosted.org/fesco/ticket/1559
17:11:24 <nirik> maxamillion: note, we don't need to normally do these...
17:11:31 <maxamillion> nirik: oh?
17:11:39 <maxamillion> nirik: are these normally only done in the ticket?
17:11:42 <number80> yes
17:11:45 <maxamillion> ah ok
17:11:48 <maxamillion> good to know :)
17:11:49 <jwb> we only discuss if there is contention
17:11:52 <nirik> unless there are -1s
17:11:54 <maxamillion> gotchya
17:12:00 <sgallagh> nirik: Any -1s on the sponsor list?
17:12:16 <number80> nope, he has all the required +1
17:12:18 <nirik> nope, we ask everyone to post feedback tot he ticket
17:12:22 <number80> (on both tickets)
17:12:34 <maxamillion> yeah, no -1's in sight .... apologies for the meeting line noise
17:12:59 <maxamillion> should I just scratch these from the meeting agenda?
17:13:40 <maxamillion> Proposal: Remove ProvenPackager tickets from the meeting agenda since there are no -1's in the tickets
17:14:11 <jwb> sure
17:14:25 <nirik> just do it yeah.
17:14:49 <maxamillion> I was just doing the proposal for the sake of meeting minutes
17:14:58 <maxamillion> #agreed Remove ProvenPackager tickets from the meeting agenda since there are no -1's in the tickets
17:15:14 <maxamillion> #topic
17:15:24 <maxamillion> oop
17:15:32 <maxamillion> #topic #1560 provenpackager request: yselkowitz
17:15:36 <maxamillion> .fesco 1560
17:15:37 <zodbot> maxamillion: #1560 (provenpackager request: yselkowitz) – FESCo - https://fedorahosted.org/fesco/ticket/1560
17:15:41 <maxamillion> #agreed Remove ProvenPackager tickets from the meeting agenda since there are no -1's in the tickets
17:15:50 <maxamillion> (for meeting minutes
17:15:51 <maxamillion> )
17:15:59 <maxamillion> sgallagh: alright, want to do firefox now or after open floor?
17:16:26 <sgallagh> Well, I haven't gotten a response back yet today, but I'll do a brief summary.
17:16:33 <maxamillion> alright
17:16:43 <maxamillion> #topic #1518 Software packaged in Fedora should not be allowed to implement DRM schemes that cannot be disabled
17:16:47 <maxamillion> .fesco 1518
17:16:50 <zodbot> maxamillion: #1518 (Software packaged in Fedora should not be allowed to implement DRM schemes that cannot be disabled) – FESCo - https://fedorahosted.org/fesco/ticket/1518
17:17:04 <sgallagh> Short version is that last week they reopened communication and it was fairly positive.
17:17:10 <jwb> we should really change the title of the ticket to reflect that we're specifically addressing something in firefox.
17:17:24 <maxamillion> jwb: agreed
17:18:05 <sgallagh> In the next couple weeks, we will want to bring in the rel-eng tools folks so we can discuss signing options (they may have a way for us to allow packagers to pre-sign the modules we build; I don't know the full details yet)
17:18:13 <maxamillion> sgallagh: alright, sounds good ... anything else on this or just still need time to get it all sorted?
17:18:55 <sgallagh> I've gotten confirmation through a back-channel that they will give us something in writing that says we can use the Debian system extension patch without violating our trademark agreement.
17:19:01 <sgallagh> But it hasn't materialized yet.
17:19:14 <maxamillion> sgallagh: sounds good
17:19:27 <maxamillion> we good to move on to open floor?
17:19:33 <sgallagh> Presumably they will assert that in a general way, not just specific to us
17:19:42 <maxamillion> sgallagh: right
17:20:00 <sgallagh> EOF
17:20:01 <maxamillion> #topic Next week's chair
17:20:17 <maxamillion> I won't be here next week, will be traveling for a wedding
17:20:28 <nirik> I havent done it in a while. I can
17:20:52 <maxamillion> #info nirik to chair next week's meeting (2016-03-18)
17:21:02 <sgallagh> The following week is a holiday for US RHT employees, FYI
17:21:03 <maxamillion> thanks nirik :)
17:21:10 <sgallagh> (March 25th)
17:21:12 <nirik> oh?
17:21:12 <maxamillion> sgallagh: oh?
17:21:19 <maxamillion> what for?
17:21:23 <nirik> so it is.
17:21:27 <nirik> "spring holiday"
17:21:40 <maxamillion> huh
17:21:41 <maxamillion> cool
17:21:46 <maxamillion> good to know
17:21:50 <dgilmore> aka good friday
17:21:53 * jsmith will be absent on April 1st
17:21:56 <nirik> so, cancel next week?
17:22:01 <paragan> #info paragan will not be available next week, attending fossasia conference.
17:22:01 <dgilmore> nirik: si
17:22:07 <maxamillion> wait, next week or week over?
17:22:07 <jsmith> nirik: WORKSFORME
17:22:14 <maxamillion> (for cancel)
17:22:28 <jwb> uh, next week is the 18th
17:22:29 <nirik> proposal: cancel meeting next week.
17:22:32 <nirik> wait.
17:22:34 <jwb> why?
17:22:39 <maxamillion> jwb: +1
17:22:53 <nirik> yeah, sgallagh confused me. ;)
17:22:57 <maxamillion> proposal: cancel meeting the week of 2016-03-25
17:22:58 <jsmith> I'd prefer to meet next week, and cancel the 25th...
17:23:15 <nirik> lets do that next week? or sure, whatever...
17:23:15 <sgallagh> Sorry, I said "the next week" meaning the one after the one under discussion
17:23:22 <sgallagh> Which is why I clarified with the actual date
17:23:23 <jwb> FYI, i'll be missing the 25th, the 1st, and the 9th.
17:23:29 <jwb> which is unfortunate, but accurate
17:24:31 <maxamillion> I'll try again :)
17:24:32 <maxamillion> Proposal: cancel meeting the week of 2016-03-25
17:24:38 <jsmith> maxamillion: +1
17:24:42 <sgallagh> +1
17:24:43 <kalev> +1
17:24:43 <nirik> +1
17:24:54 <paragan> +1
17:25:03 <jwb> +1
17:25:09 <number80> wfm
17:25:11 <number80> +1
17:25:12 <maxamillion> +1
17:25:23 <maxamillion> dgilmore: ?
17:26:17 <maxamillion> eh
17:26:18 <maxamillion> #agreed Cancel meeting the week of 2016-03-25 (+1:8, 0:0, -1:0)
17:26:22 * jsmith has to run pick up lunch for today's Security FAD -- thanks everyone!
17:26:34 <maxamillion> jsmith: cheers!
17:27:05 <maxamillion> anything else for Open Floor?
17:27:06 <sgallagh> I have something for Open Floor
17:27:11 <maxamillion> #topic Open Floor
17:27:16 * maxamillion forgot to change topic
17:27:26 <sgallagh> So, next week is Go/No-Go for F24 Alpha, yes?
17:27:53 <nirik> yep.
17:27:57 <nirik> wish we had a tc. ;)
17:27:58 <sgallagh> With the new compose process, what's our plan for RCs?
17:28:26 <maxamillion> I'm not sure I follow the context ... plan for what about RCs?
17:28:42 <nirik> sgallagh: adamw has sent several emails talking about this.
17:28:49 <sgallagh> Having them so they can be tested and hopefully signed off on
17:28:49 <nirik> you mean the naming? or ?
17:29:08 <sgallagh> Normally by this point, we'd have at least one TC
17:29:30 <sgallagh> Realistically, we need an RC by Tuesday to have any chance of Go on Thursday
17:29:30 <nirik> well, we sort of do with the nightlys
17:29:34 <nirik> https://qa.fedoraproject.org/blockerbugs/milestone/24/alpha/buglist
17:30:23 <nirik> we can't request an rc until all the blockers are quashed... but happily not too many
17:31:51 <dgilmore> sgallagh: at this point teh nightly compose is what would be in a TC
17:31:59 <sgallagh> dgilmore: OK, that's good to know.
17:32:03 <sgallagh> Thanks
17:33:16 <dgilmore> there is some questions, that will get answered when we geta  TC or RC compose request
17:35:08 <maxamillion> anything else on this topic
17:35:09 <maxamillion> ?*
17:37:03 <sgallagh> Just that if you're involved with any of those blockers, please work on them :)
17:38:32 <maxamillion> +1
17:38:41 <maxamillion> alright, anything else for Open Floor?
17:39:43 <dgilmore> nada
17:40:09 * jsmith has nothing to add
17:40:32 <sgallagh> nope
17:40:43 <paragan> nothing
17:41:54 <maxamillion> 5
17:41:58 <maxamillion> 4
17:42:01 <maxamillion> 3
17:42:04 <maxamillion> 2
17:42:06 <maxamillion> 1
17:42:11 <maxamillion> #endmeeting