kde-sig
LOGS
15:06:31 <jreznik> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-06-14
15:06:31 <zodbot> Meeting started Tue Jun 14 15:06:31 2011 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:45 <jreznik> #meetingname kde-sig
15:06:45 <zodbot> The meeting name has been set to 'kde-sig'
15:06:55 <jreznik> #topic roll call
15:07:06 <jreznik> who's present?
15:07:10 <Kevin_Kofler> Present.
15:07:23 <than> present
15:07:26 * rnovacek here
15:07:50 <rdieter_work> here
15:08:15 <jreznik> #chair jreznik Kevin_Kofler than rnovacek rdieter_work
15:08:15 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter_work rnovacek than
15:08:26 <jreznik> #info jreznik Kevin_Kofler than rnovacek rdieter_work present
15:08:40 <jreznik> ltinkl is probably still travelling home from brno
15:08:51 <jreznik> #topic agenda
15:09:46 <jreznik> anything else to be added to agenda today?
15:11:15 <Kevin_Kofler> kde-plasma-networkmanagement nm09 branch snapshots
15:13:10 <jreznik> ok
15:13:56 <jreznik> #topic kde-4.6.4 status
15:15:19 <Kevin_Kofler> So we have updates filed for 4.6.4 now.
15:15:27 <Kevin_Kofler> (for F14 and F15)
15:15:35 <Kevin_Kofler> Have we queued them to testing yet?
15:15:36 * rdieter_work is downloading them to stuff into kde-testing repo asap too
15:16:03 <rdieter_work> they're not queued yet
15:16:38 <jreznik> #info 4.6.4 update is ready, not yet queued, rdieter_work is preparing it for kde-testing repo too
15:17:08 <Kevin_Kofler> I think we should queue it for testing.
15:18:58 <than> it's already queued
15:19:06 <jreznik> Kevin_Kofler: +1
15:19:37 <than> do we want to push it to update testing now?
15:20:08 <Kevin_Kofler> Yes.
15:22:07 <than> ok, i will push it to update testing if  nobody is against it
15:22:32 <Kevin_Kofler> +1, go ahead!
15:22:36 <Kevin_Kofler> Let's move on…
15:23:26 <jreznik> #action than to push update to testing
15:23:34 <jreznik> #topic 4.6.80
15:24:14 * jreznik is slowly building portions of 4.6.80
15:24:18 * rnovacek get finally building kdeedu-4.6.80
15:24:28 <rnovacek> merged from ~20 tarballs
15:24:48 <rnovacek> but it's quite hackish
15:25:07 <jreznik> for now - no splits and looks like sebas is on our side to provide monolithic packages again...
15:25:46 <Kevin_Kofler> Let's see…
15:26:47 <jreznik> so I'd like to postpone any splits now and rnovacek prepared kdeedu as a big package, same applies for kdebindings
15:27:04 <rdieter_work> +1
15:27:10 <Kevin_Kofler> Good work, go ahead with that please. :-)
15:27:18 <than> which packages are not built yet ?
15:27:27 <jreznik> #info 4.6.80 is slowly prepared in rawhide, no splits right now
15:27:39 <rdieter_work> anything depending on kdeedu at least, ... kdeplasma-addons for one
15:28:14 <jreznik> than: kdebindings, kdegraphics
15:28:25 <jreznik> and that kdeedu dep chain
15:28:40 <jreznik> so mostly the splitted ones
15:29:34 <Kevin_Kofler> Oh, BTW, I had to rebuild kdelibs for a new qt-webkit.
15:29:48 <Kevin_Kofler> *qtwebkit, actually.
15:29:54 <Kevin_Kofler> It looks like QtWebKit silently broke the ABI.
15:30:03 <Kevin_Kofler> KWebPage was crashing, the rebuild fixed it.
15:30:16 <Kevin_Kofler> Don't you love WebKit? :-/
15:31:24 <jreznik> Kevin_Kofler: yeah, I saw that crash today, thanks
15:31:26 <rdieter_work> well, jumping from qt-4.7.x webkit to webkit-2.2 was a bit of a big jump
15:32:35 <jreznik> #info missing packages - kdeedu deps chain, kdegraphics, kdebindings
15:32:51 <jreznik> #info Kevin_Kofler rebuilt kdelibs for newer qt-webkit (kwebview crash)
15:33:37 <jreznik> I'll try to finish all builds by the end of the week but we have Openmobility conference and I'm quite busy with it as main organizer and I have a talk there
15:34:17 <rdieter_work> when 4.6.80 is done, I also think that'd be a good time to build qt-4.8.0-tp in rawhide too
15:34:23 <Kevin_Kofler> +1
15:34:26 <jreznik> +1
15:34:33 <rnovacek> +1
15:34:37 <rdieter_work> (and potentially to a mass rebuild of 4.6.80 too)
15:35:15 <jreznik> #info when 4.6.80 is done, qt-4.8.0-tp will land rawhide too (probably with mass rebuild of 4.6.80)
15:35:27 <jreznik> rdieter_work: +1
15:37:46 <jreznik> anything else for 4.6.80?
15:38:09 <Kevin_Kofler> No, move on.
15:38:10 <jreznik> #topic Lohit fonts accidentally disable the bytecode interpreter for Qt patch
15:38:29 <jreznik> .bug 705348
15:38:32 <zodbot> jreznik: Bug 705348 Lohit fonts accidentally disable the bytecode interpreter for Qt - https://bugzilla.redhat.com/show_bug.cgi?id=705348
15:39:12 <jreznik> rdieter_work already reported it upstream
15:39:31 <rdieter_work> ok, I filed this upstream.  bad news is I was a little too brief, and they closed it.
15:39:56 <rdieter_work> "This place is for bug reports. If you want to report a bug, please give a more detailed description of the problem along with a Qt example that can be used to reproduce the issue. For legal reasons, we cannot accept patches posted as bug reports. To submit a patch, please use Qt's official contribution system:..."
15:40:35 <rdieter_work> lovely people there, anyway, I followed up with more detail.  unfortunately,  their tracking doesn't seem to support adjusting the bug summary or re-opening things. :(
15:40:35 <Kevin_Kofler> Unhelpful upstream… :-(
15:40:55 <Kevin_Kofler> The promised Open Governance has been delayed, too.
15:41:07 <rdieter_work> so, I'll give it a day or 2, and file a new bug if there's no reply in the meantime
15:41:26 <jreznik> paid bug triage  monkey
15:41:55 <than> i will try to contact Lars Knoll
15:42:02 * rdieter_work does his best to avoid making any jokes about monkeys, and spanking
15:42:30 <than> i hope he will have time and can take a look at this
15:42:31 <jreznik> #info rdieter_work reported the lohit fonts bug to upstream
15:42:47 <rdieter_work> than: thanks, I figured we just needed to get the "right" people to see it
15:43:29 <jreznik> #info upstream asked for details and closed the bug meanwhile, rdieter to fill it again in case details are not accepted
15:43:53 <jreznik> #action than to try to contact the responsible troll
15:44:21 <jreznik> I think it's all we can do now...
15:44:44 <jreznik> as I suppose nobody wants to dig into qt's fontconfig implementation :)
15:44:59 <jreznik> #topic kde-plasma-networkmanagement nm09 branch snapshots
15:45:48 * rdieter_work has been testing the nm09 branch snapshots, successfully.
15:46:02 <Kevin_Kofler> Are they in kde-testing yet?
15:46:14 <rdieter_work> basic stuff.  wired auto-eth0, unencrypted wireless, wpa2 wireless
15:46:21 <rdieter_work> only kde-unstable so far
15:46:23 <Kevin_Kofler> I think we should get them out to kde-testing now, and updates-testing as soon as my current bugfix update lands in stable.
15:47:18 <rdieter_work> hmm... I kinda would rather wait until after 4.6.4 has been in testing for a bit, I'd rather avoid having them both land at the same time, and make debugging a little harder.
15:47:30 <rdieter_work> but I don't feel strongly about it
15:47:35 <jreznik> rdieter_work: +1
15:47:37 <rdieter_work> what do others thing?
15:47:39 <Kevin_Kofler> (I can queue the bugfix updates to stable in 3 days.)
15:47:41 <rdieter_work> think even?
15:48:07 <Kevin_Kofler> Well, are 3 days enough for "a bit"? :-)
15:48:12 <jreznik> #info rdieter_work reports nm snapshot works with wired auto-eth0, unencrypted wireless and wpa2 wireless
15:48:38 <jreznik> #info currently available in kde-unstable repo
15:49:39 <rdieter_work> Kevin_Kofler: 2-3+ days is ok with me
15:49:59 <Kevin_Kofler> I will queue the kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1 build to stable when Bodhi lets me, which is 3 days from now.
15:50:14 <jreznik> ok
15:50:27 <Kevin_Kofler> It got pushed to testing on 2011-06-10 at 13:34:33 UTC, so I can push it to stable on June 17 at the same time.
15:50:30 <rdieter_work> I tested that one too, I can karma it
15:50:46 <Kevin_Kofler> (Well, not at the same time because I'll be in a lecture, but after the lecture. :-) )
15:51:05 <Kevin_Kofler> (Though actually, the lecture ends at 13:30 UTC. :-) )
15:52:16 <Kevin_Kofler> If you karma it up, I could also fire it up to stable now by editing the karma threshold, hoping that still works as it used to. (Bodhi changed again, and with each Bodhi change, this kind of behavior can change.)
15:53:10 <Kevin_Kofler> So, want me to queue the bugfix update to stable now?
15:54:06 <rdieter_work> Kevin_Kofler: imo, let's wait for at least one more +1 karma
15:54:33 <rdieter_work> bonus if it's from someone who experienced the crashes this supposedly fixes
15:54:34 <Kevin_Kofler> I also don't have any confirmation that the bug is actually fixed…
15:55:12 <Kevin_Kofler> I've needinfo'd the bug report.
15:56:35 <rnovacek> I'll test the knm and add karma
15:57:02 <jreznik> #action Kevin_Kofler to needinfo the bug to get more input and karma (especially those who are affected by crashes)
15:57:11 <Kevin_Kofler> What I'd really like to is see confirmation that the crashes are fixed.
15:57:33 <Kevin_Kofler> I use a WPA-EAP configuration at the university, but I haven't seen those crashes.
15:57:38 <Kevin_Kofler> So I can't reproduce them.
15:57:50 <rnovacek> I can't reproduce it either
15:59:33 <jreznik> ok, last minute guys - anything else to be mentioned today?
16:00:00 <rdieter_work> nope
16:00:01 <rnovacek> http://progdan.cz/2011/06/akonadi-google-resource-0-2/
16:00:04 <Kevin_Kofler> Any update from the KHelpCenter docbook-styles-xsl saga?
16:00:07 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=690124
16:00:14 <rnovacek> works fine, but readonly for now
16:00:44 <Kevin_Kofler> Looks like #fedora-docs folks are now also interested by this mess, and it seems like something (maybe the same thing, maybe something entirely different) broke Yelp too.
16:00:57 <Kevin_Kofler> But that's just what I got told, I don't know the details.
16:01:36 <Kevin_Kofler> Did we build the 4.6.4 stuff with the old, good docbook-styles-xsl or with the current, bad one?
16:01:40 <rdieter_work> Kevin_Kofler: no update.
16:02:02 <rdieter_work> the old/working docbook-styles-xsl is in dist-f1{4,5}-kde buildroot
16:02:12 <than> Kevin_Kofler: with the old one
16:02:52 <rdieter_work> but not having it at runtime still means fail
16:02:55 <jreznik> ok, let's move back to #fedora-kde to talk more about it
16:03:11 <jreznik> we're over time here...
16:03:14 <jreznik> #endmeeting