fedora-meeting
LOGS
21:41:26 <mcepl> #startmeeting bugzappers meeting
21:41:26 <zodbot> Meeting started Tue Jan 18 21:41:26 2011 UTC.  The chair is mcepl. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:41:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:41:35 <mcepl> so who is present
21:41:40 <mcepl> ?
21:41:58 <adamw> yo
21:42:19 * mcepl summons fenrus02
21:42:23 * nirik is lurking around.
21:42:33 * fenrus02 appears
21:42:38 <mcepl> awesome!
21:42:49 <mcepl> First point of agenda: I am sorry. :(
21:42:51 <fenrus02> mcepl, oddly enough, i dont see your email
21:42:58 <mcepl> shuut
21:43:00 <mcepl> let me check
21:43:13 <adamw> you're damn RIGHT you're sorry
21:43:14 <adamw> :P
21:44:03 <mcepl> OK, agenda (I am not sure where there is a command for it):
21:44:11 <adamw> nope, not really
21:44:13 <mcepl> * Xorg kernel bugs
21:44:20 <mcepl> * status reports
21:44:23 <mcepl> anything else?
21:44:34 <mcepl> (concerning status report, we have http://meetbot.fedoraproject.org/fedora-meeting/2010-12-07/fedora-meeting.2010-12-07-21.04.html)
21:46:00 <adamw> not from me
21:46:10 <fenrus02> not i
21:46:17 <mcepl> OK
21:46:44 <mcepl> #chairs mcepl adamw fenrus02
21:46:56 <mcepl> #topic Xorg kernel bugs
21:47:49 <mcepl> this, just announcement: I was talking with my Xorg boss in Red Hat, and he asked me not to change component of Xorg-kernel bugs from kernel to Xorg
21:47:58 <mcepl> just to add appropriate maintainer as such.
21:48:49 <fenrus02> odd.  why?  because of kms?
21:49:08 <mcepl> which are: jglisse@RH for ati, bskeggs@RH for nouveau, ajax@RH for intel and dairlie@RH for general bugs
21:49:19 <mcepl> yes, KMS bugs shouldn't be moved to xorg-* components
21:49:23 <adamw> i'm not sure this something we should do for fedora, though
21:49:28 <adamw> i'd rather ask the fedora kernel and X team about it
21:49:40 <adamw> last guidance i had from them was what we currently do, to keep everything under the X components
21:49:52 <mcepl> well, Fedora X team is RH, I am afraid. Anybody else?
21:50:01 <adamw> mcepl: sure, but that does not mean they want the same policy
21:50:02 <fenrus02> kernel bugs tend to stay there a while.
21:50:05 <adamw> for Fedora as for RH
21:50:09 <mcepl> adamw: yes, they do
21:50:31 <adamw> mcepl: er, really? do you have that written down somewhere?
21:50:34 <fenrus02> the shorter queue would be the xorg-component
21:50:36 <mcepl> and mind you, these bugs will have X developers as assignees so for kernel team it is zero loss
21:50:50 <adamw> for everyone else, it's a significant loss
21:50:54 <adamw> it makes it much harder to find the bugs
21:51:01 <adamw> and it makes it much harder to correctly re-assign them if a team member changes
21:51:17 <adamw> i'm really against this as long we can't have sub-components for large things like the kernel
21:51:22 <mcepl> you told me that, and I don't agree with it
21:51:46 <adamw> how do we easily find all Intel driver bugs, if half of them are assigned to xorg-x11-drv-intel and half of them are simply assigned to 'kernel'?
21:52:07 <mcepl> assignee == ajax@redhat.com
21:52:17 <adamw> that's assuming the re-assigning was done correctly
21:52:21 <adamw> also, X server bugs are assigned to ajax
21:52:45 <adamw> using a person as a proxy for a component really doesn't seem robust
21:52:48 <mcepl> adamw: really, you don't know you could have in query two conditions joined by AND?
21:52:58 <fenrus02> xorg-x11-drv-intel has 165 bugs.  kernel has 925 ...  i'm not sure how this helps.
21:53:02 <adamw> sure. it makes things complex and messy.
21:53:03 <mcepl> but it is not the component ... it is really kernel.
21:53:28 <mcepl> and there are other almost-Xorg bugs which Xorg team does, and they are not assigned to any particular driver.
21:53:31 <adamw> but we don't handle the kernel as a single big component with a single team.
21:53:39 <mcepl> so there is no difference, you will have it this duality always.
21:54:04 <adamw> anyway...i'd like to see an actual written request from the X team to make this change *for Fedora*, before we do it...
21:54:32 <fenrus02> and update the wiki so that everyone has a uniform methodology for these.
21:55:13 <mcepl> uniform methodology ... don't move kernel bugs anywhere else, as I wouldn't move any other kernel bugs. What's complicated about it?
21:55:22 <mcepl> s/I/you/
21:55:42 <adamw> what about bugs reported against xorg-x11-drv-foo which are actually in the kernel module?
21:55:43 <fenrus02> i'm guessing this would be the best section to append to - https://fedoraproject.org/wiki/Xorg/Debugging#AllInfo
21:56:44 <adamw> do we reassign bugs filed against the DDX to the kernel?
22:00:54 <mcepl> don't reassign anything anywhere ... what's now in xorg-* be it there and what's kernel as well
22:01:00 <mcepl> adamw: sorry, I forgot to press ENTER
22:01:56 <adamw> well, that's less of a problem practically speaking, i don't think it makes a lot of sense, but hey, i'm willing to let it slide.
22:02:43 <mcepl> thanks
22:03:13 <mcepl> do we want to vote, or should we make it just as info?
22:03:28 <adamw> info, whatever.
22:05:03 <mcepl> #info we should stop reassigning kernel-Xorg bugs to xorg-* components, just left whatever is in kernel in kernel, what's in xorg-* there as well.
22:05:08 <mcepl> next
22:05:11 <mcepl> ?
22:05:30 <adamw> i dunno, you had the agenda =)
22:06:31 <mcepl> no, just checking that everybody is happy with the outcome of this point
22:06:43 <mcepl> #topic status
22:06:54 <fenrus02> i've added a few new users to the fas group.  not sure if they have chimed in the channel or not yet
22:06:57 <mcepl> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-12-07/fedora-meeting.2010-12-07-21.04.html
22:08:52 <mcepl> I was talking with andrewjroth, but I am not sure, whether there was any product from it.
22:09:44 <mcepl> talk with fcami still stays ... I haven't seen him in a while
22:09:48 <fcami> pong.
22:09:54 <mcepl> ha!
22:10:05 * fcami waves ;)
22:10:08 <adamw> hey fcami
22:10:15 <mcepl> hello!
22:10:22 <fcami> hello to all of you
22:10:27 <mcepl> fcami: what was the outcome of "ACTION: mcepl talk with fcami about update of Xorg triage page"
22:10:29 <mcepl> ?
22:10:50 <fcami> I think we never talked about it.
22:11:07 <fcami> I did a little cleaning back then and then got sidetracked.
22:11:44 <mcepl> OK, me too :(
22:12:11 <fcami> it's ok. I'll be more available from now on.
22:12:54 <mcepl> ok
22:13:08 <mcepl> me too, it's after Christmas hopefully now
22:13:18 <fcami> hehe :)
22:13:57 <mcepl> fenrus02: OTOH, I do remember I've made at least a brief review of
22:14:01 <mcepl> #link https://fedoraproject.org/wiki/User:Fenris02/Firefox
22:14:12 <mcepl> what is the next step to do with it?
22:15:39 <mcepl> or in other words, what stops you from moving it to the official BugZappers namespace?
22:16:37 <fenrus02> not a thing really.  wasnt sure if it should be moved anywhere out of draft
22:17:13 <mcepl> BTW, I have some tiny comments ... when I am looking now over it
22:17:56 <fenrus02> sure
22:18:06 <mcepl> I will talk with you after this in #fedora-bugzappers, right?
22:18:22 <fenrus02> sounds fine
22:18:24 <mcepl> well, we have
22:19:22 <mcepl> somewhere, I cannot find it now
22:19:29 <mcepl> special wiki pages for individual components
22:20:50 <adamw> bugzapping pages?
22:21:02 <adamw> the convention is to name them as 'How_to_debug_(packagename)_problems'
22:21:06 <mcepl> I see only  http://fedoraproject.org/wiki/Xorg/Debugging and
22:21:07 <mcepl> https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm
22:21:15 <mcepl> yes, tthos
22:21:29 <adamw> note that Xorg/Debugging is actually named https://fedoraproject.org/wiki/How_to_debug_Xorg_problems , now
22:21:42 <mcepl> yes, it is, because you have kindly fixed it
22:21:43 <mcepl> thanks
22:21:51 <adamw> https://fedoraproject.org/wiki/Category:Debugging has the existing pages
22:21:59 <mcepl> ha! http://fedoraproject.org/wiki/Category:How_to
22:22:04 <adamw> i renamed it quite a while back =) the old name still works as it's a redirect
22:22:19 <mcepl> or even better http://fedoraproject.org/wiki/Category:Debugging
22:22:44 <mcepl> so we actually have http://fedoraproject.org/wiki/How_to_debug_Firefox_problems, but that's quite miserable.
22:23:22 <fenrus02> heh. that is the page i was attempting to correct :)
22:23:23 <mcepl> so, yes, I would suggest action for fenrus02 to make his page into official How to debug Firefox problems .
22:23:32 <adamw> yup, indeed, looks like an improvement :)
22:23:41 <mcepl> fenrus02: quite so
22:24:28 <mcepl> objections?
22:24:58 <mcepl> #action fenrus02 to move his Firefox debugging page to the official "How to debug Firefox problems" one.
22:25:34 <mcepl> and yes, I shouldn't get scot free
22:25:56 <mcepl> #action mcepl to collaborate with fcami to really update Xorg triage page
22:26:05 <fcami> yes
22:26:08 <mcepl> but if that's it, this leads to
22:26:17 <mcepl> #topic open floor
22:26:18 <adamw> yeah, X triage page does need a bit of an update
22:26:22 <mcepl> anybody anything?
22:27:27 <mcepl> if not
22:27:30 <mcepl> three
22:27:32 <mcepl> two
22:27:34 <mcepl> one
22:27:40 <mcepl> #endmeeting