kde-sig
LOGS
14:01:19 <rdieter> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-04-06
14:01:20 <zodbot> Meeting started Tue Apr  6 14:01:19 2010 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:22 <rdieter> #meetingname kde-sig
14:01:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:25 <zodbot> The meeting name has been set to 'kde-sig'
14:01:32 <rdieter> #topic roll call
14:01:36 <rdieter> who's present today
14:01:38 <rdieter> ?
14:01:50 <SMParrish_mobile> Here but at work. So in and out
14:02:08 * jreznik is here
14:02:28 <ltinkl> I'm here, although I have to leave early today
14:02:43 <Kevin_Kofler> Present.
14:02:53 * than is present
14:03:04 <rdieter> #chair than Kevin_Kofler ltinkl jreznik SMParrish_mobile
14:03:04 <zodbot> Current chairs: Kevin_Kofler SMParrish_mobile jreznik ltinkl rdieter than
14:03:12 <rdieter> short agenda, hopefully won't take long today
14:03:17 <rdieter> #topic kde-4.4.2
14:03:36 <rdieter> looks like we've got all (most?) of kde-4.4.2 built , and in kde-testing repos
14:03:52 <rdieter> who wants to be the kde-4.4.2 update wrangler this time around?
14:04:35 <Kevin_Kofler> rdieter: I added 2 more items to the agenda, as I mentioned before on #fedora-kde.
14:04:55 <rdieter> Kevin_Kofler: ok
14:04:56 <Kevin_Kofler> For 4.4.2, have we gotten kdepim-runtime through?
14:05:03 <rdieter> yes
14:05:05 <Kevin_Kofler> There were some build failures on Sunday.
14:05:15 <rdieter> I requeue'd them, and it went fine (wierd?)
14:05:20 <than> Kevin_Kofler: what was the problem?
14:05:32 <than> it built fine in f13
14:05:42 <Kevin_Kofler> Some bizarre error with Nepomuk/Akonadi integration which went away after a resubmit.
14:05:50 <than> ah ok
14:06:10 <Kevin_Kofler> BTW, in kdepim, upstream disabled the Nepomuk emailfeeder due to build errors, it might also be something like that.
14:06:16 <Kevin_Kofler> I wonder if we should try reenabling it.
14:06:22 <Kevin_Kofler> It always built for us before.
14:06:39 <Kevin_Kofler> (I noticed it due to a directory vanishing from the file list.)
14:06:56 <rdieter> Kevin_Kofler: I'd ask them first before doing anything
14:07:03 <rdieter> (or just leave it as-is)
14:08:00 <Kevin_Kofler> I can take care of the 4.4.2 update, I did the previous one, so I know how to do things (query Koji for the full list of builds, tag the stuff into the updates-candidate tags, then fill in Bodhi requests).
14:08:54 <rdieter> Kevin_Kofler: thanks
14:09:12 <rdieter> #action Kevin_Kofler to serve as update wrangler for kde-4.4.2
14:09:32 <rdieter> #topic koffice-2.2 for f13
14:09:40 <Kevin_Kofler> Anything outside of the kde441 tags I should pull in?
14:09:44 <Kevin_Kofler> konq-plugins, I guess.
14:09:46 <Kevin_Kofler> Anything else?
14:10:04 <rdieter> Kevin_Kofler: that should be it
14:10:15 * thomasj_ here
14:10:37 <rdieter> thomasj_: hi!
14:10:42 <than> Kevin_Kofler: konq-plugins is only one that needs to be included
14:10:53 <Kevin_Kofler> OK
14:10:53 <thomasj_> Hello
14:11:14 <Kevin_Kofler> So re KOffice, I think we should ship 2.2.
14:11:23 <Kevin_Kofler> (as already said last week)
14:11:58 <rdieter> 2.2 testing/feedback so far has been good.
14:12:12 <than> Kevin_Kofler: do we really want to ship koffice beta in f13?
14:12:15 <rdieter> we helped get a *bunch* of fixes/crashers in and upstreamed since beta1
14:12:25 <rdieter> beta2 includes all the fixes
14:12:43 <rdieter> beta2 is in kde-unstable repo now, for further testing
14:12:49 <rdieter> I'll be doing f13 builds here shortly
14:13:05 <Kevin_Kofler> AIUI, it's a lot better than 2.1 and it's close to the final release.
14:13:22 <jreznik> yep
14:13:22 <rdieter> Kevin_Kofler: +1, I agree, by all accounts, it's looking good alright
14:13:34 <jreznik> it's a lot better than 2.1 but still unusable
14:13:49 <Kevin_Kofler> And Kexi is back. If we ship 2.1, we lose Kexi (unless we package the KOffice 1 version, but ugh).
14:13:58 <than> still unusable is not good!
14:14:03 <Kevin_Kofler> Speaking of KOffice 1 stuff, I still need to look into packaging Kivio, but it's a bit of a mess.
14:14:17 <thomasj_> It is usable, just the MS stuff import isn't good.
14:14:18 <jreznik> than: as 2.1
14:14:25 <Kevin_Kofler> jreznik: Are you sure it's unusable?
14:14:27 <thomasj_> But it never was
14:14:43 <jreznik> Kevin_Kofler: yes, even for usual office tasks
14:14:45 <Kevin_Kofler> And is it worse than 1.6?
14:15:07 <jreznik> 2.2 is still worse than 1.6 but much more better than 2.1
14:15:09 <Kevin_Kofler> 1.6 wasn't that great either. Try doing charts with KSpread and you'll see bugs all over the place, completely unusable.
14:15:21 <jreznik> for real work - oo :(
14:15:23 <rdieter> jreznik: ok, I'll add some import/export tasks to our koffice test plans
14:15:29 <jreznik> and oo is really very buggy
14:15:49 <jreznik> but I hope we'll get nice office solution soon
14:16:08 <jreznik> just try to create simple table (only simple is possible) and reopen it
14:16:10 <rdieter> fyi, http://fedoraproject.org/wiki/SIGs/KDE/KOffice_test_plan
14:16:44 <rdieter> jreznik: feel free to add test-cases too (like table save/reopen you mentioned)
14:16:54 <jreznik> it's better than 2.1 - it sometimes opened table without data, now there are no table borders but data visible ;-) just for example
14:16:57 <jreznik> rdieter: ok
14:17:14 <jreznik> if we are going to ship 2.1 then it's better to ship 2.2
14:17:25 <jreznik> we can hope for release candidate
14:17:28 <than> does someone know when koffice 2.2 will be released?
14:17:41 * rdieter looks for the release schedule
14:18:29 <rdieter> http://wiki.koffice.org/index.php?title=Schedules/KOffice/2.2/Release_Plan
14:18:47 <rdieter> rc1 Tagging on April, 23rd 2010
14:19:14 <Kevin_Kofler> RC1 will probably not make it, realistically.
14:19:20 <Kevin_Kofler> An intermediate snapshot, maybe.
14:19:42 <rdieter> if they stick to schedule, it's doable
14:19:46 <jreznik> it's in quite good condition right now... better than previous betas
14:20:07 <rdieter> final freeze is 05-04 for f13
14:20:26 <jreznik> rdieter: us format? :D
14:20:36 <rdieter> yes, sorry, May 04 :)
14:20:52 <rdieter> (not yesterday)
14:20:58 <than> it seems we could get rc1 in f13
14:21:15 <jreznik> if we can get at least rc1 - I'm +1
14:21:35 <rdieter> jreznik: if not, what's your prefered alternative ?
14:22:27 * thomasj_ is for 2.2, if beta or RC, we update it to final anyways.
14:22:50 <jreznik> then I'm +0.75 but with more beta testing
14:22:57 <Kevin_Kofler> Oh indeed, the F13 slip makes RC1 doable.
14:23:29 <Kevin_Kofler> +1 for 2.2 here.
14:23:29 <rdieter> ok, let's tentatively move forward with the plan to ship with 2.2, continuing our current active testing
14:24:08 <rdieter> anything else?  can we move on?
14:25:03 <rdieter> #topic split out libmediastreamer subpackages from linphone
14:25:07 <rdieter> see also bug #490046
14:25:20 <rdieter> .bug 490046
14:25:21 <zodbot> rdieter: Bug 490046 linphone: Update to 3.x.x? - https://bugzilla.redhat.com/show_bug.cgi?id=490046
14:25:44 <Kevin_Kofler> So F13 and Rawhide now has Linphone 3.
14:25:53 <Kevin_Kofler> libmediastreamer is part of that.
14:25:58 <Kevin_Kofler> But it's not split into subpackages.
14:26:11 <Kevin_Kofler> We need libmediastreamer and libmediastreamer-devel subpackages for Kopete.
14:26:30 <rdieter> so we'd be pulling in extra stuff we don't need ?
14:26:41 <Kevin_Kofler> That and there's no devel package.
14:26:51 <Kevin_Kofler> The library really needs to be subpackaged.
14:27:08 <rdieter> oh, ouch.  ok, -devel is needed for sure.  Is there a good space savings to be had for splitting then too?
14:27:30 <rdieter> I guess the library split would help multilib-wise too
14:27:51 <Kevin_Kofler> Well, do you want kdenetwork to drag in all of linphone?
14:28:01 <Kevin_Kofler> It's a complete app.
14:28:21 <rdieter> depends.  if it's only 4k, not a big deal. :)
14:28:50 <rdieter> anyway, looks worthwhile, who wants to be tasked to work on this?
14:28:58 <rdieter> Kevin_Kofler: do you have time, or rather someone else look at it?
14:29:45 <Kevin_Kofler> I think first of all we need to talk to the linphone maintainer.
14:30:10 <rdieter> sure, part of the "task" would be communicating our needs
14:30:30 <rdieter> (though that was done awhile back already in the aforementioned bug)
14:31:03 * rdieter can do it, but has to work on kdm/plymouth first (unless someone wants to help with that too). :)
14:31:45 <jreznik> rdieter: what's the current state of kdm/plymouth integration?
14:31:56 <rdieter> jreznik: there is none (on f13+)
14:32:12 <jreznik> Kevin_Kofler is right - we should ask maintainer first
14:32:22 <jreznik> and offer help in case he refuses to do it
14:34:51 <rdieter> alright, we'll continue to consider linphone an open issue (volunteers still welcome)
14:35:29 <rdieter> #help volunteer to lead effort to split libmediastreamer from linphone (see also bug #490046)
14:35:36 <rdieter> #topic phonon-vlc
14:36:03 <rdieter> with phonon-vlc backend on the horizon, get started on getting libvlc 1.1 into Rawhide (split into Fedora / RPM Fusion)
14:37:09 <rdieter> heliocastro mentioned having some initial work toward getting phonon-vlc packaged, but we'll still need vlc split into free/nonfree parts
14:37:59 <Kevin_Kofler> And the lib should also be a subpackage, we don't want Phonon to drag in VLC the app.
14:38:06 <Kevin_Kofler> (if that's not already the case9
14:38:07 <Kevin_Kofler> )
14:38:11 <rdieter> this is another item I can add to my todo list, but it'll be down my own list by at least 2-3 items
14:38:31 <than> is the vlc tarball ok because of patent issue?
14:38:43 <rdieter> than: it'll probably require cleaning
14:38:52 <Kevin_Kofler> than: No, it needs to be cleaned just like xine-lib.
14:38:52 <rdieter> similar to what we currently do for xine-lib
14:39:03 <than> it's needed to be clear before working on vlv package
14:39:55 * rdieter answers phone, will be afk a few minutes
14:41:18 <than> we need someone who reviews the vlc
14:41:20 <Kevin_Kofler> Of course VLC can only go into Fedora if the tarball is stripped of all patent-encumbered stuff.
14:41:47 <jreznik> how difficult would be to split?
14:42:02 <jreznik> is it prepared for split or more effort needed?
14:42:35 <than> jreznik: i'm afraid there're more works than just splitted
14:43:10 <Kevin_Kofler> I was told current VLC is modular and it should just be a matter of splitting out the offending plugins.
14:43:10 <than> it needs to be done from upstream
14:43:18 <Kevin_Kofler> Just like we handle xine-lib.
14:43:32 <Kevin_Kofler> I've also looked at it and this seems to indeed the case.
14:44:24 <than> Kevin_Kofler: it's easy if it's the case
14:45:06 <Kevin_Kofler> We still need to check what's patent-encumbered and what's not. That can take quite some time.
14:45:50 <than> Kevin_Kofler: yes, the closed review is really required here
14:46:24 <than> we need someone who knows more about vlc
14:46:52 <than> and we need a new maintainer for vlc!
14:46:53 <rdieter> ideally, else we''ll end up learning on the job
14:46:58 <jreznik> and about patented bits
14:47:24 <Kevin_Kofler> Well, I can sign up as maintainer or comaintainer, it can't be worse than xine-lib.
14:47:52 <Kevin_Kofler> But the initial split is going to require some work.
14:48:02 <rdieter> I don't think there's any rush here, it's not going to be much ready for f13 (or shipable by default anyway)
14:48:02 <Kevin_Kofler> I'm not sure if I'll have the time to do it soon.
14:48:17 <Kevin_Kofler> But we should get it ready for F14.
14:48:36 <than> yes, add it on todo for F14
14:48:38 <rdieter> #help get vlc into fedora (and split into free/nonfree parts), usable by phonon-vlc
14:48:51 <Kevin_Kofler> Also because providing it as an update will get messy, due to requiring an upgrade and a split of VLC.
14:49:16 <rdieter> no pain, no gain
14:49:30 <Kevin_Kofler> So it should be in F14 as shipped.
14:50:47 <rdieter> alrighty, that's it for the agenda today
14:50:51 <rdieter> #topic open discussion
14:50:56 <rdieter> anything else for today?
14:51:39 <jreznik> https://fedoraproject.org/wiki/FUDCon:Zurich_2010
14:51:49 <jreznik> anyone going?
14:53:26 <rdieter> not I (unless my wish for a private jet or better, transporter, materializes real soon)
14:53:44 <jreznik> rdieter: yep, for eu people :)
14:53:59 <jreznik> but some fedora transport beams...
14:54:08 <rdieter> now you're talkin
14:54:12 <Kevin_Kofler> Me, probably not, though maybe…
14:54:23 <thomasj_> jreznik, i might go to Zurich. Depends if i get the Car soon enough.
14:54:48 <Kevin_Kofler> The train journey is long and expensive, plane might be an option, but probably also expensive.
14:54:58 <jreznik> Kevin_Kofler: we can probably collect you in Vienna
14:55:07 <jreznik> it's worst way but
14:55:17 <Kevin_Kofler> That'd be a detour for you, I guess.
14:56:27 <jreznik> Kevin_Kofler: it's a little bit slower
14:56:37 <rdieter> ok, we're about out of time, can continue FUDCon:Zurich talk in #fedora-kde
14:56:41 <rdieter> thanks everybody
14:56:43 <rdieter> #endmeeting