fedora-meeting
LOGS
21:02:43 <kanarip> #startmeeting Spins SIG
21:02:43 <zodbot> Meeting started Mon Dec 14 21:02:43 2009 UTC.  The chair is kanarip. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:03:09 <kanarip> #topic whos here?
21:03:17 * kanarip is
21:03:23 * brunowolff I am
21:03:58 <kanarip> who else wants to be chair in case i lose my connection?
21:04:10 <kanarip> biertie, ping
21:04:13 * brunowolff I guess that's me
21:04:22 * biertie is here
21:04:27 <kanarip> nirik, ping
21:04:27 <biertie> but running another meeting too (:
21:04:48 <kanarip> #chair brunowolff
21:04:48 <zodbot> Current chairs: brunowolff kanarip
21:05:09 <kanarip> #topic spins pages
21:05:35 <kanarip> biertie, could you give us a quick report on the spins pages?
21:06:20 * sdziallas waves, is half-ish here.
21:06:47 <kanarip> hey sdziallas ;-)
21:06:53 * rdieter_work lurks
21:07:03 <sdziallas> quick note: we'll presumably submit a design spin for F13. the education spin might go down to cd size again (nothing confirmed, yet). maybe a sugar spin or so.
21:07:23 <biertie> currently only the moblin spin is in my pages
21:07:32 <biertie> and I have checked it once, and it looks good at first sight
21:07:42 <biertie> but I still have to look better at it
21:07:50 <biertie> but I think you can think about the moblin spin already :)
21:08:03 <brunowolff> I updated the games spin, but haven't moved it to ready for wrangler yet.
21:08:41 <Oxf13> nirik: interesting.
21:09:04 <kanarip> brunowolff, that's great
21:09:23 * Southern_Gentlem 
21:09:31 <kanarip> Oxf13, sorry?
21:09:42 <kanarip> related to spins, or...?
21:10:17 <Oxf13> kanarip: no, old topic, I was at lunch
21:10:30 <kanarip> ah, ok ;-)
21:10:44 <kanarip> next  topic, then
21:10:52 <kanarip> #topic lzma foo\
21:11:14 <kanarip> brunowolff, you're in charge of this lzma compression thing i don't understand all that much about
21:11:29 <kanarip> brunowolff, could you tell us some about it's progress?
21:11:37 <brunowolff> The patches still haven't been accepted upstream.
21:11:51 <kanarip> that's kernel patches, isn't that right?
21:11:53 <brunowolff> Lougher has posted a revised set in response to a couple of comments.
21:12:10 <brunowolff> I have made a tentative feature page, pending acceptance of the patches.
21:12:35 <kanarip> but it does concern patches to the kernel, does it not?
21:12:44 <brunowolff> I have the OK to work on squashfs-tools from Kyle, though I haven't got test builds done yet.
21:13:10 <brunowolff> Yes, the patches have been posted on lkml for inclusion in 2.6.33.
21:13:22 <brunowolff> That isn't certain to happen though.
21:13:38 <kanarip> so, in your best guesstimate, is this going to make it before Fedora 13?
21:13:46 <brunowolff> Rahul asked me to comment that Fedora would like to see the patches included and I did that.
21:13:58 <brunowolff> Someone else posted a similar comment.
21:14:17 <brunowolff> The merge window will probably close in another week or so,
21:14:28 <brunowolff> I can work on stuff while waiting.
21:14:46 <kanarip> and so that's when you'll know whether it'll end up in 2.6.33, is that right?
21:15:06 <brunowolff> If it happens I want testable stuff in early January, so spin owners can decide to add stuff fairly safely.
21:15:23 <brunowolff> Yes. I will know very soon about 2.6.33.
21:15:53 <kanarip> awesome, let us know when you do know, please
21:16:17 <kanarip> i think there's a bunch of us who would like to experiment with it a little
21:16:25 <brunowolff> I'll also put some size comparisons on the feature page when i have them. I can do the builds before the new kernel
21:16:41 <brunowolff> is in rawhide. They womn't work, but the size comparisons should be accurrate.
21:16:56 <kanarip> please announce your changes to the spins list and possibly the livecd-tools list as well when you have more details
21:17:11 <brunowolff> I'll do both.
21:17:19 <kanarip> thanks, that's great
21:17:37 <kanarip> 18 minutes in, and we're at our third topic...
21:17:40 <kanarip> but i'm out of topics
21:17:51 <kanarip> so, i motion to open the floor
21:18:08 <brunowolff> I have a question on whether or not spin owners are expected to be subscribed to the spins list.
21:18:18 <kanarip> ohw yes, they should be
21:18:23 <kanarip> #topic Open Floor
21:18:45 <brunowolff> Should I change the spin process page to include stronger language about this?
21:19:09 <kanarip> if it isn't in there already, or it is not strong enough, yes please do so
21:19:22 <brunowolff> Somethign like spin owners are expected to remain subscribed to the list so that rel eng and others can easily contact them?
21:19:46 <brunowolff> The list is mentioned but I think the wording should be a bit stronger.
21:19:49 <kanarip> #action brunowolff to put in the process page a little bit stronger the fact that spin maintainers must be subscribed to the fedora-spins mailing list
21:20:10 <brunowolff> Another FYI is related to liveusb.
21:20:27 <kanarip> i think required to be subscribed throughout the remainder of the lifecycle of the spin isn't putting it too strong
21:20:33 <brunowolff> I was trying to created some liveusb systems with images over 4gb.
21:21:05 <kanarip> through livecd-iso-to-disk, i presume?
21:21:08 <brunowolff> liveusb doesn't support ntfs and fat doesn't support files over 4g, so having sticks readable from windows
21:21:18 <brunowolff> with large images are a pain to set up.
21:21:44 <kanarip> brunowolff, this is your typical rfe to liveusb/livecd-tools
21:21:58 <brunowolff> At some point I'll look at this some more, but it wouldn't be ready by Christmas when I need it, so I'll just do things the
21:22:02 <brunowolff> hard way for now.
21:22:33 <kanarip> i think it's perfectly reasonable to make liveusb do ntfs with an option or so
21:22:35 <brunowolff> I filed an rfe ticket already. I'll probably personally try to work on it down the road, but not for a while.
21:22:56 <kanarip> please send the location of the rfe ticket to the spins mailing list, if you will
21:23:06 * sdziallas notes that jeremy isn't @ RH anymore, so I dunno where the livecd-tools tickets go.
21:23:13 <sdziallas> probably warren?
21:23:14 <brunowolff> To use ntfs I think you need to use grub2, grub and syslinux don't seem to support reading from ntfs.
21:23:19 <kanarip> sdziallas, i'll take'em
21:23:20 <warren> ?
21:23:34 <sdziallas> warren: was just wondering about the current livecd-tools maintainer
21:23:36 <warren> I fix livecd if I understand what's wrong with it
21:23:38 <warren> I'm not the maintainer
21:23:41 <brunowolff> There is a trac instance on fedorahosted.
21:23:41 <sdziallas> kanarip: ah, okay... cool ;)
21:23:52 <sdziallas> warren: nothing wrong, discussing an RFE atm.
21:23:53 <kanarip> that's true, warren has the most of all recent commits ;-)\
21:23:58 <sdziallas> warren: okay, noted.
21:24:00 <sdziallas> thanks!
21:24:20 <warren> livecd is basically unmaintained
21:24:26 <warren> if this bothers you, please escalate to FESCO or Board
21:24:33 <warren> some people might need kicking
21:24:41 <brunowolff> Jeremy seems to still have an interest in livecd-tools. I heard back for him about possible squashfs changes to use lzma.
21:24:46 <brunowolff> feom him
21:24:49 <brunowolff> from him
21:25:30 * sdziallas nods and is indeed a bit worried about having one of our core technologies to distribute Fedora unmaintained. escalating it sounds reasonable, though I dunno if or when I'll get to that.
21:26:14 <kanarip> well, there's at least one person willing to take care of the problem, and then there's a bunch of people actually taking care of the problem, so don't worry
21:26:22 <sdziallas> okay :)
21:27:22 <brunowolff> If the lzma stuff happens I'll probably have a question or two how to handle choosing the compression method.
21:27:42 <kanarip> brunowolff, please send this rfe to the mailing list where i can find it so that i can then set a little time aside to look at it
21:27:44 <brunowolff> I figured on using the livecd-tools list for that discussion.
21:28:01 <brunowolff> The liveusb one?
21:28:09 <kanarip> brunowolff, yes
21:28:12 <brunowolff> OK.
21:28:32 <kanarip> brunowolff, most likely, concerning the choice and options, we'll choose one amongst ourselves, and stick with it
21:28:48 <kanarip> (that was: re: compression methods, that is)
21:29:12 <kanarip> it's been the way things have happened and the way things will most likely continue to happen
21:29:13 <kanarip> ;-)
21:29:51 <brunowolff> There are reasons to use the older zlib. I expect the default would be lzma if things work out. So probably there needs to be
21:30:02 <brunowolff> a command line option to choose the old one.
21:30:54 <kanarip> there are reasons to use apparmor over selinux, too
21:31:13 <warren> apparmor with fedora?
21:31:14 <kanarip> that doesn't concern the choice for superior technology under a meritocracy though
21:31:53 <kanarip> warren, i'm going to assume that when you asked that you hadn't seen the full reasoning behind my statement yet ;-)
21:31:58 <brunowolff> I meant for a particular custom build done by an end user using the tool, not for the officially distributed images.
21:32:18 <warren> how fast is compressing/using the lzma livecd?  lzma is WAYYYYYYYYYYYYYYYYYYY slower than gzip, and that stage of livecd is already very slow.
21:32:35 <wwoods> lzma *compression* is much slower
21:32:48 <pjones> oh god not this argument again
21:32:49 <brunowolff> I don't know yet. Though I was more worried about the uncompressing.
21:33:25 <warren> It takes my laptop about 12 minutes to make a livecd.  I suspect it would more than double that with lzma.
21:33:28 <wwoods> maybe let's not continue this discussion further without actual data.
21:33:30 <warren> maybe even more
21:33:30 <kanarip> the decompression would be the most significant factor, yes
21:33:44 <kanarip> the compression though, not as much a problem
21:34:09 <warren> I might note that the existing squashfs uses multiple cores to compress, while lzma can't.
21:34:29 <kanarip> you can wait a little extra once if it makes you the more happy that times more often
21:34:47 <warren> I'm saying it wont be a "little"
21:34:56 <wwoods> yes, but it's only *once*.
21:35:03 <wwoods> and 12 extra minutes is pretty trivial.
21:35:05 * maxamillion is *always* late .... silly $dayjob
21:35:06 <kanarip> warren, in comparison, it will always be a little if it's only once
21:35:25 <abadger1999> warren: Note, parallel lzma was recently pre-review packaged for some testing.
21:35:32 <warren> if you're spinning all the nightly livecd's you;'re waiting hours extra for all them to complete.
21:35:52 <kanarip> either way, once it's in, let's get the numbers straightened out like wwoods said, *then* make a decision
21:35:53 <warren> but fine, let's see how it performs, we can always undo it
21:36:48 <brunowolff> I expect to have squashfs-tools 4.1 (prerelease) available soon in rawhide.
21:36:58 <kanarip> warren, i am spinning all the nightly livecd's for multiple versions of Fedora on a daily basis, or at least i was before i lost my storage array
21:37:08 <brunowolff> I didn't get it done this past weekend, but it shouldn't be too hard to get working.
21:38:38 <kanarip> brunowolff, how about i put the lzma milestone entirely on your plate, and you tell the rest of us what to do when, in order for us to be able to make up our own minds, including performance benchmarking methods especially on the decompression side of things?
21:38:57 <brunowolff> Yes.
21:39:05 <kanarip> excellent!
21:39:20 <brunowolff> I was expecting to do some initial testing myself and put data on the feature page.
21:39:30 <kanarip> #agreed brunowolff in charge of the application of lzma compression wrt. live media
21:39:53 <kanarip> brunowolff, that's exactly what i anticipated would be useful for the rest of us
21:39:53 <brunowolff> For the space tight spins (including games) to add packages it needs to be pretty much ready in early January.
21:40:26 <brunowolff> We can go up to the feature freeze and still turn on the space savings.
21:41:08 <kanarip> as long as you have a path to return to old behaviour, you can continue testing the new feature up and until beta freeze/release
21:41:09 <brunowolff> But I think that's a bit late to be significantly modifying the design of spins to take advantage of extra space.
21:42:38 <kanarip> ok, anything else wrt. spins?
21:43:26 <brunowolff> I updated the spin sig process for handling releases, but didn't know what to do for the releng side.
21:43:55 <brunowolff> I am not sure where they document the process 9if they even have separate documentation).
21:44:22 <brunowolff> So that step from an action from two weeks ago is still open.
21:44:39 <kanarip> i'm sure they don't, but i'm not exactly in a position to have an opinion about how fp.o's release engineering does its job
21:45:02 <brunowolff> For now I won't worry about it further.
21:45:18 <brunowolff> I can't stay too late today as I have to go pick up my wife.
21:46:31 * kanarip motions to close the meeting
21:46:33 * kanarip closes the meeting in 4...
21:47:22 <kanarip> 3... 2... 1...
21:47:40 <kanarip> i hate waiting around in order to close a meeting
21:47:43 <kanarip> #endmeeting