gsoc16
MINUTES

#fedora-meeting-4: Fedora CommOps GSoC 2016 Community Bonding

Meeting started by jflory7 at 18:17:22 UTC (full logs).

Meeting summary

  1. Getting started (jflory7, 18:17:50)
    1. Mentors are going to be working on figuring out where students should be going and helping determine direction (jflory7, 18:18:05)
    2. http://etherpad.osuosl.org/fedora-gsoc-welcome-2016 (jflory7, 18:18:33)
    3. All GSoC students should be familiar with Infrastructure process to be familiar with where they fit into the picture (jflory7, 18:19:23)
    4. ACTION: gsoc_students Watch puiterwijk's Flock video series and slides (jflory7, 18:19:45)
    5. ACTION: jflory7 / skamath Look more into the Infra Apprentice on-boarding (jflory7, 18:20:36)
    6. There will be weekly status reports (jflory7, 18:20:49)
    7. Status reports can use: fedmsg, taskwarrior dumps, daily stand-ups, etc. (jflory7, 18:21:08)
    8. Daily Stand-ups: Good/Bad/Ugly - Yesterday/today/tomorrow (jflory7, 18:21:41)
    9. "Tickets or it didn't happen" (jflory7, 18:21:46)
    10. Weekly IRC meeting with your "core" subproject (infra, docs, design) (jflory7, 18:21:52)
    11. https://fedoraproject.org/wiki/Infrastructure/GettingStarted (jflory7, 18:22:26)
    12. Flock is a potential place to do project presentation / meetup since it is still during the GSoC mentoring period (jflory7, 18:23:24)
    13. ACTION: jflory7 Taking the playbooks being written with other parts of Fedora Infra (jflory7, 18:27:50)
    14. ACTION: jflory7 "How to contribute to Ansible playbooks in Fedora Infrastructure" guide (jflory7, 18:28:17)

  2. Stretch goals for jflory7 (jflory7, 18:29:20)
    1. There is some technical debt within Fedora playbooks (jflory7, 18:29:33)
    2. Ansible has changed much, there is a 2.0 API. Fedora was an early adopter and some features not being utilized in new API (jflory7, 18:29:58)
    3. ACTION: jflory7 To write playbooks using Ansible 2.0 API and possibly help porting past playbooks to Ansible 2.0 API (jflory7, 18:30:20)
    4. Most everything in Fedora does have a playbook, but if anything crops up, jflory7 can help write the playbooks and Ansible things for them (jflory7, 18:31:06)
    5. https://fedoraproject.org/wiki/GSOC_2016/Student_Application_jflory7#Project_Timeline (jflory7, 18:32:42)

  3. Other notes (jflory7, 18:35:26)
    1. May 23rd is the day new interns from GSoC, Outreachy, and Red Hat are "reporting for duty" (jflory7, 18:35:45)


Meeting ended at 18:50:04 UTC (full logs).

Action items

  1. gsoc_students Watch puiterwijk's Flock video series and slides
  2. jflory7 / skamath Look more into the Infra Apprentice on-boarding
  3. jflory7 Taking the playbooks being written with other parts of Fedora Infra
  4. jflory7 "How to contribute to Ansible playbooks in Fedora Infrastructure" guide
  5. jflory7 To write playbooks using Ansible 2.0 API and possibly help porting past playbooks to Ansible 2.0 API


Action items, by person

  1. gsoc_students
    1. gsoc_students Watch puiterwijk's Flock video series and slides
  2. jflory7
    1. jflory7 / skamath Look more into the Infra Apprentice on-boarding
    2. jflory7 Taking the playbooks being written with other parts of Fedora Infra
    3. jflory7 "How to contribute to Ansible playbooks in Fedora Infrastructure" guide
    4. jflory7 To write playbooks using Ansible 2.0 API and possibly help porting past playbooks to Ansible 2.0 API
  3. puiterwijk
    1. gsoc_students Watch puiterwijk's Flock video series and slides
  4. skamath
    1. jflory7 / skamath Look more into the Infra Apprentice on-boarding


People present (lines said)

  1. jflory7 (42)
  2. skamath (12)
  3. zodbot (7)
  4. linuxmodder (3)
  5. gsoc_students (0)
  6. puiterwijk (0)
  7. decause (0)


Generated by MeetBot 0.1.4.