releng
LOGS
16:00:05 <jednorozec> #startmeeting RELENG (2021-03-02)
16:00:05 <zodbot> Meeting started Tue Mar  2 16:00:05 2021 UTC.
16:00:05 <zodbot> This meeting is logged and archived in a public location.
16:00:05 <zodbot> The chair is jednorozec. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:05 <zodbot> The meeting name has been set to 'releng_(2021-03-02)'
16:00:16 <jednorozec> #meetingname releng
16:00:16 <jednorozec> #chair nirik sharkcz pbrobinson pingou mboddu dustymabe ksinny jednorozec
16:00:16 <zodbot> The meeting name has been set to 'releng'
16:00:16 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu nirik pbrobinson pingou sharkcz
16:00:16 <jednorozec> #topic init process
16:00:22 <nirik> morning
16:00:33 <jednorozec> good morning sir
16:01:26 <nirik> hey, how's things?
16:01:31 <nirik> Just us two today I guess?
16:02:16 <jednorozec> another nice and sunny day and I was sitting in front of computer
16:02:20 <jednorozec> how about you?
16:02:39 <nirik> foggy morning here. :)
16:02:57 * bhujji is here just following :)
16:03:13 <pingou> ó/
16:03:46 <bhujji> Its too windy here today with 27mph winds (dont know in metrics)
16:04:37 <nirik> :(
16:04:38 <mboddu> Its 43.45kmh
16:04:42 <jednorozec> yeah
16:04:50 * copperi is just lurking
16:05:36 <jednorozec> mboddu, time to get wind turbine :)
16:07:10 <jednorozec> I didnt have the currage to build another anemometer after 2019 thing blown away the last one
16:08:33 <jednorozec> so should we start form oldest tickets?
16:10:11 <nirik> we could. I had a few things I wanted to talk over too
16:10:24 <jednorozec> nirik, so go for it
16:10:52 <jednorozec> I checks a couple of the oldest tickets and we asked for info or commented on them in the past weeks
16:11:05 <nirik> So, whats the status on fedora-repos now? did we get everything merged, f36 key added?
16:11:28 <jednorozec> I think so
16:11:30 <bhujji> "so should we start form oldest tickets?" message got skipped on element.io/matrix
16:11:30 * jednorozec checks
16:11:58 <nirik> well, there's a number of new pr's now.
16:12:05 <bhujji> Yes, f36 is added to f35/rawhide, but I need to check others
16:12:12 <nirik> kparal made a change that automates things a lot.
16:12:32 <jednorozec> nirik, the key should be there https://src.fedoraproject.org/rpms/fedora-repos/c/30b5fc58b1c56ad06f2ed5ead277c4350bd1e231?branch=rawhide
16:13:04 <nirik> ideally, I'd like to get all pr's merged and rawhide all happy then we can sync that back to older releases.
16:13:10 <bhujji> Yup, we need to review them
16:13:54 <jednorozec> hmm this looks lovely https://src.fedoraproject.org/rpms/fedora-repos/pull-request/104#
16:14:19 <nirik> yeah. I am fully in favor of automating as much as we can. ;)
16:14:35 <bhujji> That AUTOVALUE thingy is very complicated
16:14:46 * bhujji got a chance to look at it, but didn't review it
16:15:29 <jednorozec> its huge PR
16:15:56 <nirik> yeah.
16:16:23 <jednorozec> I can do the review, but not sooner than tomorrow
16:17:06 <nirik> it's not a big hurry... just we should get it done.
16:17:15 <nirik> also fedora-release has some outstanding PR's...
16:17:40 <nirik> and I was thinking we might want to consider a policy... like if a PR is older than 14days or a month or something we close it.
16:17:49 <nirik> because we have some ancient releng ones.
16:18:21 <nirik> https://pagure.io/releng/pull-requests
16:18:26 <jednorozec> I would prefer if last comment is >14days
16:18:40 <nirik> anyhow, wish there was a better way to track and deal with PR's...
16:18:42 <jednorozec> because some things can take time to review/fix
16:18:53 <nirik> sure. true
16:19:51 <nirik> anyhow, just wanted to point out outstanding PR's and that we should try and process them, or close them
16:20:05 <jednorozec> that is a good point
16:20:34 <nirik> https://pagure.io/pungi-fedora/pull-requests also has a bunch of old ones
16:20:36 <jednorozec> ugh there are some 2years old in the releng repo
16:21:16 <nirik> yep.
16:21:57 <jednorozec> #action jednorozec to review https://src.fedoraproject.org/rpms/fedora-repos/pull-request/104
16:22:35 <nirik> for fedora-repos we should also try and get that pr in that tests
16:22:47 <bhujji> jednorozec: Also, https://pagure.io/fedscm-admin/pull-request/62#comment-143254 ?
16:23:23 <nirik> there's https://pagure.io/user/kevin/requests?type=actionable&status=open (put your username in for mine), but mine has too many projects I am on that I don't know/care about.
16:23:35 <jednorozec> bhujji, you should fix the tests
16:24:47 <jednorozec> nirik, I didnt know about that, will check the dashboard for myaccount every morning
16:24:52 <bhujji> Yeah, I need add the tests, hopefully I will get some time today
16:25:56 <nirik> I think those are the main ones... fedora-repos, fedora-release, releng, fedora-comps, fedora-kickstarts, pungi-fedora
16:30:37 <smooge> I have something for open floor/notice
16:32:08 <jednorozec> nirik, bhujji so can we agree on closing PR's with no activity over last month? Or PR's to f2* branches?
16:33:15 <bhujji> Close the PR if no response from the requestor, if its need our attention, then we should review it and comment on it
16:33:52 <bhujji> And yes, closing the f2* branch PR's is fine but ask them if they need it and if they do, ask them to update to current branches
16:34:07 <jednorozec> bhujji, ACK
16:34:51 * jednorozec will probably write comments all Wednesday :)
16:35:29 <nirik> sounds like a fun day. :)
16:39:05 <nirik> anyhow, thats my items I guess... tickets? or open floor?
16:41:27 <jednorozec> I was looking at the tickets with meeting tag but we did walk through a lot of them in the past weeks
16:42:07 <jednorozec> I would say open floor
16:42:18 <jednorozec> any objections or particular tickets?
16:43:05 <nirik> jednorozec: oh... can you do that FMN build soon?
16:43:08 <nirik> the windows one.
16:43:18 <nirik> we should get that version out the door
16:43:22 <jednorozec> nirik, oh there is another release?
16:43:57 <jednorozec> nirik, yup will do after dinner
16:44:21 <jednorozec> #topic Open Floor
16:44:36 <jednorozec> smooge, you had something?
16:45:00 <smooge> #info there is a netapp switch change happening this friday
16:45:02 <nirik> jednorozec: yeah, in that long ticket there was a second release.
16:45:22 <smooge> #undo
16:45:43 <nirik> smooge: thursday?
16:45:51 <smooge> #info There is a Netapp switch reboot Thursday (03/04) at 15:00 EST (20:00 UTC). there is no expected downtime but should be ok
16:46:18 <smooge> zodbot didnt take my undo so I am not sure my info exists either
16:46:46 <copperi> #info There is a Netapp switch reboot Thursday (03/04) at 15:00 EST (20:00 UTC). there is no expected downtime but should be ok
16:46:47 <smooge> this could potentially affect koji
16:46:59 <smooge> thanks
16:47:36 <smooge> that was all.
16:48:01 <bhujji> Thanks smooge
16:48:22 <nirik> thanks for bringing it up smooge. :)
16:50:04 <jednorozec> if that is all I would close the meeting and build FMW
16:52:24 <nirik> +1
16:52:30 <jednorozec> #endmeeting