releng
LOGS
16:01:32 <mboddu> #startmeeting RELENG (2021-01-12)
16:01:32 <zodbot> Meeting started Tue Jan 12 16:01:32 2021 UTC.
16:01:32 <zodbot> This meeting is logged and archived in a public location.
16:01:32 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:32 <zodbot> The meeting name has been set to 'releng_(2021-01-12)'
16:01:32 <mboddu> #meetingname releng
16:01:32 <zodbot> The meeting name has been set to 'releng'
16:01:32 <mboddu> #chair nirik sharkcz pbrobinson pingou mboddu dustymabe ksinny jednorozec
16:01:32 <mboddu> #topic init process
16:01:32 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu nirik pbrobinson pingou sharkcz
16:01:53 <nirik> morning
16:02:47 <jednorozec> hello
16:07:53 <mboddu> Hello guys
16:08:02 <mboddu> Sorry, I am doing 3 things at a time
16:08:25 <mboddu> This meeting will be short as I got some other work to take care of
16:08:28 <nirik> no worries.
16:08:49 <mboddu> #topic #9941 Unpush/delete nmap>=7.90 builds
16:08:55 <mboddu> #link https://pagure.io/releng/issue/9941
16:09:02 <nirik> yeah. ;(
16:09:23 <jednorozec> how are such things done?
16:09:49 <mboddu> I know we have done it for mongodb, but it was done by Dennis and I dont know what needs to be done
16:09:53 <nirik> in the past usually we just manually go and move those specific builds off the fedora_koji volume.
16:09:57 <mboddu> nirik: So, just tag those builds to trashcan?
16:10:06 <nirik> no. we move them complely out.
16:10:14 <nirik> trashcan would mean they would stay around for months
16:10:32 <jednorozec> we should also block it so new builds are not published right?
16:10:34 <nirik> if any of them pushed out we would need to make sure they are untagged from anything
16:10:59 <nirik> jednorozec: well, in this case the older builds are ok. we can't block the package if we want to ship those
16:11:17 <mboddu> So, koji untag f34 <builds> && koji set-build-volume <something> <nvr>?
16:11:57 <mboddu> They built a new build with previous version (non issue version), so we are good with the current stable version
16:11:59 <nirik> no, because any volumes we have are still accessable... to untag and then find those builds and 'mv build'
16:12:10 <nirik> I can do it if you all like...
16:12:21 <nirik> or you can, either way. :)
16:12:54 <jednorozec> it should be documented so nex time anyone can do it
16:13:15 <jednorozec> fpaste is enough I can add it into SOP then...
16:13:59 <nirik> sure. I guess really we want to rm those builds, but I would move them to /root/something on a machine so we have them in case of some weird need
16:14:01 <mboddu> nirik: I could do it, so, 'koji untag f34 <nvrs>' and then on /mnt/koji/ 'mv /mnt/koji/packages/nmap/7.91/* <something>'
16:14:21 <nirik> yep... if 7.91 is the only one...
16:14:31 <mboddu> Yup, thats the one
16:14:44 <mboddu> Cool, I will do it and document it
16:15:21 <mboddu> Oh sorry, jednorozec you wanna do it?
16:15:54 <jednorozec> mboddu, go for it if want
16:16:01 <mboddu> Okay
16:16:16 <mboddu> #action mboddu will run the necessary steps and update the documentation
16:22:02 <mboddu> #topic Open Floor
16:22:06 <mboddu> I got one thing
16:22:29 <mboddu> #info F34 mass rebuild is scheduled for Jan 20th which is next Wednesday
16:22:36 <nirik> I got one thing too...
16:22:52 <mboddu> Go ahead nirik
16:23:44 <nirik> I adjusted the fm-releng notifications to try and not spew unrelated things... so if you notice it notfying on something it shouldn't or should... let me know and we can adjust it more.
16:25:10 <mboddu> Thanks nirik
16:26:23 <nirik> thats all I had off hand
16:28:52 <mboddu> Okay, sorry for the short meeting
16:28:57 <mboddu> Catch you all next week
16:29:03 <mboddu> Thanks everyone for joining
16:29:06 <mboddu> #endmeeting