modularity
LOGS
15:00:00 <nils> #startmeeting modularity
15:00:00 <zodbot> Meeting started Tue Feb 26 15:00:00 2019 UTC.
15:00:00 <zodbot> This meeting is logged and archived in a public location.
15:00:00 <zodbot> The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:00 <zodbot> The meeting name has been set to 'modularity'
15:00:00 <nils> #meetingtopic Weekly Meeting of the Modularity Team
15:00:00 <nils> #topic Roll Call
15:00:08 <nils> .hello nphilipp
15:00:08 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:00:13 <contyk> .hello psabata
15:00:14 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:01:05 <langdon> .hello2
15:01:06 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:01:39 <sgallagh> .hello2
15:01:40 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:02:28 <nils> #topic Agenda
15:02:28 <nils> #info #112 Discussion: Module lifecycles
15:02:28 <nils> #info #115 Discussion: Stream branch ownership for packages & modules
15:02:38 <nils> anything else?
15:02:48 <contyk> I think asamalik has some news from yesterday
15:03:01 <nils> yeah but I think it fits into one of these two, doesn't it?
15:03:08 <contyk> yeah
15:03:11 <asamalik> .hello2
15:03:12 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:03:30 <nils> ok, let's get going
15:03:40 <asamalik> unfortunatelly I don't have any update to 115
15:03:44 <asamalik> but I do have an update to 112
15:03:46 <nils> #topic #112 Discussion: Module lifecycles
15:03:46 <nils> #link https://pagure.io/modularity/issue/112
15:03:46 <nils> .modularity 112
15:03:46 <nils> #link https://pagure.io/fesco/issue/2027
15:03:48 <zodbot> nils: Issue #112: Discussion: Module lifecycles - modularity - Pagure.io - https://pagure.io/modularity/issue/112
15:03:53 <nils> #chair asamalik
15:03:53 <zodbot> Current chairs: asamalik nils
15:04:05 <nils> here you go :)
15:04:49 <asamalik> So I have reworked the proposal completely, applying feedback I got so far, and had FESCo to discuss it yesterday.
15:05:58 <asamalik> Unfortunately, it's been rejected by FESCo, because there were people strongly against storing the EOL information in PDC, advocating for dist-git.
15:06:16 <contyk> that sounds like an implementation detail
15:06:29 <contyk> I mean, other aspects of the proposal would still be valid, right?
15:07:08 <asamalik> funny fact, the PDC (or FPDC) idea came from FESCo, and there were people in favour of it... but exactly what contyk says, it feels like an implementation detail?
15:07:45 <contyk> maybe the proposal could consider both (or more) options to be more acceptable
15:08:04 <nils> did they say why they were against (F)PDC in favor of dist-git?
15:08:24 <asamalik> contyk: probably?
15:08:36 <contyk> what would you say the next steps are then?
15:09:25 <sgallagh> I think the proper step is to rephrase the proposal to eliminate implementation suggestions.
15:10:08 <sgallagh> Instead of "should be stored in [F]PDC", it should read that "A database of this information must exist and a process for updating it must be written"
15:10:22 <asamalik> sgallagh: yeah probably, good point
15:10:38 <contyk> yes, but it should still consider some implementations of the database, otherwise it's vague and feels incomplete
15:10:52 <sgallagh> Well, it should set the requirements on the database, not the implementation
15:11:04 <asamalik> there were strong opinions about implementation details, but the overall concept seemed to be received ok
15:11:17 <langdon> "database" is also an implementation detail
15:11:22 <nils> it could list the different approaches as examples: "..., for instance store it in (F)PDC, or in a file in the dist-git repository"?
15:11:27 <sgallagh> langdon: "data store" then
15:11:28 <langdon> you want an "api to the data" you don't care how it is stored
15:11:44 <langdon> sgallagh: still impl ;)
15:11:46 <contyk> the database is langdon; you have to ask him everytime you need to know
15:11:51 <langdon> +1
15:11:58 <nils> Now I want his home phone number.
15:12:12 <langdon> via comms channel defined by time and day in eastern
15:12:25 <nils> :D
15:12:32 <contyk> and that info is stored in the database as well
15:12:39 <sgallagh> asamalik: Do you want me to attempt to wordsmith it and send a PR?
15:12:40 <langdon> dont forget daylight savings.. and a mistake on comms channel will delay response by, at a minimum, 2 weeks
15:12:49 <asamalik> sgallagh: that would be awesome!
15:12:56 <sgallagh> OK, #action me then
15:14:00 <asamalik> #action sgallagh will send a PR to the lifecycles proposal removing implementation details
15:14:02 <asamalik> sgallagh++
15:14:17 <langdon> sgallagh: i might write it in terms of the data to be surfaced ... e.g. "GET /v1/<rpm>/eol" or whatnot
15:14:36 <sgallagh> langdon: I'm not going to write the API spec, just a set of requirements it has to meet
15:15:46 <asamalik> anything else regarding that proposal?
15:15:56 * asamalik thinks we're good
15:16:05 <langdon> sgallagh: re-reading.. i think the "storing the info" might be able to just be cut.. the requirement is just an externallly accessible api for the data..
15:17:02 <sgallagh> langdon: Well, there are storage implications to consider.
15:17:28 <sgallagh> I'll see what it looks like as I write it and I'll link my PR around so others can send PRs to my PR :)
15:17:51 <contyk> that's good PR
15:17:56 <asamalik> like patches to patches to dwm!
15:20:27 <nils> I guess we're done now, right?
15:20:39 <asamalik> nils: yeah
15:20:50 <nils> #topic #115 Discussion: Stream branch ownership for packages & modules
15:20:50 <nils> #link https://pagure.io/modularity/issue/115
15:20:50 <nils> .modularity 115
15:20:50 <nils> #link https://pagure.io/fesco/issue/2028
15:20:52 <zodbot> nils: Issue #115: Discussion: Stream branch ownership for packages & modules - modularity - Pagure.io - https://pagure.io/modularity/issue/115
15:21:06 <nils> asamalik, you said no updates, so I'll push this to next week
15:21:11 <asamalik> nils: thanks
15:21:20 <nils> #info postponed until next meeting
15:21:30 <asamalik> I might just remove the label and set it when it's ready?
15:21:40 <nils> 👍
15:21:57 <nils> It sounds so obvious now you mention it. :D
15:22:12 <nils> #topic Open Floor
15:22:43 <nils> I have one: I've just submitted fedmod-0.5.0 as a Fedora update
15:23:08 <nils> #info fedmod 0.5.0 released and submitted as a Fedora update
15:23:11 <asamalik> nils: I think you should write a blog post or something about why it's helpful
15:23:27 * asamalik is not sure how many people know about the tool
15:23:35 <nils> yeah
15:24:10 <asamalik> we only mention it once in the docs, and that's for generating a modulemd
15:24:11 <nils> the issue with this is that it's really a collection of tools that do pretty different things
15:24:16 <langdon> asamalik: +1
15:24:29 <langdon> nils: so a long blog post :)
15:24:44 <nils> yeah, there's that and linting, and summarizing modules (from RPM repo metadata, meanwhile from build systems (MBS))
15:24:47 <nils> haha
15:25:29 <nils> I would have to find where to blog. I guess I have this same question every time someone suggests writing a blog to me. :)
15:25:45 <nils> For completeness sake though...
15:25:47 <langdon> communityblog.fp.o
15:26:04 <asamalik> langdon: +1
15:26:06 <langdon> nils: just write the content and adam or i will get it published
15:26:20 <nils> #info summarize-module can query information from build systems (MBS) alternatively to RPM repositories now
15:26:52 <asamalik> the communityblog is technically just a wordpress you log into with your FAS and write
15:26:56 <nils> #link https://bodhi.fedoraproject.org/updates/FEDORA-2019-5f16d857b1 F28 update
15:27:07 <asamalik> and coordinate with the group (CommOps) who helps with publishing
15:27:09 <nils> #link https://bodhi.fedoraproject.org/updates/FEDORA-2019-773ef3b70b F29 update
15:27:15 <langdon> asamalik: yeah... let's not scare him :)
15:27:16 <nils> asamalik, ahh good
15:27:28 <nils> I mean, WP is not good :) but I can manage I guess
15:27:33 <langdon> just write it.. when we can guide you through  the publishing fun
15:27:38 <langdon> s/when/then
15:27:43 <asamalik> or email langdon and he'll do that for you (T's and C's apply, I'm sure)
15:27:56 <langdon> and tips.. don't forget tips
15:28:24 <nils> #action nils write a blog post and get it published to communityblog.fedoraproject.org
15:28:29 <asamalik> yes, include at least 20 % of the email again as a tip :D
15:28:34 <contyk> "Did you know...?"
15:29:22 <nils> "Did you know, you too can wait 20 minutes to get a summary of the latest module builds from MBS?" :D
15:30:02 <nils> So, anything else?
15:30:45 <asamalik> nothing from my side
15:31:44 <nils> good
15:31:51 <nils> Thanks everybody!
15:31:55 <contyk> thanks
15:31:59 <nils> #endmeeting