modularity_wg
LOGS
15:00:03 <nils> #startmeeting modularity_wg
15:00:03 <zodbot> Meeting started Tue Jan  3 15:00:03 2017 UTC.  The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:03 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:03 <nils> #meetingtopic Bi-weekly Meeting of the Modularity Working Group
15:00:03 <nils> #chair dgilmore langdon tflink
15:00:03 <zodbot> Current chairs: dgilmore langdon nils tflink
15:00:08 * asamalik waves and wishes everyone a happy new year
15:00:15 <sgallagh> .hello sgallagh
15:00:15 <nils> #topic Roll Call
15:00:15 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:19 <nils> .hello nphilipp
15:00:20 <asamalik> .hello asamalik
15:00:20 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:00:23 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:00:23 <tflink> .hello tflink
15:00:27 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:00:28 <jkurik> .hello jkurik
15:00:29 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:00:32 <nils> Hello everyone, happy new year!
15:01:38 * nils looks around...
15:02:06 <nils> #topic Agenda
15:02:06 <nils> #info Should we have office hours? (langdon)
15:02:06 <nils> #info website updates by asamalik
15:02:06 <nils> #info design update by moto-timo
15:02:26 <nils> Does anybody have another topic to put on the agenda?
15:02:29 <contyk> .hello psabata
15:02:31 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:02:38 <jkurik> nils: yes, I have one
15:02:49 <jkurik> WG membership
15:03:31 <nils> #info WG membership
15:03:36 <nils> cool
15:03:54 <nils> #topic Should we have office hours?
15:04:03 <nils> langdon, are you around?
15:05:11 <dgilmore> hi all
15:05:27 <nils> Hmm, doesn't look like it.
15:06:00 <nils> #info Shelved for next week's meeting
15:06:19 <nils> #topic website updates
15:06:23 <nils> #chair asamalik
15:06:23 <zodbot> Current chairs: asamalik dgilmore langdon nils tflink
15:06:28 <nils> Adam?
15:07:03 <asamalik> I have created a repository for the website here https://pagure.io/modularity
15:07:14 <asamalik> #link https://pagure.io/modularity Fedora Modularity website repo
15:07:22 <asamalik> and did some initial work on the website
15:07:33 <asamalik> which can be previewed here: https://docs.pagure.org/modularity/
15:07:45 <asamalik> #link https://docs.pagure.org/modularity/ some initial work done
15:08:26 <asamalik> #info the design is a theme for Sphinx - so the website is built using Sphinx - already in Fedora
15:08:40 <asamalik> I'll appreciate feedback :)
15:09:34 <asamalik> Next steps:
15:09:39 <contyk> what's the reason for abandoning the wiki again?
15:09:53 <asamalik> agree if we like it or not
15:10:01 <asamalik> move the content from wiki there
15:11:13 <asamalik> contyk: to make it easier for newcomers to understand the project (the homepage will give them an idea)
15:11:41 <contyk> how does presenting the same content at a different URL make it easier to understand it?
15:12:41 <asamalik> contyk: the same except the landing page
15:13:14 <contyk> you could make a landing wiki page
15:13:35 <contyk> I don't see much benefit here, if any -- you just make it harder for people to contribute docs content
15:14:00 * contyk shrugs
15:14:40 <asamalik> contyk: well, we can also use the landing page only and leave the docs on wiki - that was one of the options as well
15:15:09 <nils> From what I've seen, this is still testing the waters right?
15:15:38 <asamalik> nils: yes, nothing set in stone
15:16:48 <asamalik> so we clearly need a way to decide what to do next :)
15:19:09 <nils> good. shall we go to the next topic?
15:19:56 <asamalik> I don't like the idea of a wiki landing page and I think that contributing content via git repo is not a problem and may give us a nicer output - so deciding if we prefer easier editing or better output (better at least from my perspective)
15:20:15 <langdon> hi all.. sorry i was late.. meeting seems to have dropped off my calendar
15:20:25 <asamalik> but let's talk about it next time when langdon is.... ha!
15:20:58 <asamalik> hey langdon
15:21:29 <langdon> sorry.. reading scrollback
15:21:59 <langdon> contyk, the idea is that we have more flexibility in a "real" website vs a wiki to make it more inviting.. but if it isn't doing much more it may not be worth it
15:22:19 <langdon> also.. many people these days find contributing content via PR easier than wikis
15:22:40 <langdon> because then you can rely on an "approval process" when you are afraid you may be wrong
15:22:44 <contyk> langdon: really?
15:22:48 * contyk doesn't know these people
15:22:52 <langdon> contyk, ha
15:23:03 <langdon> contyk should get out more
15:23:09 * langdon kids
15:23:35 <contyk> if you see a typo on a wiki page, you log in and fix it
15:24:12 <langdon> i understand.. but that isn't what people tend to do .. most people want to have the "author review".. at least in my recent experience
15:24:23 <contyk> if you see it on a standalone website, you need to figure out if its sources are hosted somewhere, you need to have an account in that system, you need to figure out how the website is coded, know the content language, fork it, clone it, fix it, push it and file  PR
15:24:48 <langdon> but .. asamalik wanted to take a stab at it.. if we think it is working.. we keep it.. if not.. then we stick with the wiki
15:24:57 <contyk> sure
15:25:45 <asamalik> contyk: but if we are choosing here between more inviting look and fixing typos in a web browser, I'm choosing the look
15:26:16 <langdon> gh allows you to fix typos in a web browser :)
15:26:36 <asamalik> contyk: btw there is no problem to have an "edit" link there pointing to the repo and (in github at least, not sure about pagure) you can fix it in browser and send a PR by a click of a button :)
15:26:57 <asamalik> contyk: https://developer.fedoraproject.org/tools/docker/about.html
15:27:02 <contyk> didn't know; see what I'd have to figure out?
15:27:09 <langdon> ha
15:27:13 <contyk> and then wait and hope it gets approved, merged and pushed to the website :)
15:27:20 <contyk> but clearly we have different priorities
15:27:23 <asamalik> contyk: there is an edit button :)
15:28:52 <asamalik> contyk: my priority is the end user and making the project visible :) if I have to click a bit more, I don't mind that much
15:28:56 <asamalik> so how do we decide?
15:29:16 <langdon> asamalik, is it up?
15:29:24 <langdon> or just partially coded?
15:29:29 <nils> Wasn't aware we're to make a decision here :)
15:29:29 <asamalik> langdon: https://docs.pagure.org/modularity/
15:29:39 <asamalik> no content, but design done
15:29:43 <langdon> ahh read that as www .. not docs
15:29:50 <asamalik> ha!
15:30:04 <langdon> nice
15:30:25 * langdon notes we should probably file a council ticket about using "fedora"
15:30:29 * asamalik needs to work on mobile view
15:30:37 <langdon> so who is doing content?
15:30:45 <asamalik> langdon: right!
15:30:45 <langdon> asamalik, are you taking a stab at that too
15:31:12 <langdon> ??
15:31:23 <asamalik> langdon: I can move all content in one morning - but need to be sure that we are moving to the website and that people will be updating it instead of the wiki
15:31:35 <langdon> ahh i see..
15:32:43 <langdon> i think we may need to move content in it to see if it works.. even if we may have to do it twice..
15:33:15 <asamalik> langdon: right, that makes sense
15:33:44 <asamalik> so I can make it ready for next week's meeting and we can see if it's better or not
15:33:44 <contyk> don't forget to update all the links pointing to modularity wiki pages
15:33:58 <langdon> contyk, ??
15:34:06 <langdon> you mean inbound from elsewhere?
15:34:26 <langdon> or do you mean that some of the links in the website are bad?
15:34:26 <contyk> if you move the content to an external website (assuming move is not the same as copy), you should update all the wiki pages that point to the current locations
15:34:37 <langdon> right.. yeah
15:36:05 <nils> Well, copy would be bad because redundant. Then some people would continue working with the wiki and others in the new place.
15:36:05 <langdon> next topic?
15:36:08 <asamalik> contyk: if we decide to move, I will update the wiki page with "document moved here" links - so no one gets lost
15:36:46 <contyk> yeah, either that or just update the links
15:36:51 <asamalik> nils: that's why I wanted to have the decision before moving anything :)
15:36:54 <langdon> probably both
15:37:02 <asamalik> langdon: yeah, both
15:37:24 <nils> asamalik: heh yeah
15:37:45 <asamalik> so what's the action on this? copy so we have preview? nothing? definitely not move right now :)
15:38:01 <asamalik> to close it before we switch topic
15:38:12 <nils> yup
15:38:26 <langdon> i would propose laying in content and seeing what it looks like.. also get some wider feedback..
15:38:36 <nils> and to clarify, "copy would be bad in the long run", not while we're still working out things
15:38:44 * nils nods
15:39:08 <asamalik> nils: right, copy just for the preview
15:39:19 <asamalik> ok, so I will copy the content and ask of feedback
15:39:55 <nils> asamalik: do you want to #action that?
15:39:57 <asamalik> #action asamalik copies content from wiki to the page and asks for wider feedback
15:40:00 <asamalik> nils: yes :)
15:40:06 <nils> 👍
15:40:09 <nils> asamalik++
15:40:09 <zodbot> nils: Karma for asamalik changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:40:39 <langdon> arent we in the f26 release cycle?
15:40:51 <nils> langdon: F25 is latest stable
15:40:56 <jkurik> we are not, the F26 has not been released yet
15:41:21 <langdon> ohh.. right.. i always think that message is talking about "upcoming release" .. not "current release"
15:41:26 <nils> langdon: do you want to do the "office hours" topic which I've shelved for next mtg before?
15:41:35 <langdon> sure
15:41:39 <nils> ok
15:41:59 <langdon> do you want me to #topic?
15:42:01 <nils> #topic Should we have office hours? (take #2)
15:42:04 <langdon> there it is
15:42:06 <langdon> :)
15:42:08 <nils> :)
15:42:41 <langdon> so.. basically... that is the question.. i think the f-2 folks are doing them.. and i thought it might be a way to raise publicity..
15:43:30 <jkurik> who are "f-2 folks" ?
15:43:38 <langdon> i think it would be useful if we named a person per "hour" .. like a schedule.. but generally see if we could all be there when we can
15:43:42 <langdon> factory-2
15:43:47 <langdon> jkurik, ^^
15:43:51 <jkurik> ok, thanks
15:44:10 <langdon> specifically, i think threebean is holding office hours
15:44:20 <contyk> what does it mean?
15:44:42 <langdon> just a time when anyone could drop in and ask questions..
15:44:58 <contyk> I see
15:44:59 <langdon> would be promised to not be interrupting anything.. no agenda..
15:45:23 <langdon> if we are keeping this at every 2 weeks.. we could just do the alternate week
15:45:30 <langdon> and have it in #f-m
15:45:40 <asamalik> so we would explicitly say "we are here for you at this time, ask us anything"
15:45:45 <langdon> which is confusing :) fedora-modularity
15:45:50 <langdon> asamalik, exactly
15:45:50 <asamalik> right?
15:45:54 <langdon> just like reddit
15:45:59 <langdon> ;)
15:46:13 <nils> You mean bi-weekly AMAs?
15:46:26 <langdon> kinda :)
15:46:27 <contyk> I vote langdon should be doing that, he's the least busy person here
15:46:43 <langdon> contyk, +1!
15:47:31 <langdon> they are kinda handy for the "answerer" because they are a garaunteed hour when you can't be in other meetings and you can focus .. cause people don't often show up :)
15:47:32 <asamalik> I think there is nothing to loose - why not try it - I like the idea
15:48:00 <contyk> although there's generally someone available 24/7 already :)
15:48:16 <langdon> contyk, yeah.. thats actually why i am not sure it matters
15:48:36 <langdon> contyk, but.. we can publicize it.. and that may make a difference
15:48:49 <asamalik> contyk: "you can try to ask anytime, but at this exact time we guarantee an answer" - just said better :)
15:49:54 <langdon> ok.. so ill send out an email?
15:50:29 <nils> asamalik: *"we guarantee someone is there who is supposed to answer"
15:50:30 <asamalik> langdon: go for it :) so it will be in 14 days from now, right?
15:50:34 * nils channels his inner lawyer
15:50:36 <asamalik> nils: haha!
15:50:54 <langdon> nils, we promise an answer.. no promise on quality
15:51:09 <jkurik> I can put it to Fedocal as well
15:51:17 <langdon> ok..
15:51:21 <langdon> jkurik, cool.. thanks
15:51:35 <langdon> #action langdon to send out an announcement about office hours.
15:51:54 <langdon> i am planning to say brt, modularity, etc .. :)
15:52:03 <nils> langdon: "... the real answer might disturb you."
15:52:03 <langdon> contyk, think you can be around too?
15:52:14 <langdon> nils, i am pretty disturbed
15:52:20 <contyk> I'm always around
15:52:23 <langdon> ha
15:52:42 <langdon> now that znc is fixed, i am too ;)
15:52:56 <asamalik> nils: just typing "ice cream" is also an answer - and yes, it might disturb you :)
15:53:02 <contyk> although the weechat android client not working on nougat makes replying on the go a little annoying
15:53:09 <nils> langdon: I didn't quite quote our secretary of state there ;)
15:54:39 <langdon> ok.. next?
15:54:42 <langdon> we have 6m
15:55:18 <nils> #topic design update
15:55:36 <nils> hmm, moto-timo isn't there
15:55:51 <nils> #info shelve this topic for next meeting
15:55:56 <nils> #open floor
15:55:59 <nils> oops
15:56:02 <nils> #topic open floor
15:56:18 <jkurik> I have an update on the WG membership
15:56:22 <asamalik> I have created a ticket for the Design Team about the logo: https://fedorahosted.org/design-team/ticket/490
15:56:22 <langdon> curious what "#open" would do :)
15:56:32 <langdon> ohh.. right
15:56:38 <langdon> #topic WG membership
15:56:42 <jkurik> As agreed on the last WG meeting, prior the Christmas, I have contacted all the current WG members [1] having voting privilege.
15:56:47 <jkurik> [1] https://fedoraproject.org/wiki/Modularity_Working_Group
15:56:52 <jkurik> I have got a replay only from five of them: mikedep333, cydrobolt, sct, dgilmore, tflink
15:56:56 <jkurik> sct and tflink would like to stay as WG members with voting privilege
15:57:00 <jkurik> mikedep333 and cydrobolt were not much active during the recent time however they would like to stay as members and start to contribute soon
15:57:05 <jkurik> dgilmore is willing to continue, however as he is busy with other tasks he would not mind to give his position in WG to someone who will be more active, if any
15:57:10 <jkurik> I do not have any feedback from others: Harald, Langdon :)
15:57:14 <jkurik> So, that is the brief summary...
15:57:24 * langdon was pretty out of it over the break
15:57:56 <langdon> jkurik, so what is our next step?
15:58:01 <jkurik> langdon: we can postpone this to the next week meeting, so people have a bit more time after vacations
15:58:40 <jkurik> langdon: as I understand we need to decide what WG members will have voting priviledge
15:59:05 <langdon> jkurik, ok.. so .. we just need me to respond.. and i can ping harald to respond too
15:59:15 <jkurik> ok
15:59:22 <langdon> try to wrap that part up by next meeting?
16:00:45 <jkurik> ok, lets discuss the next steps the next week
16:03:10 <langdon> nils, want to close this up?
16:03:14 <langdon> do we need an action?
16:03:36 <nils> langdon: I don't know about if we need an #action for that, jkurik
16:03:37 <nils> ?
16:03:39 <jkurik> no need for an action, lets have it as a topic on the next meeting
16:03:49 <langdon> cool
16:04:10 <nils> okay
16:04:25 <nils> thanks everyone!
16:04:27 <nils> #endmeeting