modularity_wg
LOGS
15:00:39 <nils> #startmeeting modularity_wg
15:00:39 <zodbot> Meeting started Tue Jul 26 15:00:39 2016 UTC.  The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:39 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:39 <nils> #meetingtopic Weekly meeting of Modularity WG
15:01:25 <nils> #chair dgilmore-afk haraldh jkurik_mtg langdon tflink threebean
15:01:25 <zodbot> Current chairs: dgilmore-afk haraldh jkurik_mtg langdon nils tflink threebean
15:01:40 <nils> #topic Roll Call
15:01:42 <jkurik_mtg> .hello jkurik
15:01:43 <zodbot> jkurik_mtg: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:01:46 * threebean 
15:01:46 <nils> .hello nphilipp
15:01:47 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:01:48 <moto-timo> .hello ttorling
15:01:50 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:02:10 <contyk> .hello psabata
15:02:11 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:02:24 <lkocman> .hello lkocman
15:02:25 <zodbot> lkocman: lkocman 'None' <lkocman@redhat.com>
15:02:31 <cpacheco> .hello cpacheco
15:02:31 <zodbot> cpacheco: cpacheco 'Courtney Pacheco' <cpacheco@redhat.com>
15:02:38 <asamalik> .hello asamalik
15:02:40 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:03:01 <langdon> .hello langdon
15:03:03 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:03:30 <nils> anybody else?
15:03:48 <nils> #topic Agenda
15:04:15 <tflink> .hello tflink
15:04:16 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:04:19 <sctw> .hello sct
15:04:19 <zodbot> sctw: sct 'Stephen Tweedie' <sct@redhat.com>
15:04:20 <tflink> sorry, a bit late
15:04:28 <nils> #info Modularity badge theme decision
15:04:40 <nils> #info Demo Overview
15:04:54 <nils> #info Open Floor
15:05:19 <nils> probably should have waited with the open floor... anything else?
15:05:26 <nils> #undo
15:05:26 <zodbot> Removing item from minutes: INFO by nils at 15:04:54 : Open Floor
15:05:39 <nils> ok
15:05:44 <nils> #info Open Floor
15:05:59 <nils> #topic Modularity badge theme decision
15:06:01 <langdon> nils, update from lkocman about rida status
15:06:06 <nils> ahh
15:06:09 <nils> #undo
15:06:09 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4a376a10>
15:06:10 * langdon thought threebean wouldn't be here
15:06:14 <nils> #undo
15:06:14 <zodbot> Removing item from minutes: INFO by nils at 15:05:44 : Open Floor
15:06:21 <lkocman> threebean: you or me?
15:06:33 <nils> #info Rida Status
15:06:37 <nils> #info Open Floor
15:06:40 <nils> #topic Modularity badge theme decision
15:06:45 <lkocman> I did write summary here https://paste.fedoraproject.org/395784/45593146/
15:06:55 <nils> lkocman: later :)
15:07:06 <lkocman> coolio
15:07:13 <nils> #info https://fedorahosted.org/fedora-badges/ticket/466
15:07:47 <nils> There's a couple of themes/ideas that the design team could go with regarding badges for modularity group membership
15:08:05 <nils> They're listed in the ticket, I'll post a summary here:
15:08:17 <nils> jigsaw puzzle/pieces (caveat: symbol for some Autism Spectrum Disorder organizations), actual jigsaw
15:08:17 <nils> legos
15:08:17 <nils> space vehicles (space station out of modules, ...)
15:08:17 <nils> molecular chemistry
15:08:18 <nils> parts of radio, circuit board, motherboard
15:08:20 <nils> more organic: a basic lifeform has a circulatory system, digestion system
15:08:22 <nils> parts of any vehicle or automobile
15:08:49 <nils> check out the ticket for more background of each idea/theme
15:08:56 <contyk> no breadcrumbs?
15:09:08 <nils> did I miss that one?
15:09:16 <contyk> probably not :)
15:09:20 <nils> not in the ticket :)
15:09:51 <nils> anyway, we, that is the voting members present, need to decide on one of these so the design folks can do their thing
15:10:17 <nils> #info decision needed regarding which idea/theme should be worked on by design team
15:10:36 <moto-timo> +1 space vehicles
15:10:42 <langdon> +1 legos
15:10:46 <nils> I was getting to that
15:11:04 <langdon> i withdraw my vote :)
15:11:08 <nils> There's no rule I could find re: how we should vote on "one out of many".
15:11:08 <lkocman> +1 legos
15:11:20 <tflink> +1 legos
15:11:28 <jkurik_mtg> +1 chemistry/atom
15:11:42 <asamalik> +1 legos
15:11:48 <nils> So, #1 I'll only count voting members, sorry to the rest of you ;)
15:12:33 <moto-timo> any trademark issues with legos?
15:12:41 <lkocman> we can call it not-lego right?
15:12:45 <nils> and #2 I guess with the few people around, maybe it makes sense if every voting member not only have one vote, but can vote for any idea they like?
15:12:47 <nils> dunno.
15:13:00 <langdon> im for #2
15:13:13 <nils> moto-timo: we won't call it lego-anything, I'm sure
15:13:23 <nils> it will look like generic building block thingies
15:13:29 <moto-timo> +1
15:13:41 <langdon> moto-timo, my worry about legos and trademark too.. but a pic of something made of legos can still be in public domain
15:13:55 <nils> anyway, voting members: how do you want to vote on that -- only one vote per member, or distribute between ideas?
15:14:14 <nils> langdon: and it's gonna be a badge, so a drawing anyway
15:14:21 <nils> no real legos to be harmed in the process
15:14:33 <jkurik> nils: one vote per member
15:14:37 <moto-timo> "interlocking bricks"
15:15:00 <nils> jkurik: ok. any objections to that from the "voting populace"?
15:15:04 * tflink is all for whatever is most simple and gets the job done
15:15:21 <contyk> tflink: that would be an empty badge :)
15:15:37 <tflink> contyk: in terms of how we vote :-P
15:15:41 <asamalik> contyk: an empty badge with lego on it would be great :)
15:15:59 <nils> langdon, threebean, haraldh, langdon, dgilmore-afk?
15:16:10 * nils sits this out for a minute
15:16:30 <moto-timo> https://www.google.com/search?q=lego+vector+art&tbm=isch&imgil=qwXYl6QD8rkkKM%253A%253Bt8xn7g-yHxTBhM%253Bhttp%25253A%25252F%25252Fwww.clipartbest.com%25252Ffree-lego-vector&source=iu&pf=m&fir=qwXYl6QD8rkkKM%253A%252Ct8xn7g-yHxTBhM%252C_&usg=__oPpizmvTgG9AZq51fjCDE-dBgD8%3D&biw=960&bih=1025&ved=0ahUKEwiW6qyJtpHOAhUI32MKHY70DdwQyjcINQ&ei=tX6XV9a7F4i-jwOO6bfgDQ#imgrc=qwXYl6QD8rkkKM%3A
15:17:04 <nils> okay
15:17:08 <nils> one vote per member
15:18:43 <nils> I have langdon, tflink for "legos", jkurik for "chemistry"
15:19:02 <nils> threebean, haraldh, dgilmore-afk?
15:19:41 <nils> I guess not.
15:19:51 <contyk> how about this one?
15:19:54 <contyk> http://images.all-free-download.com/images/graphicthumb/lego_smiley_sad_clip_art_31777.jpg
15:19:59 <contyk> ;)
15:20:16 <contyk> ...from moto-timo's link
15:20:22 <nils> I'm not sure that "sad face" conveys the right idea ;)
15:20:32 <lkocman> or this one http://gamesnosh.com/wp-content/uploads/2015/04/The-Lego-Movie-Chris-Pratt.jpg
15:20:49 <sgilson> .hello sgilson
15:20:49 <zodbot> sgilson: sgilson 'Stephen Gilson' <sgilson@redhat.com>
15:21:08 <nils> So, I have two for legos, one for chemistry, that makes it legos.
15:21:10 <nils> Concur?
15:21:58 <moto-timo> http://edition.cnn.com/2010/BUSINESS/09/15/eu.lego.trademark/
15:22:14 <moto-timo> court rules LEGO brick not a trademark :)
15:22:22 <langdon> woot!
15:22:38 <langdon> maybe add in the note to run it by legal?
15:22:38 <asamalik> cool!
15:22:48 <langdon> and give a fall back if legal is unhappy?
15:22:54 <asamalik> so let's just use something like three or four lego blocks?
15:23:01 <moto-timo> http://www.lego.com/en-us/legal/legal-notice/fair-play
15:23:01 <tflink> do we have enough voting members to take a vote right now?
15:23:13 <jkurik> langdon, tflink: ok guys, you have won
15:23:17 <nils> tflink: good question :)
15:23:49 <langdon> tflink, i vote for yes :) .. we could ML it if we wanted
15:24:15 <nils> it's up to you guys I guess
15:24:20 <tflink> 3 people seems a bit thin but at the same time, It'd be nice to just be done with the discussion instead of dragging on forever :)
15:24:22 <nils> fine with me either way
15:24:27 <nils> yup
15:24:34 <moto-timo> +1
15:24:48 <tflink> how about "yes unless the missing voting members put their votes for something different in a ticket by the end of this week"?
15:24:53 <langdon> tflink, how about we send a note to the ML with a deadline.. if no one answers by the deadline the answer is lego.. make the deadline 1 week?
15:25:04 <tflink> sounds good to me
15:25:14 <nils> who does that?
15:25:29 <langdon> im taking volunteers :)
15:25:35 <langdon> but i can do it if necessary
15:25:46 <nils> I'm voluntelling that it should be one of the present voting members :o)
15:26:06 * langdon notes nils has a new favorite phrase
15:26:14 <jkurik> I can do it
15:26:28 <nils> langdon: I'll do all to at least make it sound official :P
15:26:42 <nils> jkurik: cool
15:27:36 <nils> #action jkurik inform voting members via the ML about the preliminary decision for "lego-like bricks", with a deadline until which they should object or be henceforth silent
15:27:45 <langdon> jkurik, woot! jkurik the voting genius..
15:27:49 <nils> I'm getting the hang of this
15:27:56 <nils> good, next one
15:28:06 <sgilson> whatever that is, I vote for it just based on the use of "henceforth"
15:28:22 <nils> #topic Demo Overview
15:28:27 <nils> #undo
15:28:27 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x483d5690>
15:28:29 <nils> #topic Demo Overview
15:28:33 <langdon> nils, you forgot #action :)
15:28:42 <nils> langdon: no I didn't
15:28:56 <nils> right before your "woot"
15:29:04 <jkurik> langdon: I already have one; it is enought
15:29:17 <nils> asamalik: the floor is yours
15:29:42 <langdon> nils, duh :)
15:29:46 <asamalik> we have recorded our demos for the sprint 10
15:30:03 <asamalik> and they are on the following youtube playlist:
15:30:19 * langdon opens web page on "how to read"
15:30:20 <asamalik> https://www.youtube.com/playlist?list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG
15:30:39 <nils> (...which is actually middle of sprint 10 because it was extended...)
15:31:03 <asamalik> exactly :)
15:31:10 <asamalik> that's all from me
15:31:13 <nils> just in case someone gets confused in two weeks because we'll be doing another round of demos I guess
15:31:16 <nils> good
15:31:33 <nils> #info https://www.youtube.com/playlist?list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG
15:31:49 <nils> #topic Rida Status
15:31:50 <langdon> asamalik, can you also link to the root of the demo folder on fedora people? so people who are not yt fans can see them?
15:31:52 <langdon> also...
15:31:55 <langdon> #undo
15:31:55 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x47abab50>
15:31:56 <nils> #undo
15:31:56 <zodbot> Removing item from minutes: INFO by nils at 15:31:33 : https://www.youtube.com/playlist?list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG
15:32:01 <nils> ugh
15:32:01 <langdon> ha
15:32:04 <nils> #info https://www.youtube.com/playlist?list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG
15:32:17 <langdon> i would like to call out the awesomeness of the overview video
15:32:17 <nils> asamalik: just #info and the link
15:32:23 <langdon> asamalik, link to that too please?
15:32:24 <nils> yep
15:32:27 <asamalik> https://fedorapeople.org/groups/modularity/sprint-10-demo/
15:32:27 <nils> asamalik++
15:32:28 <zodbot> nils: Karma for asamalik changed to 3 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:32:42 <asamalik> #info https://fedorapeople.org/groups/modularity/sprint-10-demo/
15:32:49 <nils> ace
15:33:00 <nils> ok, next
15:33:04 <nils> #topic Rida Status
15:33:07 <lkocman> #info https://paste.fedoraproject.org/395830/54716514
15:33:11 <lkocman> status available at ^
15:33:14 <nils> that was quick :)
15:33:19 <lkocman> (permanent link) :-)
15:33:31 <lkocman> next … :-)
15:33:46 <langdon> any comments?
15:34:26 <lkocman> just a “curiosity” how many folks here seen rida demos?
15:34:33 <contyk> I'll note we don't use dashes in dist tags
15:34:46 <lkocman> you mean underscores right?
15:35:01 <contyk> nope
15:35:15 <lkocman> in code we actually do replace - with _
15:35:20 <nils> yeah, dashes are forbidden in releases
15:35:22 <lkocman> so it should be all underscores
15:35:24 <lkocman> sorry for confusion
15:35:29 <nils> ugh, magic :)
15:35:45 <lkocman> nils: it just takes module mvr and does that transformation
15:35:52 <lkocman> not much of pixie dust
15:35:54 <nils> lkocman: understood :)
15:36:29 <lkocman> there is currently a convesation with rel-eng to be done … on how to not fence with system-release package as far as dist macro goes
15:36:50 <lkocman> I’d like to talk about it on flock with dgilmore and folks
15:36:56 <nils> what do you mean "fence"?
15:37:03 <lkocman> like both packages are providing dist macro
15:37:09 <lkocman> and the alphabetically last wins :-)
15:37:13 <nils> "both"?
15:37:22 <lkocman> fedora-release and module-build-macros
15:37:31 <lkocman> that’s why I built custom fedora-release which doesn't
15:37:38 <nils> ahh
15:37:56 <lkocman> nils: we want some generic-release that wouldn’t provide dist
15:38:03 <lkocman> but would provide all rest of goodies that system-release packages do
15:38:05 <nils> that makes sense
15:38:16 <lkocman> or get karsten’s patch merged into koji :-)
15:38:22 <lkocman> whatever is more likely to happen ;-)
15:38:44 <nils> Good. Any other comments or questions?
15:39:04 <nils> None.
15:39:19 <nils> #topic Open Floor
15:39:44 <nils> Anybody got something for open floor?
15:40:07 <moto-timo> https://lists.fedoraproject.org/archives/list/golang@lists.fedoraproject.org/thread/RD6TA5X3HR3XCPBLF7Z3E5D34PO6NEDW/
15:40:28 <moto-timo> just to point out that modularity approach will help solve the golang quagmire
15:41:08 <langdon> moto-timo, "we" should answer that..
15:41:37 <nils> moto-timo: can you summarize how it should help? That's an awfully long mail and not everybody is familiar with the difficulties of golang :o)
15:41:41 <langdon> i am in the midst of initiating a relationship with the server-wg along the lines of the proposal to "build server from modules in stg" by devconf
15:42:09 <moto-timo> most golang packages are never released, just pinned to a git commitish
15:42:22 <nils> ugh, what a mess ;)
15:42:22 <moto-timo> different apps require different commitishes
15:42:34 <langdon> ha.. thats what i proposed for modularity.. except for the "released" part ;)
15:42:35 <moto-timo> so update a golang package and tick-tick-boom
15:42:44 <moto-timo> everything else fails
15:42:56 <contyk> oh and I should say we're also finally thinking about some of the base modules so if you have any opinions on what should go in the base, please share
15:43:22 <nils> contyk: is that another topic, or related to the golang thing?
15:43:29 <contyk> it's unrelated
15:43:37 <langdon> re: base-runtime, check out contyk's demo: https://www.youtube.com/watch?v=IKUioQTl-Bo&list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG&index=2
15:43:38 <nils> okay
15:43:45 <langdon> mine was too
15:44:26 <langdon> comments?
15:44:28 <nils> moto-timo: "modularity can help with issues that the golang ecosystem is facing" + link, sounds good for #info?
15:44:38 <moto-timo> +1
15:45:16 <nils> #info modularity can help with issues that the golang ecosystem is facing, see: https://lists.fedoraproject.org/archives/list/golang@lists.fedoraproject.org/thread/RD6TA5X3HR3XCPBLF7Z3E5D34PO6NEDW/
15:45:48 <nils> anybody got something to add/ask re: base runtime modules?
15:46:12 <nils> nothing? good
15:46:21 <nils> any other topic for open floor?
15:46:57 <langdon> nils, just mine above
15:47:14 <nils> ahh
15:48:29 <nils> #info we're looking for opinions about what should go in the base module(s), see contyk's demo: https://www.youtube.com/watch?v=IKUioQTl-Bo&list=PLcwHJG45BmAN0XNiNsLbF7203HCNBPZWG&index=2
15:48:36 <nils> langdon: sounds good? ^^
15:48:41 <langdon> anyone want to start representing modularity in the server-wg? like hanging out on their meetings/mls and such?
15:48:52 <langdon> nils, sorry.. no the server-wg stuff
15:49:02 <langdon> <langdon> i am in the midst of initiating a relationship with the server-wg along the lines of the proposal to "build server from modules in stg" by devconf
15:49:19 <lkocman> fa
15:49:28 <nils> langdon: don't understand, is the #info above good, or shall I undo it?
15:49:48 <langdon> nils, ohh its good.. but not the "next open floor item"
15:50:33 <nils> I'm probably missing something ;)
15:50:38 <nils> but that's okay
15:50:42 <langdon> ha..
15:51:36 <nils> langdon: I can info that we're looking for someone to go to the server WG meetings. Or does this need more discussion?
15:51:47 <langdon> that sounds good..
15:53:00 <nils> #info The Modularity WG is looking for someone to represent the effort in the Server WG, meetings, mailing lists.
15:53:17 <nils> langdon: ^^ like this?
15:53:39 <langdon> nils, yeah.. cool
15:53:48 <nils> good
15:53:50 <nils> anything else?
15:54:27 <nils> apparently not
15:54:39 <nils> #endmeeting