commops
LOGS
20:56:52 <jflory7> #startmeeting Fedora CommOps Hack Session (2016-06-03)
20:56:52 <zodbot> Meeting started Fri Jun  3 20:56:52 2016 UTC.  The chair is jflory7. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:56:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:56:52 <zodbot> The meeting name has been set to 'fedora_commops_hack_session_(2016-06-03)'
20:56:55 <jflory7> #meetingname commops
20:56:55 <zodbot> The meeting name has been set to 'commops'
20:57:01 <jflory7> #topic Roll Call
20:57:03 <jflory7> .hello jflory7
20:57:05 <zodbot> jflory7: jflory7 'Justin W. Flory' <me@justinwflory.com>
20:57:08 <skamath> .hello skamath
20:57:09 <zodbot> skamath: skamath 'Sachin S Kamath ' <sskamath96@gmail.com>
20:57:11 <jflory7> #chair skamath
20:57:11 <zodbot> Current chairs: jflory7 skamath
20:57:14 <jflory7> Hiya :)
20:57:17 <skamath> Hey :)
20:57:44 <jflory7> #info We're using Google Hangouts for tonight's hack session: please try connecting at the following link!
20:57:45 <jflory7> #link https://hangouts.google.com/call/en5lzau3tffx3goxsaccqsq5tye
20:57:56 * jflory7 is away getting some coffee before we officially start
21:01:08 <jflory7> #link https://etherpad.gnome.org/p/commops-power-sessions
21:02:20 <decause> .hello decause
21:02:21 <zodbot> decause: decause 'Remy DeCausemaker' <decause@redhat.com>
21:02:36 <skamath> #chair decause
21:02:36 <zodbot> Current chairs: decause jflory7 skamath
21:02:43 <skamath> decause: o/
21:02:49 <jflory7> Hiya Remy :)
21:03:15 <jflory7> Whoops, lol, have dogs in the background
21:03:20 <skamath> lol
21:03:31 <jflory7> Hiya, decause!
21:03:38 <jflory7> Will unmute mic once dogs quiet down a bit. :)
21:03:50 <jflory7> How's PyCon going so far?
21:04:00 <jflory7> Hear you :)
21:04:54 <jflory7> mizmo++
21:05:21 <jflory7> Got this here: https://etherpad.gnome.org/p/commops-power-sessions
21:24:31 <jflory7> #topic How To Push a Badge 101
21:24:55 <jflory7> #info Ralph (threebean) explained how to push a badge in Fedora Infrastructure with a screenshare walkthrough
21:25:13 <jflory7> #info === Prerequisites ===
21:25:35 <jflory7> #info 1) Cloned `badges` repository where all badges live: https://git.fedorahosted.org/cgit/badges.git
21:25:41 <jflory7> Q: Is Badges going to live on Pagure someday?
21:26:06 <jflory7> #info 2) Sysadmin privileges on Batcave and badges-web
21:26:21 <jflory7> #info === Taking care of art assets ===
21:26:47 <jflory7> #info 1) Go to the ticket for a badge and pull the artwork assets (both png and svg) into the `badges` repository
21:27:12 <jflory7> #info 2) Place art assets into their appropriate folder, preferred to name image files the name of the badge for easy indexing later on
21:27:43 <jflory7> #info 3) Double-check to make sure the image assets you pulled down are "good" - sometimes the images can be corrupted and this can cause problems later
21:28:10 <jflory7> #info Add the files in git, commit, push (or if you don't have push privileges, make a patch and add it to the ticket to save time...??)
21:28:13 <jflory7> #undo
21:28:13 <zodbot> Removing item from minutes: INFO by jflory7 at 21:28:10 : Add the files in git, commit, push (or if you don't have push privileges, make a patch and add it to the ticket to save time...??)
21:28:17 <jflory7> #info 4) Add the files in git, commit, push (or if you don't have push privileges, make a patch and add it to the ticket to save time...??)
21:28:32 <jflory7> #info === Pushing out the badge ===
21:28:58 <jflory7> #info Important to note that just because you push to fedorahosted does not mean the badge is "out there" yet - introducing the powers of Ansible yet again
21:29:25 <jflory7> #info 1) Log into the `batcave` machine in Fedora Infrastructure and locate the `push-badges` playbook
21:29:56 <jflory7> #info 2) Sysadmins with privileges will be able to run the playbook to pull the changes from fedorahosted to batcave - the changes then get synced to the badges-web server
21:30:38 <jflory7> #link https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/playbooks/manual/push-badges.yml
21:31:01 <jflory7> #info 3) Wait for playbook to finish, check if the png is publicly viewable on badges.fp.o
21:31:10 <jflory7> #info === Adding a badge from badges.fp.o ===
21:31:49 <jflory7> #info Once the art assets are on badges-web, you will be ready to make the badge. BEWARE: Creating a badge is easy, but editing it is not! Make sure the information you are entering is right on the first go.
21:31:59 <jflory7> #info 1) Log into admin interface on badges.fp.o
21:32:09 <jflory7> #info 2) Go to add badge section
21:33:15 <jflory7> #info 3) Enter in the information (e.g. pull the badge name / description from the ticket, enter the correct image location for the badge), hit "Create badge" button
21:34:03 <jflory7> #info 4) In admin interface, grant privileges to appropriate person (IF NOT AN AUTOMATIC BADGE) at bottom of the interface. Use badge name and @fedoraproject.org email for the person who needs privileges
21:34:09 <jflory7> #info === Success! ===
21:34:22 <jflory7> #info Congratulations! You pushed a badge.
21:34:24 <jflory7> eof
21:34:29 * skamath was away for a while. Thanks jflory7
21:34:35 <skamath> jflory7++
21:34:50 <jflory7> No problem! I'm probably going to refer back to this pretty frequently anyways :P
21:34:55 <jflory7> decause: All of the above sound about right?
21:35:25 <skamath> jflory7: No editing interface, eh?
21:35:46 <jflory7> skamath: Not quite. Apparently to edit a badge later (with the exception of adding tags), it requires editing SQL tables. :P Yuck.
21:35:55 <skamath> So you basically go to PG and edit it, damn
21:36:12 <jflory7> There is an interface for badge admins to add tags to a badge later, but not remove them
21:36:17 <jflory7> Heh, yep.
21:37:45 <jflory7> #action jflory7 Write up a SOP on pushing a badge for Fedora Infra if there is not one already (make any improvements if there is one?)
21:39:54 <skrzepto> it helps when i type the correct channel :) hows everyone doing?
21:40:37 <jflory7> Hiya, skrzepto!
21:40:39 <decause> skrzepto: great!
21:40:43 <skamath> skrzepto: Hello :)
21:40:50 <jflory7> We're in a hack session right now for CommOps.
21:41:08 <skrzepto> jflory7, im aware :) anyone need help?
21:41:24 <jflory7> Ah, nice! Here's some links for you if you're interested:
21:41:32 <jflory7> https://etherpad.gnome.org/p/commops-power-sessions
21:41:40 <jflory7> https://hangouts.google.com/call/en5lzau3tffx3goxsaccqsq5tye
21:41:49 <jflory7> decause, skamath, and I are in this Hangout right now.
21:44:06 * skamath is on a shaky connection. The college wifi is throttled.
21:44:09 <decause> #link https://www.youtube.com/watch?v=QV5R-2wlzUY
21:44:24 <jflory7> college_wifi--
21:44:24 <decause> #info mizmo OSCON Open Source Award Video
21:44:32 <jflory7> #topic On to hacking!
21:44:52 <jflory7> #info jflory7 will try to draft up a post about mizmo's award at OSCON to go out near maxamillion's OSCON post on Monday
21:49:19 <decause> #link https://www.oreilly.com/ideas/oreilly-open-source-awards-oscon-austin-2016
21:52:05 <decause> #link https://twitter.com/Remy_D/status/737697932657332224
21:56:14 <maxamillion> o/
21:56:27 <skamath> Hi maxamillion:)
21:56:47 <maxamillion> what's everyone hacking on? anywhere I can jump in an help?
21:57:09 <skamath> maxamillion: https://etherpad.gnome.org/p/commops-power-sessions
21:57:37 <skamath> maxamillion: Hangouts link :  https://hangouts.google.com/call/en5lzau3tffx3goxsaccqsq5tye
21:59:28 <decause> maxamillion++
21:59:32 <decause> #link http://imgur.com/a/PvJGZ
22:00:02 <decause> #info "CommBlog Keeps it 100" wallpapers and backgrounds
22:01:22 <jflory7> maxamillion++
22:01:30 <jflory7> Hiya, welcome :)
22:02:46 <jflory7> #chair skrzepto maxamillion
22:02:46 <zodbot> Current chairs: decause jflory7 maxamillion skamath skrzepto
22:03:22 <decause> .fasinfo skrzepto
22:03:23 <zodbot> decause: User: skrzepto, Name: Szymon Mucha, email: skrzepto@gmail.com, Creation: 2015-11-10, IRC Nick: None, Timezone: UTC, Locale: en, GPG key ID: None, Status: active
22:03:25 <zodbot> decause: Approved Groups: fedorabugs packager cla_done cla_fpca
22:04:11 <skrzepto> did we add the badge to the wiki?
22:04:25 <jflory7> Hmm, to the wiki?
22:04:28 <jflory7> The PyCon badge?
22:04:48 <skrzepto> jflory7, yupp looks its not up any resource on how to update the wiki?
22:05:15 <skrzepto> yes
22:05:38 <decause> https://infrastructure.fedoraproject.org/infra/docs/badges.rst
22:07:06 <skamath> Guess I'll have to leave now. Will catch you folks later in #fedora-commops :)
22:07:21 <decause> skamath: kk, drop us a line if you have any questions
22:07:28 <decause> skamath: gsoc going well?
22:07:33 <skamath> decause: Yep :)
22:07:42 <decause> skamath: you and bee2502 got your week figured out?
22:07:55 <skamath> decause: We'll have intern stats by Tuesday or Wednesday
22:08:25 <skamath> decause: Also, I'll gave to get started with Onboarding Badge Series
22:09:20 * skamath is looking to have a brainstorming session in -fcommops later on :)
22:09:23 <decause> #link https://github.com/sindresorhus/awesome
22:09:27 <jflory7> lmacken: yo!
22:09:36 <jflory7> skamath: Alright, sounds good! See ya later!
22:09:51 <decause> #link https://github.com/vinta/awesome-python
22:10:33 <lmacken> jflory7: yoyoo
22:12:45 <jflory7> decause: https://fedoraproject.org/wiki/FAD_EDU_2016
22:12:47 <jflory7> #chair lmacken
22:12:47 <zodbot> Current chairs: decause jflory7 lmacken maxamillion skamath skrzepto
22:14:08 <jflory7> decause: https://fedorahosted.org/marketing-team/ticket/227
22:14:11 <jflory7> #link https://fedorahosted.org/marketing-team/ticket/227
22:14:57 <jflory7> #link https://fedoraproject.org/wiki/F24_release_announcement
22:24:21 <decause> https://fedoraproject.org/wiki/FAD_Cloud_WG_2016
22:24:25 <kushal> woo hoo
22:26:04 <jflory7> Hiya, kushal!
22:26:08 <jflory7> #chair kushal
22:26:08 <zodbot> Current chairs: decause jflory7 kushal lmacken maxamillion skamath skrzepto
22:26:18 * jflory7 is going to be AFK for a few minutes
22:30:02 <jflory7> Back.
22:30:04 <jflory7> Hi zoltanh7211!
22:31:25 <zoltanh7211> Hi guys
22:31:52 <zoltanh7211> Just reading the feedback that you have done in ticket
22:32:14 <jflory7> zoltanh7211: Sure thing, for Ticket #71?
22:32:28 <jflory7> zoltanh7211: If Google Hangouts is your jam, we are also here: https://hangouts.google.com/call/en5lzau3tffx3goxsaccqsq5tye
22:32:31 <zoltanh7211> jflory7: yep
22:37:09 <skrzepto> brb i have to drive my little brother somewhere.
22:43:33 <jflory7> skrzepto: No problem.
22:47:15 <maxamillion> have a good weekend all!
22:47:18 * maxamillion &
22:47:19 <jflory7> maxamillion: Same to you!
22:48:29 <decause> http://imgur.com/s1XtwQC
22:54:08 <jflory7> #endmeeting