commops
MINUTES

#fedora-meeting-3: Fedora CommOps Hack Session (2016-06-03)

Meeting started by jflory7 at 20:56:52 UTC (full logs).

Meeting summary

  1. Roll Call (jflory7, 20:57:01)
    1. We're using Google Hangouts for tonight's hack session: please try connecting at the following link! (jflory7, 20:57:44)
    2. https://hangouts.google.com/call/en5lzau3tffx3goxsaccqsq5tye (jflory7, 20:57:45)
    3. https://etherpad.gnome.org/p/commops-power-sessions (jflory7, 21:01:08)

  2. How To Push a Badge 101 (jflory7, 21:24:31)
    1. Ralph (threebean) explained how to push a badge in Fedora Infrastructure with a screenshare walkthrough (jflory7, 21:24:55)
    2. === Prerequisites === (jflory7, 21:25:13)
    3. 1) Cloned `badges` repository where all badges live: https://git.fedorahosted.org/cgit/badges.git (jflory7, 21:25:35)
    4. 2) Sysadmin privileges on Batcave and badges-web (jflory7, 21:26:06)
    5. === Taking care of art assets === (jflory7, 21:26:21)
    6. 1) Go to the ticket for a badge and pull the artwork assets (both png and svg) into the `badges` repository (jflory7, 21:26:47)
    7. 2) Place art assets into their appropriate folder, preferred to name image files the name of the badge for easy indexing later on (jflory7, 21:27:12)
    8. 3) Double-check to make sure the image assets you pulled down are "good" - sometimes the images can be corrupted and this can cause problems later (jflory7, 21:27:43)
    9. 4) Add the files in git, commit, push (or if you don't have push privileges, make a patch and add it to the ticket to save time...??) (jflory7, 21:28:17)
    10. === Pushing out the badge === (jflory7, 21:28:32)
    11. Important to note that just because you push to fedorahosted does not mean the badge is "out there" yet - introducing the powers of Ansible yet again (jflory7, 21:28:58)
    12. 1) Log into the `batcave` machine in Fedora Infrastructure and locate the `push-badges` playbook (jflory7, 21:29:25)
    13. 2) Sysadmins with privileges will be able to run the playbook to pull the changes from fedorahosted to batcave - the changes then get synced to the badges-web server (jflory7, 21:29:56)
    14. https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/playbooks/manual/push-badges.yml (jflory7, 21:30:38)
    15. 3) Wait for playbook to finish, check if the png is publicly viewable on badges.fp.o (jflory7, 21:31:01)
    16. === Adding a badge from badges.fp.o === (jflory7, 21:31:10)
    17. Once the art assets are on badges-web, you will be ready to make the badge. BEWARE: Creating a badge is easy, but editing it is not! Make sure the information you are entering is right on the first go. (jflory7, 21:31:49)
    18. 1) Log into admin interface on badges.fp.o (jflory7, 21:31:59)
    19. 2) Go to add badge section (jflory7, 21:32:09)
    20. 3) Enter in the information (e.g. pull the badge name / description from the ticket, enter the correct image location for the badge), hit "Create badge" button (jflory7, 21:33:15)
    21. 4) In admin interface, grant privileges to appropriate person (IF NOT AN AUTOMATIC BADGE) at bottom of the interface. Use badge name and @fedoraproject.org email for the person who needs privileges (jflory7, 21:34:03)
    22. === Success! === (jflory7, 21:34:09)
    23. Congratulations! You pushed a badge. (jflory7, 21:34:22)
    24. ACTION: jflory7 Write up a SOP on pushing a badge for Fedora Infra if there is not one already (make any improvements if there is one?) (jflory7, 21:37:45)
    25. https://www.youtube.com/watch?v=QV5R-2wlzUY (decause, 21:44:09)
    26. mizmo OSCON Open Source Award Video (decause, 21:44:24)

  3. On to hacking! (jflory7, 21:44:32)
    1. jflory7 will try to draft up a post about mizmo's award at OSCON to go out near maxamillion's OSCON post on Monday (jflory7, 21:44:52)
    2. https://www.oreilly.com/ideas/oreilly-open-source-awards-oscon-austin-2016 (decause, 21:49:19)
    3. https://twitter.com/Remy_D/status/737697932657332224 (decause, 21:52:05)
    4. http://imgur.com/a/PvJGZ (decause, 21:59:32)
    5. "CommBlog Keeps it 100" wallpapers and backgrounds (decause, 22:00:02)
    6. https://infrastructure.fedoraproject.org/infra/docs/badges.rst (decause, 22:05:38)
    7. https://github.com/sindresorhus/awesome (decause, 22:09:23)
    8. https://github.com/vinta/awesome-python (decause, 22:09:51)
    9. https://fedorahosted.org/marketing-team/ticket/227 (jflory7, 22:14:11)
    10. https://fedoraproject.org/wiki/F24_release_announcement (jflory7, 22:14:57)
    11. https://fedoraproject.org/wiki/FAD_Cloud_WG_2016 (decause, 22:24:21)
    12. http://imgur.com/s1XtwQC (decause, 22:48:29)


Meeting ended at 22:54:08 UTC (full logs).

Action items

  1. jflory7 Write up a SOP on pushing a badge for Fedora Infra if there is not one already (make any improvements if there is one?)


Action items, by person

  1. jflory7
    1. jflory7 Write up a SOP on pushing a badge for Fedora Infra if there is not one already (make any improvements if there is one?)


People present (lines said)

  1. jflory7 (83)
  2. skamath (19)
  3. decause (18)
  4. zodbot (15)
  5. skrzepto (6)
  6. maxamillion (4)
  7. zoltanh7211 (3)
  8. kushal (1)
  9. lmacken (1)


Generated by MeetBot 0.1.4.