fesco
LOGS
17:01:15 <decathorpe> #startmeeting FESCo (2023-08-10)
17:01:15 <zodbot> Meeting started Thu Aug 10 17:01:15 2023 UTC.
17:01:15 <zodbot> This meeting is logged and archived in a public location.
17:01:15 <zodbot> The chair is decathorpe. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:01:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:15 <zodbot> The meeting name has been set to 'fesco_(2023-08-10)'
17:01:21 <decathorpe> #meetingname fesco
17:01:21 <zodbot> The meeting name has been set to 'fesco'
17:01:26 <decathorpe> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor, tstellar
17:01:26 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok nirik sgallagh tstellar zbyszek
17:01:36 <decathorpe> #topic Init Process
17:02:16 <nirik> morning IRC people.
17:02:27 <zbyszek_> afternoon IRC dwellers
17:02:29 <decathorpe> feels like time travel
17:02:32 * nirik goes to get more coffee real quick
17:02:33 <Son_Goku> .hello ngompa
17:02:33 <bcotton> .hello2
17:02:34 <zodbot> Son_Goku: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:02:37 <zbyszek_> .hello2
17:02:37 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@funnelfiasco.com>
17:02:39 * Son_Goku sighs
17:02:40 <zodbot> zbyszek_: Sorry, but user 'zbyszek_' does not exist
17:02:46 * bcotton waves from 1997
17:02:55 <dcantrell> .hello2
17:02:56 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:03:36 <zbyszek_> .hello zbyszek
17:03:37 <zodbot> zbyszek_: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:03:38 * decathorpe waves, hello bcotton
17:03:44 <zbyszek_> hi bcotton
17:05:03 <bcotton> hi decathorpe, zbyszek_
17:05:08 <decathorpe> ok, we're five (if I can count), so let's start
17:05:19 <decathorpe> (five plus honored guests, of course)
17:05:40 <decathorpe> #link Schedule https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/3FVUSDTEXCSIDNBNYLQWDLGVHDVRFBO3/
17:06:14 <decathorpe> I tried processing all pending tickets earlier, please let me know if I missed something.
17:06:45 <decathorpe> #topic #3038  New (clarified) voting rules for FESCo
17:06:52 <decathorpe> .fesco 3038
17:06:53 <zodbot> decathorpe: Issue #3038: New (clarified) voting rules for FESCo - fesco - Pagure.io - https://pagure.io/fesco/issue/3038
17:08:03 <nirik> I'm not really happy with the complexity, but oh well, we are where we are...
17:08:07 <decathorpe> looks like the 5th draft didn't cause any more requests for changes, so I think it would be ready for approval. there were not many votes cast in ticket, so I included it on the agenda for today so we can hopefully get this done
17:09:16 <zbyszek_> Can we strike the second definition of Eligible Voters? As decathorpe said, it doesn't make sense.
17:09:24 <zbyszek_> "Eligible voters on FESCo meetings are all currently-serving members of FESCo who have not explicitly voted 0 on a proposal."
17:10:15 <bcotton> The 5th draft seems to be missing the fast track option (or I can't read)
17:10:33 <decathorpe> ok, back to ticket then? please comment there.
17:10:54 <decathorpe> sgallagh won't be able to make it to the meeting, so discussing it here is kind of pointless.
17:12:22 <zbyszek_> I think this needs one more draft:
17:12:26 <zbyszek_> 1. add back fast track
17:12:46 <bcotton> There are a few suggestions I made on the devel thread that got no feedback. Some are more important than others
17:12:46 <zbyszek_> 2. reword the stuff about eligible voters. I get the intent, but it's very very confusingly worded.
17:12:56 <bcotton> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/MJ5OJZM3VT5WW4GGEY5TGGHHRCVQXZBJ/
17:13:14 <mhayden> .hello2
17:13:15 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
17:13:34 <decathorpe> yeah, I think the redefinition of "eligible voters" can just be dropped
17:13:38 * decathorpe waves
17:14:11 <decathorpe> bcotton++ thanks for the link
17:14:13 <zbyszek_> decathorpe: I thought so, but then the text doesn't make sense, because it uses "eligible voters" as "voters minus those who voted 0" to define majority.
17:14:36 <decathorpe> yeah it could do with some simplifying.
17:14:40 <bcotton> I think that's an artifact of trying to write too formally, which is almost always a mistake :-)
17:14:57 <nirik> perhaps it could also move to be a PR? or do we want to finalize it first ?
17:15:22 <decathorpe> either is fine with me ... but either way it sounds like it won't be approved today
17:15:44 <decathorpe> so please copy all your suggestions from IRC and paste them into a beautifully formatted pagure comment ;)
17:16:06 <zbyszek_> Proposal: we'll prepare a draft taking into account the suggestions from Ben's mail and vote again in the ticket.
17:16:38 <decathorpe> fine, +1 (though at that point it could just be a fesco-docs PR that we vote on)
17:17:12 <zbyszek_> I volunteer to prepare the draft. I'll do it in the ticket but also as a PR.
17:17:22 <decathorpe> great, thanks
17:17:31 <nirik> +1
17:17:38 <zbyszek_> +1 ftr
17:17:40 <dcantrell> +1
17:17:59 <bcotton> zbyszek++
17:17:59 <zodbot> bcotton: Karma for zbyszek changed to 5 (for the release cycle f38):  https://badges.fedoraproject.org/tags/cookie/any
17:18:24 <decathorpe> Son_Goku: opinions?
17:20:17 <decathorpe> #agree Suggestions will be taken into account for a fesco-docs PR (+4, 0, -0)
17:20:47 <decathorpe> #action zbyszek to do do the drafting and PR preparing
17:21:19 <decathorpe> #topic #3053 Change: Anaconda WebUI for Fedora Workstation by default - delayed for Testable Deadline
17:21:40 <decathorpe> I wasn't sure how to handle this, so I included it in the agenda for today's meeting.
17:24:16 <nirik> so, this is just invoking the contencry plan
17:24:23 <nirik> and slipping? or ?
17:24:37 <nirik> oh, they just want an exception?
17:25:04 <decathorpe> yeah. as far as I understand, they're asking if missing the testable deadline is fine
17:25:36 <decathorpe> though I'm not thrilled that there's still missing pieces (and people that would work on those on PTO)
17:25:38 <dcantrell> what does qa say?
17:25:41 <nirik> is QE ok ?
17:26:27 * decathorpe shrugs, it doesn't say other than "we're in touch"
17:26:35 * nirik is asking adamw to drop by and join us in this basement. ;)
17:26:43 <zbyszek_> I think this is OK. IIUC, the missing parts should will be implemented.
17:27:01 <decathorpe> thanks nirik
17:27:12 <adamw_irc> hi, nirik asked me to join...
17:27:48 <decathorpe> adamw_irc: hi! thanks for joining
17:27:53 <decathorpe> we're talking about https://pagure.io/fesco/issue/3053
17:28:11 <decathorpe> so it would be great to know what QE / QA thinks here
17:28:46 <adamw_irc> i'm kinda in a few minds on it
17:29:02 <adamw_irc> on the one hand, we don't actually really *test* language stuff on the lives, much. we do all that testing on the server DVD.
17:29:03 <nirik> it's not clear how long the delay is here... I guess just a few weeks?
17:29:15 <adamw_irc> but...since this is all new, it seems kinda important to have it implemented in enough time
17:29:19 <adamw_irc> and yeah, that
17:29:24 <dcantrell> that's the risk I'm concerned with
17:29:31 <dcantrell> kind of speaking from experience here too
17:29:52 <decathorpe> the 100% code complete deadline is in 12 days
17:29:53 <adamw_irc> in my inbox, I have a mail from ray saying he'll provide a timeframe on monday or tuesday
17:30:24 <zbyszek_> Which Monday or Tuesday?
17:30:45 <adamw_irc> the coming one, i guess
17:30:52 <adamw_irc> 14th/15th
17:31:00 <nirik> proposal: say ok now, reevaulate next week?
17:31:05 <zbyszek_> +1
17:31:05 <adamw_irc> which would be...8 days to 100% complete. seems kinda tight
17:31:24 <nirik> we could also reevaluate in ticket mon/tues?
17:31:32 <nirik> (if that helps any)
17:31:57 <zbyszek_> Yeah, but if we say "no", the deadline will sail by anyway. I don't think we can do much except monitor the situation and pull the brakes at some point.
17:32:32 <decathorpe> Proposal: Punt any decisions until we either 1. have more information, or 2. next FESCo meeting (whichever happens first)
17:33:14 <adamw_irc> i'm kinda okay with this, I *guess*, if it can all show up by 100% testable deadline, but i wouldn't want to push it past that...
17:33:34 <nirik> the testable deadline is already hit. ;)
17:33:44 <adamw_irc> we have three weeks from 100% deadline to the early beta target date, so two and a half weeks to the go/no-go, which isn't a huge window to test something this bug
17:33:47 <adamw_irc> big*
17:33:53 <adamw_irc> i mean 100% complete
17:34:13 <adamw_irc> it is theoretically testable at this point, though we, uh, haven't tested it yet. i should probably do something about that.
17:34:17 <dcantrell> I think it should be tested starting now with what it has implemented and let QE determine if it's suitable for inclusion and if not, invoke the contingency plan
17:34:59 <nirik> decathorpe: +1 (and of course then the default is that it stays in until we do something right?)
17:35:52 <decathorpe> the next decision could be "invoke contingency mechanism", but I guess so, yes
17:37:24 * nirik nods.
17:38:04 <decathorpe> I'll lock this in unless I hear anything other than *chirp chirp chirp* in the next minues
17:39:12 <mhayden> 0👍
17:39:20 <mhayden> not sure where the 0 came from :|
17:39:38 <zbyszek_> decathorpe: +1, ack
17:40:55 <decathorpe> ok, three +1s, one thumbs-ups, and two chirp chirp chirps
17:42:15 <decathorpe> #agree Wait with making any further decisions until FESCo has either 1. more information, or 2. the next FESCo meeting (whichever happens first) (+4, 0, -0)
17:42:36 <decathorpe> #topic Next week's 🪑
17:43:20 <mhayden> i'll be in a partner meeting next week during this time slot 😭
17:43:46 <nirik> I will not be around next week at this time (taking the day off)
17:44:45 <decathorpe> so many volunteers
17:44:54 <zbyszek_> I can do it.
17:45:12 <decathorpe> thank you, much appreciated.
17:45:29 <decathorpe> #action zbyszek to chair next week's meeting (2023-08-17)
17:45:34 <decathorpe> #topic Open Floor
17:45:51 <decathorpe> I will end meeting at :50 if there's nothing :)
17:46:51 <zbyszek_> I updated the draft: https://pagure.io/fesco/issue/3038#comment-868471
17:46:57 <zbyszek_> Please comment or vote.
17:47:10 <decathorpe> thanks!
17:47:30 <zbyszek_> I'll post a pull request for the docs if there are no comments.
17:50:24 <decathorpe> ok, I'll give you all 10 minutes back. thanks everyone
17:50:28 <decathorpe> #endmeeting