fesco
LOGS
17:00:34 <zbyszek[m]> #startmeeting FESCO (2023-07-20)
17:00:34 <zodbot> Meeting started Thu Jul 20 17:00:34 2023 UTC.
17:00:34 <zodbot> This meeting is logged and archived in a public location.
17:00:34 <zodbot> The chair is zbyszek[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:34 <zodbot> The meeting name has been set to 'fesco_(2023-07-20)'
17:00:34 <zbyszek[m]> #meetingname fesco
17:00:34 <zodbot> The meeting name has been set to 'fesco'
17:00:34 <zbyszek[m]> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor, tstellar
17:00:34 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok nirik sgallagh tstellar zbyszek zbyszek[m]
17:01:00 <zbyszek[m]> #topic init process
17:01:00 <zbyszek[m]> .hello2 zbyszek
17:01:00 <zodbot> zbyszek[m]: Sorry, but user 'zbyszek [m]' does not exist
17:01:09 <mhayden> .hello2
17:01:10 <zbyszek[m]> It seems this works over element. Kind of.
17:01:24 <Eighth_Doctor> use .hello instead
17:01:32 <Eighth_Doctor> .hello ngompa
17:01:33 <zbyszek[m]> .hello zbyszek
17:02:04 <bcotton> .hello2
17:02:12 <zbyszek[m]> Hi Ben!
17:02:18 <nirik> morning
17:02:20 <sgallagh> .hi
17:02:35 * bcotton waves from the great beyond
17:02:38 <dcantrell> .hello2
17:03:01 <mhayden> Oh man it's a Ben Cotton (he/him)!
17:03:09 <tstellar> .hello tstellar
17:03:10 <sgallagh> Ben Cotton (he/him): Wait, you're dead? My goon wasn't supposed to get there until Sunday...
17:03:19 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
17:03:36 <bcotton> Stephen Gallagher: your goon believe in underpromising and overdelivering
17:04:32 <zbyszek[m]> #3031 Change: AllowRemovalOfTzdata
17:04:32 <zbyszek[m]> .fesco 3031
17:04:36 <codonell> :-)
17:04:49 <dcantrell> is zodbot not working?
17:04:56 <nirik> FYI, the matrix / irc bridge is having particular problems today... especially irc->matrix
17:05:04 <dcantrell> I am only on irc
17:05:14 <dcantrell> or connecting to this via irc
17:05:22 <mhayden> Perhaps there's a glitch in the matrix?
17:05:25 * nirik goes to look.
17:05:28 <zbyszek[m]> I'm on both, and I see the same content in both places.
17:05:29 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:05:32 <zodbot> zbyszek[m]: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:05:35 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@funnelfiasco.com>
17:05:38 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:05:41 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:05:44 <zodbot> tstellar: tstellar 'Tom Stellard' <tstellar@redhat.com>
17:05:47 <zodbot> zbyszek[m]: Issue #3031: Change: AllowRemovalOfTzdata - fesco - Pagure.io - https://pagure.io/fesco/issue/3031
17:05:57 <zbyszek[m]> Oh, it is a bit slow indeed.
17:06:08 <dcantrell> reminds me of modems
17:06:23 <zbyszek[m]> But the bridge is working fine, I see the message on IRC after a fraction of a second.
17:06:34 <zbyszek> The other way too, I hope.
17:06:37 <zbyszek[m]> Yes.
17:06:43 <dcantrell> speaking of slow, pagure.....
17:06:44 <codonell> (Remember when 14400 was fast...)
17:06:47 <nirik> sometimes. ;)
17:06:54 <nirik> anyhow, tzdata.
17:07:11 <sgallagh> dcantrell: Pagure seems to be having issues when you're on the VPN. I dropped from it and immediately things improved.
17:07:22 <dcantrell> I'm in a Red Hat office, no VPN
17:07:33 <zbyszek[m]> Neal and Fabio were -1.
17:07:42 <sgallagh> dcantrell: I think the issue is communication from within the firewall, not the VPN specifically
17:07:42 <nirik> I updated/rebooted it, so it might be better now? but anyhow, pagure.io reports to #fedora-admin ?
17:07:59 <codonell> Patsy and I changed the change request to move python into the optional list.
17:08:44 <codonell> I think there is value in starting small here and working towards a goal.
17:08:54 <codonell> Particularly around minimization.
17:09:10 <zbyszek[m]> Conan Kudo, Fabio Valentini if you were so kind as to change your vote to +1, we could wrap this up.
17:09:12 <nirik> Yeah... it's a step in the right direction. I guess I can be +1
17:09:37 <Pharaoh_Atem> done in ticket
17:09:50 <zbyszek[m]> With nirik's vote, the tally is (+5, 0, -2).
17:09:52 <Pharaoh_Atem> I'm unconvinced that this is a sensible idea
17:09:59 <Pharaoh_Atem> but I'm not going to stop it
17:10:06 <Pharaoh_Atem> it's fine to try and see how it goes
17:10:56 <zbyszek[m]> OK, so -1 → ? ?
17:11:03 <tstellar> This change is effectively removing tzdata from the default buildroot because glibc and gcc are usually available, so we need to be on the lookout for FTBFS in other packages that need tzdata but don't explicitly include it.
17:11:17 <tstellar> s/include/require/
17:11:24 <sgallagh> zbyszek: I think he's reserving the right to say "I told you so"
17:11:28 <Pharaoh_Atem> yes
17:11:32 <zbyszek[m]> Yeah, I think it's likely that some packages will fail in tests.
17:11:35 <Pharaoh_Atem> though not quite so directly
17:11:44 <mhayden> added my +1 in there -- didn't realize we had a new change revision in there
17:12:02 <Pharaoh_Atem> neither did I, because everything being on fire for the past three weeks
17:12:08 <nirik> too bad we didn't land this before this mass rebuild. oh well.
17:12:13 <mhayden> too many plates spinning on this end in the last couple of weeks 🥵
17:12:56 <codonell> We are all trying our best.
17:13:26 <sgallagh> <monty python>I'm not!</monty python>
17:13:37 <codonell> :-)
17:13:40 <mhayden> my goal is to reach 25% of mhroncok's efficiency by 2025 😉
17:13:56 <tstellar> nirik: Yeah, we also haven't approved the F39 toolchain change yet, but I think all those packages are already in the buildroot.
17:14:20 <nirik> sheesh. I thought we had. Oh well, anyhow...
17:14:22 <sgallagh> I'm convinced that mhroncok is actually three Skynet supercomputers in a trenchcoat
17:14:51 <codonell> tstellar, Not everything is in the buildroot, some of the redhat-rpm-config changes we held off on waiting for Fesco.
17:14:54 <zbyszek> mhayden: I don't see your +1
17:15:18 <codonell> tstellar, The packages in the system toolchain make forward progress in rawhide, and the GNU Toolchain FXX change request I file each 6 months is to make sure we talk about it.
17:15:20 <mhayden> zbyszek: pagure is spinning on my end but nothing is happening :|
17:15:29 <nirik> it's up. It's mostly idle.
17:15:36 <mhayden> ah it just landed
17:15:38 <zbyszek> Oh, now I see it.
17:15:38 <nirik> I am really thinking this is some kind of netowrk issue.
17:15:43 <sgallagh> Should we consider aborting the current Mass Rebuild and restarting it with the changes we approve today?
17:15:46 <dcantrell> what's odd is that I can't open pagure links in firefox, but they open in chromium
17:15:56 <sgallagh> Last I looked, it wasn't going spectacularly well anyway...
17:15:57 <nirik> -1
17:16:03 <codonell> sgallagh, It is not required to abort the Mass Rebuild IMO. If you ask me technically.
17:16:16 <zbyszek> #action APPROVED (+7, 0, 0)
17:16:32 <codonell> sgallagh, ... from the GNU Toolchain perspective.
17:16:35 <zbyszek> #agree APPROVED (+7, 0, 0)
17:16:36 <sgallagh> zbyszek: What's approved?
17:16:49 <decathorpe> hi, sorry, I needed to grab some food after the FPC meeting
17:16:59 <zbyszek> The ticket?
17:17:08 <decathorpe> if my vote for the tzdata thing is still required, it's still -1
17:17:09 <Pharaoh_Atem> the topic never changed
17:17:18 <zbyszek> #undo
17:17:18 <zodbot> Removing item from minutes: AGREED by zbyszek at 17:16:35 : APPROVED (+7, 0, 0)
17:17:26 <zbyszek> #agree APPROVED (+7, 0, -1)
17:17:44 <zbyszek> decathorpe: sorry, I was keeping your vote in my mind, but then it slipped.
17:18:13 <bcotton> i don't think it got #topiced
17:18:38 <zbyszek> #undo
17:18:38 <zodbot> Removing item from minutes: AGREED by zbyszek at 17:17:26 : APPROVED (+7, 0, -1)
17:19:01 <zbyszek> #topic #3031 Change: AllowRemovalOfTzdata
17:19:01 <zbyszek> .fesco 3031
17:19:03 <zodbot> zbyszek: Issue #3031: Change: AllowRemovalOfTzdata - fesco - Pagure.io - https://pagure.io/fesco/issue/3031
17:19:13 <zbyszek> Sorry, let me redo the tally.
17:19:46 <sgallagh> I thought Conan Kudo was still -1 also, or did I misread?
17:19:56 <zbyszek> I'm counting Miro, Neal, Nirik, David, me, Major, Stephen as +1, Fabio as -1.
17:20:04 <zbyszek> > Sure. Not completely convinced, but why not, I guess?
17:20:06 <zbyszek> > +1
17:20:10 <Eighth_Doctor> Stephen Gallagher: changed in ticket
17:20:19 <sgallagh> Ah, my mistake
17:20:21 <zbyszek> #agree APPROVED (+7, 0, -1)
17:20:39 <zbyszek> Phew.
17:20:41 <zbyszek> Next.
17:20:42 <zbyszek> #topic #3038 New (clarified) voting rules for FESCo
17:20:42 <zbyszek> .fesco 3038
17:20:43 <zodbot> zbyszek: Issue #3038: New (clarified) voting rules for FESCo - fesco - Pagure.io - https://pagure.io/fesco/issue/3038
17:21:10 <sgallagh> I think this is probably premature to bring up in the meeting. I suggest giving it another week in the ticket first.
17:21:20 <sgallagh> Particularly since I submitted a second draft just today
17:21:32 <nirik> Yeah, I have had no time to look at the current draft.
17:21:41 <zbyszek> Yeah, there was a bunch of comments.
17:21:41 <dcantrell> same
17:21:45 <decathorpe> I haven't had time to look at it at all
17:22:15 <Eighth_Doctor> neither have I
17:22:24 <decathorpe> so yes please more time
17:23:01 <zbyszek> #info A second draft was posted today. We'll continue the discussion in the ticket.
17:23:14 <zbyszek> Any volunteers to bring this up on fedora-devel?
17:23:17 <sgallagh> (BTW, thank you to those of you who suggested edits)
17:23:30 <zbyszek> Or should we discuss more in the ticket first?
17:24:05 <mhayden> i didn't find anything objectionable in the proposed rules, but i'm okay with others taking more time to look
17:25:31 <Eighth_Doctor> the biggest change I noticed at a glance is that 0 now coerces to majority vote rather than -1 in a meeting
17:25:33 <sgallagh> zbyszek: I don't *mind* if someone wants to bring it to devel@, but is this topic overly relevant to non-FESCo members?
17:26:08 <zbyszek> Dunno, people take our internal voting procedures very very seriously.
17:26:13 <bcotton> Stephen Gallagher: in practice? no. in appearance, i think it's important
17:26:25 <zbyszek> I don't want to be accused of crafting a secret plot to change the voting rules.
17:26:36 <nirik> yeah, I think if it's a yawn then a post doesn't hurt. ;) And we might get some things we didn't think of.
17:26:38 <dcantrell> that's a reasonable point
17:26:51 <Eighth_Doctor> I also can't take more firefighting right now
17:26:56 <sgallagh> If you think talking about it publicly is going to prevent being accused of secret plots, you haven't been paying attention lately :-)
17:26:59 <zbyszek> bcotton: fully agreed.
17:27:39 <zbyszek> sgallagh: :(
17:27:42 <bcotton> I don't want to go as far as suggesting following the Council's Policy Change Policy (https://docs.fedoraproject.org/en-US/council/policy/policy-change-policy/), which is pretty heavy, but having some degree of open discussion is important, even for trivial governance changes
17:28:17 <zbyszek> OK, I'll send an email to -devel after the meeting minutes.
17:28:28 <zbyszek> #action zbyszek to send a heads-up to fedora-devel mailing list.
17:28:37 <bcotton> if nothing else, this might serve as a good opportunity to educate the uninformed about how Fedora (and FESCo specifically) works
17:29:04 <decathorpe> sounds good to me, thanks
17:29:06 <sgallagh> At the risk of causing more debate: -devel or discourse?
17:29:13 <nirik> both?
17:29:17 <Eighth_Doctor> devel
17:29:19 <Eighth_Doctor> no more discourse
17:29:24 <Eighth_Doctor> please
17:29:28 <dcantrell> I would say devel
17:29:38 <bcotton> devel unless FESCo changes the rules to use Discourse instead (which would require a devel thread first)
17:30:03 <zbyszek> FESCo stuff is still being sent to -devel.
17:30:11 <sgallagh> Fine by me
17:30:18 <zbyszek> If there's nothing else for this topic, I'll jump to the next one.
17:30:20 <bcotton> alternatively, we could post a link to the devel thread on Discourse and lock the topic so that discussion happens in one place (not sure if that would make mattdm cry or not)
17:31:38 <zbyszek> bcotton: Hmmm. Let's leave that possibility open ;)
17:31:44 <zbyszek> #topic #3039 RFC: Roadmap for DNF5 in Fedora 39 / invoking the Contingency Mechanism
17:31:47 <zbyszek> .fesco 3039
17:31:49 <zodbot> zbyszek: Issue #3039: RFC: Roadmap for DNF5 in Fedora 39 / invoking the Contingency Mechanism - fesco - Pagure.io - https://pagure.io/fesco/issue/3039
17:32:13 <jmracek> Hello
17:32:21 <zbyszek> jmracek: hi!
17:32:25 <mattdm> bcotton: It would :)
17:32:42 <dcantrell> jmracek: welcome!
17:32:49 <Eighth_Doctor> hey jmracek
17:32:51 <nirik> 👋
17:32:52 * dcantrell hands mattdm a tissue
17:33:17 <zbyszek> I put this on the agenda because time is limited,
17:33:33 <zbyszek> but I don't really have a good overview of the details or any concrete proposal.
17:34:14 <dcantrell> where'
17:34:19 <dcantrell> s the link to the original change proposal?
17:34:36 <zbyszek> #info https://fedoraproject.org/wiki/Changes/ReplaceDnfWithDnf5
17:34:41 <dcantrell> thanks
17:34:51 <jmracek> I tried to explain the situation in #3039. Basicly most of the issues reported there are fixed ar on the good way to get fixed
17:35:04 <zbyszek> 10 Branch Fedora Linux 39 from Rawhide Tue 2023-08-08
17:35:14 <zbyszek> ^ that's the scheduled branching point
17:35:28 <nirik> right and flock is right before...
17:35:38 <dcantrell> I'm concerned we will not get enough testing done on dnf5 before branching, to confirm acceptance criteria is met
17:35:44 <tstellar> I feel like this release is going to be extra challenging due to lack of a PM, so I think it's best to be extra cautious.
17:35:45 <zbyszek> decathorpe suggested reverting in f39 branch after that.
17:36:11 <dcantrell> I think the safest option right now is to invoke the contingency plan in the change proposal
17:36:17 <decathorpe> yeah I wrote a proposal somewhere but nobody noticed
17:36:39 <zbyszek> decathorpe's proposal:
17:36:41 <zbyszek> #info https://pagure.io/fesco/issue/3039#comment-864924
17:36:46 <zbyszek> """
17:36:47 <zbyszek> I'm proposing to initiate the contingency mechanism, in the following way:
17:36:50 <zbyszek> After Fedora 39 is branched off of rawhide, the switch from DNF 4 to DNF5 by default is reverted, but Rawhide will continue with DNF5, and the switch is re-targeted at Fedora 40.
17:36:54 <zbyszek> """
17:37:18 <dcantrell> decathorpe: sorry I missed that, zbyzsek: thanks for the link
17:37:29 <decathorpe> that would give things more time to cook without being disruptive to rawhide users
17:37:47 <Eighth_Doctor> particularly to get software ported
17:37:58 <nirik> I think thats reasonable, but perhaps we could give them another week until deciding?
17:37:59 <decathorpe> yep
17:38:01 <Eighth_Doctor> which wasn't really possible to do until the first API stable release came out this week
17:38:16 <dcantrell> I think the original change proposal needs revised acceptance criteria
17:38:41 <dcantrell> specifically including the noticed items that were broken.  what was provided as acceptance criteria clearly wasn't enough
17:38:49 <jmracek> May I ask you which issue you sugest as a blocker of the replacement?
17:38:53 <sgallagh> For a moment, I'm going to doff my FESCo hat and put on my ELN/RHEL hat:
17:40:12 <sgallagh> It's public knowledge at this point that the next major RHEL release will be branched from Fedora 40. Tha means that Fedora 39 is functionally the last release that will get major public testing before the branch occurs.
17:40:39 <sgallagh> (Yes, there's still time to fix things in CentOS Stream 10, but getting fixes into Fedora is orders of magnitude easier than into CS 10)
17:41:10 <dcantrell> I don't think we should hold Fedora to the RHEL branching deadline.  If the software isn't ready for Fedora, it isn't ready.
17:41:26 <sgallagh> I realize that our job as FESCo is to think first of Fedora's needs (which is why I switched hats for this), but I think considering RHEL/CentOS Stream's needs is also important.
17:41:40 <Eighth_Doctor> I think that it's fine to hold to the F40 line for that
17:41:50 <Eighth_Doctor> after all, we did that for PipeWire with RHEL 9 pretty successfully
17:41:52 <zbyszek> sgallagh: I'm not really sure if that changes things. Because we can keep testing and improving dnf5 in F39, even if it is not the default.
17:42:07 <nirik> and also in rawhide. ;)
17:42:12 <sgallagh> zbyszek: It's the difference between targeted testing and real-world testing
17:42:17 <Eighth_Doctor> and one thing we can do that we haven't been able to do before is create alternate images to test new configurations
17:42:34 <decathorpe> I don't want Fedora users to be guinea pigs for rhel 10
17:42:35 <Eighth_Doctor> we're going to do this for osbuild-based Workstation
17:42:40 <nirik> anyhow, I think we should enumerate specific blockers if we want to do a contingency on this... so the dnf5 folks know what they have to focus on
17:42:48 <Eighth_Doctor> and we can do stuff like that for dnf5 too
17:43:13 <dcantrell> the enumerated items in the opening comment of #3039 is a good starting point
17:43:20 <dcantrell> plus some comments pointed out things that were broken
17:43:34 <jmracek> Please make a list requirements for us
17:43:39 <Eighth_Doctor> and frankly, we should be doing test day events too
17:43:52 <zbyszek> jmracek: what is your opinion on the proposed contingency mechanism (revert in f39 branch)? Would that throw a wrench in your pipeline?
17:44:29 <dcantrell> Eighth_Doctor: we (on the swm team) have been working on new plans for dnf5 test days in fedora.  you are right, these should have been happening already
17:45:23 <jmracek> I would prefer to go with original proposal, because there will be still list of problems, when next time DNF5 will go to the prodiction - stable state
17:46:08 <dcantrell> the original proposal lacks acceptance criteria for the problems noted in #3039
17:46:18 <dcantrell> I think those should be added to a revised proposal for F40
17:46:25 <decathorpe> true, but looking at the current state and what's still missing I'm just not comfortable with pushing this for f39.
17:46:52 <zbyszek> > ansible dnf5 module does not work because dnf5 changed public API, it is fixed in rc version
17:47:10 <zbyszek> Wehn can we expect that version of ansible to be available?
17:47:17 <nirik> fedora-review has patches
17:47:41 <Eighth_Doctor> I've been reluctant to merge those while dnf5 has been churning
17:47:41 <jmracek> DNF5 released 5.1 version that has stable API, therefore the issue is a past
17:48:26 <decathorpe> well, just because the API is stable now doesn't mean things are already using the now-stable API ...
17:48:44 <decathorpe> also it's not only API but also CLI flags
17:48:47 <Eighth_Doctor> this is pretty much the time where most consumers will probably earnestly try porting
17:49:40 <Eighth_Doctor> and I think it would make sense to use the time between now and F40 branching to do that effort
17:49:49 <nirik> I don't know where CI is... still broken?
17:50:22 <zbyszek> #info https://pagure.io/fedora-ci/general/issue/416
17:50:26 <nirik> not sure on best=true
17:50:41 <sgallagh> This conversation isn't really helping jmracek figure out what the DNF team needs to do, though.
17:50:54 <decathorpe> yes. those behaviour changes need to be addressed too
17:51:01 <sgallagh> Can we focus on how to get them to where we would accept it?
17:52:00 <dcantrell> in addition to the items in #3039, 'dnf system-upgrade' needs to work
17:52:26 <decathorpe> Stephen Gallagher: at this point, that would likely be "this needs more time"
17:52:35 <decathorpe> and I'm not sure that's what you wanted to hear
17:52:38 <nirik> oh yeah, thats a big one.
17:52:42 <sgallagh> That's not good enough.
17:52:43 <jmracek> Best will return to original value, bu using a differen mechanism. sgallagh Do you think fedora-release-<variant> could deliver overrides in drop in directory?
17:52:52 <Eighth_Doctor> not having system-upgrade is a huge problem
17:53:07 <decathorpe> (offline upgrade in general)
17:53:12 <Eighth_Doctor> since all of our blocking images except Workstation use that method
17:53:13 <sgallagh> jmracek: I think I missed some context there. Overrides for what?
17:54:22 <dcantrell> I can't do it now, but as part of test day planning I am working with Fedora QA on a dnf5 test matrix.  Would that be a good starting point for acceptance criteria changes for the proposal?
17:54:28 <jmracek> for dnf configuration. DNF5 is shipping empty /etc/dnf/dnf.conf and overrides will be shipped in dropin directory
17:55:12 <nirik> IMHO system-upgrade / offline updates is a hard blocker...
17:55:13 <jmracek> The `'dnf system-upgrade' ` is under development
17:55:20 <sgallagh> jmracek: And what overrides do we need?
17:55:25 <decathorpe> I'm not sure drop in files are good enough? will this work when installing into a empty target?
17:55:53 <decathorpe> (i.e. "--installroot")
17:56:13 <jmracek> to get `best=false` for workstation and keeping `best-true` for server fedora variant
17:56:31 <decathorpe> ? does Fedora Server want this?
17:56:41 <zbyszek> Yeah, exactly my question.
17:57:03 <nirik> same
17:57:28 <jmracek> That on the distribution - you can use and decide by your own
17:58:08 <sgallagh> jmracek: I remain confused about the value of either option, to be honest. But yes, per-Variant override files would be extremely easy to add to the release package.
17:58:26 <sgallagh> We already have some, like systemd presets.
17:58:45 <decathorpe> do we even want this? I don't think it makes sense to override core system stuff like package manager behaviour that way for different editions
17:58:51 <zbyszek> But we want best=false to be the implicit default.
17:59:09 <sgallagh> Fabio Valentini: Having the capability doesn't mean we have to use it
17:59:30 <sgallagh> It would still have to be reviewed and approved
17:59:54 <nirik> We've been at this a while, should we gather more hard requirements and vote next meeting on contingency? or ?
18:00:04 <jmracek> Then we can deliver proper defaults for Fedora according to your wishes. Please consider issue related to different defaults as resolved. With installation to epty installroot there is not difference with present state
18:00:20 <dcantrell> nirik: I want to gather more hard requirements.  I'll post in the 3039 ticket
18:00:50 <sgallagh> I think the idea of having a test day and then triaging from the bugs that get opened makes good sense
18:00:53 <decathorpe> I'll update the ticket as well
18:00:58 <nirik> as it is, system-upgrade is enough for me to vote on contingency, but it would be good to know more and have updated status ?
18:01:13 <dcantrell> nirik: agreed
18:01:39 <zbyszek> proposal: We'll work on an updated list of acceptance criteria in #3039. We'll revisit the issue of contingency mechanism invocation at the next meeting.
18:01:44 <dcantrell> I think we kind of need to go with the contingency plan, but moving the proposal per decathorpe's suggestion should have better acceptance criteria
18:01:50 <dcantrell> +1
18:01:53 <jmracek> System-upgrade is needed after branching of fedora 40, therefore from my point there is a time to fix it
18:02:00 <nirik> +1
18:02:15 <decathorpe> jmracek: well, no, there are people who upgrade to rawhide ...
18:02:16 <nirik> it's needed at branching. People can upgrade from 39 to rawhide...
18:02:39 <jmracek> But how many and for them there is a workaround
18:02:59 <nirik> (which to be clear could be worked around with a distro-sync or the like, but...)
18:03:12 <sgallagh> I'm less worried about upgrades to Rawhide, because that's generally a more savvy audience than standard upgrades
18:03:21 <jmracek> Or using python3-dnf
18:04:18 <zbyszek> Yeah, I think that if we had 'dnf5 system-upgrade' at Beta freeze, that'd be enough.
18:04:25 <jmracek> Anyway system-upgrade to rawhide failed due to gpg keys
18:04:50 <nirik> that... shouldn't be the case. keys should be available.
18:05:07 <nirik> anyhow, some of these requirements may have workarounds or the like... thats fine, we should note those.
18:05:26 <jmracek> yes but not in 39 path but rawhide path. This is the issue
18:05:51 <jmracek> They where available not importable
18:06:28 <nirik> I'm happy to look at the issue out of meeting. ;)
18:07:09 <jmracek> Thank you for your check list, it makes things better
18:07:24 <zbyszek> OK, so my proposal had +3, i.e. not enough.
18:07:32 <zbyszek> A different proposal?
18:07:40 <sgallagh> Question: should FESCo be involved in a post-Test Day triage?
18:07:53 <sgallagh> I think we should at least help advise which issues are blockers to our acceptance.
18:08:12 <zbyszek> sgallagh: I think so,yes.
18:08:14 <jmracek> Thank you
18:09:02 <sgallagh> jmracek: When is the next Test Day scheduled?
18:09:10 <tstellar> zbyszek: I'm +1 on that too.
18:09:15 <nirik> I agree.
18:09:56 <mhayden> sgallagh: 100% agreed
18:10:21 <dcantrell> sgallagh: I mean, I plan to help with triage if I'm helping with acceptance criteria
18:10:29 <jmracek> David Cantrell is organizing it, therefore David what is your sugestion
18:10:54 <sgallagh> I'm happy to sit in on that triage, provided it's a scheduled event
18:11:01 <dcantrell> we're not going to be able to have a test day until after Flock
18:11:05 <dcantrell> at the earliest
18:11:44 <zbyszek> Flock is 2–4 August.
18:11:52 <dcantrell> yes
18:12:55 <dcantrell> but we will have it on the fedora calendar and announce it, so there should be enough time for everyone to prepare and look over the plan, etc
18:13:05 <zbyszek> OK, we've been on this topic for 40 minutes.
18:13:37 <dcantrell> we're at +4 votes on your proposal?
18:13:43 <zbyszek> Yep.
18:13:58 <decathorpe> what was the proposal? the message must have not gotten to me
18:14:15 <zbyszek> > proposal: We'll work on an updated list of acceptance criteria in #3039. We'll revisit the issue of contingency mechanism invocation at the next meeting.
18:14:30 <decathorpe> <zbyszek> "proposal: We'll work on an..." <- oh, was it this?
18:14:40 <decathorpe> ah. got drowned in other messages. +1 from me
18:14:50 <zbyszek> mhayden, sgallagh, vote?
18:15:07 <sgallagh> +1
18:15:08 <decathorpe> (I tried to update the list in the ticket, feel free to modify / update the ticket text as needed)
18:15:08 <mhayden> +1
18:15:24 <zbyszek> #action decathorpe will update the list in the ticket
18:15:41 <zbyszek> #agree We'll work on an updated list of acceptance criteria in #3039. We'll revisit the issue of contingency mechanism invocation at the next meeting.
18:15:45 <zbyszek> #undo
18:15:45 <zodbot> Removing item from minutes: AGREED by zbyszek at 18:15:41 : We'll work on an updated list of acceptance criteria in #3039. We'll revisit the issue of contingency mechanism invocation at the next meeting.
18:15:53 <zbyszek> #agree We'll work on an updated list of acceptance criteria in #3039. We'll revisit the issue of contingency mechanism invocation at the next meeting. (+7, 0, 0)
18:16:20 <zbyszek> That's not very satisfying, but I think it's the most reasonable thing atm.
18:16:46 <dcantrell> don't we kind of know we're going to invoke contingency now?  the pending thing is updating the acceptance criteria, right?
18:17:12 <zbyszek> dcantrell: I don't think so. jmracek said that many things are close to being finished.
18:17:33 <zbyszek> "Likely" — yes. "Know" — no.
18:17:44 <dcantrell> ok, so next week then
18:17:56 <zbyszek> #topic Next week's chair
18:18:11 <nirik> jmracek: thank you for coming.
18:18:21 <zbyszek> jmracek++
18:18:21 <zodbot> zbyszek: Karma for jmracek changed to 1 (for the release cycle f38):  https://badges.fedoraproject.org/tags/cookie/any
18:18:39 <zbyszek> I've been "it" for two weeks now. Somebody else's turn.
18:18:43 <tstellar> I can chair the meeting, but I might need a mentor.
18:19:03 <zbyszek> #action tstellar will chair the next meeting.
18:19:24 <zbyszek> tstellar: https://fedoraproject.org/wiki/FESCo_meeting_process mostly says it all.
18:19:30 <zbyszek> But I'd be happy to help with any questions.
18:19:40 <tstellar> zbyszek: Ok, thanks.
18:19:45 <jmracek> have a nice day
18:19:50 <dcantrell> jmracek: thanks!
18:20:01 <mhayden> thanks, tstellar !
18:20:07 <zbyszek> #topic Open Floor
18:20:16 <mhayden> and thanks for running this one, zbyszek 😉
18:20:22 <dcantrell> I just wanted to ask who from FESCo will be at Flock?  I will be there.
18:20:28 <zbyszek> I'll be there.
18:20:30 <Eighth_Doctor> I'll be there
18:20:40 <nirik> I'll be there
18:20:45 <decathorpe> not me
18:20:55 <dcantrell> ok, so 4 of us for the panel then?
18:20:58 <mhayden> not me 😢
18:21:08 <Eighth_Doctor> you sure you're not?
18:21:11 * Eighth_Doctor is confused
18:21:30 <Eighth_Doctor> 😦
18:21:37 <tstellar> I won't be there.
18:21:50 <dcantrell> mhayden: we can bring a cardboard standup of you for the panel
18:23:20 <sgallagh> I won't be there
18:23:36 <dcantrell> sgallagh: for you we'll get a big giant stone and put a hat on it
18:23:43 <dcantrell> decathorpe: what physical avatar would you like?
18:23:44 <nirik> 😢
18:23:59 <decathorpe> an empty wallet maybe
18:24:17 <dcantrell> ha! but  :(
18:24:48 <dcantrell> well, I look forward to seeing those of you going at Flock and to everyone else, I hope to see you at another event
18:25:39 <zbyszek> I guess mhroncok is also not coming, I don't see him on the attendee list.
18:26:11 <zbyszek> Anyway, any other topics?
18:26:24 <decathorpe> ok, I've updated the list on #3039 with items from comments on the ticket and from the mailing list
18:26:34 <decathorpe> but no other topics from me
18:26:37 <dcantrell> decathorpe: thank you
18:26:44 <zbyszek> decathorpe: thanks
18:26:53 <decathorpe> feel free to edit the ticket if I missed something
18:27:01 <zbyszek> If nothing else, I'll close in a minute.
18:27:57 <decathorpe> funnily enough this sounds like the "remove" command isn't implemented yet 🤭 https://github.com/rpm-software-management/dnf5/issues/149
18:28:10 <dcantrell> yes, there are gaps
18:28:12 <gotmax23> Fabio Valentini: For changed config options, you may want to add `allow_vendor_change`
18:28:18 <gotmax23> That's now false by default
18:28:32 <decathorpe> is that the same thing as "sticky vendors"?
18:28:50 <gotmax23> Yes
18:28:53 <decathorpe> I think I might summon Conan Kudo if I say that three times
18:29:10 <Eighth_Doctor> 👋
18:29:23 <decathorpe> is this a good thing or a bad thing?
18:29:28 <gotmax23> The ansible dnf5 module is fixed, but it's not available at all on Fedora 38, which is a problem for folks using that to control rawhide machines
18:29:32 <Eighth_Doctor> sticky vendors are a very good feature
18:29:48 <gotmax23> I understand that there's merits for that
18:29:54 <Eighth_Doctor> the complaining people get about breaking things between Fedora and third party repositories mostly goes away with it
18:30:13 <gotmax23> I'm personally against it, but in any case, it should be discussed separately, and not "hidden" in this proposal
18:30:16 <Eighth_Doctor> and it makes swapping from one vendor of a package to another an explicit action
18:30:29 <decathorpe> ah, ok. I'll add it to the list
18:30:49 <zbyszek> OK, let's wrap this up.
18:30:50 <zbyszek> #endmeeting