workstation
LOGS
00:58:15 <brainycmurf> #startmeeting Workstation WG (2023-05-30)
00:58:15 <zodbot> Meeting started Wed May 31 00:58:15 2023 UTC.
00:58:15 <zodbot> This meeting is logged and archived in a public location.
00:58:15 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
00:58:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:58:15 <zodbot> The meeting name has been set to 'workstation_wg_(2023-05-30)'
00:58:15 <brainycmurf> #meetingname workstation
00:58:15 <zodbot> The meeting name has been set to 'workstation'
00:58:15 <brainycmurf> #chair Allan
00:58:15 <zodbot> Current chairs: Allan brainycmurf
00:58:36 <brainycmurf> #info Present members: Allan, Michael, Tomas, Kalev, Matthias, Chris, Jens, Owen, Neal
00:58:36 <brainycmurf> #info Guests:
00:58:36 <brainycmurf> #info Regrets: N
00:58:36 <brainycmurf> #info Missing:
00:58:36 <brainycmurf> #info Secretary: Chris
00:58:37 <brainycmurf> #topic Enable full preemption
00:58:39 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/228
00:58:41 <brainycmurf> It's recently come up on devel@
00:58:43 <brainycmurf> We're ready to do it - just not sure how. Might need to be a desktop only thing, with Anaconda being responsible for setting it.
00:58:46 <brainycmurf> It can either be set at kernel compile time or as a kernel parameter.
00:58:48 <brainycmurf> It's likely going to remain opt in rather than opt out.
00:58:50 <brainycmurf> Any hope of setting it on the command line for upgrades? Would need to be able to safely modify the boot loader configuration files. There might need to a script that inserts the boot parameter.
00:58:53 <brainycmurf> Hopefully it will land for F39.
00:58:55 <brainycmurf> #action Chris to write a change proposal
00:58:57 <brainycmurf> #topic Discussion about setting up a Silverblue SIG
00:58:59 <brainycmurf> #link https://discussion.fedoraproject.org/t/proposing-a-silverblue-sig/82925
00:59:01 <brainycmurf> Unclear where this proposal is going. What should the WG's role be?
00:59:03 <brainycmurf> Tomas: not sure a SIG is a good idea yet
00:59:07 <brainycmurf> Owen: main decision organizationally, should Silverblue SIG be made a sub to the working group or not?
00:59:10 <brainycmurf> Allan: lack of formal organization is understandably frustrating for some in the community; clarifying that relationship, even if some of us are in an advisory capacity could be useful.
00:59:13 <brainycmurf> Owen: we could put that in the charter, Silverblue is an OSTree version of Workstation, keeping them as close as possible, even so far as to say it's a two way street. Explicitly saying keeping them close as possible would be good.
00:59:17 <brainycmurf> Tomas is working on a response to the Discussion thread. There are various issues including where issues are tracked (currently on Github).
00:59:20 <brainycmurf> #agreed Do we think that the Silverblue SIG should be a subgroup of the Workstation WG? Probably not necessary, if there's an agreement that Silverblue shouldn't deviate from Workstation. Also if a few of us participate in the SIG.
00:59:24 <brainycmurf> #action Tomas to post on the thread and some of us to engage with the SIG discussion
00:59:26 <brainycmurf> Owen: SIG could be a who shows up meeting, worked by consensus, and then see if the structure needs more formalizing
00:59:29 <brainycmurf> #topic Automatically uninstalling Anaconda post-install
00:59:31 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/242
00:59:33 <brainycmurf> Looks like this was accepted as an F39 change. Is there anything to do other than making sure that it's preinstalled for 39?
00:59:38 <brainycmurf> #agreed Deferred until we have Neal
00:59:40 <brainycmurf> #topic Consider limiting journal size
00:59:42 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/213
00:59:44 <brainycmurf> We had a proposal that seemed to get a positive response, but nothing has happened since. What ar ehe next steps?
00:59:47 <brainycmurf> #action Chris will circle back with systemd upstream and write up a change proposal if it's ready
00:59:49 <brainycmurf> #topic Red Hat Bugzilla: GNOME packages are in bad shape
00:59:51 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/131
00:59:53 <brainycmurf> Tomas is still working on it, but needs to speak to Matthew Miller about some aspects of the plan.
00:59:56 <brainycmurf> #agreed Start with a smaller subset of packages (maybe the ones where the upstream is gitlab.gnome.org)
00:59:59 <brainycmurf> #action Tomas will talk to Matthew Miller. Allan will summarize in the ticket.
01:00:01 <brainycmurf> #topic Announcements and status updates
01:00:03 <brainycmurf> Continue to work through the issues next week, and clean out the ones that just aren't likely to get any action.
01:00:08 <brainycmurf> #info The minutes from last meeting have been posted online:
01:00:10 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2023-05-24/workstation.2023-05-24-17.46.log.html
01:00:13 <brainycmurf> #endmeeting