workstation
LOGS
18:35:10 <brainycmurf> #startmeeting Workstation WG (2023-04-04)
18:35:10 <zodbot> Meeting started Wed Apr  5 18:35:10 2023 UTC.
18:35:10 <zodbot> This meeting is logged and archived in a public location.
18:35:10 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:35:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:35:10 <zodbot> The meeting name has been set to 'workstation_wg_(2023-04-04)'
18:35:10 <brainycmurf> #meetingname workstation
18:35:10 <zodbot> The meeting name has been set to 'workstation'
18:35:11 <brainycmurf> #chair Michael
18:35:11 <zodbot> Current chairs: Michael brainycmurf
18:35:25 <brainycmurf> #info Present members: Michael, Tomas, Chris, Kalev, Matthias, Jens, Neal
18:35:25 <brainycmurf> #info Guests:
18:35:25 <brainycmurf> #info Regrets: Allan
18:35:25 <brainycmurf> #info Missing:
18:35:25 <brainycmurf> #info Secretary: Owen
18:35:26 <brainycmurf> #topic Fedora 38 final blockers
18:35:28 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/38/final/buglist
18:35:30 <brainycmurf> 0 bugs proposed / 0 bug approved for the Workstation related components
18:35:34 <brainycmurf> #topic systemd-oomd seems overly aggressive (tentatively scheduled)
18:35:36 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/358
18:35:38 <brainycmurf> - Some changes have been made in systemd packaging recently, to make it less aggressive
18:35:40 <brainycmurf> #action mcantanzaro to ping for progress in the issue
18:35:42 <brainycmurf> #topic Discuss proposal of having Web UI installer for Fedora 39 Workstation
18:35:44 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/362
18:35:46 <brainycmurf> Discussion of requirements:
18:35:48 <brainycmurf> - Keyboard and language selection - from our perspective this is best if done before the live setup, perhaps by running a minimal version of gnome-initial-setup. (Would we ask about try vs install at that point?)
18:35:51 <brainycmurf> - Doing keyboard and language selection before the live session doesn't solve things for silverblue or other spins - eventually anaconda will have to have a built-in solution at some point. But for the idea of making the Workstation the initial mover on moving toward the web ui for anaconda, it might be an easier approach (and provide better results for Workstation).
18:35:56 <brainycmurf> - Major work items are: gdm changes to set up this session, and modiifcations ot g-i-s to run in this mode
18:35:59 <brainycmurf> #action mclasen and matthias to discuss feasibility of implementing g-i-s approach in near timescale, report back on issue 362
18:36:04 <brainycmurf> - Custom partitionn - Michael is of the opinion that we should effectively have the same capabilities as before (but not advanced "blivet").
18:36:07 <brainycmurf> #action Michael to work on coming up with a specific list of custom partitioning capabilities
18:36:09 <brainycmurf> - Allan's list: https://pagure.io/fedora-workstation/issue/362#comment-847926
18:36:11 <brainycmurf> #topic Broadcom wireless
18:36:13 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/116
18:36:15 <brainycmurf> - Seems to be little hope of getting this hardware to work out of the box
18:36:17 <brainycmurf> - Probably best to display some sort message to user about how to proceed
18:36:19 <brainycmurf> #action aday to design how this should look
18:36:21 <brainycmurf> - What component displays the information? gnome-settings-daemon doesn't have a UI other than displaying notifications
18:36:24 <brainycmurf> #topic Announcements and status updates
18:36:26 <brainycmurf> #info F38 scheduled for release Apr 18 if no delays
18:36:28 <brainycmurf> #info encryption planning document posted for public discussion at https://discussion.fedoraproject.org/t/future-of-encryption-in-fedora/80397/1
18:36:33 <brainycmurf> #info Last week's meeting minutes posted
18:36:35 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2023-03-31/workstation.2023-03-31-00.55.log.html
18:36:38 <brainycmurf> #endmeeting