workstation
LOGS
03:15:21 <brainycmurf> #startmeeting Workstation WG (2022-10-04)
03:15:21 <zodbot> Meeting started Wed Oct  5 03:15:21 2022 UTC.
03:15:21 <zodbot> This meeting is logged and archived in a public location.
03:15:21 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
03:15:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
03:15:21 <zodbot> The meeting name has been set to 'workstation_wg_(2022-10-04)'
03:15:21 <brainycmurf> #meetingname workstation
03:15:21 <zodbot> The meeting name has been set to 'workstation'
03:15:21 <brainycmurf> #chair Allan
03:15:21 <zodbot> Current chairs: Allan brainycmurf
03:15:38 <brainycmurf> #info Present members:Allan, Kalev, Chris, Tomas, Michael, Neal, Owen
03:15:38 <brainycmurf> #info Guests: Luna Jernberg(bittin)
03:15:38 <brainycmurf> #info Regrets: Matthias Clasen,Jens Petersen (30 minute late colliding meeting)
03:15:38 <brainycmurf> #info Missing:
03:15:38 <brainycmurf> #info Secretary: Neal
03:15:39 <brainycmurf> #topic Can we move the start of the meeting by 30 minutes (Matthias and Jens will have a conflict starting today)
03:15:42 <brainycmurf> #action Allan to create a poll about a new time
03:15:44 <brainycmurf> #topic F37 release status
03:15:46 <brainycmurf> #info Final freeze: 4 October
03:15:48 <brainycmurf> #info Early target release date: 18 October
03:15:50 <brainycmurf> fKalev will be on vacation in October: 10 - 24
03:15:52 <brainycmurf> Will David keep an eye on freeze exceptions?
03:15:54 <brainycmurf> #info Flatpak builds are broken
03:15:56 <brainycmurf> #link https://pagure.io/fedora-infrastructure/issue/10912
03:15:58 <brainycmurf> #topic F37 blocker review
03:16:00 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/37/final/buglist
03:16:04 <brainycmurf> Accepted blockers:
03:16:06 <brainycmurf> #info gnome-contacts: Link Contacts feature completely broken.
03:16:08 <brainycmurf> - No fix currently.
03:16:10 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130661
03:16:12 <brainycmurf> #info gnome-contacts: Editing an existing contact's email address causes Contacts to display an empty "Unnamed Person" card, other edits made at the same time are lost.
03:16:15 <brainycmurf> - There is an upstream fix.
03:16:17 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130657
03:16:19 <brainycmurf> Niels is going to look into these in his spare time.
03:16:21 <brainycmurf> When is the deadline to decide whether to remove an app from the install image?
03:16:23 <brainycmurf> The go/no go meeting is on the 13th. The final compose needs to be ready prior to that - so a decision needs to be made by 11th October (assuming Fedora doesn't slip).
03:16:26 <brainycmurf> Should we remove contacts if it still has blockers?
03:16:28 <brainycmurf> - Yes (reluctantly): Chris, Michael,
03:16:30 <brainycmurf> - Probably: Kalev
03:16:34 <brainycmurf> - Some reservations: Neal, Matthias, Owen
03:16:36 <brainycmurf> Matthias: if you remove things, it's hard to bring them back
03:16:38 <brainycmurf> Michael: Contacts could become more important if/when GNOME Mail becomes a thing.
03:16:40 <brainycmurf> Owen: we don't have a good way to pull in new default apps on upgrade. However, we shouldn't block the release if we don't have a prospect of fixing the blocker.
03:16:43 <brainycmurf> #info gnome-calendar: Calendar does not delete events properly
03:16:45 <brainycmurf> - No fix currently.
03:16:47 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130981
03:16:49 <brainycmurf> Matthias to look at it
03:16:51 <brainycmurf> #info gnome-calendar: Editing recurring events is broken, changes a single instance instead of all instances
03:16:54 <brainycmurf> - No fix currently.
03:16:56 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130977
03:16:58 <brainycmurf> #info gnome-calendar: Month names are not in sync
03:17:00 <brainycmurf> - No fix currently.
03:17:04 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130964
03:17:06 <brainycmurf> Kalev: calendar editing shouldn't be considered "basic functionality"
03:17:08 <brainycmurf> Michael: we should block the release on this
03:17:10 <brainycmurf> #action Allan to put out a call for help
03:17:12 <brainycmurf> glibc: glibc 2.36+ breaks EAC with removal of DT_HASH (and other game libraries), making games fail to load
03:17:15 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2129358
03:17:17 <brainycmurf> There's discussion about what changes might be needed.
03:17:19 <brainycmurf> #info ON_QA firefox: Firefox cause flickering context menus on websites since 105.1 on wayland
03:17:21 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130087
03:17:23 <brainycmurf> #info Abrt does not report a segfault which is reported in journalctl
03:17:25 <brainycmurf> Could this one have gone away?
03:17:27 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2128662
03:17:29 <brainycmurf> Proposed blockers:
03:17:31 <brainycmurf> #info gnome-photos: Memory exhaustion when editing a cropped photo
03:17:35 <brainycmurf> - QA is uncertain whether this should be classified as basic functionality or not.
03:17:37 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130937
03:17:39 <brainycmurf> Do we think that this should be a blocker?
03:17:41 <brainycmurf> The issue presents itself when an image is cropped, and then has shadows or highlights adjusted.
03:17:43 <brainycmurf> If it's a gegl issue, it's going to be to tricky to fix.
03:17:45 <brainycmurf> A timely fix will probably involve disabling some functionality in Photos.
03:17:47 <brainycmurf> Is it a blocker? Owen, Michael, and Chris say no, since it requires a particular combination of actions to trigger.
03:17:50 <brainycmurf> #info gnome-shell: On Screen Keyboard cannot type a space anywhere
03:17:52 <brainycmurf> - No fix currently
03:17:54 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2131837
03:17:56 <brainycmurf> #action Matthias to ping Carlos
03:17:58 <brainycmurf> #info imsettings: Default GTK_IM_MODULE should be ibus in GNOME Xorg
03:18:00 <brainycmurf> - QA wants more information before deciding on blocker status
03:18:04 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2131673
03:18:06 <brainycmurf> Neal wonders if we should just remove this imsettings thing entirely.
03:18:08 <brainycmurf> Relevant developers are on the case.
03:18:10 <brainycmurf> #topic fontconfig brokenness on Silverblue
03:18:12 <brainycmurf> #link https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/330
03:18:14 <brainycmurf> #link https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/331
03:18:16 <brainycmurf> Matthias came up with a fix, but it needs testing.
03:18:18 <brainycmurf> Michael submitted the fix to the freedesktopsdk - wheels are in motion.
03:18:20 <brainycmurf> #action Circle back next week
03:18:22 <brainycmurf> #topic Give ABRT some love
03:18:24 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
03:18:26 <brainycmurf> deferred
03:18:28 <brainycmurf> #topic Reconsider GNOME RC testing arrangements
03:18:30 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/334
03:18:34 <brainycmurf> deferred
03:18:36 <brainycmurf> #topic Announcements, Status Updates
03:18:38 <brainycmurf> Tomas managed to talk to some ABRT people internally. Some of the issues that Michael mentioned have been fixed. We'll discuss this at another meeting in the near future.
03:18:41 <brainycmurf> SLIMBOOK Fedora Hardware is moving ahead forward
03:18:43 <brainycmurf> Fedora 37 Release party Online 4-5th November 2022
03:18:45 <brainycmurf> #info The minutes from last week have been posted.
03:18:47 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-09-27/workstation.2022-09-27-16.18.log.html
03:27:27 <brainycmurf> #endmeeting