workstation
LOGS
20:35:57 <brainycmurf> #startmeeting Workstation WG (2022-09-13)
20:35:57 <zodbot> Meeting started Tue Sep 13 20:35:57 2022 UTC.
20:35:57 <zodbot> This meeting is logged and archived in a public location.
20:35:57 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
20:35:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:35:57 <zodbot> The meeting name has been set to 'workstation_wg_(2022-09-13)'
20:35:57 <brainycmurf> #meetingname workstation
20:35:57 <zodbot> The meeting name has been set to 'workstation'
20:35:57 <brainycmurf> #chair Allan
20:35:58 <zodbot> Current chairs: Allan brainycmurf
20:36:20 <brainycmurf> #info Present members: Allan, Chris, Michael, Kalev, Matthias, Jens, Neal, Owen
20:36:21 <brainycmurf> #info Guests:
20:36:21 <brainycmurf> #info Regrets: Tomáš, Luna
20:36:21 <brainycmurf> #info Missing:
20:36:21 <brainycmurf> #info Secretary: Matthias
20:36:21 <brainycmurf> #topic F37 release status
20:36:23 <brainycmurf> Kalev reports things are mostly up-to-date, except for gnome-terminal.
20:36:25 <brainycmurf> #info gnome-contacts 43.rc is stuck, due to issues
20:36:27 <brainycmurf> #link https://gitlab.gnome.org/GNOME/gnome-contacts/-/issues/266
20:36:29 <brainycmurf> Kalev is the new gnome-contacts package maintainer
20:36:31 <brainycmurf> #info gnome 43 final, test week results
20:36:33 <brainycmurf> #link https://testdays.fedoraproject.org/events/140
20:36:35 <brainycmurf> The test week happened in #fedora-workstation, but we did not see that many
20:36:37 <brainycmurf> new people start talking in the channel. We will keep trying next cycle.
20:36:39 <brainycmurf> We haven't heard an update from Sumantro on changing the format of
20:36:41 <brainycmurf> test day results.
20:36:43 <brainycmurf> Matthias noticed that live iso and installation transitions need some attention.
20:36:45 <brainycmurf> #topic i18n test day results
20:36:47 <brainycmurf> #link https://fedoraproject.org/wiki/Test_Day:2022-09-06_I18N_Test_Day
20:36:51 <brainycmurf> Jens reports that the participation was a bit lower (16), a few issues were
20:36:53 <brainycmurf> found. Some problem with ibus activation in X11 sessions. Anaconda has an
20:36:55 <brainycmurf> issue with geolocation. IBus can now be restarted in Wayland sessions.
20:36:57 <brainycmurf> #topic F37 blocker bugs
20:36:59 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/37/final/buglist
20:37:01 <brainycmurf> Accepted blockers
20:37:03 <brainycmurf> * flatpak - https://bugzilla.redhat.com/show_bug.cgi?id=2124857 (fixed)
20:37:05 <brainycmurf> * gnome-contacts - https://bugzilla.redhat.com/show_bug.cgi?id=2111003 (fixed upstream)
20:37:07 <brainycmurf> * gnome-initial-setup - https://bugzilla.redhat.com/show_bug.cgi?id=2121110 (not fixed, this is the one Kalev said he'd look at, Kalev reports this is actually in the shell, Matthias will ping Carlos)
20:37:10 <brainycmurf> * gnome-initial-setup - https://bugzilla.redhat.com/show_bug.cgi?id=2123494 (fixed upstream)
20:37:12 <brainycmurf> * gnome-shell - https://bugzilla.redhat.com/show_bug.cgi?id=2125252 (fixed upstream)
20:37:14 <brainycmurf> * gnome-software - https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1895 (sounds like it's fixed?)
20:37:19 <brainycmurf> #action Matthias to ping Carlos or Ray about the keyboard issue
20:37:21 <brainycmurf> Proposed blockers
20:37:23 <brainycmurf> * gnome-shell - https://bugzilla.redhat.com/show_bug.cgi?id=2125439 (no fix, no upstream ticket listed)
20:37:26 <brainycmurf> Matthias: doesn't seem like a blocker (my main point was: what criteria does this hit?)
20:37:28 <brainycmurf> Kalev: media who are testing the release may notice it
20:37:30 <brainycmurf> Owen: it's a serious issue, probably not a blocker though
20:37:32 <brainycmurf> Neal: should be a blocker
20:37:34 <brainycmurf> We need to verify that the tester had the fix to the previous issue
20:37:36 <brainycmurf> #action Matthias to comment on the issue
20:37:38 <brainycmurf> * chrome-gnome-shell - https://bugzilla.redhat.com/show_bug.cgi?id=2106868 (not a blocker, since the requirements don't cover this; attention wanted anyway)
20:37:41 <brainycmurf> #info proposal to cover it under release criteria
20:37:43 <brainycmurf> #link https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/thread/2RWICSBROMIPKYYP2T73NRYNRZG5PVJB/
20:37:46 <brainycmurf> Kalev thinks he can fix this. It involves adding a new package
20:37:50 <brainycmurf> #action Kalev will reach out to the package maintainer
20:37:52 <brainycmurf> Some discussion on whether extension installation should be blocking
20:37:54 <brainycmurf> release.
20:37:56 <brainycmurf> Jens suggests that maybe packaged extensions should pull in the extensions app.
20:37:58 <brainycmurf> Allan points out that there is hesitation to making extensions too prominent and
20:38:00 <brainycmurf> easy to find, since installing extensions is a "void your warranty" move.
20:38:02 <brainycmurf> Neal states that he think the extensions app should be preinstalled.
20:38:04 <brainycmurf> There are problems around the stability of the extensions website api,
20:38:06 <brainycmurf> and we don't have control over it.
20:38:08 <brainycmurf> The general sentiment seems to be: yes, but it is difficult to formally
20:38:10 <brainycmurf> support, since we don't control all the parts. At the very least, we want
20:38:12 <brainycmurf> to know about it, so we can mark it as a known issue.
20:38:14 <brainycmurf> The gnome-contacts regression is still on the blocker list because the update
20:38:16 <brainycmurf> wasn't pushed, and the origin blocker bug is still open.
20:38:20 <brainycmurf> #action: Michael to reach out to Niels about the regression
20:38:22 <brainycmurf> #topic Announcements, Status Updates
20:38:24 <brainycmurf> #info The minutes from last week have been posted.
20:38:26 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-09-07/workstation.2022-09-07-01.10.log.html
20:38:29 <brainycmurf> Matthias mentions GNOME 43 tarballs due this weekend. He is on the hook
20:38:31 <brainycmurf> for building the release next week. Kalev will keep up with Fedora builds,
20:38:33 <brainycmurf> and Allan is working on upstream release notes.
20:38:35 <brainycmurf> Chris volunteered for looking for Fedora magazine article volunteer for
20:38:37 <brainycmurf> covering GNOME 43 in Fedora 37.
20:38:39 <brainycmurf> Neal announces that his anaconda-removal systemd service is in rawhide now,
20:38:41 <brainycmurf> but the work to enable it has not done yet. Open discussion whether to just do
20:38:43 <brainycmurf> it in rawhide and 38. We anticipate problems with parts of udisks getting removed
20:38:45 <brainycmurf> as a side-effect, so doing it only for 38 is the responsible thing to do.
20:38:47 <brainycmurf> One suggestion was to make it only install openh264 and not remove anaconda
20:38:51 <brainycmurf> for f37.
20:41:31 <brainycmurf> #endmeeting