workstation
LOGS
15:08:10 <brainycmurf> #startmeeting Workstation WG (2022-08-23)
15:08:10 <zodbot> Meeting started Wed Aug 24 15:08:10 2022 UTC.
15:08:10 <zodbot> This meeting is logged and archived in a public location.
15:08:10 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:08:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:08:10 <zodbot> The meeting name has been set to 'workstation_wg_(2022-08-23)'
15:08:10 <brainycmurf> #meetingname workstation
15:08:10 <zodbot> The meeting name has been set to 'workstation'
15:08:10 <brainycmurf> #chair Allan
15:08:10 <zodbot> Current chairs: Allan brainycmurf
15:08:26 <brainycmurf> #info Present members: Allan, Michael, Kalev, Matthias, Chris, Tomas, Jens, Neal, Owen
15:08:26 <brainycmurf> #info Guests: Luna Jernberg (bittin), Sumantro, Jimmac
15:08:26 <brainycmurf> #info Regrets:
15:08:26 <brainycmurf> #info Missing:
15:08:26 <brainycmurf> #info Secretary: Michael
15:08:27 <brainycmurf> #topic F37 release status
15:08:29 <brainycmurf> #info F37 beta freeze has just begun
15:08:31 <brainycmurf> #info Next GNOME development release is the RC on 2022-09-03
15:08:33 <brainycmurf> #info Early target date for F37 beta is 2022-09-13
15:08:35 <brainycmurf> #info Beta go/no-go meeting is 2022-09-08
15:08:37 <brainycmurf> #info F37 beta blockers
15:08:39 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/37/beta/buglist
15:08:41 <brainycmurf> Everything is up to date currently except Maps
15:08:43 <brainycmurf> Can we get the GNOME RC into F37 beta? Will require a freeze break.
15:08:45 <brainycmurf> #topic GNOME 43 test day results
15:08:47 <brainycmurf> #link https://testdays.fedoraproject.org/events/138
15:08:49 <brainycmurf> Kalev: test week last week went well
15:08:51 <brainycmurf> Tomas, Neal: Maybe we should use Fedora Workstation channel next time instead of the test week channel, to avoid conflicting with kernel test week discussion.
15:08:56 <brainycmurf> Sumantro: test week was amazing, but using the same week as kernel test week is quite busy. Using Workstation channel would be a good idea.
15:08:59 <brainycmurf> Luna: should review the GNOME extensions test cases before next test week
15:09:01 <brainycmurf> Luna: reported various bugs that are now fixed
15:09:03 <brainycmurf> Tomas: what do we do with the results of the test week? Would be good to have a summary of the results.
15:09:06 <brainycmurf> Matthias: wiki format makes it a little difficult to review results; would be better to have bug reports
15:09:09 <brainycmurf> Allan: not sure how to turn test day results into actionable issues
15:09:11 <brainycmurf> Kalev: Test results for Music look bad, maybe something is wrong with tracker?
15:09:13 <brainycmurf> Luna: It's probably https://gitlab.gnome.org/GNOME/tracker/-/issues/376
15:09:15 <brainycmurf> Michael: We're not able to ship Music yet anyway since the change to open audio files did not land yet. Will stick with Rhythmbox for F37
15:09:18 <brainycmurf> Allan: found that Software is missing most content from the homepage due to stale data and changes to featured apps. Poor first impression. https://bugzilla.redhat.com/show_bug.cgi?id=2119089
15:09:21 <brainycmurf> Allan: various issues found with nautilus GTK 4 port https://bugzilla.redhat.com/show_bug.cgi?id=2117710 e.x
15:09:26 <brainycmurf> #topic Reduce default service timeout to 15s
15:09:28 <brainycmurf> #link https://pagure.io/fesco/issue/2853
15:09:30 <brainycmurf> #link https://github.com/systemd/systemd/pull/18386
15:09:32 <brainycmurf> Allan: FESCo wants us to follow the change proposal process, so this won't make F37
15:09:34 <brainycmurf> Kalev: sad, but so be it... unless can we fix PackageKit?
15:09:36 <brainycmurf> Neal: suspects the problem is librepo, not PackageKit. librepo creates a gpg agent for each metadata refresh but has no way to shut them down; this keeps PackageKit alive when it shouldn't be. Should be fixed with dnf 5.
15:09:40 <brainycmurf> Matthias: PackageKit is not the only problem here anyway. Same problem with podman
15:09:42 <brainycmurf> Neal: Same problem with bluez
15:09:44 <brainycmurf> Punt to 38 or Change Proposal?
15:09:46 <brainycmurf> Neal: Maybe we can fix it upstream. Otherwise we are going to need a change proposal for F38.
15:09:48 <brainycmurf> #action Chris to ask Anita if this can be changed upstream
15:09:50 <brainycmurf> If this fails, Allan will help with the change proposal
15:09:54 <brainycmurf> #topic Evaluate the state of gnome-calendar
15:09:56 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/306
15:09:58 <brainycmurf> Michael: calendar is important, don't want to get rid of it. It's buggy, but not as buggy as it used to be.
15:10:01 <brainycmurf> Kalev: not sure we need it
15:10:03 <brainycmurf> Neal: live and die by calendar, but doesn't edit calendar entries locally
15:10:05 <brainycmurf> Luna: there was someone in the blocker bugs meeting yesterday 22th August finding they could not delete calendar events in gnome-calendar, but nothing was proposed yet, they will discuss it more on Monday next week 29th August
15:10:09 <brainycmurf> Michael: gnome-calendar is now better with timezones, but not so good at deleting a series of events
15:10:12 <brainycmurf> Matthias: Online Accounts does not seem to work
15:10:14 <brainycmurf> Michael: it launches Online Accounts panel in gnome-control-center for me
15:10:16 <brainycmurf> Allan: calendaring is hard, not fond of having apps in default install that fall apart when you try to use them. Doesn't seem very serious as it stands today.
15:10:19 <brainycmurf> Neal: suspect most users do not try to edit calendar entries locally. Seems reliable otherwise.
15:10:21 <brainycmurf> Michael: gnome-contacts has blockers bugs if QA notices them, but gnome-calendar just have some minor issues thats not blocker issues as i see it
15:10:26 <brainycmurf> Matthias: seems worth to keep it around
15:10:28 <brainycmurf> Allan: let's keep track of the more serious issues
15:10:30 <brainycmurf> Luna: keep it around and try to fix it
15:10:32 <brainycmurf> #topic Release blocking criteria for preinstalled apps
15:10:34 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/304
15:10:36 <brainycmurf> #deferred
15:10:38 <brainycmurf> #topic Announcements, Status Updates
15:10:40 <brainycmurf> #info The minutes from last week have been posted.
15:10:42 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-08-17/workstation.2022-08-17-02.53.log.html
15:10:45 <brainycmurf> #info KDE aKademy first week of October in Barcelona
15:10:47 <brainycmurf> #link http://akademy.kde.org/2022
15:10:49 <brainycmurf> Neal is working on ffmpeg5 stuff and wants to get a hold of Christian Schaller to talk about codecs. Matthias and Tomas will help with this.
15:10:54 <brainycmurf> Allan has been working on the PRD
15:10:56 <brainycmurf> #link https://docs.fedoraproject.org/en-US/workstation-working-group/prd/
15:10:58 <brainycmurf> Allan has updated the WG schedule
15:11:00 <brainycmurf> #link https://docs.fedoraproject.org/en-US/workstation-working-group/schedule/
15:11:02 <brainycmurf> #endmeeting