workstation
LOGS
17:27:58 <brainycmurf> #startmeeting Workstation WG (2022-08-09)
17:27:58 <zodbot> Meeting started Tue Aug  9 17:27:58 2022 UTC.
17:27:58 <zodbot> This meeting is logged and archived in a public location.
17:27:58 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:27:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:27:58 <zodbot> The meeting name has been set to 'workstation_wg_(2022-08-09)'
17:27:58 <brainycmurf> #meetingname workstation
17:27:58 <zodbot> The meeting name has been set to 'workstation'
17:27:58 <brainycmurf> #chair Allan
17:27:58 <zodbot> Current chairs: Allan brainycmurf
17:28:11 <brainycmurf> #info Present members:Kalev, Allan, Neal, Chris, Jens, Matthias, Tomas
17:28:11 <brainycmurf> #info Guests:Luna Jernberg (bittin), Zac
17:28:11 <brainycmurf> #info Regrets:
17:28:11 <brainycmurf> #info Missing:
17:28:11 <brainycmurf> #info Secretary: Neal
17:28:12 <brainycmurf> #topic F37 release status
17:28:14 <brainycmurf> GNOME 43 beta tarball deadline was last Saturday
17:28:16 <brainycmurf> Kalev: most of GNOME 43 beta is built, gnome-shell hasn't been released, webkitgtk is not built yet, blocks gnome-initial-setup
17:28:21 <brainycmurf> Michael: ppc64le and s390x is OOMing, blocking successful builds of webkitgtk. Complains about lack of s390x resources
17:28:24 <brainycmurf> Neal: s390x builders are shared between RHEL and Fedora, unfortunately.
17:28:26 <brainycmurf> Chris: maybe tuning zram and adding swap may help fix the OOM issue
17:28:28 <brainycmurf> F37 GNOME test day coming up
17:28:30 <brainycmurf> #link https://pagure.io/fedora-qa/issue/705
17:28:32 <brainycmurf> Kalev: Proposes test week next week
17:28:34 <brainycmurf> Neal: Next week is DevConf.US, he won't be around
17:28:36 <brainycmurf> Luna: not anywhere near Boston, so will be around to help test
17:28:38 <brainycmurf> Allan: We'll shoot for Monday to start test week as the team will be around
17:28:40 <brainycmurf> Allan: would like people to test it asap to help upstream
17:28:42 <brainycmurf> Neal: might give it a shot on his work laptop with Chris' btrfs reversible upgrade procedure
17:28:44 <brainycmurf> #info draft write-up for a reversible dual-boot test station using btrfs snapshots
17:28:46 <brainycmurf> #link https://fedoraproject.org/wiki/User:Chrismurphy/Draft/dualboot_teststation
17:28:50 <brainycmurf> Allan notes this will also include Nautilus ported to GTK4 too
17:28:52 <brainycmurf> Allan: will reach out to get the test week wiki page to have test focus info
17:28:54 <brainycmurf> #topic F37 milestone issue review
17:28:56 <brainycmurf> #link https://pagure.io/fedora-workstation/issues?status=Open&milestone=Fedora+37&close_status=
17:28:58 <brainycmurf> We'll cover #306 and #164 separately.
17:29:00 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/84
17:29:02 <brainycmurf> Neal: working on OpenH264 (#84) install and Anaconda removal (#242) on firstboot scripts
17:29:04 <brainycmurf> Michael: Milan has theoretically fixed GNOME Software to work as our updates policy intends (#107)
17:29:07 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
17:29:09 <brainycmurf> Michael and Tomas say the ABRT reports are decent quality now, but lots of dupes filed because it keeps making private bugs when it doesn't need to (#130)
17:29:12 <brainycmurf> Neal suggests someone volunteer to disable the logic for creating private bugs
17:29:14 <brainycmurf> #action Matthias will try to find someone to work up an ABRT PR
17:29:16 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
17:29:20 <brainycmurf> Tomas has ongoing work for this. It's not tied to a particular release, so we can drop the F37 milestone.
17:29:23 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/163
17:29:25 <brainycmurf> This issue has been stuck for a while. We would like it for F37 though.
17:29:27 <brainycmurf> zbyszek did post a PR, but it was only for system units (#163)
17:29:29 <brainycmurf> #link https://github.com/systemd/systemd/pull/18386
17:29:31 <brainycmurf> Recent attempts to hail zbyszek have so far failed
17:29:33 <brainycmurf> #action Michael to propose a downstream patch
17:29:35 <brainycmurf> If it doesn't get accepted, we can raise the issue with FESCo
17:29:37 <brainycmurf> Allan: For the new string to replace "recommendation" phrase, we'll need downstream translations (#203)
17:29:40 <brainycmurf> Neal: Suggests maybe a generic "Available for your system" string instead of distro-specific one?
17:29:42 <brainycmurf> Matthias: It's possible to make a placeholder for distro name in the string
17:29:44 <brainycmurf> Neal: Is it even possible to translate metainfo files in Weblate?
17:29:46 <brainycmurf> Allan: thinks so, but can't find a reference for it
17:29:50 <brainycmurf> #topic Improve GTK4 font rendering by default for 1080p displays
17:29:52 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/295
17:29:54 <brainycmurf> Deferred
17:29:56 <brainycmurf> #topic Remove Photos from the default apps
17:29:58 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/164
17:30:00 <brainycmurf> Deferred
17:30:02 <brainycmurf> #topic Evaluate the state of gnome-calendar
17:30:04 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/306
17:30:06 <brainycmurf> Deferred
17:30:08 <brainycmurf> #topic Announcements, Status Updates
17:30:10 <brainycmurf> Matthias: working on writing up test cases
17:30:12 <brainycmurf> Neal: Will be at DevConf.US next week
17:30:14 <brainycmurf> Fedora Nest 2022 recordings of talks is up until November if you did sign up on Hopin if not they will be up on Fedoras Youtube channel in 1-2 months
17:30:17 <brainycmurf> #info The minutes from last week have been posted.
17:30:21 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-08-02/workstation.2022-08-02-19.31.log.html
17:30:24 <brainycmurf> #endmeeting