workstation
LOGS
20:43:20 <brainycmurf> #startmeeting Workstation WG (2022-07-05)
20:43:20 <zodbot> Meeting started Tue Jul  5 20:43:20 2022 UTC.
20:43:20 <zodbot> This meeting is logged and archived in a public location.
20:43:20 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
20:43:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:43:20 <zodbot> The meeting name has been set to 'workstation_wg_(2022-07-05)'
20:43:21 <brainycmurf> #meetingname workstation
20:43:21 <zodbot> The meeting name has been set to 'workstation'
20:43:21 <brainycmurf> #chair Allan
20:43:21 <zodbot> Current chairs: Allan brainycmurf
20:43:34 <brainycmurf> #info Present members: Michael, Kalav, Neal, Matthias, Chris, Allan
20:43:34 <brainycmurf> #info Guests: Jorge, Maira, Zac
20:43:34 <brainycmurf> #info Regrets: Tomas, Luna
20:43:34 <brainycmurf> #info Missing: Jens
20:43:34 <brainycmurf> #info Secretary: Michael
20:43:35 <brainycmurf> #topic Drop flathub filtering
20:43:37 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/300
20:43:39 <brainycmurf> Matthias: Most of feedback on devel@ was off topic
20:43:41 <brainycmurf> Neal: But lack of vendor preference in GNOME Software is a legitimate issue: we now prefer third-party sources to Fedora sources
20:43:44 <brainycmurf> Michael: Prefers Flatpaks over RPMs no matter what
20:43:46 <brainycmurf> Allan: What happens if we have flatpaks from different sources (Fedora vs. Flathub)?
20:43:48 <brainycmurf> Kalev: GNOME Software prefers whatever comes first alphabetically (Flatpak > RPM, then Fedora > Flathub)
20:43:51 <brainycmurf> Michael: We received negative feedback about difficulty of building Fedora flatpaks, broken for several months
20:43:54 <brainycmurf> Kalev: Do we want to continue building Fedora flatpaks at all?
20:43:56 <brainycmurf> Michael: We still want to replace preinstalled apps with Flatpaks...
20:43:58 <brainycmurf> Neal, Michael: ...but we cannot enable content from Flathub by default, it has to remain opt-in
20:44:00 <brainycmurf> Kalev: Will try to fix the build infrastructure for Fedora Flatpaks
20:44:02 <brainycmurf> Michael, Neal: Big problem: Fedora Flatpaks are not updated when RPMs are updated
20:44:06 <brainycmurf> #link https://discussion.fedoraproject.org/t/rfc-build-tag-in-rpms-nvr-nvrb/39954
20:44:08 <brainycmurf> Michael: Should probably focus discussion on vendor preference in GNOME Software
20:44:10 <brainycmurf> #action: mclasen to talk to Milan about GNOME Software vendor preferences
20:44:12 <brainycmurf> Michael: Do we have consensus that Flathub should be preferred vs. Fedora RPMs?
20:44:14 <brainycmurf> Neal: No
20:44:16 <brainycmurf> Michael presents tirade about importance of sandboxing. RPMs are unsafe compared to flatpaks.
20:44:18 <brainycmurf> Neal: Suggests using firejail
20:44:20 <brainycmurf> Michael: It's possible, but requires extra work
20:44:22 <brainycmurf> Neal: Still wants Fedora content to always be preferred over third-party sources
20:44:24 <brainycmurf> Allan: Doesn't look like we will agree on this point, might need to discuss more elsewhere, perhaps in ticket.
20:44:27 <brainycmurf> #topic Adding Fedora toolbx as part of iso
20:44:29 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/320
20:44:31 <brainycmurf> WG has consensus to include only the command line client, but not toolbx images which would increase install media size.
20:44:36 <brainycmurf> Allan: What is our reason for this?
20:44:38 <brainycmurf> Neal: Promote toolbx as first-class developer tool, alongside Boxes. People will give it greater consideration when shipped by default.
20:44:41 <brainycmurf> #agreed Ship toolbx
20:44:43 <brainycmurf> #action Kalev to update comps
20:44:45 <brainycmurf> #topic Move Fedora bookmarks to Fedora start page
20:44:47 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/313
20:44:49 <brainycmurf> Neal: would rather not remove bookmarks, having them is an easy way to help people find things
20:44:51 <brainycmurf> Neal: also useful to have bookmarks appear in omnibar. People don't know these services exist unless advertised.
20:44:54 <brainycmurf> Michael: maybe we could compromise on removing some of these, rather than all
20:44:56 <brainycmurf> Maira: But most Fedora users are not Fedora developers. Bookmarks are personal.
20:44:58 <brainycmurf> Matthias: Isn't it sufficient to display links on Fedora start page?
20:45:00 <brainycmurf> Maira: It's less intrusive to users to have these links on the Fedora start page
20:45:02 <brainycmurf> Chris: I would have one Fedora bookmark that links to a website that displays all other links
20:45:06 <brainycmurf> Neal: Putting links on the start page does not help for users who change the start page
20:45:08 <brainycmurf> WG discusses possibility of bringing back a local documentation web browser app to view online docs
20:45:11 <brainycmurf> Michael: Proposes removing Red Hat and Free Content bookmarks folders. These are not Fedora-related.
20:45:14 <brainycmurf> Allan: What about website redesign? If website improves then we'd have less need for these bookmarks.
20:45:17 <brainycmurf> #action Neal will submit a pull request to reduce the quantity of bookmarks
20:45:19 <brainycmurf> #topic Improve GTK4 font rendering by default for 1080p displays
20:45:21 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/295
20:45:23 <brainycmurf> Deferred
20:45:25 <brainycmurf> #topic Announcements, Status Updates
20:45:27 <brainycmurf> #info The minutes from last week have been posted.
20:45:29 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-06-29/workstation.2022-06-29-00.35.log.html
20:45:32 <brainycmurf> Michael discusses libsoup 2 -> libsoup 3 change proposal
20:45:36 <brainycmurf> #endmeeting