workstation
LOGS
19:45:29 <brainycmurf> #startmeeting Workstation WG (2022-06-14)
19:45:29 <zodbot> Meeting started Tue Jun 14 19:45:29 2022 UTC.
19:45:29 <zodbot> This meeting is logged and archived in a public location.
19:45:29 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:45:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:45:29 <zodbot> The meeting name has been set to 'workstation_wg_(2022-06-14)'
19:45:29 <brainycmurf> #meetingname workstation
19:45:29 <brainycmurf> #chair mcatanzaro
19:45:29 <zodbot> The meeting name has been set to 'workstation'
19:45:29 <zodbot> Current chairs: brainycmurf mcatanzaro
19:45:53 <brainycmurf> #chair aday
19:45:53 <zodbot> Current chairs: aday brainycmurf mcatanzaro
19:46:09 <brainycmurf> #info Present members: Allan, Chris, Mattias, Jens, Michael, Neal, Tomas
19:46:10 <brainycmurf> #info Guests:Luna Jernberg(bittin), Matthew Miller, Alejandro and Javier from Slimbook
19:46:10 <brainycmurf> #info Regrets:
19:46:10 <brainycmurf> #info Missing:
19:46:10 <brainycmurf> #info Secretary: Chris
19:46:10 <brainycmurf> #topic Slimbook with Fedora Workstation/GNOME and Fedora KDE ?
19:46:14 <brainycmurf> Guests Alejandro & Javier, with Slimbook. We'd like to collaborate with Fedora, release a Fedora device to the market, has been in discussion for a while. We are from the laptop maker slimbook, community focused brand, we want to produce a product with very good compatibility with Linux distributions.
19:46:18 <brainycmurf> Matthew: The idea is to have a Fedora branded Slimbook, and it would be preinstalled. This would be an visible option on both Fedora and Slimbook web sites.
19:46:21 <brainycmurf> Matthew: Is this a specific model you have in mind already? Future models would be equivalent? Main concern, we don't have resources to do hardware enablement, for example WiFi. We can commit to testing, but we can't commit to making it work. What are you expecting from us? A lot of things could be issues, power management, camera - if it's tested to work, that's great, but what happens if things change with the next model with new hardware?
19:46:26 <brainycmurf> Chris: What's your relationship with upstream kernel development?
19:46:28 <brainycmurf> Alejandro: We don't but we try to avoid troublesome hardware by choosing hardware that already works and has good compatibility with Linux kernel.
19:46:31 <brainycmurf> Matthias: Which distro kernel are you making hardware decisions on ?
19:46:33 <brainycmurf> Alejandro: All kernels, we try to compile the kernel ourselves and try to get the hardware working.
19:46:36 <brainycmurf> Neal: I recall some third party kernel modules for ACPI and power management, we don't ship out of tree kernel modules in Fedora, so I'm wondering how that will work.
19:46:39 <brainycmurf> Alejandro: We use some 3rd party modules, I don't think those will be merged upstream.
19:46:43 <brainycmurf> Matthew: That could be a problem, because things that can't be in the upstream kernel, we'll have the same reasons for not putting it in the Fedora kernel.
19:46:46 <brainycmurf> Alejandro: Is it a problem if we add those to the preinstalled Fedora?
19:46:48 <brainycmurf> Michael: Are you asking if you can provide your own repository on top of Fedora?
19:46:50 <brainycmurf> Neal: It works OK without the 3rd party modules, but it works better with them. But we should talk about how to get more of this upstreamed, so everyone benefits.
19:46:53 <brainycmurf> Matthew: If we make it available post-install that's not a problem. We prefer the preinstalled image exactly the same as "Get Fedora" images, so they're not getting a special exception. And then they can add the extras later.
19:46:57 <brainycmurf> Alejandro: Facial recognition won't work out of the box, but other than that...
19:46:59 <brainycmurf> Allan: We're talking about that topic later today.
19:47:01 <brainycmurf> #action WG to figure out who the best person would be to receive Slimbook hardware for testing. QA? Desktop hardware enablement?
19:47:04 <brainycmurf> Neal: Some of the allotment for test models should go to Fedora QA.
19:47:06 <brainycmurf> Allan: Do you plan on doing your own QA testing against Fedora?
19:47:08 <brainycmurf> Alejandro: Yes. So far testing has been positive.
19:47:10 <brainycmurf> Allan: What about routine testing, with development releases to ensure the next version of Fedora will work with existing hardware products?
19:47:15 <brainycmurf> Alejandro: We don't usually test unstable versions but we do test stable versions.
19:47:17 <brainycmurf> Matthew: Do you wait until there's a stable release?
19:47:19 <brainycmurf> Michael: You'll want to test earlier than that. In Fedora users quickly move to the release version and if there's something broken, they'll run into it.
19:47:22 <brainycmurf> Michael and Neal: Don't see issues from a Workstation perspective on moving forward with this idea.
19:47:25 <brainycmurf> Matthew: Workstation procedure for approval? Do that? Recorded consensus would be good. Hardware commitments for working group and QA. Trademark issues go through Council.
19:47:28 <brainycmurf> #action: Matthew to help coordinate trademark and websites issues.
19:47:30 <brainycmurf> Neal: Would be nice to have a formalized procedure to help us through this process, as it becomes more common.
19:47:33 <brainycmurf> * Some additional discussion on having a consistent procedure
19:47:35 <brainycmurf> #action WG to summarise their expectations for Slimbooks - what we expect in terms of the experience, QA processes, software required (topics to cover: secure boot enabled? NVIDIA support. 3rd party kernel modules. Advance testing of Fedora releases. Standard of hardware support.)
19:47:39 <brainycmurf> Matthew: What video hardware?
19:47:43 <brainycmurf> Alejandro: NVIDIA
19:47:45 <brainycmurf> Matthew: Does it work OK with nouveau?
19:47:47 <brainycmurf> Alejandro: Yes
19:47:49 <brainycmurf> Matthew: Is Secure Boot enabled?
19:47:51 <brainycmurf> Alejandro: It can be enabled or not by default, whatever Fedora wants
19:47:53 <brainycmurf> Tomas: Will there be some documentation you produce? Some kind of onboarding guide? How to start with GNOME/Fedora/Workstation, any of those?
19:47:56 <brainycmurf> * some additional discussion of scope of expectations and how to deliver them
19:47:58 <brainycmurf> Neal: I was talking about a sheet of paper included with the hardware
19:48:00 <brainycmurf> Tomas: Basically a way to get familiar with FOSS projects
19:48:02 <brainycmurf> Allan: Also what next steps the user should take? If 3rd party software should be installed, how to do that.
19:48:05 <brainycmurf> * discussion of some of the hardware specs
19:48:07 <brainycmurf> * note general enthusiasm by the group for this
19:48:09 <brainycmurf> #topic Planning for Fedora 37/38
19:48:13 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/318
19:48:15 <brainycmurf> deferred
19:48:17 <brainycmurf> #topic Ship preininstalled apps as Flatpaks
19:48:19 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/269
19:48:21 <brainycmurf> deferred
19:48:23 <brainycmurf> #topic PRD
19:48:25 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/262
19:48:27 <brainycmurf> There are a couple of changes based on feedback from Council. We have a couple of amendments based on suggestions.
19:48:30 <brainycmurf> * No objections to the proposed changes, and forwarding the draft back to Council.
19:48:32 <brainycmurf> #topic Improve GTK4 font rendering by default for 1080p displays
19:48:34 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/295
19:48:36 <brainycmurf> deferred
19:48:38 <brainycmurf> #topic Howdy integration
19:48:40 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/272
19:48:44 <brainycmurf> deferred
19:48:46 <brainycmurf> #topic Announcements, Status Updates
19:48:48 <brainycmurf> #info The minutes from last week have been posted.
19:48:50 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-06-07/workstation.2022-06-07-21.13.log.html
19:48:53 <brainycmurf> Mattias: Asked Ray how long it would take to integrate Howdy, so we'll have an update next week hopefully.
19:48:56 <brainycmurf> Discussion about new web based Anaconda
19:48:58 <brainycmurf> GUADEC 2022 in July 20-25th https://events.gnome.org/event/77/
19:49:00 <brainycmurf> Fedora Hatch Stockholm 25th June https://pagure.io/flock/issue/352 going to Kungshallen restaurant: http://www.kungshallen.eu/
19:49:03 <brainycmurf> #endmeeting