workstation
LOGS
17:42:19 <brainycmurf> #startmeeting Workstation WG (2021-11-16)
17:42:19 <zodbot> Meeting started Tue Nov 16 17:42:19 2021 UTC.
17:42:19 <zodbot> This meeting is logged and archived in a public location.
17:42:20 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:42:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:42:20 <zodbot> The meeting name has been set to 'workstation_wg_(2021-11-16)'
17:42:20 <brainycmurf> #meetingname workstation
17:42:20 <brainycmurf> #chair Allan
17:42:20 <zodbot> The meeting name has been set to 'workstation'
17:42:20 <zodbot> Current chairs: Allan brainycmurf
17:42:50 <brainycmurf> #info Present members: Matthias, Owen, Chris, Allan, Neal, Michael,
17:42:50 <brainycmurf> #info Present guests: Felipe, Zac
17:42:50 <brainycmurf> #info Regrets: Jens, Tomas
17:42:50 <brainycmurf> #info Secretary: Chris
17:42:50 <brainycmurf> #topic Call for F36 workstation changes
17:42:51 <brainycmurf> Do we want to do this? Try to align with change proposal process?
17:42:53 <brainycmurf> Generally a good idea, useful to include wider community opinions. We should make it clear that these are for specific things, not grandiose ideas that there are no resources for, just be careful about the phrasing
17:42:56 <brainycmurf> #action Neal will post to desktop@ list
17:42:58 <brainycmurf> #topic Improve the user feedback for OOM situations
17:43:00 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/202
17:43:04 <brainycmurf> #link https://github.com/systemd/systemd/issues/20649#issuecomment-914401230
17:43:06 <brainycmurf> Discussion mainly to get eyeballs on the tickets and current status, progress is happening, and we'll need to check in again
17:43:09 <brainycmurf> #topic 2 minute shutdown timer is too long
17:43:11 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/163
17:43:13 <brainycmurf> Also a quick check on status, partial fix in place, minus PackageKit
17:43:15 <brainycmurf> Seems like a good idea to file a PackageKit bug with a reproducer
17:43:17 <brainycmurf> #action chris will attempt to locate a PK reproducer and file a bug
17:43:19 <brainycmurf> #action Matthias to reach out to Zbyszek
17:43:21 <brainycmurf> #topic Enable full preemption
17:43:23 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/228
17:43:25 <brainycmurf> There are 3 modes for preemption. None: used for traditional servers. RHEL & Fedora use volutary (a comprimise between none and full). Work happening in the kernel to allow setting preemption mode at runtime. Will likely be a command line option.
17:43:29 <brainycmurf> If we want to do it, we'd need to find a way to get Anaconda to do it just for Workstation. Server and CoreOS will continue to be voluntary.
17:43:34 <brainycmurf> Full preemption gives you a bit more responsiveness from the system when its under pressure. Cgroups kernel devs don't see an issue with it.
17:43:37 <brainycmurf> Justin Forbes wants there to be testing, to identify edge cases.
17:43:39 <brainycmurf> May or may not be within in scope for F36.
17:43:41 <brainycmurf> There is evidence of lower pointer latency under pressure with full preemption.
17:43:43 <brainycmurf> No known disadvantages for desktops. No objections - the group seems broadly in favour.
17:43:45 <brainycmurf> Suggestion - call for testing on full preemption on all editions.
17:43:47 <brainycmurf> Do we have a test suite to show differential latencies with the various options?
17:43:49 <brainycmurf> Nothing to do until full preemption is available. Chris to monitor the situation and keep us informed.
17:43:52 <brainycmurf> #link https://www.codeblueprint.co.uk/2019/12/23/linux-preemption-latency-throughput.html
17:43:54 <brainycmurf> #action chris will ask anaconda devs about how to do this so we've got an idea
17:43:56 <brainycmurf> #topic Status updates & announcements
17:43:58 <brainycmurf> Anything that the group needs to know or be aware of?
17:44:00 <brainycmurf> Fedora 35 release party happened
17:44:04 <brainycmurf> #info Last week's minutes have been posted
17:44:06 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021-11-02/workstation.2021-11-02-18.29.log.html
17:44:13 <brainycmurf> #endmeeting