workstation
LOGS
15:35:31 <cmurf> #startmeeting Workstation WG (2021-06-15)
15:35:31 <zodbot> Meeting started Fri Jun 18 15:35:31 2021 UTC.
15:35:31 <zodbot> This meeting is logged and archived in a public location.
15:35:31 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:35:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:35:31 <zodbot> The meeting name has been set to 'workstation_wg_(2021-06-15)'
15:35:33 <cmurf> #meetingname workstation
15:35:33 <zodbot> The meeting name has been set to 'workstation'
15:35:35 <cmurf> #chair Neal
15:35:35 <zodbot> Current chairs: Neal cmurf
15:35:49 <cmurf> #topic Rollcall
15:35:51 <cmurf> #info present:  Owen, Michael (secr.), Allan, Jens, Matthias, Chris, Langdon, Neal ,Tomas
15:35:53 <cmurf> #info regrets: Kalev
15:35:55 <cmurf> #info present guests:
15:35:57 <cmurf> #topic Approval of June 8 minutes
15:35:59 <cmurf> https://meetbot.fedoraproject.org/teams/workstation/workstation.2021-06-11-17.07.log.html
15:36:01 <cmurf> #agreed no objections
15:36:03 <cmurf> #topic Announcements, follow-ups, status reports
15:36:05 <cmurf> WG discusses conference sponsorships
15:36:07 <cmurf> #topic encryption of user data (excludes system)
15:36:09 <cmurf> #link https://pagure.io/fedora-workstation/issue/82
15:36:11 <cmurf> Chris: btrfs fscrypt works and has reached feature parity with ext4 fscrypt, but important btrfs features are not yet supported, and the work is not yet merged upstream.
15:36:13 <cmurf> Chris: Do we want to use systemd-homed, or roll a different solution?
15:36:15 <cmurf> Neal: Users should be able to upgrade to an encrypted system without reinstalling. Michael says that might be too much to expect.
15:36:17 <cmurf> Neal: Discusses how System76 handles encrypted OEM installs. Anaconda cannot do this.
15:36:19 <cmurf> Allan: Would be nice to have a user-guided upgrade process to enable the new encryption feature. But we are not very good at testing features that run only once when upgrading from one release to another.
15:36:21 <cmurf> Neal: Not sure how we would implement such a feature. (Could it use LEAPP?)
15:36:23 <cmurf> Chris: Discusses systemd-homed. Copying files from original unencrypted filesystem to new filesystem would be awkward. Do we upgrade all users, or only new users? Using btrfs fscrypt would be simpler and lower-risk since it reuses existing compression codepaths that handle this on-the-fly.
15:36:25 <cmurf> Crickets. Chirp chirp.
15:36:27 <cmurf> Chris: fscrypt might be a better default than systemd-homed LUKS since it avoids space consumption and "file system on top of a file system" complexities.
15:36:29 <cmurf> Neal: Suggests having useradd create a new btrfs subvolume for each new user account. This could be useful to enable fscrypt in the future.
15:36:31 <cmurf> Matthias: Cautions against relying on code that hasn't yet landed in the kernel. Should keep in touch with Lennart regarding systemd-homed.
15:36:33 <cmurf> Chris: should also keep in touch with halfline regarding gdm and accountsservice support for systemd-homedir.
15:36:35 <cmurf> Neal: should try to get Omar into the same meeting with Lennart to discuss both approaches.
15:36:37 <cmurf> Chris: fscrypt on systemd-homed might be a good default, with LUKS on systemd-homed as an alternative for users who require additional security.
15:36:39 <cmurf> Neal: systemd-homed requires that user home directories use separate subvolumes. fscrypt on its own does not (can encrypt different home directories with different keys).
15:36:41 <cmurf> #info systemd-homed makes it easier to support no encryption, and multiple encryption schemes (ext4/fscrypt, btrfs/fscrypt, LUKS);
15:36:43 <cmurf> #info but homed is a fundamentally different login/user authentication scheme, so we need to evaluate that independently from encryption schemes.
15:36:45 <cmurf> #action Neal to create a ticket for considering btrfs subvolumes for different users.
15:36:47 <cmurf> #action Matthias to invite Lennart to future WG meeting to discuss systemd-homed.
15:36:49 <cmurf> Neal: Wonders how systemd-homed plus enterprise login would work.
15:36:51 <cmurf> Chris: systemd-homed needs to handle user password changes *without* requiring reencrypting all files. This is probably a blocker.
15:36:53 <cmurf> Chris: There is a Google tool called 'fscrypt' which is a key manager and interface for setting up native file system encryption on ext4, f2fs, ubifs and will support Btrfs. This tool also provides PAM integration,
15:36:55 <cmurf> Chris: and it also provides for user password changes without requiring reencryption of files.
15:36:57 <cmurf> #link https://github.com/google/fscrypt
15:36:59 <cmurf> #topic Open Floor
15:37:01 <cmurf> Michael asks about Fedora move to Matrix. Neal says it is held up on legal.
15:37:26 <cmurf> #endmeeting